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Introduction

Welcome to Adobe Illustrator CS6 on Demand, a visual quick
reference book that shows you how to work efficiently with
Illustrator.  This book provides complete coverage of basic to
advanced Illustrator skills.

How This Book Works
You don’t have to read this book in any particular order.
We’ve designed the book so that you can jump in, get the
information you need, and jump out. However, the book does
follow a logical progression from simple tasks to more com-
plex ones. Each task is presented on no more than two facing
pages, which lets you focus on a single task without having
to turn the page. To find the information that you need, just
look up the task in the table of contents or index, and turn to
the page listed. Read the task introduction, follow the step-
by-step instructions in the left column along with screen illus-
trations in the right column, and you’re done.

What’s New
If you’re searching for what’s new in Illustrator CS6, just look
for the icon: New!. The new icon appears in the table of con-
tents and throughout this book so you can quickly and easily
identify a new or improved feature in Illustrator. A complete
description of each new feature appears in the New Features
guide in the back of this book.

Keyboard Shortcuts
Most menu commands have a keyboard equivalent, such as
Ctrl+P (Win) or A+P (Mac), as a quicker alternative to using
the mouse. A complete list of keyboard shortcuts is available
on the web at www.perspection.com and in the back of this
book.

How You’ll Learn

How This Book Works

What’s New

Keyboard Shortcuts

Step-by-Step Instructions

Real World Examples

Workshops

Adobe Certification

Get More on the Web

www.perspection.com
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Step-by-Step
Instructions
This book provides concise step-
by-step instructions that show you
“how” to accomplish a task. Each
set of instructions includes illus-
trations that directly correspond to
the easy-to-read steps. Also
included in the text are time-
savers, tables, and sidebars to
help you work more efficiently or
to teach you more in-depth infor-
mation. A “Did You Know?” pro-
vides tips and techniques to help
you work smarter, while a “See
Also” leads you to other parts of
the book containing related infor-
mation about the task. 

Real World Examples
This book uses real world exam-
ple files to give you a context in
which to use the task. By using
the example files, you won’t waste
time looking for or creating sam-
ple files. You get a start file and a
result file, so you can compare
your work. Not every topic needs
an example file, such as changing
options, so we provide a complete
list of the example files used
throughout the book. The example
files that you need for project
tasks along with a complete file
list are available on the web at
www.perspection.com.

Real world
examples help
you apply what
you’ve learned
to other tasks.

Illustrations
match the
numbered
steps.

Numbered
steps guide
you through
each task.

Did You Know? alerts
you to tips, techniques
and related information.

See Also points you to
related information in
the book.

Easy-to-follow
introductions
focus on a
single concept.

www.perspection.com
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The Workshops
walk you through
in-depth projects
to help you put
Illustrator to
work.

Introduction xix

Workshops
This book shows you how to put
together the individual step-by-
step tasks into in-depth projects
with the Workshop. You start each
project with a sample file, work
through the steps, and then com-
pare your results with a project
results file at the end. The Work-
shop projects and associated files
are available on the web at
www.perspection.com or at
queondemand.com.

Adobe Certification
This book prepares you fully for
the Adobe Certified Expert (ACE)
exam for Adobe Illustrator CS6.
Each Adobe Certified Expert certifi-
cation level has a set of objec-
tives, which are organized into
broader skill sets. To prepare for
the certification exam, you should
review and perform each task
identified with an ACE objective to
confirm that you can meet the
requirements for the exam. Infor-
mation about the ACE program is
available in the back of this book.
The Adobe Certified Expert objec-
tives and the specific pages that
cover them are available on the
web at www.perspection.com.

www.perspection.com
www.perspection.com
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Get More on the Web
In addition to the information in
this book, you can also get more
information on the web to help
you get up-to-speed faster with
Illustrator CS6. Some of the infor-
mation includes: 

Transition Helpers
◆ Only New Features.

Download and print the new
feature tasks as a quick and
easy guide.

Productivity Tools
◆ Keyboard Shortcuts.

Download a list of keyboard
shortcuts to learn faster ways
to get the job done. Also
available in the back of this
book.

More Content
◆ Photographs. Download

photographs and other
graphics to use in your
Illustrator documents. 

◆ More Content. Download
new content developed after
publication.

You can access these additional
resources on the web at
www.perspection.com.

Additional
content 
is available
on the web. 

www.perspection.com
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Getting Started with
Illustrator CS6

Introduction

Adobe Illustrator CS6 is a graphics design and drawing pro-
gram that runs seamlessly on both Windows and Macintosh
platforms. Adobe Illustrator CS6 is a stand-alone program,
but it’s also part of Adobe's Creative Suite of professional
programs that work together to help you create designs in
print, on the web, or on mobile devices. Many of the Creative
Suite 6 programs also include additional Adobe programs
and services—Bridge, Camera Raw plug-in, Media Encoder,
Extension Manager, and ExtendScript Toolkit—to help you
manage and work with files.

Creative artists from Hollywood, brochure designers, as
well as casual users turn to Illustrator for its proven ability to
create top-of-the-line vector artwork and complex graphic
designs. Illustrator's ability to manipulate illustrations for use
in books, brochures, multimedia presentations, or on the
web, has made Illustrator the undisputed leader in the graph-
ics industry. When it comes to vector illustration, Illustrator is
literally the best software the computer industry has to offer. 

With Illustrator, you can create anything from simple
icons to multilayered illustrations, as well as manipulate text.
And Illustrator's ability to work with other programs allows
you to import Excel data for graph building, export Illustrator
files directly to Adobe InDesign and QuarkXPress, as well as
open layered Illustrator files in Photoshop, making it a snap
to move back and forth between programs as you design. 1

1
What You’ll Do

Install and Start Illustrator

View the Illustrator Window

Show and Hide Panels

Work with Panels

Use the Tools and Control Panel

Open a Document

Open a Document with Adobe Bridge

Insert Images in a Document

Work with Document Windows

Use the Status Bar

Check for Updates and Patches

Get Help While You Work

Save a Document

Finish Up

1
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The process of installing the Illustrator application, either 32- or 64-bit
edition (New!), is fairly straightforward; you insert the Illustrator CS6
installation disc into your DVD drive or download the software online to
your computer, double-click the setup program and simply follow the on-
screen instructions. The first thing that will happen is that the installer
will check to see if you have the minimum system requirements. If you
meet the minimums, the installer will guide you through the steps to
complete the installation. The whole process takes about ten minutes,
and at the end of the process you can launch Illustrator for the first
time. Remember to have your serial number handy, because you will
have to type it in during the installation process. It's a good idea to have
that serial number in a safe place, just in case you would need to rein-
stall Illustrator.

Installing 
Illustrator 

Install Illustrator CS6 in
Windows

Insert the Illustrator CS6 or Adobe
Collection CS6 disc into your DVD
drive, or download the software
online to your hard disk.

If necessary, double-click the DVD
icon or open the folder with the
downloaded software, and then
double-click the setup icon.

Follow the on-screen instructions
to install the product; the installer
asks you to read and accept a
licensing agreement, enter or
create an Adobe ID or skip the
step, enter a serial number,
indicate the language you want,
and specify where you want to
install the software.

3

2

1

Did You Know?
The DVD comes with bonus content.
The Resources and Extras DVD
included with Adobe CS6 products
includes bonus content and files in the
Goodies or Cool Extras folder. Check it
out! For more free online resources, go
to www.adobe.com and visit Adobe
Exchange.

2

3

www.adobe.com
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Install Illustrator CS6 in
Macintosh

Insert the Illustrator CS6 or Adobe
Collection CS6 disc into your DVD
drive, or download the software
online to your hard disk.

If necessary, double-click the DVD
icon or open the folder with the
downloaded software, and then
double-click the Install icon.

Follow the on-screen instructions
to install the product; the installer
asks you to read and accept a
licensing agreement, enter or
create an Adobe ID or skip the
step, enter a serial number,
indicate the language you want,
and specify where you want to
install the software.

3

2

1

Hardware/Software Minimum (Recommended)

WINDOWS

Computer Processor Intel Pentium 4 or AMD Athlon 64 or compatible

Operating System Microsoft Windows XP SP3 or Windows 
Vista SP1 or Windows 7 SP1

Hard Drive 2 GB of available space

Available RAM 1 GB (3 GB recommended) for 32-bit; 
2 GB (8 GB recommended) for 64-bit 

Video Card 16-bit 

Monitor Resolution 1024 x 768 (1280 x 800 recommended)

DVD-ROM drive Any type

MACINTOSH

Computer Processor Multi-core Intel-based Macs for 64-bit

Operating System Macintosh OS X 10.6.8, 10.7, or higher

Hard Drive 2 GB of available space

Available RAM 2 GB (8 GB recommended) 

Video Card 16-bit

Monitor Resolution 1024 x 768 (1280 x 800 recommended)

DVD-ROM drive Any type

Did You Know?
Most Adobe applications can be
downloaded. It's all very simple; you
go to www.adobe.com, click the
Products menu item, and then select
the application you want to purchase.
You will need a credit card (of course),
and a lot of bandwidth.

Illustrator CS6 System Requirements

3

www.adobe.com


ptg8126863

4 Chapter 1

You can start Illustrator in several ways, depending on the platform you
are using. When you start Illustrator, the software displays the
Illustrator window. After you launch Illustrator, the program checks for
updates to Illustrator and related CS6 software using the Adobe
Application Manager. If you want to access the Adobe Application
Manager at any time, you can choose Updates from the Help menu.
Once inside this dialog box, you can click on Preferences to set Adobe
Application Manager Preferences options. You can choose to be noti-
fied of new updates on the menu bar and you can also choose to allow
Adobe to verify the success or failure of an update by sending a failure
status to you.

Getting Started

Start Illustrator CS6 in Windows

Click Start on the taskbar.

Point to All Programs (which
changes to Back).

Point to an Adobe Collection CS6
menu, if needed.

Click Adobe Illustrator CS6.

If you’re starting Illustrator CS6 for
the first time, you might be
prompted to specify the following:

◆ Enter or create an Adobe ID to
register the product, click
Submit, and then click Done.

◆ Specify whether you want to
migrate presets from earlier CS
versions.

5

4

3

2

1

Did You Know?
You can create and use a shortcut
icon on your desktop to start Illustrator
(Win). Click Start on the taskbar, point
to All Programs, right-click Adobe
Illustrator CS6, point to Send To, and
then click Desktop (Create Shortcut).
Double-click the shortcut icon on your
desktop to start Illustrator.

1 2 4
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Start Illustrator CS6 in
Macintosh

Open the Applications folder
(located on the main hard drive).

◆ For Lion, you can also click the
Launchpad icon on the Dock,
and then click the Adobe
Illustrator CS6 icon.

Double-click the Adobe Illustrator
CS6 folder or an Adobe Collection
CS6 folder, if installed.

Double-click the Adobe Illustrator
CS6 program icon.

If you’re starting Illustrator CS6 for
the first time, you might be
prompted to specify the following:

◆ Enter or create an Adobe ID to
register the product, click
Submit, and then click Done.

◆ Specify whether you want to
migrate presets from earlier CS
versions.

4

3

2

1

Did You Know?
You can create a shortcut on the
Macintosh. Drag and drop the
Illustrator application to the bottom of
the monitor screen, and then add it to
the dock.

You can create and use a keyboard
shortcut to start Illustrator (Win). Click
Start on the taskbar, point to All
Programs, right-click Adobe Illustrator
CS6, and then click Properties. In the
Shortcut Key box, type or press any
letter, number, or function key, such as
I, to which Windows adds Ctrl+Alt.
Click OK to create the keyboard short-
cut. From anywhere in Windows, press
the keyboard shortcut you defined
(Ctrl+Alt+I) to start Illustrator. 

Shortcut for Adobe Illustrator CS6

3

Launchpad icon in Mac OS X Lion

Using Illustrator in 32-bit and 64-bit Mode
The terms 32-bit and 64-bit refer to the way a computer CPU process-
es information. A 64-bit system handles large amounts of RAM more
effectively than 32-bit systems. Illustrator in 64-bit mode (New!)
takes advantage of more than 4 GB of RAM when needed, instead of
swapping out to the hard drive, which increases performance. When
you install a 64-bit version of Illustrator on a 64-bit system and ver-
sion of Windows 7/Vista/XP, you can use Illustrator in 32-bit or 64-bit
modes. When you install a 32-bit version of Illustrator, you can only
use it in 32-bit mode. For Windows on a 64-bit system, Illustrator CS6
installs 32-bit and 64-bit versions with shortcuts on the Start menu,
where you can start either one. Any 32-bit plug-ins will no longer
work in the 64-bit version. For the Mac (10.6.8, 10.7, or higher),
Illustrator CS6 only installs one version in 64-bit mode. 

For Your Information
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Viewing the Illustrator Window

When you start Illustrator, the program win-
dow displays several windows of varying
types you can use to work with graphics and
illustrations. In Illustrator, windows appear in
the workspace in panels. A panel is a window
you can collapse, expand, and group with
other panels, known as a panel group, to
improve accessibility and workflow. A panel
group consists of either individual panels
stacked one on top of the other or related
panels organized together with tabs to navi-
gate from one panel to another. 

The Tools panel contains a set of tools you
can use to create shapes, such as lines, rec-

tangles, rounded rectangles, and ellipses. You
can fill shapes and text with a color, pattern,
or custom tile. When you select a tool, addi-
tional options appear on the Control panel.

A menu is a list of commands that you use
to accomplish specific tasks. A command is a
directive that accesses a feature of a program.
Illustrator has its own set of menus, which are
located along the top of the Illustrator win-
dow. Next to the menus is the Application bar
with additional options for accessing Adobe
Bridge, changing the document layout, and
choosing a workspace.

Control panel
Displays options for the
currently selected tool. 

Panels 
Give you
tools to
modify and
check your
documents,
such as
Appearance,
Color, Layers,
and Links.

Tools panel
Contains

drawing and
other related

tools to
create and
manipulate

graphics.

Application bar
Displays buttons and menus to
change the document layout.

Menus
Displays a list of
commands.
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The Document window displays open
Illustrator documents with one or more art-
boards on a canvas. Illustrator includes tabs
to make it easier to switch back and forth
between documents and a close button to
quickly close a document.

Changing the User Interface
Illustrator allows you to change the color of
the user interface from a dark gray (default)
(New!) to a light gray (similar to Illustrator
CS5). You can change the interface color in
User Interface Preferences. Click the Edit
(Win) or Illustrator (Mac) menu, point to

Preferences, click User Interface, click the
Brightness list arrow, and then select a color,
or drag the Brightness slider to the percent-
age you want. In addition, you can change
the canvas color area around the image. In
User Interface Preferences, click the Match
User Interface Brightness or White option
(New!). When you’re done, click OK. Dialog
boxes use the interface color too. Also, com-
mit buttons, such as OK, Save, Done, etc., are
at the bottom-right corner in all modal dialog
boxes (New!). In addition, you have full key-
board access in all dialog boxes (New!).

Canvas
Provides a work area

outside of an artboard.

Document Window
Displays open Illustrator
documents.

Artboard
Provides the workspace
for designs in Illustrator.
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Panels on Window menu

1

Panels give you easy access to many task-specific commands and
operations from color control to vector path information. By default, the
main panel display is located along the right side of your window. You
can use the Window menu or click a panel tab within a group to display
it, and then select options on the panel or choose panel-specific 
commands from the Panel Options menu to perform actions. Instead of
continually moving, resizing, or opening and closing windows, you can
use the header bar with the panel tabs to collapse or expand individual
panels within a window to save space. When you want to resize a
panel, there is a handy Resize bar (New!) at the bottom of the panels
that need it, not all panels have a Resize bar.

Showing and Hiding
Panels

Open and Close a Panel

Click the Window menu.  

Point to a submenu (if needed),
such as Type, Extensions, or a
library (Brush, Swatch, etc.).

Click a panel name, such as Color,
Layers, or Navigator.

A panel name with a check mark
indicates the panel is open.

TIMESAVER To close a panel,
or a single tab, right-click (Win) or
control-click (Mac) a panel tab,
and then click Close Tab Group or
Close (for a single tab).

3

2

1

2

3
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Collapse or Expand a Panel

To collapse or expand an open
panel, click the dark gray area or
double-click a title tab on the
header bar of the panel. 

If the panel is in icon mode, click
on the icon to expand or collapse
it. To reduce the panel back to
icon mode, click on the double
right-facing arrows in the dark
gray area. To expand from icons to
panels, click on the double left
facing arrows.

Resize a Panel

To resize a panel vertically or
horizontally, point to the middle of
the resize bar, and then drag up or
down. 

To resize a panel in to any size,
point to a corner in the resize bar
or a corner with dots, and then
drag in any direction.

1

1

Expanded panels

1

Expanded
panels

Collapsed
panels

1

Resize corner with dots

Resize bar

Resized panel
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Working with 
Panels

Dock a Panel

Select a panel; click on a named
panel, or click the Window menu,
and then click a panel name.

Drag the window away from the
panel to a different panel.

◆ Add to Panel. Drag to a panel
until a blue rectangle appears
around the panel.

◆ Append to Panel. Drag to a
panel until a blue line appears
along the side of the panel.

Undock a Panel

Select a panel; click on a named
panel, or click the Window menu,
and then click a panel name.

Drag the panel out of the group.

Drop it onto the Illustrator window.3

2

1

2

1

The movable panels are organized into groups, such as Color/Color
Guide and Actions/Links, to save screen space and help with workflow.
You can also dock (add) or undock (subtract) specific panels within a
group to customize your workspace. A panel appears with a header,
which includes the tab titles and three options: the Collapse to Icons or
Expand Panels button, the Close button, and an Options menu. The
Options menu provides you with panel commands. The entire set of
panels includes a double arrow at the top you can use to collapse and
expand the entire panel back and forth between icons and full panels.
All panel icons have been redesigned for better identification (New!).

2

Append two panels:
Color and Color Guide1

2

Did You Know?
You can dock and undock panels to a
docking channel. You can dock and
undock, panels or panel groups in
docking channels. A docking channel
is a region located on the left and right
side of the Illustrator window to which
you can attach and detach panels.
When you drag a panel over a dock-
able area, a blue line appears.

Hiding Panels While You Work
If Illustrator's panels get in the way, just press the Tab key to tem-
porarily hide all the panels. Or, you can hold down the Shift key, and
then press the Tab key to hide the panels, but leave the Toolbox and
Control panel. Press the Tab key again to restore all the panels to
their most recent positions.

For Your Information

1
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Collapse and Expand the Panel
Set Between Icons and Panels

◆ To collapse the panel set to icons
with text, click the double arrow
pointing right (Collapse to Icons) at
the top of the panels.

◆ To expand the panel set from icons
with text to full panels, click the
double arrow pointing left (Expand
Panels) at the top of the panels.

◆ To have an expanded panel icon
automatically collapse or hide
when you click away, right-click
(Win) or Control-click (Mac) a
panel, and then click Auto-
Collapse Iconic Panels or Auto-
Show Hidden Panels. 

Use the Panel Options Menu

Open or expand a panel.

Click the Options button on the
right side of the panel header bar.   

Click a command from the list
(commands vary).

◆ Show Options or Hide Options.
Many of the panels include a
Show Options command that
displays additional commands. 

If you don’t see an option in a
panel, click the Options button,
and then click Show Options. If
you want to hide the additional
options, click the Options
button, and then click Hide
Options.

3

2

1

3

Click to collapse the
panel set

1

Click to expand
the panel set

2
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Illustrator has an abundance of tools that give
an Illustrator designer tremendous control
over any creative designing problems that
may crop up. For example, the Illustrator tool-
box contains a variety of different tools: selec-
tion tools, painting or shape tools, type tools,
and other tools dedicated to creating art-
boards, working with slices and transforming
and viewing illustrations. Add to that collec-
tion, slicing, sampling, and viewing tools and
you have all the tools you need to do any job. 

When you work on a document, it's impor-
tant to know what tools are available, and
how they can help in achieving your design
goals. Illustrator likes to save space, so it con-
solidates similar tools under one button. To
access multiple tools, click and hold on any

Tools panel button that contains a small black
triangle, located in the lower right corner of
the tool button. Take a moment to explore the
Illustrator toolbox and get to know the tools.

The Illustrator Tools panel contains the
tools needed to work through any Illustrator
job, but it's not necessary to click on a tool to
access it. Simply using a letter of the alphabet
can access all of Illustrator's tools. For exam-
ple, pressing the P key switches to the Pen
tool, and pressing the T key switches to the
Type tool. In addition, if a button has more
than one tool available, clicking the arrow on
the right side of the tool menu displays all the
tools in a small panel for easy access. When
you display the small panel, you can click the
arrow on the right edge to change the menu

Using the Tools and Control Panel

Tools panel
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to a panel, which stays open. You can click the
Close button to dismiss it. You can refer to
Adobe Illustrator CS6 Keyboard Shortcuts
(available for download on the web at
www.perspection.com) for more information
on all the letter assignments for the various
tools. To really get efficient in Illustrator, you
need to learn to use both hands. Use one
hand for your mouse or drawing tablet, and
the other on the keyboard to make quick
changes of tools and options. Think of playing
Illustrator like playing a piano—you need to
use both hands. 

Using the Control Panel
The Control panel displays the options for
the currently selected tool. For most tools,
your options include Selection, Fill Color,
Stroke Color, Weight, and Width Profile,
Brush Definition, Opacity, Graphic Style
panel, Document Setup, Preferences, and
Select Similar Objects.  The important thing
to remember is that the Control panel is cus-
tomized based on the tool you have selected;
it has been redesigned and reorganized with
most controls appearing in the same place
for easier usage (New!).

Control panel

Tools panel

www.perspection.com
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Illustrator lets you open image files created in different formats, such
as TIFF, JPEG, GIF, PNG, Adobe FXG and Adobe Idea File (New!), as
well as Illustrator documents in the AI format. If you want to simply
open an image or Illustrator document, the Open dialog box is the most
efficient way. However, if you need to manage, organize, or process
files, Adobe Bridge is the way to go. You open an existing Illustrator
document or image file the same way you open documents in other
programs. In Windows Explorer (Win) or Finder (Mac), you can double-
click an Illustrator document to open the Illustrator program and the
document. When you open a document, a tab appears across the top of
the Document window, with the document title. You can click the tab at
any time to display that particular document.

Opening a Document

Open an Existing Document

Click the File menu, and then click
Open to display all file types in the
file list of the Open dialog box.

Click the Files of Type (Win) or
Enable (Mac) list arrow, and then
select a format.

Navigate to the location with the
document you want to open.

Click the image file you want to
open. 

TIMESAVER Press and hold
the Shift key to select multiple
contiguous files to open while in
the Open dialog box.

Click Open. 5

4

3

2

1

5

4

3

Did You Know?
You can delete a file in a dialog box
(Win). In the Open or Save As dialog
box, right click the file you want to
delete, and then click Delete.

You can no longer open Freehand doc-
uments. In the Open dialog box, the
Freehand extensions (FH7, FH8, FH9,
FH10, FH11, and FT11) are no longer
supported (New!).

Open file formats

2
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Open a Recently Opened
Document

Click the File menu, and then point
to Open Recent Files.

Click the document you want to
open.

2

1

1

2

Did You Know?
You can open a recent file quickly
from the Start menu (Win). Click the
Start button, point to Adobe Illustrator
CS6 (7), Recent Items (Vista) or My
Recent Documents (XP), and then click
the file name you want to open.

You can open files from the Adobe
Creative Cloud. Adobe Illustrator CS6
comes with the Adobe Creative Cloud
desktop plug-in, which you can open
and edit files (.IDEA) (New!) created
in your Adobe Touch Apps.
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With Adobe Bridge, you can drag assets into your layouts as needed,
preview them, and add metadata to them. Bridge allows you to search,
sort, filter, manage, and process files one at a time or in batches. You
can also use Bridge to create new folders; rename, move, delete and
group files (known as stacking); edit metadata; rotate images; and run
batch commands. You can also view information about files and data
imported from your digital camera.

1

Opening a Document
with Adobe Bridge

Browse and Open Documents
with Adobe Bridge

Click the Go to Bridge button on
the Application bar or click the
File menu, and then click Browse
in Bridge.

In Bridge, select a specific
workspace to view your files the
way you want.

Navigate to the location where the
file is located.

To open an image in Illustrator, use
any of the following:

◆ Double-click on a thumbnail to
open it in the default program.

◆ Drag the thumbnail from the
Bridge into an open Adobe
application.

◆ Select a thumbnail, click the
File menu, point to Open With,
and then click Adobe Illustrator
CS6.

◆ Select a thumbnail, click the
File menu, point to Place, and
then click In Illustrator.

To return to Illustrator, click the
File menu, and then click Return to
Adobe Illustrator.

5

4

3

2

1

4

235



ptg8126863

Chapter 1 Getting Started with Illustrator CS6 17

Work with Files Using Bridge

Click the Go to Bridge button on
the Application bar or click the
File menu, and then click Browse
in Bridge.

Click the Folders tab and choose a
folder from the scrolling list.

Click the Favorites tab to choose
from a listing of user-defined
items, such as Pictures.

To narrow down the list of images
using a filter, click the criteria you
want to use in the Filter panel.

Click an image within the preview
window to select it.

Click the Preview tab to view a
larger thumbnail of the selected
image. Multiple images appear
when you select them.

Drag the Zoom slider to increase
or decrease the thumbnail views.

Use the file management buttons
to rotate or delete images, or
create a new folder.

Double-click on a thumbnail to
open it in the default program, or
drag the thumbnail from the Bridge
into an open Adobe application.

9

8

7

6

5

4

3

2

1

Did You Know?
You can reveal a document in Adobe
Bridge from Illustrator. Open a docu-
ment in Illustrator, click the triangle to
the right of the Status Bar, and then
click Reveal in Bridge.

7

3 2 8 5 6

1

View buttons94



ptg8126863

18 Chapter 1

You can use Illustrator's Place command to insert artwork into an open
document. To increase your control of the new image information,
Illustrator places the new image into a separate layer. Illustrator lets
you place files saved in Illustrator AI, Adobe PDF, Illustrator PSD, BMP,
JPEG, EPS, PNG, TIFF, and TXT, DOC, or RTF formats to name a few.
When you first place a vector-based image into Illustrator, you have the
ability to modify the width, height, and rotation while retaining the vec-
tor format of the file. 

Inserting Images in 
a Document

Insert an Image in a Document
Using the Place Command

Open an Illustrator document.

Click the File menu, and then click
Place.

Navigate to the location with the
image, and then select the image
you want to place into the active
document.

Select any of the following
options:

◆ Link. Places a screen version
of the image and links the
document to the image file.
Deselect to embed a copy of
the image in the document.

◆ Template. Places a dimmed
version of the image on a
template layer.

◆ Replace. Replaces the current
image.

Click Place.

If an additional dialog box
appears, specify the Place options
that you want, and then click OK.

Illustrator places the image in the
active layer, and then encloses it
within a transformable bounding
box.

Control the shape by manipulating
the corner and side nodes of the
freeform bounding box.

7

6

5

4

3

2

1
3

5

4

6

7
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Using the Status Bar

Use the Status Bar

Click the black triangle near the
Status bar info box, point to Show,
and then select from the following
options:

◆ Artboard Name. Displays the
current artboard name.

◆ Current Tool. Displays the current
tool.

◆ Date and Time. Displays the
current date and time.

◆ Number of Undos. Displays the
current number of undos.

◆ Document Color Profile. Displays
the current document color
profile.

To switch between artboards, use
any of the following: 

◆ First or Last. Displays the first or
last artboard.

◆ Previous or Next. Displays the
previous or next artboard.

◆ Artboard Navigation. Displays the
specified artboard.

To change the view size, click the
View Size list arrow, and then select
a view percentage or Fit On Screen.

3

2

1

To work efficiently in Illustrator you need information about the active
document. Details about the document's color profile can help in the
design and preparation of the final document. Illustrator displays cur-
rent information about the active document through the Status Bar,
located at the bottom of the document window. You can display the
current artboard name, current tool, date and time, and the number of
undoes.  From the Status Bar, you can also switch between artboards
and change the view size percentage. 

123
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When you open multiple documents, you can use the Arrange
Documents or Window menu or tabs at the top of the Document win-
dow to switch between them. You can click a tab name to switch to
and activate the document. By default, tabs are displayed in the order
in which you open or create documents. When you want to move or
copy information between documents, it’s easier to display several doc-
ument windows on the screen at the same time and move them around.
However, you must make the window active to work in it. Each tab also
includes a Close button to quickly close a document. If the document
view is too small or large, you can change it to suit your needs.

Working with
Document Windows

Work with Multiple Documents

Open more than one document.

Click a tab name to switch to the
document.

TIMESAVER Press Ctrl+Tab or
Ctrl+Shift+Tab to cycle to the tab
you want.

◆ You can also click the Window
menu, and then click a
document name at the bottom
of the menu.

To move a document window
around, do any of the following: 

◆ To rearrange the order of
tabbed documents drag a
window’s tab to a new location.

◆ To switch to another document
when dragging a selection,
drag the selection over the
document’s tab. 

3

2

1
2

3 Undocked floating document window
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Arrange Multiple Documents

Open more than one document.

Click the Arrange Documents
menu on the Application bar.

On the menu, select an
arrangement button icon:

◆ Consolidate All. Displays all
active documents as tabs.

◆ Tile All In Grid. Displays all
open documents in a grid
pattern on the screen.

◆ Tile All Vertically. Displays all
open documents vertically on
the screen.

◆ Tile All Horizontally. Displays
all open documents horizontally
on the screen.

◆ 2-Up, 3-Up, 4-Up, 5-Up, or 6-Up.
Displays the number of
documents in the selected
pattern (in the menu icon) on
the screen.

To dock or undock a document
window, drag the window’s tab out
of the group or into the group. 

4

3

2

1
1

Arranged documents

32
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As time passes, Illustrator—like any other program—will change.
There are two types of changes to a program: updates and patches.
Updates are improvements to a program such as a new feature, option,
or command. Patches are software fixes for problems discovered after
the public release of the program. The good news is that both updates
and patches are free, and once downloaded, are self-installing. Adobe
gives you two ways to check for changes. You can check manually by
going to the Adobe web site, or automatically through the Adobe
Application Manager. The Adobe Application Manager Preferences
dialog box allows you to set update options for Illustrator and other
installed Adobe products, such as Bridge. You can also set an option to
have Adobe notify you of updates in the menu bar.

Checking for Updates
Online

Check for Updates Directly from
the Internet

Open your Internet browser.

Go to the following web address:
www.adobe.com/downloads/
updates/

Click the list arrow, and then click
the Illustrator - Macintosh or
Illustrator - Windows.

Click Go.

Any updates or patches appear in
a list.

Based on your operating system,
follow the onscreen instructions to
download and install the software.

IMPORTANT Checking on your
own requires a computer with a
connection to the Internet. Since
some of the updates can be rather
large, it’s recommended you have
high-speed access.

5

4

3

2

1

2

4

3

www.adobe.com/downloads/updates/
www.adobe.com/downloads/updates/
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Check for Updates from the
Illustrator Help Menu

Click the Help menu, and then
click Updates.

Adobe checks your software with
the latest available version.

To manually check, click the
Check For New Updates button.

To change preferences, click
Preferences, select the update
options you want, and then click
OK.

Select the check boxes with the
updates you want to install, and
then click Update.

◆ Click the Expand/Collapse
arrow to show or hide updates.

When you’re done, click the Close
button.

5

4

3

2

1

Did You Know?
You can deactivate or activate
Illustrator to use on another computer.
You can use your serial number on only
one computer at a time. If you’re mov-
ing from one computer to another, you
can deactivate your serial number on
one computer and then activate it
another one. Click the Help menu, click
Deactivate, click Suspend Activation
(saves serial number) or Deactivate
Permanently (removes serial number),
and then click Done. To activate it,
click the Help menu, click Activate, and
then follow the instructions.

You can complete or update your
Adobe ID profile. An Adobe ID allows
you to access Adobe online services.
To complete or update your Adobe ID
profiles, click the Help menu, click
Complete/Update Adobe ID Profile, and
then follow the online instructions.

1

3

4

5

2
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At some time, everyone has a question or two about using a program.
When you start Illustrator Help, the Adobe Community Help window
opens, displaying help categories and topics. You can search product
help from Local Help, Community Help, or Adobe.com by using key-
words or phrases or browsing through a list of categories and topics to
locate specific information. Local Help accesses product help on your
local computer, Community Help accesses product help online, and
Adobe.com accesses related help information on Adobe.com. When
you perform a search using keywords or phrases, a list of possible
answers is shown from the search location with the most likely
responses at the top. Along with help text, some help topics include
links to text and video tutorials. In addition, comments and ratings from
users are available to help guide you to an answer. You can add feed-
back and suggestions by signing in to Adobe.com using an Adobe ID.

2

Getting Help While
You Work

Get Help Information

Click the Help menu, and then
click Illustrator Help.

TIMESAVER Press F1 (Win) or
A+/ (Mac).

The Adobe Community Help
window opens.

Click Help categories (plus sign
icons) until you display the topic
you want.

Click the topic you want. 

Read the topic, and if you want,
click any links to get information
on related topics or definitions. 

When you’re done, click the Close
button (Win) or click the Adobe
Help menu (Mac), and then click
Quit Adobe Help.

5

4

3

2

1

3

1

5

4

Click to collapse/
expand panel

Click to open help in a PDF 
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Search for Help Information

In Illustrator, on the Application
bar, type one or more keywords in
the Search box, and then press
Enter (Win) or Return (Mac). 

◆ You can also click the Help
menu, and then click Illustrator
Help to open Help and use the
Search box.

The Adobe Community Help
window opens, displaying a list of
topics that match the keywords
you entered in the Search box.

To search another CS product,
click the Select Product list arrow,
and then select a CS product. 

To refine a search, click Search
Options to expand it, and then
select any of the following options:

◆ Search This Help System Only.
Select to constrain the search
to the selected product.

◆ Search Location. Select Local
Help, Community Help, or
Adobe.com.

◆ Filter Results. For Adobe.com,
select a filter option.

Click the link to the topic you want
from the search list of results. 

◆ What’s New. Click the plus sign
(+) next to Resources, and then
click What’s New. 

Read the topic, and if you want,
click any links to get information
on related topics or definitions. 

◆ Next and Previous Topics. Click
the Previous or Next button on
the right side of the Help web
page.

When you’re done, click the Close
button (Win) or click the Adobe
Help menu (Mac), and then click
Quit Adobe Help.

6

5

4

3

2

1

4

Participating in Adobe Product Improvement

You can participate in the Adobe Product Improvement Program. Click
the Help menu, click Adobe Product Improvement Program, and then
follow the on-screen instructions. This is an opt-in program that allows
you to test Adobe products and make suggestions for future products.
This program enables Adobe to collect product usage data from cus-
tomers while maintaining their privacy. 

For Your Information

623

5

Search results

1
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Saving a Document

Save an Illustrator Document

Click the File menu, and then click
Save As.

Enter a name for the file.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click Adobe Illustrator (*.AI).

Navigate to the location where
you want to save the document. 

Click Save.

Select from the available options:

◆ Version. Specify an Illustrator
version in which to save.

◆ Fonts. Specify when to embed
the entire font or characters. 

◆ Create PDF Compatible File.
Select to save a PDF in the file.

◆ Include Linked Files. Select to
include linked files.

◆ Embed ICC Profiles. Select to
embed the color profiles.

◆ Use Compression. Select to
compress the file.

◆ Save Each Artboard To A
Separate File. Select to save
artboards in a file.

◆ Transparency. Specify options
for transparent objects.

Click OK.7

6

5

4

3

2

1

When you finish working on your Illustrator document, you need to save
it before you close the document or exit Illustrator. Before you save a
file, you should ask yourself, What is the intended final output of the
image? Each output device, whether monitor or paper-based, requires a
specific format. A file type specifies the document format (for example,
a template) as well as the program in which the file was created (for
example, Illustrator). You might want to change the type if you’re creat-
ing a custom template or sharing files with someone who doesn’t have
the Adobe Illustrator program. If you have multiple artboards, you can
save them in separate files. If you’re saving a document created in an
earlier version of Illustrator, known as a legacy format (New!), you’ll get
a dialog box, asking if you want to continue.

32

5

6

7

4



ptg8126863

Chapter 1 Getting Started with Illustrator CS6 27

Save a Document in Other
Formats

Click the File menu, and then click
Save As.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then select a format.

◆ Adobe FXG. Creates a FXG
(Adobe Flex) graphics file.

◆ Adobe PDF. Creates a PDF
(Portable Document Format)
document.

◆ Illustrator EPS. Creates an
Illustrator-based EPS image
file.

◆ SVG or SVG Compressed.
Creates a SVG (Scalable Vector
Graphics) image file.

Enter a name for the file.

Navigate to the location where you
want to save the document. 

Click Save.

Specify the options that you want
for the file type (options vary), and
then click OK.

◆ For help, point to an option to
display a description at the
bottom of the dialog box. 

6

5

4

3

2

1

Did You Know?
You can save a copy of an Illustrator
document. Open the document that you
want to save as a copy, click the File
menu, click Save A Copy, specify a
name and location, click Save, specify
Illustrator options, and then click OK. 

You can revert to the last saved ver-
sion. Click the File menu, and then
click Revert.

2

4

5

3

6

Warning for legacy format
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After you work on a document, you can finish up by closing the docu-
ment or by exiting Illustrator. You should save the document before
closing it. Exiting Illustrator closes the current document and the
Illustrator program and returns you to the desktop. You can use the Exit
command on the File menu (Win) or Quit Illustrator command on the
Illustrator menu (Mac) to close a document and exit Illustrator, or you
can use the Close button on the Illustrator Document tab. If you try to
close a document without saving your final changes, a dialog box
opens, asking if you want to do so.

Finishing Up

Close a Document

Click the Close button on the
Document tab, or click the File
menu, and then click Close.

TIMESAVER Press Ctrl+W
(Win) or  A+W (Mac) to close a
document.

If necessary, click Yes to save any
changes you made to your open
documents before the program
quits.

Exit Illustrator

Choose one of the following:

◆ Click the Close button, or click
the File menu, and then click
Exit (Win). 

◆ Click the Illustrator menu, and
then click Quit Illustrator
(Mac). 

TIMESAVER Press Ctrl+Q
(Win) or A+Q (Mac) to exit
Illustrator.

If necessary, click Yes to save any
changes you made to your open
documents before the program
quits.

2

1

2

1
1

1 Exit (Win) Click to exit (Win)

Document tab
Close button
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Creating and Viewing a
Document

Introduction

You can either open an existing document or create a new
one to work on in Illustrator. When you create a new docu-
ment, you can create one from scratch or use one of the
built-in profiles, such as print, web, mobile, devices (iPad,
iPhone, Xoom, Fire/Nook or Galaxy S), film, and video. The
built-in profiles make it easy to create documents for specific
purposes without the hassle of specifying individual settings.
However, if you know the individual settings you want, you
can create a new document from scratch. 

At the same time you create a new document, you can
also create multiple artboards. Artboards are regions of a
document that contain printable artwork. Multiple artboards
are useful for creating documents with different sizes, creat-
ing and organizing artwork elements in different places
within the same document, and creating multiple-page PDFs. 

Having problems squinting at the small details of an
image? Using the Navigator panel or Zoom tool is a great
way to get you focused where you need to be. Zooming into
a specific section of a document makes touching up the fine
details just that much easier. 

Illustrator's navigation and measurement systems—rulers,
grid, guides, smart guides—are more than just information;
they represent control of the document and control of the
creative process. In addition, the Info panel gives you up-to-
date information on the exact position of the cursor inside
the document, as well as detailed color information that can
be indispensable in preparing your designs. 2

2
What You’ll Do

Create a New Document

Create a New Document Using
Document Presets

Create a New Document from a
Template

Set Up a Document

Use and Work with Multiple Artboards

Change the Display View

Change the View with the Navigator
Panel

Customize the Navigator Panel

Change the Screen Display Mode

Change the View with the Zoom Tool

View and Use Rulers

Use Guides and Smart Guides

Use the Grid

Move Around with the Hand Tool

Use Crop Marks

Work with the Info Panel

Use Undo and Redo

Create and Select Workspaces

29
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Creating a New
Document 

Create a New Document

Click the File menu, and then click
New.

Type a name for the document.

Click the Profile list arrow, and
then select a preset, or choose
your own options to create a
custom document.

◆ Number of Artboards. Specify a
number, and then select options
for arrangement and spacing.

◆ Size. Select from the various
sizes, such as Letter or Legal.

◆ Width and Height. Select from
various measurements, such as
points, centimeters, or inches.

Click the Advanced button (if
necessary), and then select the
advanced options you want: 

◆ Color Mode. Select a color
mode, such as RGB or CMYK.

◆ Raster Effects. Select the
resolution for raster effects.

◆ Preview Mode. Default displays
artwork in vector view; Pixel
displays artwork with a
rasterized look, and Overprint
displays an ink preview.

◆ Align New Objects to Pixel
Grid. Sets an object to have its
vertical and horizontal paths
aligned to the pixel grid.

Click OK.5

4

3

2

1

Creating a new Illustrator document requires more thought than creat-
ing a new word processing document. For example, there are bleed,
color mode, and raster effect considerations to keep in mind. You can
create as many new documents as you need. However, since opening
more than one document takes more processing power, it's probably
best to work on only one new document at a time. Once a new docu-
ment is created, you have access to all of Illustrator's design and
manipulation tools to create anything you can imagine. 

3

Selecting a Color Mode
A color mode determines how Illustrator displays and prints an
image. You choose a different color mode (based on models used in
publishing) for different tasks. You can choose a color mode when
you create a new document or change a color mode for an existing
document. The common color modes include: RGB (Red, Green, and
Blue). Best for online and multimedia color images. Red, green, and
blue are also the primary colors on a monitor. CMYK (Cyan, Magenta,
Yellow, and Black). Best for commercial printing of color images. A
color space is a variant (such as Adobe RGB or Apple RGB, of a color
mode and has a specific gamut (range) of colors for different devices
(monitor, scanner, printer, printing press, or digital camera). 

For Your Information

4

5

2
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When you create documents for specific purposes, such as print, web,
film, video, or for use on a mobile device, you know the importance of
creating documents that will perfectly match the output requirements
of the intended file destination. The preset file sizes available in the
Profile menu let you create images at a size and pixel aspect ratio that
compensate for scaling when you incorporate them into various output
modes. When you work with the Profile menu, the guesswork involved
in creating compatible photo, web, mobile, device (including iPad,
iPhone, Xoom, Fire/Nook or Galaxy S) (New!), video and film, or Adobe
Flash Builder (New!) documents in Illustrator is a thing of the past. 

3

Creating a New
Document Using
Presets

Create a New Document 
Using Presets

Click the File menu, and then click
New.

Click the Profile list arrow, and
then select a preset:

◆ Print
◆ Web (New!)
◆ Mobile
◆ Devices (New!)
◆ Video and Film
◆ Basic RGB

◆ Flash Builder. An Adobe
development tool (New!).

◆ Custom

Click the Size list arrow, and then
select the preset you want; options
vary depending on the profile type.

◆ Print. For example, Letter or
Legal.

◆ Web. For example, 960 x 560 or
1280 x 800 (New!).

◆ Mobile. For example, 768 x 1024.

◆ Devices. For example, iPad,
iPhone, Xoom, Fire/Nook or
Galaxy S (New!).

◆ Video & Film. For example,
HDTV 1080.

If you want, adjust the available
options.

Click OK.5

4

3

2

1

Enter name

Using Adobe Flash Builder
Adobe Flash Builder is a stand-alone professional interaction devel-
opment tool for rapidly creating cross-platform, interactive content
for mobile (Google Android and Apple iOS), web, and desktop appli-
cations using ActionScript 3.0 and the open source Flex framework.
You can transform artwork created in Adobe Illustrator, Photoshop,
and Fireworks into interactive designs. For example, you can create
screen designs or graphics in Illustrator, open the artwork in Flash
Builder, and add interactive components to it, yet still maintain the
ability to make changes back in Illustrator without affecting the
Flash Builder content. For more information about Flash Builder and
where to get it, go to www.adobe.com/products/flash-builder.htm.

For Your Information

5

4

2

www.adobe.com/products/flash-builder.htm
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A template is a special document that makes it easier to create a new
document. If you frequently use an existing document, such as
Stationery, to start a new document, then you should create a template,
which uses the Illustrator Template (AIT) file format. You can create
your own template or use one provided by Illustrator. Illustrator comes
with a variety of templates, such as Banner Ads, Boxes, Brochures,
Business Cards, CD Cases, and Stationery. When you create a new
document from a template, the document appears as untitled with the
extension (AI), so you don’t mistakenly make and save changes over
the template file. 

Creating a New
Document from a
Template

Create a New Document 
from a Template

Click the File menu, and then click
New From Template.

◆ You can also click Templates in
the New dialog box.

The Templates folder appears,
displaying different types of
templates available for Illustrator.

Click the Files of Type (Win) or
Enable (Mac) list arrow, and then
click All Formats or a specific one.

Navigate to the location where the
template you want to use is stored.

Click the template file you want to
use. 

Click New. 5

4

3

2

1

4

5

2

3

New Untitled document from a template

See Also
See Chapter 3, “Working with Objects,”
on page 63 for information on selecting
and changing objects.
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Create a Template Document 

Open a new or existing document.

Create a custom document.

Click the File menu, and then click
Save As Template.

The Templates folder appears,
displaying different types of
templates available for Illustrator.

Type a name for the new template.

Click the Save as Type (Win) or
Format (Mac) list arrow, and then
click Illustrator Template (*.AIT), if
necessary.

Navigate to the location where
you want to store the template.

Click Save. 7

6

5

4

3

2

1
3 1 2
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After you create a document, you can use the Document Setup com-
mand on the File menu to change your document’s default options. In
the Document Setup dialog box, you can change options for bleed and
view, transparency, and type. For Bleed and View, you can change the
units of measure and bleed size, view images in Outline mode and high-
light substituted fonts and glyphs. For Transparency, you can change the
transparency grid size and color. If you regularly print or export trans-
parency, you can specify preset (New!) or custom flattener settings for
the best resolution for rasterizing transparent areas. For Type, you can
change the document language, double and single quotes styles, super-
script and subscript settings, and export options.  

Setting Up a Document

Change Document Options

Click the File menu, and then click
Document Setup.

Select from the following Bleed
and View Options settings:

◆ Edit Artboards. Click to close
the dialog box and use the
Artboard tools to edit
artboards.

◆ Units. Specify measurement
units for the document.

◆ Bleed. Specify the amount of
bleed around the edges of the
document.

◆ Show Images in Outline Mode.
Select to show image in Outline
mode.

◆ Highlight Substituted Fonts.
Select to highlight unavailable
fonts that are substituted for
existing fonts on your
computer. 

◆ Highlight Substituted Glyphs.
Select to highlight unavailable
type glyphs that are substituted
for existing glyphs on your
computer. 

Select from the following
Transparency settings:

◆ Grid Size. Specify a size (Small,
Medium or Large) for the
transparency grid.

3

2

1

2

3
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◆ Grid Colors. Specify an
intensity and color (Light,
Medium, Dark, Red, Orange,
Green, Blue, or Purple) for the
transparency grid.

◆ Simulate Colored Paper. Select
if you plan to print on colored
paper. This option replicates
the effect of colored paper. This
is shown when the
transparency grid is not visible.

◆ Preset. Specify a resolution
preset (High, Medium, Low, or
For Complex Art (New!)) or
select a custom setting. The
resolution depends on your
output device.

Select from the following Type
Options settings:

◆ Use Typographer’s Quotes.
Select to use curly quotes
instead of straight ones.

◆ Language. Specify the
language for the document.

◆ Double Quotes. Specify the
character for double quotes.

◆ Single Quotes. Specify the
character for single quotes.

◆ Superscript. Specify the size
and position (as a percentage)
for text that appears higher
than the text line.

◆ Subscript. Specify the size and
position (as a percentage) for
text that appears lower than
the text line.

◆ Small Caps. Specify the size (as
a percentage) for small cap
text.

◆ Export. Specify an option to
preserve text editability or
appearance.

Click OK.5

4

4

5
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Artboards are regions of a document that contain printable artwork. You
can use artboards as crop areas for printing or placement. They are
useful for working with multiple artwork elements. You can create multi-
ple artboards (1 to 100) at different sizes and position them anywhere on
the screen. You can create multiple artboards by using the New dialog
box, the Artboard tools in the Tools panel, or the Artboards panel.
Multiple artboards are useful for creating documents at different sizes,
creating and organizing artwork in different places within the same doc-
ument, and creating multiple-page PDFs. You can also specify custom
names for artboards, rearrange the artboard layout, reorder artboards,
and duplicate artboards.

Using Multiple
Artboards

Create an Artboard

Select the Artboard tool on the
Tools panel.

To use a preset dimension, click
the Preset list arrow on the Control
panel, and then select a preset.

Drag in the workspace (outside an
artboard) to create an artboard.

◆ To create an artboard within an
artboard, hold down Shift and
then drag.

To duplicate an existing artboard,
click to select the artboard, click
the New Artboard button on the
Control or Artboards panel, and
then click to place it. 

◆ To create multiple duplicates,
Alt-click instead as many times
as you want.

◆ To open the Artboards panel,
click the Window menu, and
then click Artboards.

Enter a name in the Name box on
the Control Panel. 

To navigate between artboards,
use the Navigation buttons on the
Status bar or on the Artboards
panel. 

To exit the artboard editing mode,
press Esc or click a different tool.

7

6

5

4

3
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1
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4 5 Artboards panel

Artboards panel button
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Change Artboard Options

Select the Artboard tool on the
Tools panel.

Select from the options below in
Step 3 on the Control panel, or
click the Artboard Options button
on the Control panel to open the
Artboard Options dialog box.

Select from the following options:

◆ Artboard Name. Specify a
name for an artboard.

◆ Preset. Specify artboard
dimensions using predefined
measurements.

◆ Width and Height. Specify the
size of the artboard.

◆ Orientation. Specify a portrait
or landscape orientation.

◆ Constrain Proportions. Keeps
the artboard size proportional.

◆ X and Y Position. Specifies the
position of the artboard.

◆ Show Center Mark. Displays
the center point in the artboard.

◆ Show Cross Hairs. Displays
cross hair lines through the
center of each artboard side.

◆ Show Video Safe Areas.
Displays guides inside the
video viewable area.

◆ Video Ruler Pixel Aspect Ratio.
Specify the aspect ratio for
artboard rulers.

◆ Fade Region Outside Artboard.
Displays the area outside the
artboard in a darker shade.

◆ Update While Dragging.
Displays the area outside the
artboard darker as you drag to
resize the artboard.

◆ Artboards. Displays the current
number of artboards.

Click OK.4

3

2

1
2

Artboard options on the Control panel

3

Working with Artboards and Objects
The Object menu includes an Artboard submenu that you can use to
convert objects (non-rotated ones that are not clipping masks) to
artboards, rearrange artboards, resize the artboard to the artwork
bounds, and resize the artboard to the select objects. Click the
Object menu, point to Artboards, and then click Convert to
Artboards, Rearrange, Fit To Artwork Bounds, or Fit To Selected Art. 

For Your Information

4
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After you create one or more artboards, you can edit and work with
them to display your artwork. You can view all of your artboards by
using Artboard Navigation on the Status bar or in the Artboards panel.
Each artboard is numbered and named so you can quickly switch
between them or reorder them. In order to work with an artboard, you
need to activate it first. You can only activate one artboard at a time.
After you activate an artboard, you can perform the following artboard
operations: change the view (outline or preview), resize, move the art-
board with or without its contents, rotate, and delete. In addition, you
can also change the artboard layout, display for artboard rulers, center
mark, cross hairs, and video safe areas. 

Working with Multiple
Artboards

Work with Multiple Artboards
◆ Artboards Panel. Click the Window

menu, and then click Artboards or
click the Artboards button. 

◆ Activate. Select the Artboard tool
on the Tools panel, and then click
an artboard or click an artboard in
the Artboards panel.

◆ Show or Hide Artboards. Click the
View menu, and then click Show
Artboards or Hide Artboards. You
can also press Shift+Ctrl+H (Win)
or Shift+A+H (Mac), and then
press an arrow key.

◆ Resize. Select the Artboard tool on
the Tools panel, point to the edge or
corner (cursor changes to a
double-arrow), and then drag to
resize the artboard.

◆ Move with or without Contents.
Select the Artboard tool on the
Tools panel, click to select or
deselect the Move/Copy Artwork
With Artboard button on the
Control panel, and then drag the
artboard.

◆ Delete. Select the Artboard tool on
the Tools panel, click the artboard
to activate it or select it in the
Artboards panel, and then click the
Delete button on the Control or
Artboards panel or press Delete.

◆ Rearrange Artboard Layout. Open
the Artboards panel, click the
Options button, click Rearrange
Artboards, select layout, columns,
and spacing options, and then 
click OK.

Artboards

Artboards panel

Rearrange Artboard options
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Switch Between Artboards

◆ Switch to a Specific Artboard.
Click the Artboard Navigation list
arrow on the Status bar, and then
select an artboard or click an
artboard in the Artboards panel.
You can also press Alt (Win) or
Option (Mac), and then press an
arrow key.

◆ First and Last Artboard. Click the
First or Last button on the Status
bar.

◆ Previous and Next Artboard. Click
the Previous or Next button on the
Status bar.

◆ Reorder Artboards. Open the
Artboards panel, select an
artboard, and then click the Move
Up or Move Down button.

Change the Artboard Display

◆ Rulers. Click the View menu, point
to Rulers, and then click Change to
Artboard Rulers.

◆ Center Mark. Select the Artboard
tool on the Tools panel, and then
click the Show Center Mark
button (toggle on/off) (New!).

◆ Cross Hairs. Select the Artboard
tool on the Tools panel, and then
click the Show Cross Hairs button
(toggle on/off) (New!).

◆ Safe Area. Select the Artboard
tool on the Tools panel, and then
click the Show Video Safe Areas
button (toggle on/off) (New!).

◆ View as Outline. Right-click the
artboard, and then click Outline. 

To preview the artboard, right-click
the artboard, and then click
Preview.

Switch between artboards

Artboard display options

Cross Hairs

Video Safe Areas

Center Marks
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Illustrator uses two main views: Preview and Outline. Preview displays
your artwork in color as it appears on the screen, while Outline dis-
plays your artwork as an outline, or paths. Outline view speeds redraws
for complex artwork. If your artwork doesn’t fit on a printed page, you
can use tiling options in the Print dialog box to print it. If you want to
see how it will print, you can change the view to show print tiling. You
can also view your artwork as it will appear in final output, either
printed or viewed on the web or a mobile device. If you like a certain
view with different options than the Preview or Outline views, you can
also create and work with custom views.

Changing the Display
View

Change the Display View

◆ Preview View. Click the View
menu, and then click Preview.

◆ Outline View. Click the View
menu, and then click Outline.

To view all artwork in a layer as
outlines, Ctrl-click (Win) or
Command-click (Mac) the eye icon
for the layer in the Layers panel.

To view all items in unselected
layers as outlines, Alt-Ctrl-click
(Win) or Option-Command-click
(Mac) the eye icon for the layer in
the Layers panel.

◆ Show Print Tiling. Click the View
menu, and then click Show Print
Tiling. To hide print tiling, click the
Show Print Tiling command again.

◆ Create a New View. Set up the
view the way you want, click the
View menu, click New View, enter
a name, and then click OK.

◆ Rename or Delete a View. Click
the View menu, click Edit Views,
select a view, rename it or click
Delete, and then click OK. 

◆ Switch Between Custom Views.
Click the View menu, and then
select a view by name. 

Outline view

Show Print Tiling

New view
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Display Output Views

◆ Overprint Preview Mode. Displays
an ink preview with blending,
transparency, and overprinting in
color separated output. Click the
View menu, and then click
Overprint Preview. 

◆ Separations Preview Mode.
Displays separations as they print.
Click the Window menu, and then
click Separations Preview. 

◆ Pixel Preview Mode. Displays the
artwork as it’s rasterized and
viewed on the web. Click the View
menu, and then click Pixel
Preview. 

◆ To view the pixel grid, zoom to
600% or higher in Pixel Preview
mode. To set preferences for
viewing pixel grid, click the
Illustrator (Mac) or Edit (Win)
menu, point to Preferences,
click Guides & Grid, select the
Show Pixel Grid (Above 600%
Zoom) check box, and then
click OK.

◆ Flattener Preview Mode. Displays
and highlights artwork areas that
are flattened when saved or
printed. Click the Window menu,
and then click Flattener Preview. 

◆ Soft Proofs. Displays your artwork
as it will appear on a monitor or
output device. Click the View
menu, point to Proof Setup, and
then select a proof.

Overprint preview

Separations preview

Separations Preview panel
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Illustrator's Navigator panel gives you an overall view of the image and
the ability to navigate through the document or change the zoom size.
Viewing images at different sizes gives you the ability to focus on small
elements of the design without actually changing the image in any way.
Once small areas of an image are enlarged, it's easier for you to make
minute changes. The Navigator panel contains a thumbnail view of the
image, and under the thumbnail are easy-to-use controls that let you
adjust the zoom of the image. In addition, changes made in the
Navigator panel are immediately viewable in the active document win-
dow (what you see is what you get). The Navigator panel gives you a
visible approach to changing the viewable area of the image. The view
box in the Navigator panel represents the visible boundaries of the
active document window, which is the viewable area of the image. 

Changing the View
with the Navigator
Panel

Change the View Size with the
Navigator Panel

Select the Navigator panel.

Use one of the following methods
to change the view size:

◆ Drag the triangular slider to the
right to increase the zoom or to
the left to decrease the zoom.

◆ Click the small and large
mountain icons, located to the
left and right of the triangular
slider, to decrease or increase
the zoom.

◆ Enter a value from 3.13% to
6400% into the Zoom box.

2

1

1

Click mountain icons to increase
or decrease the zoom.

Drag slider to zoomEnter a zoom value

Did You Know?
There are additional ways to zoom in
using the Navigator panel. In the View
box, hold down the Ctrl (Win) or
Command (Mac) key, and then drag to
resize the active document.

You can constrain the view box to
drag horizontally or vertically. Hold
down the Shift key, and then drag the
view box horizontally or vertically.



ptg8126863

Chapter 2 Creating and Viewing a Document 43

Change the View Area with the
Navigator Panel

Select the Navigator panel.

Drag the view box in the thumbnail
of the active image. 

Click within the thumbnail. 

The position of the view box
changes, which also changes the
viewable area of the image in the
document window.

3

2

1

3

1

2
Did You Know?

You can change the Zoom size of an
image using the Navigator thumbnail.
Hold down the Ctrl key (Win) or the A
key (Mac), and then drag in the thumb-
nail. When you release your mouse,
the selected area expands. It's just like
using the Zoom tool, except you're
dragging in the Navigator's thumbnail.
Conversely, if you drag a second time
(this time using a larger rectangle), the
image zooms out.

Navigator Panel Shortcut
You can control the view of the document through a great shortcut.
Simply click once in the Zoom input box on the Navigator panel, and
then use the Up/Down arrow keys to increase or decrease the zoom
value of the document 1% at a time. Not fast enough for you? Then
hold down the Shift key, and use the Up/Down arrow keys to change
the zoom size 10% at a time. 

For Your Information
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The colored box in the Navigator panel (proxy preview area) defines
the viewable area of the image. It's important for the colored lines of
the view box to stand out clearly against the image. The default color of
the view box is a light red; however, some documents contain elements
that are predominantly the same color as the colored lines of the view-
able area, making the viewing area difficult to identify. By changing the
color of the lines, you can make sure they stand out against the image.
This may seem like a small thing, but choosing a color that contrasts
with my image significantly cuts down on my frustration level when I'm
attempting to identify the viewable area. 

Customizing the
Navigator Panel

Change the View Box Color

Select the Navigator panel.

Click the Navigator Options button,
and then click Panel Options.

Click the View Box Color list
arrow, and then click a predefined
color, or click the Color Box to
select a custom color from the
Color Picker dialog box.

Specify a Greeking value (in point)
to set a size approximation for text
characters on the screen.

Select the Draw dashed lines as
solid lines check box to display
dashed lines as solid to make them
easier to view.

Click OK.6

5

4

3

2

1

View box

5

1

2

Did You Know?
You can increase the size of the
Navigator panel’s thumbnail. 
Drag the lower right corner of the
Navigator panel to expand the size of
the panel. As the Navigator panel
increases in size, so does the 
thumbnail.

3

6

4
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In Illustrator, the Screen Display mode determines the background dis-
played behind the active image. For example, you can choose a Screen
Mode that hides all the panels, title bar, or menu bar. Since monitor
backgrounds, combined with Illustrator's panels, add distracting colors
to your workspace, changing the Screen Mode gives you a chance to
isolate your image against a solid color background. Viewing your
images against a gray background helps your eyes identify the true col-
ors within an image.

Changing the Screen
Display Mode

Change the Screen Mode

Click Change Screen Mode button
to toggle between screen modes,
and then select the mode you
want:

◆ Normal Screen Mode. Displays
the artwork in a standard
window. All menus, panels, and
scroll bars are visible.

◆ Full Screen Mode with Menu
Bar. Displays the artwork full
screen. All menus, panels, and
scroll bars are visible.  

◆ Full Screen Mode. Displays the
artwork full screen. No title bar,
menus, or panels are visible.

TIMESAVER Press F to toggle
between the screen modes.

1

Full Screen Mode
with Menu Bar

Full Screen Mode

1

Normal Screen
Mode

Did You Know?
You can temporarily hide all of
Illustrator's panels and Tools panel.
Press the Tab key to hide the panels.
Press the Tab key a second time to dis-
play the hidden panels. Hold down the
Shift key, and then press the Tab key to
hide the panels, but not the Tools and
Control panels.
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Working with the Zoom tool gives you one more way to control exactly
what you see in Illustrator. Just like the Navigator panel, the Zoom tool
does not change the active image, but allows you to view the image at
different magnifications. The Zoom tool is located towards the bottom
of Illustrator's Tools panel, and resembles a magnifying glass. The max-
imum magnification of an Illustrator document is 6400%, and the mini-
mum size is 3.13%. Increasing the magnification of an image gives you
control over what you see and gives you control over how you work.
Large documents are difficult to work with and difficult to view. Many
large documents, when viewed at 100%, are larger than the maximum
size of the document window, requiring you to reduce the zoom in order
to view the entire image.

Changing the View
with the Zoom Tool

Zoom In the View of an Image

Select the Zoom tool on the Tools
panel. 

Use one of the following methods:

◆ Click on the document.The
image increases in
magnification centered 
on where you clicked. 

◆ Drag to define an area with the
Zoom tool. The image
increases in magnification
based on the boundaries of the
area you dragged.

◆ Set a specific view size. Click
the View Size on the Status bar,
and then select a specific
percentage size magnification.

◆ Fit in Window. Click the View
menu, and then click Fit All In
Window or Fit Artboard In
Window.

2

1

1

2

Zoom in 

Click and drag method
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Zoom Out the View of an Image 

Select the Zoom tool on the Tools
panel. 

Hold down the Alt (Win) or Option
(Mac) key, and then click on the
screen to reduce the zoom of the
active document.

The zoom reduction centers on
where you click on the active
document.

IMPORTANT The best way to
really see what the printed results
of your artwork will look like is to
view the image (even if it is too big
for the screen) at 100%.

2

1

1

Did You Know?
You can zoom in or out using shortcut
keys regardless of what tool you’re 
currently using. To zoom in, press
Ctrl+Spacebar (Win) or A+Spacebar
(Mac) and click or drag to define an
area. To zoom out, press Ctrl+Space-
bar+Alt (Win) or A+Spacebar+Option
(Mac) and click or drag to define an
area.

Zoom out

2
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Carpenters know that precise measurements are essential to making
things fit, so they have a rule: Measure Twice, Cut Once. The designers
of Illustrator also know that measurements are essential and give you
several measuring systems—among them are the rulers. Rulers are
located on the horizontal and vertical sides of the active document win-
dow, and serve several purposes. They let you measure the width and
height of the active image, they let you place guides on the screen to
control placement of other image elements, and they create markers
that follow your cursor as you move. Illustrator displays rulers for docu-
ments (known as global) and artboards at the top and left side of the
document window; you can only show and use one at a time. If you
want to show a ruler around an individual artboard, you can display the
video ruler. The point where 0 (zero) appears on each ruler is called the
ruler origin. The origin appears in the upper-left corner where the
rulers intersect. For artboards, the origin is oriented from the upper left-
corner and changes based on the active artboard. The coordinates of a
ruler are also saved with the document. The default measurement for a
ruler is in points, which you can change in Preferences.

Viewing and Using
Rulers 

Change Ruler Options

Click the Edit (Win) or Illustrator
(Mac) menu, point to Preferences,
and then click Units.

Click the General list arrow, and
then select a measurement from
the available options.

Click OK. 

IMPORTANT If the Rulers are
not visible in the active document,
click the View menu, point to
Rulers, and then click Show
Rulers.

3

2

1

2

3
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Work with Rulers

◆ Show or Hide Rulers. Click the
View menu, point to Rulers, and
then click Show Rulers or Hide
Rulers. 

TIMESAVER Press Ctrl+R
(Win) or A+R (Mac).

◆ Change to Artboard Rulers or
Global Rulers. Click the View
menu, point to Rulers, and then
click Change to Artboard Rulers or
Change to Global Rulers. 

TIMESAVER Press Alt+Ctrl+R
(Win) or Option+ A+R (Mac).

◆ Show or Hide Video Rulers. Click
the View menu, point to Rulers,
and then click Show Video Rulers
or Hide Video Rulers. 

◆ Change Measurement Units.
Right-click (Win) or Option-click
(Mac) a ruler, and then select a
unit of measure.  

◆ Change Ruler Origin. Point to the
upper-left corner where the rulers
intersect, and then drag the
pointer to where you want the new
ruler origin.

◆ Reset Ruler Origin. Double-click
the upper-left corner where the
rulers intersect.

Horizontal Ruler bar

Vertical Ruler bar

Did You Know?
You can switch guides on the fly. If
you're dragging a vertical or horizontal
guide onto the document window,
when in fact you wanted the opposite
guide, press the Alt (Win) or Option
(Mac) key, while still dragging the
guide. Vertical guides become horizon-
tal, and horizontal guides become 
vertical.

Ruler origin; intersection of rulers
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A guide is a vertical or horizontal line that helps you align text and
graphic objects. With the Snap to Guide command, you can align an
object to a guide. When the object’s edge comes within 2 pixels of a
gridline, it snaps to the guide point. You can use Guides & Grid prefer-
ences to set guides settings, such as color and style. To create and use
guides, the rulers must first be visible.

Using the Guides

Change Guides Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, point to Preferences,
and then click Guides & Grid.

Select from the following options:

◆ Color. Specify a grid color. Click
the Color box to specify a
custom color.

◆ Style. Specify a grid style,
either Lines or Dots.

Click OK.

Work with Guides

◆ Show or Hide Guides. Click the
View menu, point to Guides, and
then click Show Guides or Hide
Guides. 

◆ Lock Guides. Click the View menu,
point to Guides, and then click
Lock Guides.

◆ Snap an Object to Guides. Click
the View menu, and then click
Snap To Point.

When you drag an object near a
guide or anchor point, the object
snaps to it.  

3

2

1

Guide Snap to guide

2

3
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Create and Move Guides

Click the View menu, point to
Rulers, and then click Show
Rulers to display the ruler bars
within the document window.

Move to the vertical or horizontal
Ruler bar, and then click and drag
into the document.

Return to the Ruler bar and
continue to drag until you have all
your guides properly set.

Click the View menu, point to
Guides, and then click Lock
Guides to lock the existing guides
in place, or click Clear Guides to
remove all guides.

Click the Selection tool on the
Tools panel to drag existing guides
to a new position (make sure Lock
Guides is not selected).

5

4

3

2

1

Did You Know?
You can convert a vector object to a
guide. Select the object, click the View
menu, point to Guides, and then click
Make Guides. To convert it back, click
the View menu, point to Guides, and
then click Release Guides.

You can remove one guide at a time.
Make sure Lock Guides is clear, select
the guide, and then press Backspace
(Win) or Delete (Mac), or choose
Edit/Cut or Edit/Clear.

21

5

Guide
commands
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Using Smart Guides

Use Smart Guides

Open or create a multi-layered
document.

To turn Smart Guides on and off,
click the View menu, and then
click Smart Guides.

TIMESAVER Press A+U
(Mac) or Ctrl+U to show or hide
Smart Guides.

Select the Selection or Direct
Selection tool, and drag the
object.

◆ Press Ctrl (Win) or Command
(Mac) to use the center point or
edge of one object or artboard.

As you move the object, Smart
Guides appear to help you align
the objects.

Release the mouse and the guides
disappear.

4

3

2

1

Illustrator gives you the ability to use Smart Guides to help align
shapes, slices, and selections as you draw. They appear automatically
as you draw a shape or create a selection or slice, and then disappear
after the shape is drawn. They enable you to visually align one object to
another with a minimum of effort. Smart Guides also display alignment
and measurement information, such as distances between objects and
angles of rotation, to make alignment even easier. Smart Guides are
automatically turned on by default. You can use Smart Guide prefer-
ences to set color and information display options to customize your
Smart Guides. 

3

4

Did You Know?
You can snap symbol instances to
smart guides. In normal mode, you can
snap the contents of a symbols
instance to smart guides (not to the
bounding box like previous versions).
Symbols instances now behave like
groups for snapping.
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Change Smart Guide
Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, point to Preferences,
and then click Smart Guides.

Select from the following options:

◆ Color. Specify a guide color.

◆ Alignment Guides. Select to
display guides along the center
and edges of objects, artboard,
and bleeds.

◆ Anchor/Path Labels. Select to
display path intersection and
anchor point information.

◆ Object Highlighting. Select to
highlight objects below the
pointer as you drag.

◆ Measurement Labels. Select to
display tool or object location
information. 

◆ Transform Tools. Select to
display information when you
scale, rotate, and shear
objects.

◆ Construction Guides. Select to
display guides as you draw
new objects. Specify guide
angles for anchor points.

◆ Snapping Tolerance. Specify
how close the object must be
(measured in number of points)
before it snaps to the guide.

Click OK.3

2

1

2

3
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A grid is a checkerboard display that you can use to help you align text
and graphic objects. The grid appears behind your artwork, so it 
doesn’t get in the way. With the Snap to Grid command, you can align
an object to a grid line. When the object’s edge comes within 2 pixels of
a gridline, it snaps to the gridline point. You can use Guides & Grid pref-
erences to set grid settings, such as color, style, and spacing.

Using the Grid

Change Grid Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, point to Preferences,
and then click Guides & Grid.

Select from the following options:

◆ Color. Specify a grid color.

◆ Style. Specify a grid style, either
Lines or Dots.

◆ Gridline Every. Specify a
measurement for the interval of
gridlines (default 72 points).

◆ Subdivisions. Specify the
number of grid subdivisions.

◆ Grids In Back. Select to display
grids in back of your artwork.

◆ Show Pixel Grid (Above 600%
Zoom). Select to display pixel
grids above 600% view.

Click OK.

Work with the Grid

◆ Show or Hide Grid. Click the View
menu, and then click Show Grid or
Hide Grid. 

◆ Snap Object to Gridline. Click the
View menu, and then click Snap To
Grid.

◆ If the current view is set to Pixel
Preview, the Snap To Grid
command changes to Snap To
Pixel.

When you drag an object near a
gridline, it snaps to the gridline.  

3

2

1

Grid

2

3
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One of those little used, but handy, tools is Illustrator's Hand tool. The
Hand tool (so named because it resembles an open hand) lets you
quickly move the active image within the document window without
ever using the scroll bars. For example, you've zoomed the image
beyond the size that fits within the document window and you need to
change the visible portion of the document. It's a simple operation, but
a handy one to know.

Moving Around with
the Hand Tool

Move an Element Around in the 
Document Window 

Select the Hand tool on the Tools
panel.

Drag in the active document to
move the image. 

2

1

1

2

Did You Know?
You can quickly access the Hand tool
whenever you need it. Hold down the
Spacebar to temporarily change to the
Hand tool. Drag in the active document
to the desired position, and then
release the Spacebar. You're instantly
returned to the last-used tool. It’s
important to note that you cannot use
the Spacebar to access the Hand tool
if you are currently using the Type tool.

You can move more quickly between
tools using Spring-loaded keys. Rather
than go back to the Tools panel when
you want to switch tools, just hold
down the shortcut letter key for the
new tool, use the tool, and then let go
of the shortcut key and you'll be back
using the first tool.
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Crop marks (also known as trim marks) indicate where you want a
printer to cut the printed page. They are printed with black registration
lines so when separations are printed, the printer can align the pages.
You can create and display multiple crop marks, which are also useful
for trimming or aligning objects on an artboard or exporting them to
another program. You can create crop marks as noneditable live effects
or editable ones you can adjust and format. If you no longer need or
want crop marks, you can delete them. You can delete live effect crop
marks by selecting Crop Marks in the Appearance panel and using the
Delete Selected Item button at the bottom of the panel. You can also
delete editable crop marks by using the crop marks with the Selection
tool and pressing the Delete key. Crop marks do not replace trim marks
created with the Marks & Bleed options in the Print dialog box.

Using Crop Marks

Create and Delete Crop Marks
as Live Effects Around an Object

Select one or more objects.

Click the Effect menu, and then
click Crop Marks.

To delete crop marks, select Crop
Marks in the Appearance Panel,
and then click the Delete Selected
Item button.

3

2

1

Did You Know?
You can change the registration color.
The registration color is used for crop
marks and other marks used by com-
mercial printers to align printing plates.
If you need to change the registration
color so it stands out from the colors
used in your document, you can click
the Registration swatch in the
Swatches panel, and then move the
Tint slider on the Color panel.

2 1Crop marks

3

Select “Crop Marks”
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3 1Editable trim marks
Create and Delete Editable Trim
Marks Around an Object

Select one or more objects.

Click the Object menu, and then
click Create Trim Marks.

To adjust trim marks, select the
trim marks with the Selection tool
on the Tools panel, and then drag
an anchor point or segment.

To delete trim marks, select the
trim marks with the Selection tool
on the Tools panel, and then press
Delete.

To change the color of trim marks,
select the trim marks with the
Selection tool on the Tools panel,
and then change the stroke color
using the Control, Color, or Tools
panel.

5

4

3

2

1

4
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Illustrator's Info panel gives you a wealth of data on the current 
document. The Info panel displays information on the x and y (horizon-
tal/vertical) position of your mouse cursor within the active document
window. In addition, when you're using one of Illustrator's drawing,
measuring, or transformation tools, the Info panel gives you up-to-date
information on the size of the object you're creating. When an object is
selected, the Info panel display the x and y position, width (w) and
height (h). If you select multiple objects, only information that is the
same for all selected objects appears in the Info panel. When you’re
using the Zoom tool, the Info panel displays the magnification factor
and the x and y position. The Info panel also displays color information
when you choose to show options.

Working with the
Info Panel 

Create a Specific Size Object

Select the Info panel.

Select a drawing tool on the Tools
panel.

Drag in the document window to
create a shape.

Release the mouse when the Info
panel displays the correct
dimensions.

To display color fill and stroke
information and the name of any
pattern gradient or tint for a
selected object, click the Options
menu, and then click Show
Options.

5

4

3

2

1

Did You Know?
You can measure the distance
between objects. Select the Measure
tool in the Tools panel, and then click
two points, or click the first point and
drag to the second point. Use Shift-
drag to constrain the tool to multiples
of 45 degrees. The Info panel displays
the distances from the x and y axes,
the absolute horizontal and vertical
distances, the total distances, and the
angle measured.

1

5
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Probably one of the greatest inventions of the computer industry is the
ability to Undo, and Redo. Now, if we could just figure out how to give
real life an undo feature… that would be something. Illustrator gives us
the ability to undo our past mistakes, and redo something we wished
we had not undone.

Using Undo and Redo

Undo or Redo One Action 
at a Time 

◆ Click the Edit menu, and then click
Undo to reverse your most recent
action, such as typing a word or
formatting a paragraph.

TIMESAVER Press Ctrl+Z (Win)
or A+Z (Mac) to undo.

◆ Click the Edit menu, and then click
Redo to restore the last action you
reversed. 

TIMESAVER Press Shift+Ctrl+Z
(Win) or Shift+A+Z (Mac) to  redo
your undo.

Click to Undo or
Redo the previous
command or action.
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Creating and Selecting
Workspaces

Create a Workspace

Open and position the panels you
want to include in a panel set.

Click the Workspace menu on the
Application bar (the menu name
displays the current workspace),
and then click New Workspace.

◆ You can also click the Window
menu, point to Workspace, and
then click New Workspace.

Type a name in the Name box.

Click OK.

The panel set and its location is
now saved.

Display a Workspace

Click the Workspace menu on the
Application bar (the menu name
displays the current workspace),
and then select a panel option:

◆ Custom panel name. Displays a
custom panel layout that you
created.

◆ Automation, Essentials, Layout
(New!), Painting, Printing and
Proofing, Tracing (New!),
Typography, or Web. Displays
panel layouts created by Adobe
for specific uses in Illustrator.

1

4

3

2

1

As you work with Illustrator, you'll open, close, and move around win-
dows and panels to meet your individual needs. After you customize the
Illustrator workspace, you can save the location of windows and panels
as a workspace, which you can display by using the Workspace menu
on the Application bar or the Workspaces submenu on the Window
menu. You can create custom workspaces, or use one of the work-
spaces provided by Illustrator, which are designed for space and work-
flow efficiency. The built-in workspaces include Essentials, Automation,
Layout (New!), Painting, Printing and Proofing, Tracing (New!),
Typography, and Web. If you no longer use a custom workspace, you
can remove it at any time. You can also rename a custom workspace to
improve recognition.

3

1

Default workspaces

Custom workspace

4

2
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Delete a Workspace

Click the Window menu, point to
Workspace, and then click
Manage Workspaces.

The Manage Workspaces dialog
box opens.

Select the workspace you want to
delete.

Click the Delete button.

Click OK.

The workspace is now deleted.

Rename a Workspace

Click the Window menu, point to
Workspace, and then click
Manage Workspaces.

The Manage Workspaces dialog
box opens.

Select the workspace you want to
rename.

Type a new name.

The workspace is now renamed.

Click OK.4

3

2

1

4

3

2

1

Did You Know?
You can hide a panel. Click the
Window menu, and then click a panel
to remove the check mark.

2

2

3

3

4

4
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Working with Objects

Introduction

Adobe Illustrator is an application that that provides tools you
can use to work with vector graphics, which include vector
shapes and vector objects. Vector graphics are created using
mathematical shapes, not pixels, and that's why vector
shapes are considered resolution-independent. When you
draw a vector object, you create one or more lines called a
path. A path is made up of one or more curved or straight line
segments. The start and end points for a line segment is
known as an anchor point, which you can drag to change and
move. 

Illustrator provides drawing tools on the Tools panel that
you can use to create a variety of shapes, including rectan-
gles, rounded rectangles, ellipses, polygons, stars, flares,
lines, arcs, spirals, rectangle grids, and polar (circular) grids.
After you draw an object, you can use Illustrator selection
tools to modify it. The two main selection tools are the
Selection tool and the Direct Selection tool. The Selection tool
allows you to select entire objects, while the Direct Selection
tool allows you to select paths and segments. In addition to
these tools, you can also use the Select menu. The Select
menu provides a variety of powerful selection commands for
you to use in a document or artboard. For example, you can
select objects whose attributes (including Appearance,
Blending Modes, Fill & Stroke, Opacity, and Stroke Color) are
similar to the current or last selection. 

After you select one or more objects, you can move,
align, group, and transform them. The transformation tools
allow you to rotate, scale (resize), reflect (mirror image), or
shear (slant) an object. 

What You’ll Do

Understand Vector and Raster Images

Understand Paths

Select a Drawing Mode

Create Pixel Aligned Objects

Create Rectangles and Ellipses

Create Polygons and Stars

Create Line Segments

Create Arcs, Spirals, and Grids

Use the Shape Builder Tool

Create Perspective Objects

Use the Selection Tool

Use the Direct Selection Tool

Use the Lasso Tool

Use the Magic Wand Tool

Select and Group Objects

Save and Edit Selections

Move and Duplicate Objects

Align and Distribute Objects

Transform Objects

Rotate, Scale, Reflect, or Shear Objects

Apply Multiple Transformations

Reshape Objects with Envelopes
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Illustrator is an application that gives you
great control over vector graphics, which
include vector shapes and vector objects.
Vector graphics are created using mathemati-
cal shapes, not pixels, and that's why vector
shapes are considered resolution-independ-
ent. For example, if you enlarge a vector
image to 100 times its original size, Illustrator
merely changes the mathematical formulas to
reflect the new size, and since vector shapes
are constructed of mathematical data instead
of pixels, file sizes are extremely small.

Raster graphics, such as bitmaps and pho-
tographs, are images creating using individ-
ual pixels that identify one piece of color
information. The reason raster images are
considered resolution-dependent is that once
the image is created or scanned, any enlarge-
ment of the image forces Illustrator to enlarge
and average the existing color information in
the document. This process, called interpola-
tion, is what causes enlarged raster images to
become blurred, or pixelated. 

Understanding Vector and Raster Graphics

Raster ImageVector Image

Close up shows lines Close up shows pixels 
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When you draw an object, you create one or
more lines called a path. A path is made up of
one or more curved or straight lines, known
as segments. The start and end points for a
segment is called an anchor point. An anchor
point is a bending point to modify the line
segment. A path can be open or closed. An
open path has open-ended endpoints, such as
a line, while a closed path has connected end-
points, such as a circle. Paths can have two
types of anchor points: smooth points or cor-
ner points. A smooth point connects two
curved segments to create a smooth line,
while a corner point connects two straight or
curved segments to create a path direction
change. You can draw a path using both
smooth and corner points. The outline of a
path is called a stroke, which you can format
with different characteristics. You can specify
stroke weight (thickness), color, or a dashed
pattern. The interior of an open or closed path
is called a fill, which you can also format with
a color or gradient.

You can change the shape of a path by
dragging its anchor point. A selected anchor
point or endpoint appears as a solid square,
while an unselected one appears as a white
square.  When you select an anchor point
with a curved segment, a direction line
appears with direction points on each end,
which you can drag to change the shape of
the path. When you change the shape of a
smooth point with curved segments on each
side, both segments get changed. When you
change a shape of a corner point, the corner
is maintained, but adjusted based on the
change. 

Working with Anchor Points
In Illustrator, you can show or hide anchor
points, direction lines, and direction points by
choosing the View menu, and then choosing
Show Edges or Hide Edges. If you want to
show or hide direction lines for selected
anchor points, select the Direct Selection tool,
select the anchor point that you want, and
then click Show Handles For Multiple Selected
Anchor Points or Hide Handles For Multiple
Selected Anchor Points button in the Control
panel.

You can specify options in the Selection &
Anchor Display preferences to always show
handles when multiple anchor points are
selected (this option is turned off by default).

Understanding Paths

Closed path

Open path



ptg8126863

66 Chapter 3

Selecting a Drawing
Mode

Select a Drawing Mode

Select the Drawing Mode tool on
the Tools panel:

◆ Draw Normal. Draws an object
on top of any other object; the
default mode.

◆ Draw Behind. Draws an object
behind all objects (no selection)
or directly behind a selected
object.

◆ Draw Inside. Draws an object
inside a single selected object.

TIMESAVER Press Shift+D to
cycle through the Drawing Mode
tools.

1

In Illustrator, you can specify how and where you want to draw an
object. You can draw on top of an object, behind an object, or inside an
object using one of the following drawing modes: Draw Normal, Draw
Behind, or Draw Inside. Draw Normal mode is the default drawing mode
and the one used in previous versions of Illustrator. The Draw Behind
mode allows you to draw behind all objects on a selected layer (no
other objects selected). If an object is selected, the new object is drawn
directly behind it. The Draw Inside mode allows you to draw inside a
single selected object, which automatically creates a clipping mask
from the selected object. You can select a drawing mode at the bottom
of the Tools panel or use the Shift+D keyboard shortcut to cycle through
each one.

Did You Know?
You can create a clipping mask using
the Draw Inside mode. Select the path
you want to draw, and then click the
Draw Inside mode button on the Tools
panel. Subsequent paths are clipped
by the selected path until you switch to
the Draw Normal mode. The clipping
masks created using the Draw Inside
mode retain the appearance on the
clipping path unlike the Make com-
mand on the Clipping Mask submenu
on the Object menu. 

1

Draw Inside

Draw Behind

Draw Normal

Draw Normal

Draw Behind

Draw Inside
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Creating Pixel Aligned
Objects

Work with Pixel Aligned
Objects
◆ Align All Objects in a New

Document. Click the File menu,
click New, specify new document
settings, select the Align New
Objects To Pixel Grid check box in
the Advanced section, and then
click OK.

◆ Align Existing Objects. Select the
object, open the Transform panel,
and then select the Align To Pixel
Grid check box. If not available,
click the Options button, and then
click Show Options.

◆ Not Align Objects. Select the
objects you want to change, click
the Select menu, point to Object,
and then click Not Aligned To
Pixel Grid.

◆ View The Pixel Grid. Click the
View menu, click Pixel Preview,
and then zoom to 600% or higher. 

◆ To set preferences for viewing
pixel grid, click the Edit (Win)
or Illustrator (Mac) menu, point
to Preferences, click Guides &
Grid, select the Show Pixel
Grid (Above 600% Zoom) check
box, and then click OK.

Pixel aligned vector objects allow you to create precisely drawn images
that look crisp and sharp for use on different outputs, such as the Web
and mobile devices. The Align to Pixel Grid option enables the vertical
and horizontal segments of the paths of an object to be nudged and
aligned to the pixel grid. The stroke width values become full integer to
create crisp paths. To view the pixel grid, zoom to 600% or higher in
Pixel Preview mode. The Align to Pixel Grid option remains enabled with
the object until it’s disabled. You can set the option in the Advanced sec-
tion of the New Document dialog box or the Options menu on the
Transform panel. The option in the New Document dialog box applies it
any new objects in the document. You cannot pixel-align objects without
paths, such as rasters, raster effects, and text objects.

Align To Pixel Grid option
in the Transform panel

Pixel Preview at 600% Object aligned to pixel grid
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Creating Rectangles
and Ellipses

Draw an Ellipse or Circle

Select the Ellipse tool on the Tools
panel. 

TIMESAVER Press L to select
the Ellipse tool.

Select a Stroke and Fill Color from
the Colors area of the Tools panel.

Click and drag on the artboard,
and then release the mouse. 

TIMESAVER Press and hold
Shift while you drag to create a
circle.

To create an oval or circle with a
specific width and height, click on
the artboard where you want the
top left corner, enter width and
height values, and then click OK.

4
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The Illustrator Tools panel includes several tools for quickly creating
simple geometric vector shapes. They are easy to use; you just click and
drag on the Stage to create the shapes. The Rectangle tool creates rec-
tangles with square or rounded corners. The Ellipse tool creates circular
shapes such as ovals and circles. These shapes can be comprised
either of Strokes, which are lines that surround and define the shape, or
Fills, which can be a color or texture inside the shape, or both.

Did You Know?
You can enter values ranging from 0 to
16,383 points (New!) in the Rounded
Rectangle Settings dialog box. A value
of zero gives you a straight-sided-
square. Higher numbers produce
squares with more rounded sides.

You can draw shapes without a stroke
or a fill. Set either of these properties
to No Fill in the Colors section of the
Tools panel or in the Color panel.

1
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4



ptg8126863

Chapter 3 Working with Objects 69

Draw a Rectangle or Rounded
Rectangle  

Click the Rectangle or Rounded
Rectangle tool on the Tools panel. 

TIMESAVER Press M to select
the Rectangle tool.

Select a Stroke and Fill color from
the Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse. 

TIMESAVER Press and hold
Shift while you drag to create a
square.

To create a square, rectangle, or
rounded rectangle with a specific
width and height, click on the
artboard where you want the top
left corner, enter width and height
values, and then click OK.

4

3

2
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Did You Know?
You can change the corner radius for a
rounded rectangle. While you drag a
rounded rectangle, press the Up Arrow
or Down Arrow key. To create square
corners, press the Left Arrow key. To
create corners with maximum round-
ness, press the Right Arrow key.

You can draw shapes with no stroke
or fill. If you want to draw an oval or a
rectangle without a stroke or fill, you
can set either of these options to No
Fill in the Colors area of the Tools panel
or in the Color panel.

You can create a flare shape using the
Flare tool. Select the Flare tool on the
Tools panel, click and drag on the art-
board, and then release the mouse. 
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Creating Polygons 
and Stars

Draw a Polygon or Star Shape

Select the Polygon or Star tool on
the Tools panel. 

The pointer becomes a crosshair
that you can drag anywhere on the
artboard.

Select a Stroke and Fill color from
the Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse. 

TIMESAVER Press and hold
Shift while you drag to create a
proportional shape.

To create a shape with a specific
radius and number of sides or
points, click on the artboard where
you want the center of the shape,
enter the following values, and
then click OK.

◆ Polygon. Enter a radius and
number of sides for the
polygon. To create a triangle,
enter 3 sides.

◆ Star. Enter radius 1 for the
distance from the center of the
star to the innermost points and
enter radius 2 for the distance
from the center to the
outermost points.

4
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The Polygon and Star tools work in much the same way as the Ellipse
and Rectangle tools do to allow you to easily create complex vector
shapes. You can use these tools to create either polygons or stars.
Polygons are shapes based on a center radius and a number of sides,
while stars are shapes based on two center radiuses: one for the dis-
tance from the center of the star to the innermost points, and another
for the distance from the center to the outermost points. Experiment
with several options to get the kind of shape you want.

1

2

3

Polygon options4

Star options4
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Creating Line
Segments

Draw a Line Segment

Click the Line Segment tool on the
Tools panel. 

The pointer becomes a crosshair
that you can drag on the artboard.

TIMESAVER Press \ to select
the Line tool.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the line is the length you need. 

TIMESAVER Hold down the
Shift key, and then drag to draw a
45, 90, or 180 degree line. 

To create a line with a specific
length and angle, click on the
artboard where you want the line
to begin, enter length and angle
values, select the Fill Line check
box to fill the line with the current
fill color, and then click OK.
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The Line Segment tool draws perfectly straight lines in any direction
you drag your mouse. In Illustrator, a line is called a stroke and there is
a variety of thicknesses, styles, colors, and fills that can be applied to it.
You can also create your own line style for specific types of dashed,
dotted, or artistic lines. You can constrain the path a line draws to 45-
degree angles or create closed shapes by intersecting the lines you
draw.

2
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Creating Arcs and
Spirals

Draw an Arc

Click the Arc tool on the Tools
panel. 

The pointer becomes a crosshair
that you can drag on the artboard.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the arc is the length you need. 

To create an arc with specific
settings, click on the artboard
where you want the arc to begin,
enter x and y lengths, specify type
(open or closed), arc direction
(Base Along) and slope options,
select the Fill Arc check box to fill
the arc with the current fill color,
and then click OK.

4
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The Arc and Spiral tools make it easy to create unique and interesting
shapes. These tools draw curved lines to create an individual arc or a
Spiral wind. An arc consists of an x and y axis length, open or closed
path, arc direction (known as the Base Along), arc slope, and arc fill
(optional). A Spiral consists of a radius from the center to the outermost
point in the Spiral, decay (the amount each wind decreases), number of
segments for the spiral, and Spiral style. Each full wind of a Spiral con-
sists of four segments.
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Draw a Spiral

Click the Spiral tool on the Tools
panel. 

The pointer becomes a crosshair
that you can drag on the artboard.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the Spiral is the length you need. 

To create a Spiral with specific
settings, click on the artboard
where you want the Spiral to
begin, enter a radius (distance)
from the center to the outermost
point, decay percentage (amount
of the wind decreases), the
number of segments, and style
options, and then click OK.
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Creating Grids

Draw Rectangle Grids

Click the Rectangle Grid tool on
the Tools panel. 

The pointer becomes a crosshair
that you can drag on the artboard.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the grid is the size you need. 

To create a grid with specific
settings, click on the artboard
where you want the grid reference
point, enter a width and height for
the grid, specify the number of
horizontal and vertical dividers,
select the Use Outside Rectangle
As Frame check box to replace
individual segments with a
separate rectangle object, select
the Fill Grid check box to fill the
grid with the current fill color, and
then click OK.
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The grid tools on the Tools panel allow you to create a rectangular or
circular polar grid. The Rectangular Grid tool creates rectangular grids
of a specified size and number of horizontal and vertical dividers. The
Polar Grid tool creates concentric circles of a specified size and spe-
cific number of concentric and radial dividers.
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Draw Circular Polar Grids

Click the Polar Grid tool on the
Tools panel. 

The pointer becomes a crosshair
that you can drag on the artboard.

Select a Stroke color from the
Colors area of the Tools panel. 

Click and drag on the artboard,
and then release the mouse when
the grid is the size you need. 

To create a grid with specific
settings, click on the artboard
where you want the grid reference
point, enter a width and height for
the grid, specify the number of
concentric and radial dividers,
select the Create Compound Path
From Ellipses check box to
replace circles with separate
compound paths, select the Fill
Grid check box to fill the grid with
the current fill color, and then 
click OK.

4

3

2

1

2

1

3

4



ptg8126863

76 Chapter 3

Using the Shape
Builder Tool

Create an Object with the Shape
Builder Tool

Click the Selection tool on the
Tools panel, and then select only
the paths you want to merge to
create a shape. 

Click the Shape Builder tool on the
Tools panel. By default, merge
mode is selected.

To break or extract a region from
the shape, click the selected
region. 

To merge paths, drag along the
region.  

The two regions get merged to
form a new shape. The attributes
from the region are applied to the
merging shapes.

TIMESAVER Pressing Shift as
you drag displays a rectangle
marquee for merging multiple
paths.

To erase paths, press Alt (Win) or
Option (Mac) and click the closed
region or edge you want to delete.
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The Shape Builder tool allows you to create complex objects by merg-
ing and erasing simpler objects. The Shape Builder tool selects edges
and regions of an object, which can be merged or erased to form a
new object. An edge is any section of a path that doesn’t intersect the
path of other selected objects and a region is a closed area. You can
also break overlapping objects to create new ones. The style attributes
of an object are adopted after the merge. By default, the Shape Builder
tool is in merge mode; however, you can switch to erase mode by using
the Alt (Win) or Option (Mac) key. Before you start using the Shape
Builder tool, you can set up and customize options, such as coloring
source, highlighting, and gap detection, to suit your own 
preferences.

2

1

3

4

5

Selected objects



ptg8126863

Chapter 3 Working with Objects 77

Set Shape Builder Tool Options

Double-click the Shape Builder
tool on the Tools panel. 

To detect and show the gap
between objects, select the Gap
Detection check box, and then
select a Gap Length, either Small
(3 points), Medium (6 points), or
Large (12 points), or select the
Custom check box and specify a
point size length.  

IMPORTANT Make sure the
gap length value is close to the
actual gap length, otherwise
Illustrator may not detect it.

Specify the Options and Highlight
settings you want:

◆ Consider Open Filled Path as
Closed. Select to create an
invisible edge for an open path
to make a region.

◆ In Merge Mode, Clicking
Stroke Splits the Path. Select
to split the parent path into two;
the first edge you click
specifies the split location. 

◆ Pick Color From. Select Color
Swatches or Artwork as the
source for coloring objects. If
you select Color Swatches,
select the Cursor Swatch
Preview check box to preview
and select colors. 

◆ Fill. Select to highlight the
merged area in gray or mouse
over the selected path.

◆ Highlight Stroke When
Editable. Select to highlight
strokes you can edit in the
color you select.

Click OK.4
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Creating Perspective
Objects

Draw Perspective Objects

Click the Perspective Grid tool on
the Tools panel.

◆ If the grid doesn’t appear, click
the View menu, point to
Perspective Grid, and then
click Show Grid. 

To select a perspective grid
preset, click the View menu, point
to Perspective Grid, point to a
Point Perspective (One, Two, or
Three), and then select a preset. 

To draw objects on the grid, do
any of the following: 

◆ Draw Perspective Objects.
Select a Line tool (other than
the Flare tool) or Rectangle
tool, and then drag to draw it. 

◆ Attach Normal Objects. Select
the plane to which you want to
use, select the normal object,
click the Object menu, point to
Perspective, and then click
Attach to Active Plane.

◆ Release Perspective Objects.
Select the attached object,
click the Object menu, point to
Perspective, and then click
Release with Perspective.

◆ Move Plane to Match Objects.
Select the existing object, click
the Object menu, point to
Perspective, and then click
Move Plane To Match Object. 

3
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The Perspective Grid tool allows you to display a perspective grid that
you can use to draw shapes and create scenes with 1, 2, or 3-point
perspective. For example, you can create a row of trees down a street
to create perspective. The perspective grid provides presets with a 1, 2,
or 3-point perspective to help you get started. You can change the
viewing angle and distance along with widgets to control vanishing
points, horizon height, ground level, and the origin. You can draw
objects directly on the perspective grid or attach existing ones to it. If
you want to match the depth or height of an existing perspective
object, you can use the Move Plane To Match Object command to
adjust the grid, so you can draw or adjust another object to it.

21

3 Drawn perspective object
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Adjust the Perspective Grid

Click the Perspective Grid tool on
the Tools panel.

◆ If the grid doesn’t appear, click
the View menu, point to
Perspective Grid, and then click
Show Grid. 

To select the active grid plane, click
a plane in the cube (Right, Left, or
Horizontal) in the Plane Switching
Widget. Click the area outside the
cube to select no plane.

To adjust the perspective grid, drag
the left or right controls on the grid
for any of the following: 

◆ Ground Level. Moves the
perspective grid. 

◆ Vanishing Points. Adjusts the
perspective in or out.

◆ Horizon Height. Adjusts the
horizon line up or down.

◆ Extend the Grid. Extends or
shortens the perspective grid.

◆ Grid Plane Controls. Adjust the
Right, Horizontal, or Left. 

◆ Grid Cell Size. Increases or
decreases the grid cell size.

◆ Origin. Adjusts the X and Y
coordinates of the grid plane. 

To set perspective grid related
options, click the View menu, point
to Perspective Grid, and then click
any of the following: 

◆ Show/Hide Rulers. Shows or
hides the ruler on the height line. 

◆ Snap to Grid. Snaps an object to
a perspective gridlines. 

◆ Unlock/Lock Grid. Unlocks or
locks the perspective grid. 

◆ Lock Station Point. Locks the
station point in place. When you
move one vanishing point, the
other one moves in sync. 
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1 point perspective 2 point perspective

3 point perspective
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Grid Plane Controls
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Horizon Level

Ground Level



ptg8126863

80 Chapter 3

Working with
Perspective Objects

Modify Perspective Objects

Click the View menu, point to
Perspective Grid, and then click
Show Grid.

Click the Perspective Selection
tool on the Tools panel.

To work with perspective objects
on the grid, do any of the following: 

◆ Move Perspective Objects.
Select the object, and then drag
it to another position or use the
Arrow keys. Press tilde (~) to
constrain the move to parallel.

◆ Move or Copy Perspective
Objects and Grid Plane.
Double-click a grid plane
control, click the Move All
Objects or Copy All Objects
option, click OK, and then drag
the grid plane control.

◆ Copy Perspective Objects.
Select the object, and then
Option+drag (Mac) or Alt+drag
(Win) it to another position.

◆ Resize Perspective Objects.
Select the object, and then drag
a resize handle.

◆ Add Normal Objects. Select the
active plane, and then drag the
normal object to the plane. 

◆ Add Text and Symbols. Select
an existing normal text or
symbol, and then drag it on the
active plane. To modify the text
and symbols, use the Edit Text,
Edit Perspective, and Isolate
Selected Object buttons on the
Control panel.
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The Perspective Selection tool allows you to select, move, scale, copy,
and transform objects in perspective. You can also add normal objects,
text, and symbols to the perspective grid. When you move or change a
normal object to the perspective grid, its appearance and scale change
to adhere to the grid. You can select perspective objects in the grid with
the Perspective Selection tool by clicking individual objects or dragging
a selection marquee, just like normal objects. 

Three perspective objects on the grid;
they were moved, copied and resized.

3
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Customizing a
Perspective Grid

Set Perspective Grid Options

Double-click the Perspective Grid
tool on the Tools panel.

Select the Show Active Plane
Widget check box to display it.  

Click the Widget Position list
arrow, and then select a position. 

Select the Anchor Point Of
Perspective Artwork or the
Intersection Of Gridlines check
boxes to specify the points where
you want to temporarily hide the
active plane with the Shift key. 

Click OK.

Create a Perspective Grid Preset

Click the View menu, point to
Perspective Grid, and then click
Define Grid to create a grid (steps
3 thru 6) or manually create one.

Click the View menu, point to
Perspective Grid, and then click
Save Grid As Preset. 

Type a name for the preset.

Specify the perspective grid
settings you want.

Specify the grid color & opacity
settings you want.

Click OK.

To edit a grid preset, click the Edit
menu, click Perspective Grid
Presets, select a preset, click Edit,
make changes, and then click OK.
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If you create your own perspective grid, you save it as a preset  for use
later. You can create a perspective grid by using the Define Grid com-
mand to set exacting measurements and options or by manually adjust-
ing an existing grid, and then saving it as a preset, which you can edit
at any time. When you create or work with an existing perspective grid,
you can set grid options to show or hide the active plane widget,
change the widget position, and specify which points you want to use
to temporarily hide the active plane with the Shift key.
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When you create vector graphics in Illustrator,
they are comprised of distinct segments that
can be selected separately or as a whole with
a variety of selection tools. The type of editing
you need to perform determines which tool
you use. For example, a simple rectangle is
comprised of four line segments that sur-
round the contour of the shape and one fill in
the center. Each of these parts can be selected
as a group with the Selection tool or individu-
ally with the Direct Selection tool. To select an
object using the fill, you need to deselect the
Object Selection by Path Only check box in
Selection & Anchor Display preferences. If an
object is behind another object, you can use
the keyboard shortcut A+click (Mac) or
Ctrl+click (Win) to select it. The pointer
changes to an arrow with a small caret on the
first A/Ctrl+click; as you continue to click, the
selection moves through the objects under
the pointer. To use this option, you need to
select the Control (Win) or Command (Mac)
Click to Select Objects Behind check box in
Selection & Anchor Display preferences.

In addition to the Selection and Direct
Selection tools, you can also use the Group
Selection tool to select all the anchor points
on a single path. With the Group Selection
tool, click to select an object, click twice to
select the object’s group, and click three times
to select the group within the group (if avail-
able). The Group Selection tool is useful for
working with multiple objects. If you want to
work with an individual object without affect-
ing other objects, it’s better to use Isolation
Mode. 

The Lasso tool is a classic selection tool
that allows you to select path points and seg-
ments by dragging a freeform marquee
around them. 

The Magic Wand tool allows you to select
objects of the same or a similar fill color,
stroke color, stroke weight, opacity, or blend-
ing mode.

Understanding Selections

Selection preferences
Selection tool

Lasso tool

Direct Selection tool

Magic
Wand

tool Group Selection tool
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Using the Selection 
Tool

Select an Object with the
Selection Tool 

Click the Selection tool on the
Tools panel. 

The pointer becomes an arrow.

TIMESAVER Press V to select
the Selection tool.

Position the arrow on the edge of
the object, and then click it. 

◆ You can also drag a marquee
across all or part of the object
to select the entire path.

◆ If the path has a color fill,
appears in Preview mode, and
the Object Selection by Path
Only check box is deselected in
Selection & Anchor Display
preferences, you can also click
the fill to select the object.

To add or subtract objects from the
selection, hold down the Shift key,
and then click unselected objects
to add or click selected objects to
subtract them from the selection.
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There are several ways to select objects in Illustrator. With the
Selection tool, you can select an object's stroke or fill. You can only
select an object using the fill if the path appears in Preview mode, and
the Object Selection by Path Only check box is deselected in Selection
& Anchor Display preferences. After you select one or more objects,
you can add or subtract objects to/from the selection. In addition, you
can use the Selection tool and drag a marquee to select parts of the
object or drag over a portion of it to create a selection rectangle.
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Using the Direct
Selection Tool

Select Anchor Points and
Segments with the Direct
Selection Tool 

Click the Direct Selection tool on
the Tools panel. 

The pointer becomes an arrow.

TIMESAVER Press A to select
the Direct Selection tool.

Position the arrow on the edge of
the path and click to select a
segment, and then click an anchor
point to select it.

◆ You can also select an anchor
point directly. Pass the pointer
over a path, point to an anchor
point and then click it.

◆ You can also drag a marquee
across all or part of the object
to select the entire path.

To add or subtract anchor points
or segments from the selection,
hold down the Shift key, and then
click unselected items to add them
or selected items to subtract them
from the selection.
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With the Direct Selection tool, you can select individual points and seg-
ments of a path. After you select one or more individual points and seg-
ments, you can add or subtract items to/from the selection. In addition,
you can also use the Direct Selection tool and drag a marquee to select
parts of the path or drag over a portion of it to create a selection rec-
tangle.
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Using the Lasso Tool

Select with the Lasso Tool

Click the Lasso tool on the Tools
panel. 

Draw around the shapes you want
to select. 

To complete the selection, return
to the point where you started.  
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Use the Lasso tool when you want to select shapes that are very close
to shapes you don't want to select. This tool allows you to draw around
the shape, selecting everything contained within the drawn area. When
you draw a selection, you can drag across a path to include it in the
selection instead of dragging completely around it. This selection tool is
useful when you are working with overlapping paths.

Did You Know?
You can select single or multiple
objects. Holding the Shift key adds line
segments and fills them. Shift-clicking
selected items deselects them. 
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The Magic Wand tool (so named since it looks like a magic wand) is
unique in the fact that you do not drag and select with this tool; you
simply click. The Magic Wand tool creates a selection based on the
shift in brightness ranges within an image. If there is a definable shift in
the brightness of the pixels, it can be a very powerful tool for the selec-
tion of odd-shaped areas. To use the Magic Wand, click on the Magic
Wand Tool button on the Tools panel.

Using the Magic 
Wand Tool

Select Options for the Magic
Wand Tool

Double-click the Magic Wand tool
on the Tools panel.

◆ You can also click the Window
menu, and then click Magic
Wand to display the panel.

Click the Options menu, and then
select the Show Stroke Options
and Show Transparency Options
(if necessary) to display them in
the Magic Wand panel.

◆ You can also click the double-
arrow next to the Magic Wand
title to display options.

Select the check box for the
attributes that you want the Magic
Wand to select. The options
include: Fill Color, Stroke Color,
Stroke Weight, Opacity, or
Blending Mode. 

Enter a Tolerance value (0 to 255).
The higher the value, the more
information the Magic Wand tool
selects.

To select objects on all layers,
click the Options menu, and then
select Use All Layers to check it.
Select it again to select objects
only on the current layer.

To reset all fields in the Magic
Wand panel, click the Options
menu, and then click Reset.
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Use the Magic Wand Tool

Select the Magic Wand tool on the
Tools panel.

Click an object area to make a
selection.

Depending on the options you
selected in the Magic Wand panel,
other objects with the same or
similar attributes (fill color, stroke
color, stroke weight, opacity, or
blending mode) are selected.

To add to the selection, hold down
the Shift key, and then click
another unselected object. 

To subtract from the selection,
hold down the Alt (Win) or Option
(Mac) key, and then click a
selected object.
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Selecting and grouping objects makes it easier to work with multiple
objects as if they were a single object. You can easily select, isolate,
cut, copy, paste, move, recolor, and transform a grouped object. You
can group all types of objects, yet still edit individual objects within the
group as needed without having to ungroup them first by using
Isolation Mode. Illustrator places a grouped object on the top level of
the top object in the group and uses the same selection color. If you no
longer need to group objects, you can ungroup them. 

Selecting and
Grouping Objects

Create a Group

Select the Selection tool on the
Tools panel.

Use a selection method to select
the objects that you want in the
group.

Click the Objects menu, and then
click Group.

◆ You can use the Group
command again to group
objects already in a group; this
is known as a nested group. 

Ungroup Objects

Select the Selection tool on the
Tools panel.

Select the grouped objects that
you want to ungroup.

Click the Objects menu, and then
click Ungroup.

◆ If you have nested groups
within an object, you can use
the Ungroup command again to
ungroup it. 
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Use Isolation Mode to Work
with Groups

Select the Selection tool on the
Tools panel.

Double-click a grouped object.

◆ You need to click the Isolate
Selected Object button on the
Control panel or select the
Double-click to Isolate check
box in General preferences.

A gray bar appears with the name
of the group at the top of the
document window. All objects
outside the group are dimmed out
and uneditable. The words
“Isolation Mode” also appear on
the Layers panel.

Edit individual objects or add new
objects to the group.

To exit Isolation Mode, click the
gray bar. 
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The Select menu provides a variety of powerful selection commands
for you to use in a document or artboard. In addition to the common
commands, such as All, Deselect, and Inverse, you can also select
objects whose attributes (including Appearance, Blending Modes, Fill &
Stroke, Opacity, and Stroke Color) are similar to the current or last
selection. For more selection power, you can select objects based on
the object type (including All on Same Layers, Direction Handles,
Bristle Brush Strokes, Clipping Masks, Stray Points, Text Objects).

Selecting Similar
Objects

Use the Select Menu to Select
Objects

Click the Select menu.

Select the command that you
want:

◆ All. Selects all objects in the
document. 

◆ All on Active Artboard. Selects
all objects in the active
artboard. 

◆ Deselect. Deselects all objects
in the document.

◆ Reselect. Reselects the most
recent selection.

◆ Inverse. Inverses the current
selection.

◆ Next Object Above. Selects the
next object above the current
selection. 

◆ Next Object Below. Selects the
next object below the current
selection. 
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Select Similar Objects or Object
Attributes

Select an object on which to base
the new selection or deselect all
objects to base the new selection
on the last selected object.

Click the Select menu, and then
point to Same or Object.

Choose the command that you
want to use to make a selection.

Select Objects in the Layers
Panel

Open the Layers panel.

Click the expand/collapse triangle
to display the layer that you want
to select.

Click the selection area on the
right side of the layer in the Layers
panel that has the object that you
want to select.

◆ You can also click the Select
menu, point to Object, and then
click All on Same Layers to
select all on a layer. 
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If you frequently select the same elements in a document, you can save
yourself some time by saving the selection with a name of your choice.
After you save a selection, the saved selection name appears as a
menu command at the bottom of the Select menu. When you need to
make the same selection, simply choose the command. When you no
longer use a saved selection, you can delete it. 

Saving and Editing
Selections

Save and Use a Selection

Make the selection that you want
to save.

Click the Select menu, and then
click Save Selection.

Enter a name for the selection.

Click OK.

Click the Select menu, and then
click the name of the saved
selection at the bottom of the
menu.

Edit a Saved Selection

Click the Select menu, and then
click Edit Selection.

Select the saved selection that
you want to rename or delete.

To delete a saved selection, click
Delete.

To rename a saved selection,
change the name in the Name box.

Click OK.5
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Moving an object or group of objects is very easy. The simplest way is
to drag the edge of an object in Outline or Preview view. If you want to
constrain the movement of the object in multiples of 45 degrees, then
use the Shift key as you drag. While you drag an object, Smart Guides
appear automatically to make it easier for you to align objects with
other objects. 

Moving Objects

Move an Object

Select the Selection tool on the
Tools panel.

Select one or more objects that
you want to move.

Drag the edge of an object.

◆ To constrain the movement of
the object to multiples of 45
degrees or the current angle in
General preferences, hold
down the Shift key as you drag. 

◆ If the path has a color fill,
appears in Preview mode, and
the Object Selection by Path
Only check box is deselected in
Selection & Anchor Display
preferences, you can also click
the fill to select the object.

3

2

1

See Also
See “Using Smart Guides” on page 52
for more information on setting Smart
Guide preferences and using Smart
Guides.

Did You Know?
You can delete an object. Select the
object that you want to delete, and
then press Delete, or click the Edit
menu, and then click Clear. 
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Duplicating objects can be a powerful way of creating geometrical art-
work. You can duplicate one or more selected objects by dragging
them, using Arrow keys, copying to and pasting from the Clipboard, or
using the Offset Path command. When you copy objects to the
Clipboard, you can paste them on an artboard several different ways:
Paste, Paste in Front, Paste in Back, Paste in Place, or Paste on All
Artboards. The Offset Path command duplicates a path (along with fill
and stroke attributes) and places it on the artboard based on the offset
distance specified in the Offset Path dialog box. The duplicate path is
reshaped to fit around the original path.

Duplicating Objects

Duplicate or Copy Objects

Select the Selection tool on the
Tools panel.

◆ If the object is in a group,
select the Direct Selection tool
on the Tools panel.

Use any of the following methods:

◆ Same Document. Hold down Alt
(Win) or Option (Mac), and then
drag the edge or fill of the
object. 

◆ Different Documents. Open the
documents side by side, and
then drag the edge or fill of the
object from one document to
another. 

◆ Copy/Paste from Clipboard.
Select the object, click the Edit
menu, and then click Copy.
Click in the target document or
artboard, click the Edit menu,
and then click Paste, Paste in
Front, Paste in Back, Paste in
Place, or Paste on All
Artboards.

◆ Keyboard. Select the object,
press Control (Win) or A
(Mac), and then use an Arrow
key to move the duplicated
object in the direction you
want. The duplicate object
moves away from the original
object based on the current
keyboard increment value in
General preferences.
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Duplicate Objects Using an
Offset

Select the Selection tool on the
Tools panel.

Select an object.

Click the Object menu, point to
Path, and then click Offset Path.

Enter the distance you want to
offset the duplicate path from the
original object.

Click the Joins list arrow, and then
select a bend style: Miter
(pointed), Round (circular), or
Bevel (square-cornered).

You can set a limit (1-16,000) to
determine when a mitered corner
changes into a beveled corner. A
low number creates a more
beveled corner, while a high
number creates a sharper corner.

Click OK.7

6

5

4

3

2

1
1

2

4

Results

6

7

5



ptg8126863

96 Chapter 3

Aligning and
Distributing Objects

Align or Distribute Objects

Select the Selection tool on the
Tools panel.

Select two or more objects to align
them or select three or more
objects to distribute them.

Select the Align panel or click
Align on the Control panel.

Click the Options menu, and then
click Use Preview Bounds. A
checked option uses the object’s
stroke weight and any applied
effects when aligning or
distributing.

If you want to align objects along
the edges of the artboard, click the
Align To button on the Align or
Control panel, and then click Align
to Artboard. Objects are moved on
the artboard based on the
alignment or distribution command
to the closest edge (top and
bottom, or left and right). 

If you want to align objects to a
key object, click an object to make
it the key object (a thick blue
outline appears and the Align To
Key Object option is selected in
the Align and Control panel).  

Use the alignment and distribution
buttons on the Align or Control
panel.

7
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In addition to using grids and guides to align objects to a specific point,
you can align a group of objects to each other. The Align panel buttons
make it easy to align two or more objects relative to each other or to
the page. To evenly align several objects to each other across the doc-
ument, either horizontally or vertically, select them and then choose a
distribution option. Before you select an align command, specify how
you want Illustrator to align the objects. You can align the objects in
relation to the document or to the selected objects. If you want to align
all the objects to another object, you can select and use a key object,
before you select an alignment option. 
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Transforming Objects

Transform an Object with the
Bounding Box

Click the View menu, and then
click Show Bounding Box to
display it.

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Use any of the following methods:

◆ Scale. Drag a corner handle to
scale along two axes; drag a
side handle to scale along one
axis; Shift-drag to scale
proportionally; hold down Alt
(Win) or Option (Mac), and then
drag to scale from the center.
Also hold down Shift to scale
from the center proportionally.

◆ Reflect. Drag a side handle all
the way across the object to
the other side. 

◆ Rotate. Point slightly outside a
corner handle (pointer changes
to a double arrow), and then
drag in a circular motion. 

To rotate an object 180
degrees, drag a corner handle
diagonally all the way across
the object.

To transform an object using exact
values or percentages, select the
Transform panel. 

5
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The easiest way to transform an object is to use the bounding box. With
the bounding box, you can quickly scale (resize), reflect (mirror), and
rotate an object. However, you cannot copy an object or move the ref-
erence point. As you drag to transform an object, you can use keyboard
keys to alter the results of a transformation. Experiment with the differ-
ent options to create some new results.
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Rotate
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Using the Free
Transform Tool

Transform an Object with the
Free Transform Tool

Select the Free Transform tool on
the Tools panel.

Select one or more objects to
transform.

Use any of the following methods:

◆ Scale. Drag a corner handle to
scale along two axes; drag a
side handle to scale along one
axis; Shift-drag to scale
proportionally; hold down Alt
(Win) or Option (Mac), and then
drag to scale from the center.
Also hold down Shift to scale
from the center proportionally.

◆ Reflect. Drag a side handle all
the way across the object to
the other side. 

◆ Rotate. Point slightly outside a
corner handle (pointer changes
to a double arrow), and then
drag in a circular motion. To
rotate in 45 degree increments,
Shift-drag. 

To rotate an object 180
degrees, drag a corner handle
diagonally all the way across
the object.

◆ Shear. Drag a side handle and
then hold down Ctrl (Win) or
A (Mac) as you continue to
drag. To constrain the
movement, also press Shift. To
shear from the center, also
press Alt (Win) or Option (Mac). 

3
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The Free Transform tool allows you to rotate, scale (resize), reflect (mir-
ror image), or shear (slant) an object. In addition, you can apply per-
spective and distortion to an object. However, you cannot copy an
object or move the reference point. As you drag to transform an object,
you can use keyboard keys to alter the results of a transformation. To
help you align the results the way you want, you can use Smart Guides
to make it easier.  

1

2

Shear
Shear results
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◆ Perspective. Drag a side
handle and then hold down
Ctrl+Alt+Shift (Win) or
A+Option+Shift (Mac) as you
continue to drag. 

◆ Distort. Drag a corner handle
and then hold down Ctrl (Win)
or A (Mac) as you continue to
drag. 

To use Smart Guides as you
transform an object:

◆ Select the Transform Tools
check box in Smart Guides
preferences.

◆ Click the View menu, and then
click Smart Guides to display
them.

◆ As you drag to transform an
object, smart guides appear in
your document, which you can
use to align the transformed
object.

To transform an object using exact
values or percentages, select the
Transform panel. 

◆ X & Y Coordinates. Enter X and
Y values, which refer to the
selected reference point; click
a white square to change it. 

◆ Width (W) & Height (H). Enter
width and height values. Use
the Lock icon to constrain
proportions.

◆ Rotate Angle. Enter a rotate
angle.

◆ Shear Angle. Enter a shear
angle.

◆ Align to Pixel Grid. Select to
pixel-align individual object to
the pixel grid. 

◆ Scale Strokes & Effects. Select
to scale strokes and effects
along with objects (New!). 

◆ Click the Options button to
select additional options.

5
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Perspective

Perspective
results
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Rotating and Scaling
Objects

Rotate or Scale an Object

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Select the Rotate or Scale tool on
the Tools panel.

To move the reference point, click
a new point.

Use the appropriate method:

◆ Rotate. Drag in a circular
motion. To rotate in 45 degree
increments, Shift-drag. 

◆ Scale. Drag away from or
toward the object. Shift-drag to
scale proportionally; hold down
Alt (Win) or Option (Mac), and
then drag to scale from the
center. Also hold down Shift to
scale from the center
proportionally.

◆ Scale and Flip. Drag across the
entire object. 

◆ Scale and Copy. Hold down
Alt+Shift (Win) or Option+Shift
(Mac), and then drag. 

To rotate or scale an object using
exact values or percentages,
select the Transform panel.
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After you create an object, you can change its orientation by rotating it
or change its size by scaling it. For a freeform rotation, when you want
to rotate the object in other than 90 or 180 degree increments, you can
use the Rotate tool. To resize an object, either smaller or larger, you can
use the Scale tool. With either tool, you can transform the object from
its center or the reference point. To rotate or scale an object using
exact values or percentages, use the Transform panel, which is avail-
able on the Control panel or Window menu.
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Reflecting and
Shearing Objects

Reflect or Shear an Object

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Select the Reflect or Shear tool on
the Tools panel.

To move the reference point, click
a new point.

Use the appropriate method:

◆ Reflect. Click to establish a
reference point, and then click
again to establish the axis of
reflection. 

◆ Shear. Drag away from the
object.

To reflect or shear an object using
exact values or percentages,
select the Transform panel.
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The Reflect and Shear tools on the Tools panel allow you to be creative
as you transform an object. The Reflect tool creates a mirror image of
an object, while the Shear tool creates a slanted image of an object. To
reflect or shear an object using exact values or percentages, open the
Transform panel, which is available on the Control panel or Window
menu.
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Applying Multiple
Transformations

Use the Transform Each Command

Select the Selection tool on the Tools
panel.

Select one or more objects to
transform.

Click the Object menu, point to
Transform, and then click Transform
Each.

Select the Preview check box to
view your object changes.

Do any of the following:

◆ Scale Horizontal or Vertical.
Specify to scale objects from their
reference point.

◆ Move Horizontal or Vertical.
Specify to move objects left or
right and up or down.

◆ Rotate Angle. Enter a rotate angle
or drag the dial. 

◆ Reflect X or Y. Select to create a
mirror reflection.

◆ Random. Select to apply random
transformations using the values
in the dialog box. 

◆ Scale Strokes & Effects. Select to
scale strokes and effects along
with objects (New!). 

◆ Transform Objects. Select to
transform only objects (New!). 

◆ Transform Patterns. Select to
transform only the object’s fill
pattern (New!). 

◆ Reference Point. Click a square to
change the reference point. 

Click OK or Copy (creates a copy and
applies the transformation).
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The Transform Each command allows you to transform—such as rotate,
reflect, scale, and shear—multiple objects relative to their reference
points instead of a single reference point. You can scale or move
objects, rotate objects by a specific angle, and create a mirror reflection
of the objects. If you want to create a unique effect, you can also have
Illustrator apply random transformations. You can also use the
Transform Effect command to create and modify similar effects. 
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Transformation
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Use the Transform Effect

Select the Selection tool on the
Tools panel.

Select one or more objects to
transform.

Click the Effect menu, point to
Distort & Transform, and then click
Transform.

Select the Preview check box to
view your object changes.

Do any of the following:

◆ Scale Horizontal or Vertical.
Specify to scale objects from
their reference point.

◆ Move Horizontal or Vertical.
Specify to move objects left or
right and up or down.

◆ Rotate Angle. Enter a rotate
angle or drag the dial. 

◆ Reflect X or Y. Select to create
a mirror reflection.

◆ Random. Select to apply
random transformations using
the values in the dialog box. 

◆ Scale Strokes & Effects. Select
to scale strokes and effects
along with objects (New!). 

◆ Transform Objects. Select to
transform only objects (New!). 

◆ Transform Patterns. Select to
transform only the object’s fill
pattern (New!). 

◆ Reference Point. Click a square
to change the reference point. 

◆ Copies. Enter the number of
copies you want.

Click OK.

To edit the transformation, select
the object, and then click
Transform on the Appearance
panel.
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Repeating a Transformation
The Transform Again command allows you to quickly repeat the last
transformation with the last-used values on a selected object. To use
the command, transform and select an object or group, click the
Object menu, point to Transform, and then click Transform Again or
press Ctrl+D (Win) or A+D (Mac).

For Your Information
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Reshaping Objects
with Envelopes

Distort Objects with an Envelope

Select the Selection tool on the
Tools panel.

Select one or more objects to
reshape.

Click the Object menu, point to
Envelope Distort, and then click
one of the following:

◆ Make With Warp. Uses a
preset warp shape.

◆ Make with Mesh. Uses a
rectangle grid.

◆ Make With Top Object. Uses an
object as the shape of the
envelope. The object needs to
be at the top of the stacking
order. 

Specify the options you want for
the envelope type; select the
Preview check box to view your
changes on the selected object.

Click OK.

Do any of the following:

◆ Reshape. Select the Selection
or Mesh tool, and then drag
any anchor points. 

◆ Delete Anchor Points. For a
mesh grid, select the Selection
or Mesh tool, select an anchor
point, and then press Delete.

◆ Add Anchor Points. For mesh
grid, select the Mesh tool, and
then click on the grid. 
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Envelopes are objects you can use to reshape other objects, except
graphs, guides, or linked objects. You can use one of the built-in
envelopes or create your own out of an existing object. The built-in
envelopes use warp shapes or a mesh grid as the object. After you
apply an envelope, you can edit the original object or the envelope
(anchor points), separately, using the Selection and Mesh tools on the
Tools panel. In addition, you can specify envelope options to determine
how objects are distorted to fit the envelope.
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Mesh point

Mesh grid
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Set Envelope Options

Click the Object menu, point to
Envelope Distort, and then click
Envelope Options.

To set options for an object, select
one or more objects to reshape.

Do any of the following:

◆ Anti-Alias. Select to smooth
rasterized images when
distorted with an envelope.

◆ Preserve Shape Using. Select
the option to specify how to
rasterized images preserve
their shape when distorted by
nonrectangular envelopes. Use
a clipping mask on the raster
image or apply an alpha
channel (transparency) to the
raster image.

◆ Fidelity. Drag the slider or enter
a number to specify how you
want to fit the envelope mold. 

◆ Distort Appearance. Select to
distort appearance attributes
along with an object’s shape.

◆ Distort Linear Gradient Fills.
Select to distort linear
gradients along with an object’s
shape.

◆ Distort Pattern Fills. Select to
distort pattern fills along with
an object’s shape. 

◆ Preview. Select to view your
changes in the Document
window. 

Click OK.4
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Working with Color

Introduction

When you create or open a document, Illustrator creates or
looks for a color profile, which specifies color usage in the
document. Color modes define the colors represented in the
active document. Although you can change the color mode of
a document, it is best to select the correct color mode when
you create a document. Illustrator's main color modes are
RGB (Red, Green, and Blue) for onscreen and web projects
and CMYK (Cyan, Magenta, Yellow, and Black) for commercial
printing projects. 

Illustrator provides several panels (Tools, Color, Swatches,
Color Guide, and Kuler) for you to use to work with color and
apply color to one or more objects. For example, the Color
panel lets you create colors using different sliders and spec-
trum color selectors. Illustrator not only lets you select virtu-
ally any colors you desire, it also lets you store those colors
for future use in the Swatches panel. Along with the panels,
Illustrator also provides the Live Color dialog box, which you
can use to change multiple colors in your artwork at the same
time by editing and applying color groups. This makes it easy
to recolor your artwork. 

As you start to use color in your document, it’s important
to view how your document will actually appear with your
current color settings. With Illustrator, you can view a soft
proof on your screen to quickly see a simulation of how your
colors will appear based on your output device. 4

4
What You’ll Do

Change Color Settings

Change Color Profiles

Work with Color Modes

Change Color Modes

Apply Colors

Work with the Color Panel

Work with the Swatches Panel

Create Groups in  the Swatches Panel

Work with Swatch Libraries

Add Colors Using the Kuler Panel

Replace or Invert Colors

Use the Color Guide Panel

Apply Color with the Color Guide Panel

Edit Colors with Live Color

Proof Colors on the Screen
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Illustrator does its best to manage color for you. However, sometimes
there are color conflicts or you have specific color requirements that
you want to use. When you create or open a document, Illustrator cre-
ates or looks for a color profile, which specifies color usage in the doc-
ument. The Color Settings dialog box allows you to specify color
settings and select options to deal with conflicts. The two main color
settings are Working Space and Color Management Policies. Working
Space controls how RGB and CMYK colors are used in a document that
doesn’t have an embedded profile, while Color Management Policies
controls how Illustrator works with color when opening files that don’t
have a color profile or one that doesn’t match your current color set-
tings from the RGB and CMYK menus. If you need to convert colors
between color spaces, use Advanced mode.

Changing Color
Settings

Change Color Settings

Click the Edit menu, and then click
Color Settings.

Click the Settings list arrow, and
then select from the following
preset color settings:

◆ Monitor Color. Useful for video
and on-screen content. Sets
the RGB working space to your
current monitor space.

◆ North America General
Purpose 2. Useful for screen
and print content in North
America. 

◆ North America Newspaper.
Useful for common newspaper
press conditions in North
America. CMYK values are
preserved.

◆ North America Prepress 2.
Useful for common printing
conditions in North America.
The default RGB color space is
set to Adobe RGB.

◆ North America Web/Internet.
Useful for non-print content on
the Web in North America.

Click OK to use the defined
settings, or select your own
custom settings on the next page.
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To create your own custom
settings, select from the following:

◆ Working Spaces. Controls how
RGB and CMYK colors are used
in a document that doesn’t
have an embedded profile.

Select Monitor RGB for
onscreen output; Adobe RGB
for photo inkjet printers
(converts RGB images to CMYK
images); ProPhoto RGB for
inkjet printers; and sRGB
IEC61966-2.1 for web output. 

◆ Color Management Policies.
Controls how Illustrator works
with color when opening files
that don’t have a color profile
or one that doesn’t match your
current color settings from the
RGB and CMYK menus.

Select Off to prevent the use of
color management, Preserve
Numbers to preserve the
document color profile for
CMYK documents, Preserve
Embedded Profiles to preserve
links to color profiles, or
Convert to Working Space to
use the working space color
(useful for the web).  

Select the appropriate check
boxes to choose if and when
Illustrator will warn you of
profile mismatches (no
warning, when opening the file,
or when pasting) or missing
profiles (when opening a file or
no warning).

Click More Options to specify
Conversion options that let you
control how Photoshop handles
the color changes as the profiles
change from one color space to
another. Click Less Options to
collapse the dialog box.

Click OK.6

5

4

Selecting Advanced Color Options
In the Color Settings dialog box, you can click the More Options but-
ton to set advanced color conversion options. You can set options
for the color engine, rendering intent, and whether to use black point
compensation. The color engine specifies the color management sys-
tem you want to use. The rendering Intent defines how the selected
color profile is converted from one color space into another. The Use
Black Point Compensation check box maps the full color range of the
source to the full color range of the destination profile.

Synchronizing Color Settings Using Bridge
If you're using Adobe Creative Suite, you can use Adobe Bridge to
synchronize your color settings for all programs in the suite. When
you synchronize your color settings, you can avoid color profile con-
flicts. In Adobe Bridge, click the Edit menu, and then click Creative
Suite Color Settings, select one of the settings, and then click Apply. 

For Your Information
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When you create or open a document, Illustrator creates or looks for a
color profile, which specifies color usage in the document. If a docu-
ment’s profile doesn’t match the current working color space or is
missing an assigned color profile, you can use the Assign Profile dialog
box to change or remove a profile to avoid conflicts. When you change
a color profile, color in your document may shift to match the new color
profile. 

Changing Color
Profiles

Change or Remove Color
Profiles

Click the Edit menu, and then click
Assign Profile.

Select one of the following
options:

◆ Don’t Color Manage This
Document. Select to remove a
color profile from your
document.

◆ Working RGB/CMYK. Select
when your document doesn’t
have an assigned profile or its
profile is different from the
current working space.

◆ Profile. Select to assign a
different profile to your
document.

Click OK.3
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Color modes define the colors represented in
the active document. Although you can
change the color mode of a document, it is
best to select the correct color mode at the
start of the project. Illustrator's main color
modes are RGB (Red, Green, and Blue) and
CMYK (Cyan, Magenta, Yellow, and Black). 

Color modes determine the number of col-
ors and the file size of an image. For example,
an RGB image has at least three colors (like a
printing plate), one for red, green, and blue
color information. Color modes not only
define the working color space of the active
document, they also represent the color space
of the output document. It's the document
output (print, press, or monitor) that ulti-
mately determines the document color mode.
Color modes do not just determine what col-
ors the eye sees; they represent how the col-
ors are mixed, and that's very important
because different output devices use different
color mixes. 

Therefore, when selecting a color mode,
know the file format of the document and
where it will be used. An image taken with a
digital camera and then opened in Illustrator
would most likely be in the RGB color mode.
An image displayed on a monitor would be
RGB, or possibly Indexed Color. A photograph
scanned on a high-end drum scanner would
most likely be in the CMYK color mode. An
image being sent to a 4-color press would be
CMYK, too. If you were creating a Illustrator
document from scratch, the color mode you
choose should represent the eventual output
destination of the document, such as on a
web page, to an inkjet printer, or a 4-color
press. 

Switching Between Color Modes
Unfortunately, images do not always arrive
in the correct format. For example, you
take several photographs with your digital
(RGB) camera, but the images are being
printed on a 4-color (CMYK) press, or you
want to colorize a grayscale image.
Changing color modes is a snap, but
changing the color mode of an image isn't
the problem. The problem is what happens
to the digital color information when you
change color modes. For example, if you
open an RGB image with the intent of
sending it out to a 4-color press (CMYK),
the smartest course of action is to remain
in the RGB color mode through the pro-
cessing of the image, and then convert the
image into the CMYK mode at the end. The
reason has to do with how Illustrator
moves between those two color spaces.
For example, if you move a color-corrected
CMYK image into the RGB color mode,
and then back to CMYK, the colors shift
because Illustrator rounds color values
during the change process. On top of that,
a CMYK image is 25% larger than an RGB
image, and the RGB color mode repre-
sents the color space of your monitor, not
a printing press. It is impossible to view
subtractive CMYK color on an RGB device.
If, however, the image originally came to
you as a color-corrected CMYK image,
then stay in and work inside that color
mode.

Working with Color Modes
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When you create a new document, you need to select a color mode,
either RGB or CMYK, depending on the type of document that you want
to produce. For web and other onscreen projects, RGB is the best
choice. For commercial printing, CMYK is the best choice. If you want
to create documents for both types of projects, you can save a copy of
the document and then change the color mode. When you change the
color mode, colors will convert to the mode in the document. You will
see a shift in color. 

Changing Color Modes

Change Color Modes

Click the File menu, and then click
Save As to make a copy of the
document.

Click the File menu, and then point
to Document Color Mode.

Click CMYK Color or RGB Color.

◆ If you don’t like the change, you
can use the Undo command on
the Edit menu to reverse the
color conversion.
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The Tools panel provides color boxes to make it easy for you to apply
fill and stroke colors. The color box in the foreground is the Fill box and
the outlined box in the background is the Stroke box. When you select
an object, fill, or stroke, the color boxes (also known as thumbnails), on
the Tools panel display the current colors. To change the fill or stroke
color, select an object, fill or stroke, select the Fill or Stroke box, and
then select a color from the Color, Swatches, or Color Guide panel.

Applying Colors 

Apply Colors to an Object, Fill 
or Stroke

Select an object, fill, or stroke
using the appropriate selection
tool. 

Click the Fill or Stroke color box
on the Tools panel to choose the
color's destination.

Click the Color button on the Tools
panel to apply a color or click
None to apply no color.

Use any of the following to change
the active fill or stroke colors:

◆ Select the Swatches panel, and
then click a color swatch to
change the color. 

◆ Select the Color panel, and
then specify a color using the
controls.

◆ Select the Color Guide panel,
and then click a color swatch
to change the color. 

◆ Double-click the Fill or Stroke
color box to open the Color
Picker dialog box, select a
color or enter color values, and
then click OK.

◆ To set default colors of black
and white, click the Default Fill
and Stroke icon on the Tools
and Color (New!) panels.

◆ To set switch the current fill
and stroke color, click the
Swap Fill and Stroke icon on
the Tools and Color (New!)
panels.

4

3

2

1

2

1

3

Color panel

Color Guide panel

Swatches panel

Stroke color

Default Fill and Stroke icon

Swap Fill and Stroke icon

Fill color
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Illustrator not only lets you select virtually any colors you desire, it also
lets you store those colors for future use. For example, you create a
color scheme for a recurring brochure and you want a way to save
those colors, or you're working on an Internet graphic and you need a
web-safe color panel. Whatever your color needs, Illustrator stands
ready to meet them. The Color panel gives you access to Illustrator's
color-generation tools. This single panel lets you create colors using
different sliders, spectrum color selectors, a grayscale ramp, and an
option that lets you create a color ramp for the current fill and stroke
colors. The CMYK spectrum displays a rainbow of colors in the CMYK
color gamut. Moving the eyedropper into the spectrum box and clicking
lets you select any color and gives you a visual representation of the
relationships between various colors. The Grayscale ramp gives you
linear access to the 256 available grayscale values.

Working with the
Color Panel

Work with the Color Panel

Select the Color panel.

Click the Options menu.

Select from the following Color
Sliders:

◆ Grayscale. Creates a single
slider going from white (0) to
black (100). Converts the lower
portion of the Color panel to a
grayscale ramp. Clicking
anywhere in the ramp changes
the active color.

◆ RGB. Creates three sliders (red,
green, and blue). Each slider
has a possible value from 0 to
255. Converts the lower portion
of the Color panel to the RGB
spectrum. Clicking anywhere in
the spectrum changes the
active color.

◆ HSB. Creates three additive
sliders (hue, saturation, and
brightness). Each slider has a
possible value from 0 to 255.

◆ CMYK. Creates four subtractive
sliders (cyan, magenta, yellow,
and black). Each slider has a
possible value from 0 to 100. 
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In web color (click to correct) 

Out of web color warning (click to correct)
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Converts the lower portion of
the Color panel to the CMYK
spectrum. Clicking anywhere in
the spectrum changes the
active color.

◆ Web Safe RGB. Creates three
sliders (red, green, and blue).
Each slider has a possible
hexadecimal value from 00 
to FF. Restricts the color
spectrum to only the 216 
web-safe colors.

To change a color, click a color
box, use a slider, enter specific
color values, or click a color in the
spectrum. The box with the red
diagonal line is the None color.

To change a color using the Adobe
Color Picker, double-click a color
box, select a color using the color
range or color mode options, and
then click OK.

5

4

5

Select options or click the color
range to select a color.

Cube indicates the color is not web-
safe; click to select the closest web
color. An alert triangle indicates the
color is out-of-gamut (non-printable).

Understanding Colors

In Windows, you can use the Color dialog box, which displays basic
and custom color squares and a color matrix with the full range of
colors in the color spectrum, to help you select a color. You can enter
RGB values for hue, saturation, and luminosity (also known as bright-
ness) to specify a color. Hue is a pure color (one without tint or
shade); the name of the color (red, green, etc.) is measured by its
location on the color wheel. Saturation is a measure of how much
white is mixed in with the color. A fully saturated color has vivid
tones; a less saturated color is more of a washed-out pastel.
Luminosity is a measure of how much black is mixed with the color. 
A very bright color contains little or no black. You can also change
the hue by moving the pointer in the color matrix box horizontally; you
can change the saturation by moving the pointer vertically, and the
luminosity by adjusting the slider to the right of the color matrix box.
On the Macintosh, you click one of the color modes and select a
color, using its controls. You can select RGB values by selecting the
color sliders at the top of the dialog box, then choosing RGB Sliders
from the pop-up menu, and dragging the Red, Green, and Blue slid-
ers. Or, you can enter values (color numbers) to select a color. You
can select hue, saturation, and brightness (or luminosity) values by
selecting Color Sliders, choosing HSB Sliders, then dragging the 
sliders or entering your own values.

For Your Information

Did You Know?
You can identify out-of-web colors. If
an out of web warning icon (a cube)
appears below the color boxes on the
Color panel, it indicates that the cur-
rent color is not web safe. Web safe
colors are the 216 colors used by all
browsers, regardless of the platform.
Click the cube icon to shift it to the
closest web-safe color.

You can identify out-of-gamut colors. If
an out-of-gamut warning icon (a trian-
gle with an exclamation point) appears
below the color boxes on the Color
panel, it indicates that the current RGB
or HSB color doesn’t have a CMYK
equivalent, which means you can’t use
it on a commercial project.
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Illustrator not only lets you select virtually any colors you desire, it also
lets you store those colors for future use in a library of color swatches,
the Swatches panel. Where the Color panel lets you select virtually any
color you need, the Swatches panel lets you save, group, and use spe-
cific colors that you use often. In the Swatches panel, you can point to
a color box to display a tooltip indicating its color settings. If you want
to view more information, you can change the Swatches panel display
to make it easier to view and work with colors. In a list view, you can
also rename colors in the Swatches panel (New!). 

Working with the
Swatches Panel

Change the Swatches Panel
Display

Select the Swatches panel.

Click the Options menu, and then
choose from the following options:
Small Thumbnail View, Medium
Thumbnail View, Large Thumbnail
View, Small List View, or Large
List View. 

To sort the colors in the Swatches
panel, click the Swatches Options
menu, and then click Sort by Name
or Sort by Kind (by solid, gradients,
patterns, and groups).

To search for colors by name, click
the Swatches Options menu, and
then click Show Find Field. In the
Find field, enter a keyword for the
color you want to find, and then
press Enter (Win) or Return (Mac).

To display swatches by type, click
the Show Swatch Kinds Menu
button, and then select an option:
Show All Swatches, Show Color
Swatches, Show Gradient
Swatches, Show Pattern
Swatches, or Show Color Groups.
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Add, Edit, or Duplicate a Color

Select the Swatches panel.

To edit or duplicate a color, select
a swatch color.

TIMESAVER Drag a color 
from the color boxes on the Tools
or Control panel to the Swatches
panel.

Click the Swatch Options button to
edit a color or click the New
Swatch button to add or duplicate
a color on the panel.

For a new or duplicate color, enter
a name.

For a new or edited color, select a
color type, select or deselect the
Global check box, select a color
mode, and then specify the color
that you want.

Click OK.

To rename a color name in the
Swatches panel (New!), double-
click the name in a list view, edit it,
and then press Enter (Win) or
Return (Mac).

◆ Change to a list view. Click the
Options menu, and then click
Small List View or Large List
View.
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Did You Know?
You can delete a color from the
Swatches panel. Open the Swatches
panel, display and select the color you
want to delete, click the Delete button,
and then click Yes.
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Where the Color panel lets you select virtually any color you need, the
Swatches panel lets you save, group, and use specific colors that you
use often. In the Swatches panel, you can create color groups to keep
colors for a specific project together, which make it easier to find and
use. You can select colors in the Swatches panel or use the colors in a
selected artwork (New!) to group together. 

Creating Groups in the
Swatches Panel

Create a Color Group

Select the Swatches panel.

Select the solid colors that you
want in the group. 

Use Shift+click to select
contiguous color boxes or
Ctrl+click (Win) or Command+click
(Mac) to select noncontiguous
color boxes.

Click the New Color Group button.

The Selected Swatches option is
selected.

Enter a name.

Click OK.5
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Did You Know?
You can delete a color group from the
Swatches panel. Open the Swatches
panel, display and select the color
group you want to delete, click the
Delete button, and then click Yes.
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Color group

Click to edit color group
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Create a Color Group from
Selected Art

Select the Swatches panel.

Select the art object from which
you want to create a color group. 

Click the New Color Group button.

Enter a name.

Select the Selected Artwork
option (New!), if necessary, and
then specify the following options:

◆ Convert Process to Global.
Select to automatically convert
Process Spot colors to Global
colors.

◆ Include Swatches for Tints.
Select to include swatches for
tints.

Click OK.6
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Did You Know?
You can ungroup a color group from the
Swatches panel. Open the Swatches
panel, display and select the color
group you want to ungroup, click the
Options button, and then click Ungroup
Color Group.

You can duplicate a color group from the
Swatches panel. Open the Swatches
panel, display and select the color
group you want to duplicate, and then
click Duplicate Color Group.
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Color group from artwork

Click to edit color group

2

3



ptg8126863

120 Chapter 4

In addition to the standard color swatch libraries, such as Basic RGB
and Basic CMYK, you can access the Swatch Libraries menu to use
colors from all types of color libraries, such as Corporate, Foods, Kids
Stuff, Nature, Skintones. Swatch Libraries also includes Vonster
Patterns designed by artist Von Glitschka (New!). After you open a
library, you can apply colors to fills and strokes, as well as copy
swatches between libraries. After you modify a swatch library, you can
save it to create your own user-defined custom swatch library. 

Working with Swatch
Libraries

Display and Use a Swatch
Library

Select the Swatches panel.

Click the Swatch Libraries menu,
point to a library (if necessary),
and then select a swatch library. 

◆ To use default libraries, point to
Default Swatches, and then
click Basic CMYK, Basic RGB,
or one of the other available
libraries.

◆ To use Vonster Patterns, point
to Patterns, point to Decorative,
and then click Vonster Patterns
(New!). 

The Library panel appears,
displaying the Swatch library.

To view other related libraries,
click the Load Next Swatch
Library or Load Previous Swatch
Library button on the Library panel.

To copy swatches between
libraries, open the libraries, and
then drag the color box or color
group from one library to another.

◆ If a Swatch Conflict dialog box
appears, select an option to
merge swatches or add a new
one.

To apply a color to a selected fill or
stroke, select the element, click
the Fill or Stroke color box on the
Tools or Color panel to choose the
color's destination, and then
select a color in the Swatch
library.
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Save Customized Swatches
Panels

Select the Swatches panel.

Create a customized swatch panel
by adding and/or deleting colors
from an existing panel.

Click the Swatch Libraries menu,
and then click Save Swatches.

Enter a name in the File name box.

Click the Save In (Win) or Where
(Mac) list arrow, and then select a
location to store the swatch.

Click Save.6
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Did You Know?
You can access your customized
swatches from the Swatch Libraries
menu. When you save swatches in the
Color Swatches folder (default loca-
tion), your customized swatches
appear on the User Defined submenu
on the Swatch Libraries menu. 
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Adding Colors Using 
the Kuler Panel

Browse Themes

Click the Window menu, point to
Extensions, and then click Kuler. 

To search for a theme, click in the
Search box, enter the name of the
theme, a tag, or a creator, and
then press Enter (Win) or Return
(Mac). 

IMPORTANT In a search, use
only alphanumerical characters 
(Aa-Zz, 0-9).

To narrow down the browse list,
click the popups, and then select
the filter options you want. Some
include Highest Rated, Most
Popular, Newest. 

◆ To save a search, click the first
popup, click Custom, enter your
search criteria, and then click
Save.

To browse for a theme, click the
View Previous Set of Themes or
View Next Set of Themes button. 

Select a theme in the panel.  5

4

3
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The Kuler panel is an extension to Illustrator that allows you to use
groups of color, or themes in your projects. You can use the panel to
browse thousands of color themes from the Kuler community. After you
find the theme you want, you can add it to the Swatches panel for use
in your project. You can access the Kuler panel by using the Extensions
submenu on the Window menu. The Kuler panel is also available in
Photoshop, InDesign, Flash, and Fireworks. In many of these programs,
you can also create your own theme using complementary harmony
rules, share them with others in the Kuler community, and use them in
Illustrator. 
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Add Themes to the Swatches
Panel

Click the Window menu, point to
Extensions, and then click Kuler. 

To search for a theme, click in the
Search box, enter the name of the
theme, a tag, or a creator, and
then press Enter (Win) or Return
(Mac). 

To narrow down the browse list,
click the popups, and then select
the filter options you want. Some
include Highest Rated, Most
Popular, Newest. 

◆ To save a search, click the first
popup, click Custom, enter your
search criteria, and then click
Save.

To browse for a theme, click the
View Previous Set of Themes or
View Next Set of Themes button. 

Select a theme in the panel.  

To add the theme to the Swatches
panel, click the Add Selected
Theme to Swatches button. 

6

5

4

3

2

1

5

3

24

6

Added theme from Kuler



ptg8126863

124 Chapter 4

Illustrator uses global and nonglobal process colors along with spot
colors. A global color is one that is updated for all uses, while a non-
global color is one that is only updated where it’s being used on
selected objects. A global process color appears in the Swatches
panel with a white corner and no dot, while a nonglobal process color
appears in the color with no indicators. A spot color appears with a
white corner and a dot. You can change a color back and forth
between global and nonglobal by using the Swatch Options dialog box. 

Replacing Colors

Change Global and Nonglobal
Colors

◆ Switch Between Colors. To
change a color to global or
nonglobal, double-click a global or
nonglobal process color in the
Swatches panel, select or
deselect the Global check box,
and then click OK.

◆ Edit Colors. To edit colors, double-
click a global or nonglobal process
color in the Swatches panel,
select the Preview check box,
drag the sliders to change the
color, and then click OK.

◆ Replace Colors. To replace a
global or spot color (which
updates it everywhere it’s used),
Alt (Win) or Option (Mac) drag the
new color over the color that you
want to replace. 

Nonglobal colorSpot color

Global color

Edit color mode

Process or spot color

Global or nonglobal
color
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Replace Colors

Select an object with the
nonglobal process colors that you
want to replace.

Click the Select Similar Options
list arrow on the Control panel.

Select one of the following
options: All, Fill Color, Stroke
Color, Fill & Stroke Color, or
Stroke Weight.

Click the Fill or Stroke color box
on the Tools or Color panel to
choose the color's destination.

Select a replacement color from
the Swatches or Color Guide
panels.
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Did You Know?
You can colorize a grayscale image.
Select the grayscale image that you
want to change, click the Fill box on
the Tools or Color panel, and then
select a color from the Color,
Swatches, or Color Guide panels. Gray
areas are recolored with the new
color, while a white background
remains opaque white. 

You can change a color image to
grayscale. Select the colored image,
click the Edit menu, point to Edit
Colors, and then click Convert To
Grayscale.
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Illustrator provides two commands to invert colors, which changes the
color to their opposite values on the color scale. The Invert Colors com-
mand allows you to invert multiple nonglobal process colors in a
selected object, while the Invert command allows you to invert the fill
or stroke color (global, nonglobal, or spot). 

Inverting Colors

Invert Nonglobal Colors

Select an object with the
nonglobal process colors that you
want to invert.

Click the Edit menu, point to Edit
Colors, and then click Invert
Colors.

Invert a Global, Nonglobal, or
Spot Color

Select an object with the
nonglobal process colors that you
want to invert.

Select the Color panel.

Click the Fill or Stroke color box
on the Tools or Color panel to
choose the color's destination.

Click the Options menu, and then
click Invert.
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Inverted colors
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The Color Guide panel allows you to display and apply variations for a
color. Along with the Live Color dialog box, you can edit colors in an
object or color group, create new color groups, and apply harmony
rules, which are predefined color schemes. Variations appear in the
Color Guide panel based on a range of color, left or right from center
(the small black triangle). You can change the number of columns that
appear as well as the color range.   

Using the Color Guide
Panel

Select Variation Options

Select the Color Guide panel.

Click the Options menu, and then
click Color Guide Options. 

Set the number of variation steps
(columns of color) to display on
either side of the center column.

Drag the Variation slider to set the
range of variation.

Click OK.

Display Variation Types

Select the Color Guide panel.

Click the Options menu.

Select one of the following
variation types: 

◆ Show Tints/Shades. Adds black
to the colors on the left and
white to the colors on the right
of center.

◆ Show Warm/Cool. Adds red to
the colors on the left and blue
to the colors on the right of
center.

◆ Show Vivid/Muted. Adds gray
to the colors on the left and
increases saturation to the
colors on the right.
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After you set up the Color Guide panel to display color variations the
way you want, you can now start applying colors to objects in your
document. You can apply colors to an object based on current colors in
the object or use colors from other swatches. Illustrator makes it easy
to display and apply variations with Harmony Rules (sets of predefined
color schemes), such as Complementary, Analogous, Monochromatic,
Shades, or High Contrast. If you want to save a customized set of varia-
tions, you can create a color group in the Swatches panel for future
use.

Applying Color with
the Color Guide Panel

Apply Colors to an Object, Fill 
or Stroke

Select an object. 

Click the Fill or Stroke color box
on the Tools or Color panel to
choose the color's destination.

Select the Color Guide panel.

Click the Limit Colors to Swatch
Library button, and then click
None.

◆ If you want to use another
swatch for color, you can
select it from the menu.

Click the Set Base Color to Current
Color button.

Click the Options menu, and then
select a variation type: Show
Tints/Shades, Show Warm/Cool,
or Show Vivid/Muted. 

Click the variation color that you
want to apply.

TIMESAVER Drag a variation
color over any unselected object
to apply it.
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Use Variations Based on
Harmony Rules

Select an object.

Click the Fill or Stroke color box
on the Tools panel to choose the
color's destination.

Select the Color Guide panel.

Click the Limit Colors to Swatch
Library menu, and then click None.

Click the Set Base Color to Current
Color button.

Click the Harmony Rules list arrow,
and then select a rule. 

Click the variation color that you
want to apply.

Create a Color Group

Select the Color Guide panel.

Display the color variations that
you want to save as a color group.

Click the gray area below the color
variations to deselect everything.

Click the Save Color Group to
Swatches Panel button.
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Did You Know?
You can copy a single variation to the
Swatches panel. Simply drag the color
box in the Color Guide panel to the
Swatches panel. 
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The Live Color dialog box allows you to change multiple colors in your
artwork at the same time by editing and applying color groups. This
makes it easy to recolor your artwork. You can apply a color group, such
as a harmony rule, to objects, or reassign individual colors within a
color group to objects. If you have too many colors within objects, you
can also reduce the number of colors used while you reassign them.  

Editing Colors with
Live Color

Apply Color Groups to an Object
with Live Color

Select the objects that you want to
recolor. 

Select the Color Guide panel.

Click the Edit or Apply Colors
button on the Color Guide panel or
click the Recolor Artwork button
on the Control panel.

Click the Edit tab.

Select the Recolor Art check box. 

Click the Get Colors from Selected
Art button to create a color group
from the selected objects, and
then enter a name in the field next
to the button for the group.

Click the New Color Group button
to save the color group in the list.

To change color groups, select
one from the Color Groups list or
click the Harmony Rules list arrow,
and then select a rule.

To edit a color, select a color box,
and then drag the sliders and the
round markers (largest marker is
the base color) on the color wheel
to display the color you want. 

◆ Use the buttons below the color
boxes to change the wheel
display, show saturation or
brightness (drag slider to adjust
it), add or remove colors, and
unlink or link harmony rules.  

Click OK.10
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Assign Color Groups to an
Object with Live Color

Select the objects that you want to
recolor. 

Select the Color Guide panel.

Click the Edit or Apply Colors
button on the Color Guide panel or
click the Recolor Artwork button
on the Control panel.

Click the Assign tab.

Select the Recolor Art check box. 

Click the Get Colors from Selected
Art button to create a color group
from the selected objects, and
then enter a name in the field next
to the button for the group.

Click the New Color Group button
to save the color group in the list.

To change color groups, select
one from the Color Groups list or
click the Harmony Rules list arrow,
and then select a rule.

To reduce the number of colors
used in objects, click the Colors
list arrow and then specify the
number of colors you want. 

◆ Click the Color Reduction
Options button to specify how
you want to recolor the objects.

To change a new color, select a
color and then use the color
sliders below it. 

To assign a color, drag a current
color to another row. 

To prevent a color assignment
change, click the arrow between
the columns (it changes to a line).
Click it again to change it back.

Click OK.13
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As you start to use color in your document, it’s important to see how
your color settings appear. It would be nice to see a printed copy in
color to see how colors actually look. However, that is not always pos-
sible. Instead you can view a soft proof on your screen to quickly see
how your colors will appear. A soft proof simulates the color output of
your device, such as a printer with a specific type of paper. 

Proofing Colors on 
the Screen

Display a Soft Proof

Click the View menu, and then
point to Proof Setup.

Select a preset from one of the
available color output for devices
to simulate, or click Customize to
setup your own. The soft proof
presets include the following:

◆ Working CMYK. Creates a soft
proof using the current CMYK
working color space.

◆ Legacy Macintosh RGB.
Creates a soft proof of RGB
colors simulating Mac OS 10.5
and earlier.

◆ Internet Standard RGB. Creates
a soft proof of RGB colors
simulating Windows and Mac
OS 10.6 and later.

◆ Monitor RGB. Creates a soft
proof of RGB colors using your
current monitor profile.

◆ Color Blindness. Creates a soft
proof that reflects colors visible
to a person with color
blindness.

For a custom soft proof setup,
select from the following options:  

◆ Device to Simulate. Select a
target device to simulate.
Simulates how the colors
appear without being converted
to the color space of the output
device.
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◆ Preserve CMYK or RGB
Numbers. Select to use colors
as they are and not convert
them to the working color
space. Deselect to use a
rendering intent option to
display colors.

◆ Rendering Intent. Select an
option to display colors:
Perceptual (for continuous-tone
images), Saturation (for vivid
graphics), Absolute
Colorimetric (for color
preservation) or Relative
Colorimetric (for color
accuracy).  

◆ Simulate Paper Color. Select to
simulate the dingy white of real
paper.

◆ Simulate Black Ink. Select to
simulate dark gray for black
instead of a solid black. This
option is grayed out if the
Simulate Paper Color check
box is selected.

Click OK.

Click the View menu, and then
click Proof Colors.
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Applying Fills, Strokes, and
Gradients

Introduction

The Stroke panel makes it easy to change stroke attributes,
such as weight (width), position on the path, and its style. The
weight of a stroke refers to the thickness of the line. The
Eyedropper tool on the Tools panel is another way you can
quickly pick up an object’s color and stroke attributes and
apply them to another object. Instead of using a solid color
as an object fill, you can create and use patterns. The process
is very simple. In Illustrator, create a pattern using drawing
tools, select and drag the object pattern to the Swatches
panel, and then give it a name. 

A blend uses two or more objects to create a transitional
object in between. If you’re just getting start with blends, the
Make command on the Blend submenu is an easy way to cre-
ate a blend. All you need to do is select the objects that you
want to use, and then choose the command. That’s it. If you
want a little more control over the way a blend turns out, you
can specify options in the Blend Options dialog box. If you
want to specify the locations where the blend takes place,
you can use the Blend tool. Transparency, or the opacity level
of an object, is set in Illustrator by adjusting the Opacity
option in the Transparency or Control panels. Along with the
Opacity option is the blending mode, which blends colors
together for objects in a group as well as all the objects
below it.  

A gradient is a smooth transition between two or more
colors in an object. You can apply one of Illustrator’s built-in
gradients or create one of your own by using the Gradient
panel. There are two types of gradients: Radial (circular) and
Linear (horizontal). With the Gradient tool, you can edit gradi-
ent colors applied to the object by adding or changing color
stops, applying transparency, and changing gradient direc-
tion (linear) or angle (radial).  5

5
What You’ll Do

Apply Fill and Stroke Colors

Change Stroke Attributes and Style

Create Variable Stroke Widths

Use the Eyedropper Tool

Create, Edit, and Use Patterns as Fills

Blend Color Fills

Create Blends Automatically

Apply Blend Options

Create Blends with the Blend Tool

Modify Blend Objects

Set Transparency Options

Create Transparency Masks

Flatten Object Transparency

Control Transparency Effects

Use the Transparency Grid

Apply, Create, and Edit Gradients

Use Gradient Libraries

Use the Gradient Tool

Create a Gradient Mesh
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Eyedropper
tool

Color Picker dialog box

Color panel

Swatches panel

Stroke color

Fill color

The Tools panel provides color boxes to make it easy for you to apply
fill and stroke colors. The color box in the foreground is the Fill box and
the outlined box in the background is the Stroke box. When you select
an object, fill, or stroke, the color boxes (also known as thumbnails), on
the Tools panel display the current colors. To change the fill or stroke
color, select an object, fill or stroke, select the Fill or Stroke box, and
then select a color from the Color, Swatches, or Color Guide panel, or
use the Eyedropper to apply a color from the active document.

Applying Fill and
Stroke Colors

Apply Colors to an Object, Fill or
Stroke

Select an object, fill, or stroke
using the appropriate selection
tool. 

Click the Fill or Stroke color box
on the Tools or Color panel to
choose the color's destination.

Click the Color icon on the Tools
panel to apply a color or click the
None icon to apply no color.

Use any of the following methods
to change the active fill or stroke
colors:

◆ Select the Swatches panel, and
then click a color swatch to
change the color. 

◆ Select the Color panel, and
then specify a color using the
controls.

◆ Select the Color Guide panel,
and then click a color swatch
to change the color. 

◆ Select the Eyedropper tool on
the Tools panel, and then click
anywhere in the active
document to change the color. 

◆ Double-click the Fill or Stroke
color box to open the Color
Picker dialog box, select a
color or enter color values, and
then click OK.
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Use Default and Switch the Fill
and Stroke Colors

Click the Default Fill and Stroke
Colors buttons to revert the fill and
stroke colors to their default
values of black and white.

Click the Swap Fill and Stroke
Colors button to switch current
colors.

TIMESAVER Press D to
change the fill and stroke colors to
their default values of black and
white, and press X to switch the
current colors.

2

1

2

1

Did You Know?
You can add colors from the Color
Picker to the Swatches panel. Open
the Color Picker dialog box, select the
color you want to add to the Swatches
panel, click Add To Swatches, type a
name for the color, and then click OK.
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The Stroke panel makes it easy to change stroke attributes, such as
weight (width), position on the path, and its style. The weight of a
stroke represents the thickness of the line. A weight smaller than .25
may not print and a weight of 0 removes the stroke. In addition to the
width of a stroke, you can also specify the position (known as align-
ment) of the stroke on the path (either center, inside, or outside) and
change the caps or joins of a stroke to sharpen or round endpoints and
corners. A cap is the end of an open line, while a join is a corner.

Changing Stroke
Attributes

Change the Weight of a Stroke 

Select one or more objects.

Select the Stroke panel.

Specify or enter a weight in the
Stroke or Control panel.

◆ Click the up or down arrow, or
Shift+click to change the
weight by a larger interval.

Change the Alignment of a
Stroke on the Path

Select one or more closed objects.

Select the Stroke panel.

Click one of the following
alignment buttons:

◆ Align Stroke to Center.

◆ Align Stroke to Inside.

◆ Align Stroke to Outside.
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Change Stroke Caps or Joins 

Select one or more objects. 

Select the Stroke panel.

To change the endpoints, click one
of the following buttons:

◆ Butt Cap. Creates a square-
edged end.

◆ Round Cap. Creates a rounded
end.

◆ Projecting Cap. Creates a
square-edged end that extends
past the endpoint.

To change the bends on corner
points, click one of the following:

◆ Miter Join. Creates a pointed
join point.

◆ Enter a miter limit between 1
and 500. When the length of
the point reaches the limit
(default 4) times the stroke
weight, Illustrator switches
from a miter join to a bevel
join. 

◆ Round Join. Creates a rounded
join point.

◆ Bevel Join. Creates a beveled
(cut off) join point.
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Style is what stands out on the page. You can change the stroke style
by applying dashes and arrowheads using the Stroke panel. When you
create a dashed stroke, you can choose to align the dashes around
corners and at the end of open paths or preserve the dashes and gaps
in the stroke. In addition to dashes, you can also add and define an
arrowhead to a stroke. After you add an arrowhead to a stroke, you can
adjust its alignment and scale.

Changing Stroke Style

Create a Dashed Stroke

Select one or more objects. 

Select the Stroke panel.

Select the Dashed Line check box.

Click the Preserve Exact Dash and
Gap Lengths or Aligns Dashes to
Corners and Path Ends, Adjusting
Lengths to Fit icon.

Enter a value in the first Dash box.

If you don’t enter any more values,
the value in the first box is used
for the rest of the boxes.

Enter a value in the first Gap box.

Fill in the remaining boxes.

◆ To create a dotted line, click the
Round Cap button, enter a dash
value of 0, and then enter a gap
value greater than or equal to
the stroke weight.

Click one of the Cap buttons to
sharpen or round endpoints.
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Add Arrowheads

Select one or more objects. 

Select the Stroke panel.

Click the Start Point Arrowhead or
End Point Arrowhead list arrow,
and then select an arrowhead.

◆ To remove an arrowhead,
select None from the list.

To swap the start and end
arrowheads, click the Swap Start
And End Arrowheads button. 

Click the Start Arrowhead Scale
or End Arrowhead Scale list
arrow, and then drag a scale
percentage for the arrowhead.

◆ To link the start and end
arrowhead scale, click the Link
Start And End Arrowhead
Scales button.

To change the arrowhead
alignment, click the Extend Arrow
Tip Beyond End Of Path or Place
Arrow Tip At End Of Path button.
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Did You Know?
You can customize arrowheads. To
define custom arrowheads, open the
Arrowheads.ai file, follow the direc-
tions in the file, and then place the
updated Arrowheads.ai file in the
<Illustrator home>\plug-ins\. 

The Arrowheads.ai file is located under
ShowPackageContent\Required\
Resources\<locale>\ (Mac) or \Support
Files\Required\Resources\,<locale>\
(Win).
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The Width tool allows you to create a variable width stroke and save
your settings as a profile that you can apply to other strokes. When you
point to a stroke with the Width tool, a small circle appears on the path,
where you can drag to create a variable width. After you create a vari-
able width, you can move, duplicate, or delete a width point on the
path. Each width point contains an inward/outward handle, which you
can drag on the path to adjust the width. If you want to create a vari-
able width with exact measurements, you can use the Width Point Edit
dialog box. After you create a variable width point, you can save it as a
profile from the Stroke or Control panel. 

Creating Variable
Stroke Widths

Create or Adjust a Variable
Stroke Width

Select the Width tool on the Tools
panel. 

Use any of the following methods
to create and adjust a variable
width stroke:

◆ Create a Variable Width Point.
Point to the path, and then click
on the path and drag to size it.

◆ Change a Variable Width Point
Position. Point to the path,
point to a width point, and then
drag it along the path.

◆ Change a Variable Width Point
Size. Point to the path, point to
a width point, and then drag the
inward/outward handle.

◆ Set Exact Variable Width Point
Sizes and Options. Point to the
path, double-click the width
point, specify the sizes you
want, select the Adjust
Adjoining Width Points check
box to adjust neighboring width
points, and then click OK. 

◆ Delete a Variable Width Point.
Point to the path, click the
width point, and then press
Delete.

◆ Select Multiple Width Points.
Point to the path, press Shift
and click width points.
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Set exact variable width point sizes and options

Adjust Adjoining Width Points check box

Variable width point on path

Inward/outward handle



ptg8126863

Chapter 5 Applying Fills, Strokes, and Gradients 143

Width Control Keyboard Shortcuts (Win/Mac)

Create non-uniform widths Alt/Option+drag

Create a copy of a width point Alt/Option+drag

Copy/move all points along the path Alt/Option+Shift+drag

Move multiple width points Shift+drag

Select multiple width points Shift+click

Delete selected width points Delete

Deselect a width point Esc

Width Tool Shortcuts

Create and Apply a Stroke 
Width Profile

Select the Width tool on the Tools
panel. 

Select the Stroke panel.

Use any of the following methods
to create or adjust a variable width
stroke:

◆ Create a Width Profile. Create
or select a variable stroke
width, click the Profile list
arrow on the Stroke panel, click
the Add To Profiles button, type
a name, and then click OK.

◆ Apply a Width Profile. Select a
path, click the Profile list arrow
on the Stroke panel, and then
select the width profile you
want.

◆ Remove a Width Profile. Select
the variable stroke width you
want to remove, click the
Profile list arrow on the Stroke
panel, and then click Uniform.

◆ Flip a Width Profile. Click the
Profile list arrow on the Stroke
panel, select the profile you
want to flip, and then click the
Flip Along or Flip Across
button.

◆ Delete a Width Profile. Click
the Profile list arrow on the
Stroke panel, select the profile
you want to delete, and then
click the Delete Profile button,
and then click Yes.

◆ Restore the Default Width
Profile Set. Click the Profile list
arrow on the Stroke panel, click
the Reset Profiles button, and
then click OK. This removes any
custom saved profiles.
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Variable width stroke
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Profile list arrow

Add To Profiles,
Delete Profile,
Reset Profiles

Flip buttons
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The Eyedropper tool on the Tools panel makes it easy to quickly pick up
a color from one area of your artwork and apply it to another area.
When you click an object with the Eyedropper tool, it picks up the
object’s color and stroke attributes and displays them in the Tools,
Color, and Stroke panels. You can pick up attributes from any type of
object, even a graphic image and the object doesn’t need to be
selected. If an object is selected, the color and stroke attributes are
applied to the selected object. The Eyedropper tool also provides
options for you to customize the attributes—such as Appearance,
Transparency, Focal Fill and Focal Stroke, Character Style and
Paragraph Style—that you want to pick up with the tool.

Using the Eyedropper
Tool

Apply Colors and Attributes with
the Eyedropper Tool

If you want to apply the pick up
color and attributes to one or more
objects, then select them. 

Select the Eyedropper tool on the
Tools panel.

Click an object in any window that
contains the color and attributes
that you want to pick up and apply.

◆ If you want to apply color
attributes from the currently
selected object and apply them
to another object you select,
Alt+click (Win) or Option+click
(Mac) the objects. 

◆ To have the Eyedropper tool
only pick up an object’s color
and not other attributes, click
the Fill or Stroke box on the
Tools or Color panel, and then
Shift+click the color to be
picked up. 
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Change Eyedropper Options

Double-click the Eyedropper tool
on the Tools panel. 

In the left column, select the
check boxes for the options that
you want the Eyedropper to pick
up and deselect the ones you
don’t.

In the right column, select the
check boxes for the options that
you want the Eyedropper to apply
and deselect the ones you don’t.

Click the Raster Sample Size list
arrow, and then select a sample
size for the pick up color and
attributes.

Click OK.5
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Instead of using solid color or gradients as object fills, you can create
and use patterns. The process is very simple. In Illustrator, use existing
artwork (nothing with a painted pattern) or create a pattern using
tools—such as Rectangle, Ellipse, Polygon, Arc, Spiral, Star, or Flare—
on the Tools panel, and then drag it to the Swatches panel. If you want
to create a more complex pattern, you can make and edit patterns
using the Pattern Options panel (New!). The pattern consists of a
group of objects, which you can also edit using Isolation Mode.

Creating Patterns for
Fills

Create a Pattern for Fills

Use existing or draw objects to be
used as a pattern. 

Select the Selection tool on the
Tools panel.

Select all the objects.

Click the Object menu, point to
Pattern, and then click Make.

If prompted with an alert dialog
box, click OK.

The object is added to the
Swatches panel, the Pattern
Options panel opens, and the
pattern appears in Isolation Mode.

Type a name for the pattern.

Click the Tile Type list arrow, and
then select a layout: Grid, Brick by
Row, Brick by Column, Hex by
Column, or Hex by Row.

◆ Brick Offset. If you select one
of the brick title types, click the
Brick Offset list arrow, and
then select an offset.

To adjust tiling manually, click the
Pattern Tile Tool button, and then
drag a white square handle to
resize it.

Specify any of the following
options:

◆ Width and Height. If you want
an exact width and height,
specify the values you want.
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◆ Size Tile to Art. Select to size
the pattern tile to the applied
object. If you select his option,
specify horizontal (H) and
vertical (V) spacing.

◆ Move Tile with Art. Select to
move the pattern tile with the
applied object.

◆ Overlap. Select Left in Front or
Right in Front and Top in Front
or Bottom in Front.

Specify any of the following
options:

◆ Copies. Specify the number of
patterns you want in the grid.

◆ Dim Copies to a Percentage.
Select to dim the pattern copies
by an opacity percentage. 

◆ Show Tile Edge. Select to show
the edge of the pattern tile.

◆ Show Swatch Bounds. Select
to show the bounding edge of
the pattern swatch.

When you’re done modifying the
pattern, click Done on the gray bar
to exit Isolation Mode.

◆ Cancel. Click Cancel to exit
Isolation Mode with creating an
pattern.

◆ Save a Copy. Click Save a Copy
to create a copy of the pattern;
Enter a name, and then click
OK.
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Isolation Mode

Pattern based on Pattern Options panel
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Did You Know?
You can add an object to the
Swatches panel as pattern. Drag the
object selection to a blank area in the
Swatches panel.  
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After you create a pattern using the Pattern Options panel (New!), you
can use the Edit Pattern command (New!) on the Pattern submenu on
the Object menu to edit the pattern. When you edit a pattern from the
Swatches panel, the Pattern Options panel opens and the pattern
appears in Isolation Mode. With the Direction Selection tool, you can
edit individual objects in the pattern. With the Pattern Options panel,
you can edit how the pattern appears as a fill.

Editing Patterns

Edit a Pattern

Select the Swatches panel.

Select the pattern you want to
edit.

Click the Object menu, point to
Pattern, and then click Edit
Pattern.

The Pattern Options panel opens
and the pattern appears in
Isolation Mode.

With the Direct Selection tool, edit
individual objects in the pattern.

In the Pattern Options panel, make
the changes you want to pattern;
see the previous page for option
specifics.

To adjust tiling manually, click the
Pattern Tile Tool button, and then
drag a white square handle to
resize it in Isolation Mode.

When you’re done modifying the
pattern, click Done on the gray bar
to exit Isolation Mode.

◆ Cancel. Click Cancel to exit
Isolation Mode with creating a
pattern.

◆ Save a Copy. Click Save a Copy
to create a copy of the pattern;
enter a name, and then click
OK.
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After you create a pattern, you can apply the pattern from the
Swatches panel to an object’s fill or stroke. You can apply a pattern just
as you would apply a solid or gradient color. Simply, select the object,
select the Fill or Stroke color box on the Tools panel, and then click the
pattern you want to use from the Swatches panel.

Using Patterns as Fills

Use a Pattern as a Fill or Stroke

Select the Selection tool on the
Tools panel.

Select an object.

Click the Fill or Stroke color box
on the Tools panel.

Select the Swatches panel.

Click the pattern in the Swatches
panel.
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Pattern applied to object

Did You Know?
You can reposition a pattern fill. To
reposition the pattern fill or stroke in
an object without moving the object,
select the Selection tool, hold down 
~ (tilde) and drag inside the object. 

You can expand a pattern into individ-
ual objects. Select the object with the
pattern, click the Object menu, click
Expand, select the Fill check box
and/or the Stroke check box, and then
click OK.
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The Edit Color submenu allows you to blend fill colors for three or more
objects. The more objects that you select, the more gradual the color
blend. Stroke colors and attributes remain the same. Illustrator takes
the objects on the edges (front and back, left and right, and top and
bottom) as the starting and ending colors in the blend. All objects in
between the starting and ending ones are intermediate blends. 

Blending Fill Colors

Blend Fill Colors

Select three or more objects that
contain fill colors. 

◆ The objects cannot contain
global process colors, patterns,
or gradients.

Click the Edit menu, and then point
to Edit Colors.

Select any of the following
commands:

◆ Blend Front to Back. Uses the
fill color of the front and back
objects in the selection as the
starting and ending colors in
the blend.

◆ Blend Horizontally. Uses the fill
color of the left side and right
side objects as the starting and
ending colors in the blend. 

◆ Blend Vertically. Uses the fill
color of the top and bottom
objects as the starting and
ending colors in the blend. 
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If you’re just getting started with blends, the Make command on the
Blend submenu is an easy way to create a blend. All you need to do is
select the objects that you want to use in the blend, and then choose
the Make command. That’s it. Illustrator creates all the transitional
objects in between. If you don’t like the results, you can undo the blend
and try something else. If you no longer want the blend, you can
release it, which removes the transitional objects and leaves the origi-
nal objects and the path.

Creating Blends
Automatically

Make and Release Blend
Objects

Select two or more objects or
groups (with space in between
them) that you want to blend. 

Click the Object menu, point to
Blend, and then click Make.

◆ To undo the creation of the
blend objects, click the Edit
menu, and then click Undo.

Select the blend objects.

To release the blend objects, click
the Object menu, point to Blend,
and then click Release.

The transitional objects between
the original objects are removed,
while the original objects and path
remain intact.
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If you want a little more control over the way a blend turns out, you can
specify options in the Blend Options dialog box. The settings automati-
cally apply to any selected objects and future blends. The settings
include Smooth Color, Specified Steps (number of transitional steps),
Specified Distance, Align to Page, and Align to Path. The Preview
option allows you to view your changes on the screen as you make
them.

Applying Blend
Options

Change and Apply Blend
Options

Select an existing blend object. 

Click the Object menu, point to
Blend, and then click Blend
Options.

Select the Preview check box to
view your changes.

Click the Spacing list arrow, and
then select one of the following:

◆ Smooth Color. Select to
automatically create a smooth
color blend based on the
number of transitional steps
needed.

◆ Specified Steps. Enter the
number of transitional steps (1-
1000) that you want.

◆ Specified Distance. Enter the
distance (.1-1000 pixels)
between the transition objects
in the blend.

Select one of the following
orientation buttons:

◆ Align to Page. Click to align the
blend objects perpendicular to
the horizontal axes.

◆ Align to Path. Click to align the
blend objects perpendicular to
the path.

Click OK.6
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If you want to specify the locations where the blend takes place, you
can use the Blend tool on the Tools panel. The Blend tool allows you to
select the anchor points on the objects to determine the direction of
the blend. For the best results and smoothest transitions, click anchor
points on corresponding locations on the objects. If you’re not sure
which anchor points to use, you can also select an object’s fill to let
Illustrator select the anchor point for you. Experiment with it to deter-
mine what works best for you. 

Creating Blends with
the Blend Tool

Create a Blend with the Blend
Tool

Select two or more objects or
groups (with space in between
them) that you want to blend. 

Select the Blend tool on the Tools
panel.

Click the fill of the first object (not
the center point) to let Illustrator
determine an anchor point to use,
or click the anchor point that you
want to use.

Click the fill or an anchor point on
the next object. If the path is open,
click an endpoint.

For the best results and smoothest
transitions, click anchor points on
corresponding locations on the
objects.

Continue to click corresponding
anchor points on the selected
objects.

To release the blend objects,
select the blend, click the Object
menu, point to Blend, and then
click Release.
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After you create a blend, you can use commands on the Blend sub-
menu to reverse stacking order, reverse spine location, and replace the
spine. These commands allow you to quickly change the look of the
blend. If you want to modify a blend, you can change blend objects
using other Illustrator features, such as recoloring, reshaping, or trans-
forming. Experiment to determine what works best for you. 

Modifying Blend
Objects

Modify Blend Objects

◆ Reverse Stacking Order. Changes
the stacking order (front to back)
without changing the x/y location.
Select a blend object, click the
Object menu, point to Blend, and
then click Reverse Front to Back. 

◆ Reverse Spine. Changes the x/y
location of the blend objects
without changing the stacking
order. Select a blend object, click
the Object menu, point to Blend,
and then click Reverse Spine. 

◆ Replace Spine. Replaces the
current spine in a blend with a
new path. Create a new path for
the spine, select a blend object
and the new path, click the Object
menu, point to Blend, and then
click Replace Spine. 

◆ Recolor. Select all the objects in
the blend that you want to recolor,
click the Recolor Artwork button
on the Control panel, specify the
color changes you want, and then
click OK.

◆ Transform. Select all the objects in
the blend, and then use the
object’s bounding box, the Free
Transform tool, or other
transformation tools.

◆ Reshape Path. Move one of the
original blend objects with the
Direct Selection tool or use any of
the reshaping path tools.

Edit blend

Reverse spine location

Reshape path

Blend transformed
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Transparency, or the opacity of an object (to what degree you can see
through the object), is set in Illustrator by adjusting the Opacity option
in the Transparency, Control, or Appearance panels. The Opacity option
allows you to specify a percentage to set the transparency level. Along
with opacity, you an also change the blending mode, which controls
how object colors blend with other object colors below it. You can
apply transparency options to an object, group, or layer. This includes
an object’s fill or stroke, and type. 

Setting Transparency
Options

Change the Opacity or Blending
Mode of an Object

Select an object, group, or layer.

◆ For a layer, click the target
circle on the Layers panel. 

◆ For type, select individual
characters or the entire object.

◆ For an object’s fill or stroke,
click the target circle on the
Layers panel, and then click Fill
or Stroke on the Appearance
panel.

Select the Transparency panel.

To change opacity, click the
Opacity list arrow, and then
specify a percentage.

To change the blending mode,
click the Blending Mode list
arrow, and then select a blending
mode.
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When you apply a blending mode to a group, the blend is applied to all
the objects in the group as well as all the objects below it. If you want
to isolate the blend to only the objects nested in the group, you can use
the Isolate Blending option in the Transparency panel. You can also use
the option on individual objects with overlapping strokes and fills. If
objects in a group overlap, you can use the Knockout Group option to
control whether objects will show through each other (except for semi-
transparent objects) or be knocked out. 

Controlling
Transparency Effects

Isolate a Blending Mode to
Certain Objects

Click the target circle for a group
or layer on the Layers panel that
contains nested objects with a
blending mode. 

Select the Transparency panel.

Click the Options menu, and then
click Page Isolated Blending.

Use the Knockout Group Option

Click the target circle for a group
or layer on the Layers panel that
contains nested objects. 

Select the Transparency panel.

Click the Options menu, and then
click Page Knockout Group to
knock out the objects so that you
can't see through them. However,
you’ll still see through any semi-
transparent objects. Deselect this
option to allow objects to be seen
through each other. 
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You can use an opacity mask and a masking object to change trans-
parency. The opacity mask is an object whose shape masks out every-
thing except the contents behind the shape. The masking object is the
area that becomes transparent. You can use any colored object or
raster image as the masking object. When the opacity mask is white,
the artwork is fully visible. When the opacity mask is black, the artwork
is hidden. Using shades of gray in the mask provides the varying opac-
ity levels of transparency in the artwork. You can create an opacity
mask in the Transparency panel.

Creating Transparency
Masks

Use Opacity Masks to Create
Transparency

Select two or more objects or
groups.

Select the Transparency panel.

Click Make Mask on the
Transparency panel.

The Clip check box becomes
selected. The Clip option sets the
mask background to black. If you
have black objects, they will be
hidden, unless you use a different
color or deselect the Clip check
box.

To reverse the opacity of the
masked artwork (80% transparent
becomes 20% transparent), select
the Invert Mask check box. 

◆ You can also change opacity
with the Opacity list arrow. 

To edit a masking object, click the
thumbnail (on right), edit the mask,
and then click the masked artwork
thumbnail (on left) to exit.

◆ Alt-click (Win) or Option-click
(Mac) the thumbnail to hide all
other artwork in the document. 

To unlink or relink an opacity mask,
click the Link icon between the
thumbnails.

To remove an opacity mask, click
Release on the Transparency
panel.
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If you have problems printing or saving artwork with transparent
objects, you can use the Flatten Transparency command on the Object
menu to flatten the object. In most cases when you’re working with
legacy artwork, this will fix the problem. The best way to flatten the
transparency within an object is to try one of the presets. Otherwise,
you can specify your own settings. If you plan to use the settings in the
future, you can save them as a custom preset.

Flattening Object
Transparency

Flatten Object Transparency

Select the objects you want to
change.

Click the Object menu, and then
click Flatten Transparency.

Click the Preset list arrow, and then
select a preset.

Click OK to use the preset, or
specify the custom settings:

◆ Raster/Vector Balance.
Preserves vector information.

◆ Line Art and Text Resolution.
Rasterizes art and text objects;
typically set to 600-1200. 

◆ Gradient and Mesh Resolution.
Rasterizes gradient and mesh
objects; typically set to 72-2400. 

◆ Convert All Text to Outlines.
Select to convert to outlines;
discards all type glyph info. 

◆ Convert All Strokes to Outlines.
Select to convert strokes to
filled paths. 

◆ Clip Complex Regions. Select to
reduce stitching where rasters
and vectors meet. 

◆ Anti-alias Rasters. Select to
smooth raster images (New!). 

◆ Preserve Alpha Transparency.
Select to retain appearance and
transparency. 

◆ Preserve Overprints and Spot
Colors. Select when printing
separations. 

To save the custom settings, click
Save Preset, enter a name, and
then click OK.
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The Transparency grid makes it easier to work with semi-transparent
objects. The gray and white checkerboard background allows you to
distinguish between different levels of transparencies. You can quickly
show or hide the transparency grid by using the Show Transparency
Grid command on the View menu. Before you use the command, you
can customize the look of the grid in the Document Setup dialog box. 

Using the
Transparency Grid

Select Transparency Grid
Preferences

Click the File menu, and then click
Document Setup. 

Click the Grid Size list arrow, and
then select a size: Small, Medium,
or Large. 

Click the Grid Colors list arrow,
and then select a color: Light,
Medium, Dark, or a specific color.

Select the Simulate Colored Paper
check box to simulate the use of
colored paper, which blends with
objects. 

Click the Preset list arrow, and
then select a resolution.

Click OK.6
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Did You Know?
You can show and hide the trans-
parency grid. Click the view menu, and
then click Show Transparency Grid or
Hide Transparency Grid.
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A gradient is a smooth transition between two or more colors in an
object. You can apply one of Illustrator’s built-in gradients or create one
of your own by using the Gradient panel. The built-in gradients are
available from gradient libraries. You can apply a gradient to an object’s
fill or stroke (New!). After you apply a gradient, you can change the
direction or smoothness of the color transition.

Applying Gradients

Apply a Gradient Fill to an
Object

Select an object with the fill you
want to change.

◆ For type, convert it to outlines
(click the Type menu, and then
click Create Outlines), or select
the type, and then select Add
New Fill from the Appearance
panel menu.

Select the Swatches and Gradient
panels.

◆ To use gradients from a
gradient library, click the
Swatch Libraries menu on the
Swatches panel, point to
Gradient, select a gradient
library, and then click a
gradient.

Click the Fill color box on the
Gradient (New!) or Tools panel.

Click a gradient swatch on the
Swatches panel or use the
Gradient Fill box list arrow on the
Gradient panel to apply any of the
gradients on the Swatches panel.

To change the direction of the
gradient, click the Reverse
Gradient button.
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Apply a Gradient to a Stroke

Select an object with the stroke
you want to change.

Select the Swatches and Gradient
panels.

◆ To use gradients from a
gradient library, click the
Swatch Libraries menu on the
Swatches panel, point to
Gradient, select a gradient
library, and then click a
gradient.

Click the Stroke color box on the
Gradient (New!) or Tools panel.

Click a gradient swatch on the
Swatches panel or use the
Gradient Fill box list arrow on the
Gradient panel to apply any of the
gradients on the Swatches panel.

Click a stroke button (New!) to
specify where to apply the
gradient:

◆ Within Stroke. 

◆ Along Stroke. 

◆ Across Stroke. 

To change the direction of the
gradient, click the Reverse
Gradient button.
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Did You Know?
You can expand a gradient fill to cre-
ate an effect. Select an object with a
gradient fill, click the Object menu,
click Expand, click the Specify option
in the Expand Gradient To area, and
then enter the number of objects that
you want to create. For a smooth color
transition, enter a large number (100),
and then click OK.
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You can apply one of Illustrator’s built-in gradients or create one of your
own by using the Gradient panel. The built-in gradients are available
from gradient libraries, which you can access from the Swatches panel.
The gradient libraries open in a panel, displaying individual gradients.
When you select a swatch from a gradient library, it’s automatically
added to the Swatches panel. You can apply a gradient to an object’s fill
or stroke using the Swatches, gradient library, or Gradient panels.

Using Gradients
Libraries  

Add Library Gradients to the
Swatches Panel

Select the Swatches panel.

Click the Swatch Libraries menu
on the Swatches panel, point to
Gradient, and then select a
gradient library.

Click a gradient swatch on the
gradient library panel.

The swatch from a gradient library
is automatically added to the
Swatches panel, where you can
apply it to fills and strokes.
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Instead of using one of Illustrator’s built-in gradients, you can create
your own by using the Gradient panel. It’s easy and you can be creative
in the process. You can create a gradient with two or more colors and
add transparency. There are two types of gradients: Radial (circular)
and Linear (horizontal). After you create a gradient, you need to save it
in the Swatches panel in order to use it again later. 

Creating Gradients

Create a Gradient Fill for an
Object

Select an object.

Select the Gradient panel.

Click the Gradient Fill box on the
Gradient panel.

Click the left color stop and use
the Color panel to create the color
you want, or Alt+click (Win) or
Option+click (Mac) a color swatch
on the Swatches panel.

Repeat the previous step for the
right color stop.

Click the Type list arrow, and then
select a gradient type: Radial or
Linear.

To add color stops, click below the
gradient spectrum in a blank area.
To remove a color stop, drag it
down and away from the gradient
spectrum.

To adjust the amount of each color
in the gradient, drag the diamond
above the gradient spectrum.

To add transparency, select a
color stop, and then specify an
Opacity value. 

To save the gradient, drag the
Gradient Fill box from the Gradient
panel to the Swatches panel. 

◆ To save and name the gradient,
click the Gradient Fill box on
the Gradient panel, click the
New Swatch button on the
Swatches panel, enter a name,
and then click OK.
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After you apply a built-in gradient or use one of your own, you can edit
it. You can edit a gradient in an object and keep the gradient in the
Swatches panel unchanged or you can edit the gradient in the
Swatches panel and keep the gradient in an object unchanged. Editing
a gradient is similar to creating one. The techniques are the same. All
you need to do is select the element that you want to edit. 

Editing Gradients

Edit a Gradient

Select an object with a gradient,
or click the gradient swatch on the
Swatches panel you want to edit.

Select the Gradient panel.

Click the Gradient Fill box on the
Gradient panel, or click the
Gradient Fill box list arrow, and
then select one of the saved
gradients (from Swatches panel).

To change the gradient type, click
the Type list arrow, and then select
a gradient type: Radial or Linear.

Do any of the following:

◆ Add color stops. Click below
the gradient spectrum in a
blank area. 

◆ Remove color stops. Drag the
color stop down and away from
the gradient spectrum.

◆ Move color stops. Drag the
color stop or enter a Location
value.

◆ Duplicate color stops. Alt+drag
(Win) or Option+drag (Mac) a
color stop. 

◆ Adjust color amount. Drag the
diamond above the gradient
spectrum.

◆ Change Transparency. Select a
color stop, and then specify an
Opacity value. 

To save the gradient, Alt-drag
(Win) or Option-drag (Mac) the
Gradient Fill box from the Gradient
panel over the old gradient on the
Swatches panel. 
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The Gradient tool on the Tools panel allows you to change how a gradi-
ent appears for an object. You can change how gradient colors blend,
the angle of a linear gradient, and the location of the center for a radial
gradient with a drag of the mouse over the gradient fill. You can also
edit gradient colors on the object by adding or changing color stops,
applying transparency to color stops, and changing gradient direction
(linear) or angle (radial) using the Gradient Annotator, which you can
show and hide from the View menu.

Using the Gradient
Tool

Use the Gradient Tool to Change
a Gradient

Select an object with a gradient
that you want to change.

Click the Gradient tool on the Tools
panel.

Click the View menu, and then
click Show Gradient Annotator.

Do any of the following:

◆ Short Color Transitions. Drag
the diamond icon on the object
a short distance. 

◆ Gradual Color Transitions. Drag
the diamond icon on the object
a long distance.

◆ Change Position. Drag the
larger circle on the object.

◆ Reverse Color Direction. Drag
the diamond icon on the object
in the opposite direction.

◆ Change Radial Center. Drag the
small circle attached to the
larger circle on the object. 

◆ Change Linear Angle. Alt+drag
(Win) or Option+drag (Mac) the
diamond icon to another angle.

◆ Change Color Stops. Click
below the spectrum line to add,
drag to move, and drag away to
remove color stops. 

◆ Change Transparency. Double-
click a color stop on the object,
and then specify an Opacity
value in the Gradient panel. 
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A mesh object is a multicolored gradient type object that allows colors
to flow in different directions and transitions from one point to another.
A mesh object uses mesh lines (like a grid) to make it easier for you to
modify color flow, transitions, intensity, and opacity. The points in the
grid are called mesh points (diamonds). Mesh points are like anchor
points, except you can assign color and transparency to them. The
area between four mesh points is a mesh patch for which you can
modify the color and transparency. You can create two types of mesh
objects: one with an irregular pattern of mesh points or one with a reg-
ular pattern of mesh points.

Creating a Gradient
Mesh

Create a Gradient Mesh

Select an object.

Do one of the following:

◆ Irregular Pattern. Select the
Mesh tool on the Tools panel,
select a fill color for mesh
points, click to place the first
mesh point, and then continue
to click to place other mesh
points. 

◆ Regular Pattern. Click the
Object menu, and then click
Create Gradient Mesh. Set the
number of rows and columns,
select the highlight direction,
enter a percentage of white
highlight (100% = white, 0% =
no white), and then click OK.

To edit a mesh object, select the
Mesh tool on the Tools panel, and
then do any of the following:

◆ Delete Mesh Point. Alt-click
(Win) or Option-click (Mac) a
mesh point to delete it.

◆ Move Mesh Point. Drag to
move a mesh point. Shift-drag
to keep the mesh point on a
mesh line.

◆ Add Mesh Point. Select a color
for the new mesh point, and
then click to add a mesh point.
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Set Color and Transparency for a
Gradient Mesh

Select the Mesh tool on the Tools
panel.

Select one or more mesh points or
patches on the object.

To change the color of a mesh
point or path, drag a color from the
Color or Swatches panel onto the
point or patch. 

◆ You can also deselect all
objects, select a fill color, and
then select the mesh object
and use the Eyedropper tool to
apply the full color.

Select the Transparency panel.

Click the Opacity list arrow, and
then specify a percentage.

IMPORTANT If you save the
object to the CS5 format, or EPS or
PDF, the transparency on the mesh
object is retained by creating a
opacity mask.
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Did You Know?
You can convert a gradient to a mesh
object. Select an object with a gradient
fill, click the Object menu, click
Expand, click the Gradient Mesh
option, and then click OK.

You can convert a mesh object back to
a path object. Select the mesh object,
click the Object menu, point to Path,
click Offset Path, enter zero for the off-
set value, and then click OK.
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What You’ll Do

169

Working with Points and
Paths

Introduction

When you use Illustrator's vector drawing, or pen tools,
Illustrator creates a path to store that information. Paths are
defined mathematically using anchor points and segments.
Once created, they can be precisely modified to fit any design
situation. 

Working with the various Pen tools, it's possible to create
precise paths, and even create complicated selections around
virtually any shape. Once the path is created, it's a simple
matter to subtract anchor points, and add new or modify
existing anchor points to produce complex paths. It's even
possible to convert straight segments (the visible line that
connects two anchor points together) into elegantly curved
segments, or you can remove the curve from a segment with
a single click. 

Paths can be used to precisely guide a brush stroke, or
the interior of a path can be filled with any color, pattern, or
gradient available in Illustrator using Stroke and Fill com-
mands. Paths can even be used to create a clipping mask,
which is an object whose shape masks out everything except
the contents behind the shape. 

What You’ll Do

Draw with the Pen Tools

Set Anchor Point Preferences

Move Points and Segments

Convert Points

Add and Delete Anchor Points

Align and Join Anchor Points

Reshape Paths

Erase to Reshape Paths

Smooth Paths

Simplify Paths

Divide Paths

Split Paths

Merge Paths

Work with Shape Mode

Work with Pathfinder

Create a Compound Path

Create a Clipping Set

Edit a Clipping Set
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When you work with Illustrator's Pen tool, you're creating a path. The
path consists of curved and straight segments connected by anchor
points. When you click with the Pen tool, you create corner points and
straight segments. When you drag with the Pen tool, you can create
smooth points and curve segments, which have direction handles 
you can use to change the curved segment. The shape of the curve
segment is defined by the length and direction of the direction handles.
As you create drawings with the Pen tool, you can turn on Smart
Guides to help you align the segments.

Drawing with the
Pen Tools

Draw a Polygon with the Pen
Tool

Click the Fill box on the Tools
panel and then click the Color or
None to specify whether you want
to fill the object or not.

Select the Pen tool on the Tools
panel.

Click to create the first anchor
point.

◆ To draw segments constrained
to 45 degrees, hold down Shift
while you click.

Click to create the second anchor
point at another location.

A line segment appears between
the two anchor points.

Continue to add anchor points. 

Do any of the following to
complete the shape as a:

◆ Open Path. Click the Pen tool or
any other tool on the Tools
panel, or Ctrl+click (Win) or 
A+click (Mac) outside the
new shape to deselect it.

◆ Closed Path. Point to the
starting anchor point, and then
click it.
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Draw Curves with the Pen Tool

Click the Fill box on the Tools
panel and then click the Color or
None to specify whether you want
to fill the object or not.

Select the Pen tool on the Tools
panel.

Click and drag to create the first
anchor point.

As you drag, the direction handles
move.

Release the mouse, and then move
to where you want the second
point.

Click and drag to create the
second anchor point.

A curve segment appears between
the two anchor points. As you
drag, the direction handles move,
which changes the the curve
segment.

The shape of the curve segment is
defined by the length and direction
of the direction handles. 

Continue to add anchor points and
direction handles. 

Do any of the following to
complete the shape as a:

◆ Open Path. Click the Pen tool or
any other tool on the Tools
panel, or Ctrl+click (Win) or 
A+click (Mac) outside the
new shape to deselect it.

◆ Closed Path. Point to the
starting anchor point, and then
click it.
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Illustrator's Selection & Anchor Displays preferences allow you to 
set selection and anchor options. The Anchor Display options allow 
you to determine how handles and anchors appear on the screen. As
you work with anchor points, it’s easier to select them when they
appear highlighted on a mouse over, which you can enable in this 
dialog box.

Setting Anchor Point
Preferences

Move an Anchor Point or
Segment

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Selection & Anchor Display. 

Select the Anchor Point and
Handle Display options you want
to use:

◆ Anchors. Specify the display of
anchor points. 

◆ Handles. Specify the display of
handle end points (direction
points).

◆ Highlight anchors on mouse
over. Select to highlight the
anchor point located directly
below the mouse pointer.

◆ Show handles when multiple
anchors are selected. Select to
display direction lines on all
selected anchor points when
you use the Direct Selection or
Group Selection tool to select
an object.

Deselect to display direction
lines for an anchor point when
it is the only anchor point on
the path or when the Bezier
segment for the direction line is
selected and the anchor point
is not selected.

Click OK.4
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It’s hard to draw a segment right the first time. Moving anchor points
and segments is all part of the process of creating artwork. When you
move an anchor point, the segments that are connected to it change.
When you move a straight segment, the anchor points on the segment
move with it. When you move a curve segment, the curve changes, but
the connecting anchors remain the same. You can also change a curve
segment by adjusting a direction point on the direction handle. 

Moving Points and
Segments

Move an Anchor Point or
Segment

Select the Direct Selection tool on
the Tools panel.

Click a blank area to deselect all
points.

Drag an anchor point or drag the
middle of a segment.

◆ For a smaller move, click the
anchor point or segment, and
then press an arrow key.

◆ To constrain the movement of
anchor points or segments to
45 degrees, hold down Shift
while dragging.

To reshape a curve segment, click
an anchor point or a curve
segment, and then drag a direction
point at the end of the direction
handle. 
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Did You Know?
You can average the position of
anchor points. Select the anchor
points you want with the Direct
Selection tool, click the Object menu,
point to Path, click Average, click the
Horizontal (x axis), Vertical (y axis) or
Both option, and then click OK.
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When you create a curve with the Pen tool, the curve segment after the
second anchor point appears on the opposite side as the first curve
segment. If you want the second curve segment to appear on the same
side as the first, you need to convert the anchor point from a smooth
point to a corner point. You can make this conversion as you create the
curve segment with the Pen tool or you can do it later with buttons on
the Control panel or with the Convert Anchor Point tool.

Converting Points

Convert Points on a Path Using
the Control Panel

Select the Direct Selection tool on
the Tools panel.

Click the point that you want to
convert.

Click one of these buttons on the
Control panel:

◆ Convert to Corner. Click the
Convert Selected Anchor
Points to Corner button.

◆ Convert to Smooth. Click the
Convert Selected Anchor
Points to Smooth button.
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Converted to a corner point

Did You Know?
You can convert a mesh object back to
a path object. Select the mesh object,
click the Object menu, point to Path,
click Offset Path, enter 0 for the offset
value, and then click OK.
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Convert Points on a Path Using
the Convert Anchor Tool

Select the Convert Anchor Point
tool on the Tools panel.

◆ To turn the Pen tool into a
temporary Convert Anchor
Point tool, hold down Alt (Win)
or Option (Mac).

To convert a corner point to a
smooth point, drag a direction
handle from a corner point.

To convert a smooth point to a
corner point, click a smooth point. 

◆ To convert a smooth point to a
corner point with a nonsmooth
curve, drag a smooth point so it
forms a V shape.
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Creating a path is not necessarily the end of the job; in fact, there are
many ways you can modify a path once it's been created. For example,
you can add, subtract, or delete anchor points on an existing path. You
can also modify those points to conform to any desired shape. In addi-
tion, existing anchor points can be modified to change the segments
connecting the points. Just like anything else in Illustrator, paths are
flexible. They can be modified to meet whatever design considerations
are needed to make the job successful. 

Adding and Deleting
Anchor Points

Add Anchor Points

Select the Direct Selection tool on
the Tools panel.

Select the object to which you
want to add an anchor point.

Select the Add Anchor Point tool
on the Tools panel.

Click once on the path to add a
new anchor point.

◆ If you missed the path, click OK
in response to the alert, and
then try again.

When you add an anchor point to
a curve segment, a smooth point
appears on the path. When you
add an anchor point to a straight
segment, a corner point appears.

Click and drag on the path to add
and modify the segment. 
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Add Anchor Points to an 
Open Path

Select the Pen tool on the Tools
panel.

Point to the endpoint to which you
want to add an anchor point. 

A slash appears next to the Pen
pointer.

Click the endpoint to make it a
corner point or drag it to make a
smooth point.

Click once on the path to add a
new anchor point.

Delete Anchor Points

Select the Direct Selection tool on
the Tools panel.

Select the object from which you
want to delete an anchor point.

Select the Delete Anchor Point
tool on the Tools panel.

Click once on an existing anchor
point to remove it from the path.

The anchor points on either side of
the deleted point are now used to
define the segment.

◆ You can also click a point with
the Direct Selection tool, and
then click the Remove Selected
Anchor Points button on the
Control panel.
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In addition to aligning objects, the Align buttons on the Control panel
can also align points on a path along the horizontal and vertical axis.
For example, you can use the Vertical Align Center button to align two
anchor points to the center point between the two original points along
the vertical axis. If you have an open path with two endpoints that you
want to connect, you can use the Connect Selected End Points button
to connect them with a straight line. You can also join two endpoints
into a single point. If you want Illustrator to join the closed end points
for two paths, you can select the paths with the Selection tool, and
then use the Join command. 

Aligning and Joining 
Anchor Points

Align or Distribute Anchor
Points

Select the Lasso tool on the Tools
panel.

Drag to select two or more points
on the path.

◆ If you want to select points
individually, select the Direct
Selection tool, and then
Shift+click the points that you
want to select.

Click the Align To button, and then
select an align to option: Align to
Selection, Align to Key Anchor, or
Align to Artboard.

Click any of the following Align or
Distribute buttons on the Control
panel:

◆ Horizontal. Click one of the
Horizontal Align or Horizontal
Distribute buttons to move and
align the points horizontally.

◆ Vertical. Click one of the
Vertical Align or Vertical
Distribute buttons to move and
align the points vertically.

◆ Overlap. Click a Horizontal
Align button and then click a
Vertical Align button (or vice
versa) to move and align the
points horizontally and
vertically. 
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Join Anchor Endpoints with a
Straight Line

Select the Direct Selection tool on
the Tools panel.

Shift+click the two endpoints that
you want to join.

Click the Connect Selected End
Points button on the Control panel.

A straight line segment connects
the two endpoints.

Join Anchor Endpoints into 
a Single Point

Select the Direct Selection tool on
the Tools panel.

Shift-click the two endpoints that
you want to join.

◆ To quickly join the closed end
points, select the path with the
Selection tool, click the Object
menu, point to Path, and then
click Join.

To have the endpoints meet in the
middle (one on top of the other),
use the Horizontal Align and
Vertical Align buttons on the
Control panel.

Click the Connect Selected End
Points button on the Control panel.
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The Reshape tool on the Tools panel allows you to move points and
segments around to modify paths. This tool is useful for extending the
side of an object path. When you select multiple points, you can extend
or contract the selected point while leaving the unselected points
unchanged. You can also reshape a path with the Pencil or Paintbrush
tool. 

Reshaping Paths

Use the Reshape Tool

Select the Direct Selection tool on
the Tools panel.

Click a blank area to deselect
everything, and then click to select
an anchor point on a path.

Select the Reshape tool on the
Tools panel.

To drag multiple points at the same
time, Shift+click or use a selection
tool to select the ones that you
want.

Drag any point or segment.5
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Did You Know?
You can change the pointer into cross
hairs. Press Caps Lock to change the
pointer into a Precise Cursor (cross
hairs). Press Caps Lock again to
change it back.
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Reshape a Path with the Pencil
or Paintbrush Tool

Select the Pencil tool on the Tools
panel to reshape a path that
doesn’t have a brush stroke, or
select the Paintbrush tool to
reshape a path with a brush
stroke.

Select the path that you want to
reshape. Ctrl+click (Win) or
Command+click (Mac) a path.

Drag the edge of the path to
reshape it. 

3

2

1

Did You Know?
You can set Paintbrush options.
Double-click the Paintbrush tool on the
Tools panel, set the options that you
want, including Edit Selected Paths
Within X pixels, and then click OK.

You can add thickness to a stroke
path. Select the path with the stroke
you want to change, click the Object
menu, point to Path, and then click
Outline Stroke. The stroke expands to
become a filled shape that you can edit
with the Pen tool. This allows you to
tweak the path to make it appear as if
the stroke is thinner and thicker in dif-
ferent places. 

1
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When you use the Eraser tool on the Tools panel to remove parts of an
object, the remaining parts of the object path are reconnected to
reshape and close the path. When you erase inside of a filled object,
Illustrator creates a compound path. This is useful when you want to
simplify a complex drawing or remove a background.To make it easier
to erase, you can also press the [ or ] key to decrease or increase the
Eraser tool diameter. 

Erasing to Reshape
Paths

Erase Parts of Paths

Select the object that you want to
reshape with the Selection tool.

Select the Eraser tool on the Tools
panel.

Drag across the parts of the object
that you want to erase.

◆ Press the [ or ] key to decrease
or increase the Eraser tool
diameter. 

The remaining parts of the path
reconnect to close the path.

3

2

1

Did You Know?
You can set Eraser tool options.
Double-click the Eraser tool on the
Tools panel, and then set the options
that you want, including Angle,
Roundness, and Diameter, and then
click OK.
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Sometimes the appearance of a path is more ragged than you want.
You can use the Smooth tool to smooth the appearance of path or
stroke until you get the desired smoothness you want. You can change
the way the Smooth tool works by adjusting tool options. You can con-
trol how far you have to move your mouse or stylus before a new
anchor point is added to the path or the amount of smoothing applied to
the path when you use the tool.

Smoothing Paths

Smooth a Path

Select the object that you want to
smooth with the Selection tool.

Select the Smooth tool on the
Tools panel.

Drag across the length of the path
you want to smooth out.

Continue smooth until the path or
stroke is the smoothness you
want.

To adjust options, double-click the
Smooth tool on the Tools panel,
adjust the following tolerances,
and then click OK.

◆ Fidelity. Controls how far you
have to move your mouse
before a new anchor point is
added to the path (0.5-20
pixels). The higher the value,
the smoother and less complex
the path. 

◆ Smoothness. Controls the
amount of smoothing applied to
the path (0% to 100%). The
higher the value, the smoother
the path. 

◆ Reset. Sets the Smooth Tool
options back to the default.
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After you create a path, you can simplify it, which reduces the file size
and makes it display and print faster. Simplifying a path removes extra
anchor points without changing the shape of the path. You can specify
how you want Illustrator to reshape the path by using the Curve
Precision and Angle Threshold sliders. 

Simplifying Paths

Simplify a Path

Select the Direct Selection tool on
the Tools panel.

Select the object with the path
that you want to simplify.

Click the Object menu, point to
Path, and then click Simplify.

Select the Preview check box to
show a preview of the simplified
path as you make changes.

Drag the sliders to adjust the
Curve Precision and Angle
Threshold.

◆ Curve Precision. Specify a
percentage value between 0
and 100. A higher percentage
creates more points and a
close fit.

◆ Angle Threshold. Specify a
degree angle between 0 and
180 to control the smoothness
of corners. This is useful to
keep corners sharp, even if the
Curve Precision is low.

Select the Straight Lines check
box to creates straight lines
between the object’s original
anchor points.

Select the Show Original check
box to show the original path
behind the simplified path.

Click OK.8
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path cut out

The Divide Objects Below command allows you to use an object shape
to cut out other objects to divide them. Think of it like a cookie cutter.
When you cut through other objects, Illustrator discards the original
selection. In addition, you can use the Split Into Grid command to divide
objects into a grid or the Knife tool to cut objects along a freehand path
you draw with the tool, dividing objects into their compound filled
faces. A face is an area undivided by a line segment. 

Dividing Paths

Divide a Path

Create or select an object (not a
group) that you want to use as the
cutting object.

Select the Selection tool on the
Tools panel, and then move the
cutting object on top of the objects
that you want to divide.

Click the Object menu, point to
Path, and then click Divide
Objects Below.

Drag the edge of the path to
reshape it.

4
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Did You Know?
You can divide objects into a grid.
Select one or more closed path
objects, click the Object menu, point to
Path, click Split Into Grid, specify val-
ues for the grid, and then click OK.

You can cut objects with the Knife
tool. Select the Knife tool on the Tools
panel, drag the pointer over an object
with a curved path, or Alt+drag (Win)
or Option+drag (Mac) the artboard with
a straight path.
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The Scissors tool on the Tools panel allows you to split an open path
into two paths or open a closed path. You can split a path at an anchor
point or in the middle of a segment. If you want to split a path at an
anchor point, you can also use the Cut Path at Selected Anchor Points
button on the Control panel. 

Splitting Paths

Split a Path

Select the Direct Selection tool on
the Tools panel.

Select the object with the path
that you want to split.

Select the Scissors tool on the
Tools panel.

Click the object’s path where you
want to split it.

If you click on a closed path, it
turns into an open path. If you
click on an open path, it splits it
into two paths.

If you click a line segment, two
endpoints appear, one on top of
the other. 

To move the endpoints, select the
Direct Selection tool, and then
drag the selected endpoint to
display the endpoint below it.
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Split a Path Using the Control
Panel

Select the Direct Selection tool on
the Tools panel.

Select the object with the path,
and then click the anchor point
that you want to split.

Click the Cut Path at Selected
Anchor Points button on the
Control panel.

A new anchor point appears on
top of the selected one.

To move the anchor point, drag the
selected point to display the other
anchor point below it.
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Did You Know?
You can create new paths by an offset
amount. The Offset Path command cre-
ate a new vector path that is scaled to
be larger or smaller than the original
with affecting the original. If the path is
open, it creates a closed path, appear-
ing on both the inside and outside of
the original path, so you may need to
delete the part of the path that is not
needed. Select the object, click the
Object menu, point to Path, Offset Path,
specify the offset and options, and then
click OK.

See Also
See “Duplicating Objects” on page 94
for more information on setting options
with the Offset Path command.
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The Blob Brush tool on the Tools panel allows you to merge adjacent
paths without strokes. When drawing with the Blob Brush tool, new
paths merge with the topmost, matching the path that it connects with.
This works when the Blob Brush tool is set up to paint with the exact
same fill and appearance settings. When you intersect the paths, the
Blob Brush tool creates paths with a fill and no stroke. 

Merging Paths

Create Merged Paths with the
Blob Brush Tool

Select the Direct Selection tool on
the Tools panel.

Click a blank area to deselect
everything, and then click to select
an anchor point on a path.

Select the Appearance panel.

Click the Options menu, and then
deselect the New Art Has Basic
Appearance option.

When this option is deselected,
the Blob Brush tool uses the
attributes of the selected artwork.

Select the Blob Brush tool on the
Tools panel.

Make sure the Blob Brush is set
up to have the same fill color, no
stroke, and appearance settings
as the artwork.

Draw paths that intersect with the
artwork. 
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Set Blob Brush Options

Double-click the Blob Brush tool
on the Tools panel.

Select from the following options:

◆ Keep Selected. Select to keep
all paths during the merge
selected.

◆ Merge Only with Selection.
Select to have the Blob Brush
merge only with the selected
artwork.

◆ Fidelity. Specify how far (0.5 to
20 pixels) you need to move to
add an anchor point.

◆ Smoothness. Specify the
amount of smoothing applied to
the path. The higher the
percentage, the smoother the
path.

◆ Size. Specify the size of the
brush.

◆ Angle. Specify the angle of
rotation for the brush.

◆ Roundness. Specify the
roundness of the brush. 

Click OK.3
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If you have overlapping objects, you can use Shape Mode buttons on
the Pathfinder panel to create compound shapes, which are editable
and releasable (restoring original attributes). You can use Shape Mode
buttons (Unite to Shape Area, Minus Front from Shape Area, Intersect
Shape Area, or Exclude Overlapping Shape Areas) on almost any
object, except placed or rasterized images, mesh objects, or a single
group.

Working with Shape
Mode

Apply a Shape Mode Command

Select two or more overlapping
objects.

Select the Pathfinder panel.

Select from the following Shape
Mode buttons:

◆ Unite to Shape Area. Use to
join the outer edges of selected
objects into a compound shape.

◆ Minus Front from Shape Area.
Use to remove objects in front
of other objects and still
preserve paint attributes.

◆ Intersect Shape Area. Use to
preserve object areas that
intersect.

◆ Exclude Overlapping Shape
Areas. Use to change
overlapping areas to
transparency.

3

2

1

Did You Know?
You can expand a compound shape to
create a single path. Select the
Selection tool on the Tools panel,
select the compound shape, and then
click the Expand button on the
Pathfinder panel.

You can release a compound shape to
restore object attributes. Select the
Selection tool on the Tools panel,
select the compound shape, and then
click the Release Compound Shape on
the Options menu on the Pathfinder
panel.

1 2 3

Subtract shape mode Exclude shape mode
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The commands in the Pathfinder panel allow you to create a group of
separate, non-overlapping closed paths or lines. You start with overlap-
ping objects and you end up with non-overlapping ones. When you use
the Pathfinder commands—Divide, Trim, Merge, Crop, Outline, and
Minus Back—the original objects can’t be restored. You can only undo
the operation.

Working with
Pathfinder

Apply a Pathfinder Command

Select two or more overlapping
objects.

Select the Pathfinder panel.

Select from the following
Pathfinder buttons:

◆ Divide. Use to create a
separate, non-overlapping
object from an overlapping
area.

◆ Trim. Use to preserve the
frontmost object and delete
objects behind and overlapping.

◆ Merge. Use to merge adjacent
or overlapping objects with the
same fill attributes.

◆ Crop. Use to crop the frontmost
object; similar to a clipping
mask.

◆ Outline. Use to create an
outline of the overlapping
objects. 

◆ Minus Back. Use to remove
objects in the back, leaving
only part of the frontmost
object.

3
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1

Did You Know?
You can convert a stroke into a filled
object. Select an object with a stroke,
click the Object menu, point to Path,
and then click Outline Stroke.

1 2 3

Crop pathfinder Minus Back pathfinder
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A compound path is a single object made up from two or more objects.
In overlapping areas, a compound path removes the overlapping space
displaying the attributes of the backmost object behind it. Think of it like
a cookie cutter. After you create a compound path, you can release
(restore) it at any time. However, the results are not exact. If you want
to add another object to the compound path, you need to arrange the
object in front or back of the compound object, select them, and then
re-use the Make command for Compound Path.

Creating a Compound
Path

Create a Compound Path

Arrange your objects so that the
frontmost object will cut out to
reveal the attributes of the
backmost object.

Select all the objects that you
want to include in the compound
path.

Click the Object menu, point to
Compound Path, and then click
Make.

To add another object to the
compound path, arrange the
object in front or back of the
compound object, select them, and
then click the Object menu, point
to Compound Path, and then click
Make.
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1

Compound path

Did You Know?
You can convert strokes to compound
paths. Select the object, click the
Object menu, point to Path, and then
click Outline Stroke. The compound
path is grouped with the filled object.
To modify it, ungroup it from the fill or
select it with the Group Selection tool.
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Reverse an Object’s Fill in a
Compound Path

Click in a blank area to deselect
the compound path.

Select the Direct Selection tool on
the Tools panel.

Click the edge of the object for
which you want to reverse the fill.

Select the Attributes panel.

Click the Reverse Path Direction
Off button or Reverse Path
Direction On button. 

Release a Compound Path

Select the compound path.

Click the Object menu, point to
Compound Path, and then click
Release.

The single object reverts back to
individual objects. All the objects
are selected and painted with the
attributes from the compound
path, not their original attributes.
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Reverse an object’s fill

1

Released compound path



ptg8126863

194 Chapter 6

A clipping mask, or clipping path, is an object whose shape masks out
everything except the contents behind the shape. The clipping mask
(vector only) and the masked objects (any artwork) are called a clip-
ping set. You can create a clipping set from a selection of two or more
objects or from all objects in a group or layer. The main thing to remem-
ber is that the clipping mask object needs to be above the object that
you want to mask in the Layers panel or group. When you move or
transform a masked object, Illustrator displays only the masked area.

Creating a Clipping 
Set

Create a Clipping Mask

Create or select the clipping mask
object that you want to use as the
mask.

Move the clipping mask object
above the object that you want to
mask.

Select the clipping mask object
and the objects you want to mask.

Click the Object menu, point to
Clipping Mask, and then click
Make.
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Clipping set
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Create a Clipping Mask for a
Group or Layer

Create or select the clipping mask
object that you want to use as the
mask.

Select the Layers panel.

Move the clipping mask object and
the object that you want to mask
into a layer or group.

Move the clipping mask object
above the object that you want to
mask in the Layers panel or group. 

Select the layer or group.

Click the Make/Release Clipping
Mask button in the Layers panel.

Release Objects from a Clipping
Mask

Do one of the following to release
objects:

◆ Select the layer that contains
the clipping mask in the Layers
panel, click the Make/Release
Clipping Mask button.

◆ Select the group that contains
the clipping mask, click the
Object menu, point to Clipping
Mask, and then click Release.
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After you create a clipping set, you can edit the clipping mask or the
paths within the clipping set. At the same time you edit a clipping mask,
you can add or remove an object from the masked artwork. You can
also view and edit the mask independently of all other objects in
Isolation Mode. When you’re editing a clipping set, the main thing to
remember is that the clipping mask object needs to be above the object
that you want to mask in the Layers panel or group. 

Editing a Clipping 
Set

Edit a Clipping Set

Do one of the following to select
the clipping path or set:

◆ Select and target the clipping
path in the Layers panel.

◆ Select the clipping set, click the
Object menu, point to Clipping
Mask, and then Edit Mask.

Do any of the following to edit the
clipping mask:

◆ Select the Direct Selection tool
on the Tools panel, and then
drag the object’s center
reference point to move it.

◆ Select the Direct Selection tool
on the Tools panel, and then
reshape the clipping path.

◆ Apply a fill and stroke to a
clipping path.

To add or remove an object from
the masked artwork, drag the
object into or out of the group or
layer that contains the clipping
path.
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Edit Paths Within a Clipping Set

Do one of the following to select
the clipping path or set:

◆ Select and target the clipping
path in the Layers panel.

◆ Select the Direct Selection tool
on the Tools panel, and then
point to and click the paths
outline.

Drag to edit the path.

Edit the Masked Object in
Isolation Mode

Do one of the following to edit the
Masked object in Isolation Mode:

◆ Select the masked object, and
then click the Isolate Selected
Object button on the Control
panel.

◆ Select the layer with the
masked object in the Layers
panel, click the Layers Option
menu, and then click Enter
Isolation Mode.

Edit the masked object.

Click the gray bar or press Esc to
exit Isolation Mode.
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Working with Layers

Introduction

To be successful with Adobe Illustrator, you need to be in
control. You need to control color, to control elements of the
design, and you even need to control the order of design ele-
ments. If control is what you crave, then Layers, more than
any other feature, helps you achieve that control. Layers give
you the ability to separate individual elements of your
design, and then control how those elements appear. You can
think of Layers as a group of transparent sheets stacked on
top of each other. Through the creative use of these electronic
sheets, you can blend the elements of two or more layers,
and create layers to adjust and control contrast, brightness,
and color balance. You can even group layers together to
help organize and manage your design.

Layers are a digital designer's canvas, and they are just as
real as a stretched canvas is to a natural media designer. The
strokes you apply to a real canvas, using a brush, are equiva-
lent to strokes in an Illustrator layer when you use any of the
painting tools. The natural artist may use oils or watercolor in
the design while the Illustrator artist uses electronic ink. The
Layers panel allows you to view the image almost as if you
were actually painting or designing with natural media.
However, our canvas—the Layers panel—goes far beyond
anything possible in the "real" world. 

In Illustrator, using multiple layers is the way to control
the information within a document. There are times when
you will create several layers; each layer will contain a sepa-
rate aspect of the total design. Having multiple layers allows
you to adjust and move each element independently.
Eventually, multiple layers may no longer be necessary.
However, you might not want to link them together, or even
place them within the same folder. Instead, you might want
to combine them into a single unit. Once again, Illustrator
comes to the rescue by giving you several options for com-
bining layers without flattening the entire document.

7

7
What You’ll Do

Understand the Layers Panel

Set Layers Panel Options

Create Layers

Select Layers

Delete Layers

Select Objects with Layers

Arrange Layers and Objects

Duplicate Layers and Objects

Lock Layers and Objects

Show and Hide Layers and Objects

Merge Layers and Objects

Move Objects to a Layer

Flatten Artwork

Locate Objects in the Layers Panel

Create a Template Layer

View Layers as Outlines
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With the Layers panel, you can control ele-
ments of an Illustrator design by assigning
separate layers to each individual object. A
top-level layer appears at the top of the Layers
panel, which indicates the top of the stacking
order. You can create layers and sublayers
(nested layers) within a top-level layer. The cur-
rent layer in the Layers panel appears with a
white triangle in the upper right corner of the
layer. The circle icon on the right is the target,
which you can use to apply and edit appear-
ances. A small square next to the target indi-
cates an object selection. The arrowhead next
to a layer thumbnail allows you to expand/col-
lapse a layer group. To access the Layers
panel, select the Layers panel or, if the Layers
panel is not visible, click the Window menu,
and then click Layers.

Show/Hide. Click this icon to show and hide
the layer, sublayer, group, or object.

Lock/Unlock. Click this icon to lock or unlock
the layer, sublayer, group, or object.
Target. Click this icon to apply or edit
appearances for an object or group.
Locate Object. Click this button (New!) to
locate a selected object in your document in
the Layers panel.
Make/Release Clipping Mask. Click the Lock
Transparent Pixels, Lock Image Pixels, Lock
Position, or Lock All button.
New Sublayer. Click this button to create a
new sublayer in the active document.
New Layer Click this button to create a new
layer in the active document.
Delete Selection. Click this button to delete
the active layer.
Layers Options. Click this button to access a
menu of layer-specific commands.

Understanding the Layers Panel

Lock/Unlock

Show/Hide

Target

Top-level layer

Delete Selection

New Layer
New SublayerMake/Release Clipping Mask

Layers Options

Current Layer triangle

Sublayer

Group

Selection square

Locate Object
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Illustrator doesn't have a lot of options for controlling the Layers panel
itself; in fact, there are only a few—changing the size of the layer row
and showing or hiding layers by type. You can choose to view the layer
row size in a small (12 pixels), medium (20 pixels), or large (32 pixels)
size, or you can select a custom size. You can choose to show or hide
thumbnails based on type, including Layers, Top Level Only, Groups,
and Objects.

Setting Layers Panel
Options

Set Layers Panel Options

Select the Layers panel.

Click the Options menu, and then
click Panel Options.

Deselect the Show Layers Only
check box to show all layers.
Select it to show only top-level
layers and sublayers.

Click an option for Row Size:
Small, Medium, Large, or Other,
and then enter a size (12-100
pixels).

Select the check boxes you want
for Thumbnails: Layers, Top Level
Only, Groups, and Objects.

Click OK.6
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Layers give you control over the design elements of your document, so
Illustrator makes sure you have plenty of layers available to you. This
flexibility guarantees that you have the creative options to carry your
designs to any level you desire. To create a new layer, you must first
have an open document. A new document in Illustrator has a single top
level layer. If you have more than one document open, make sure the
active image is the one to which you want to add a layer. You can
quickly create a top level layer or sublayer using a button or add a layer
and select options using a dialog box, and then edit the name directly in
the Layers panel (New!). When you create a new vector object, you
also create a sublayer with the name <Path>. Each object that you cre-
ate or place appears as a new sublayer in the Layers panel.

Creating Layers

Create a New Top Level Layer

Select the Layers panel.

Click the top level layer that you
want the new layer to appear
above.

Click the New Layer button on the
Layers panel.

A new top level layer appears with
the name Layer and the next
number in order.

To rename the layer, double-click
the layer name, enter or edit the
name (New!), and then press
Enter (Win) or Return (Mac).

Create a Sublayer

Select the Layers panel.

Click the top level layer or
sublayer that you want the new
sublayer to appear within.

Click the New Sublayer button on
the Layers panel.

A new sublayer appears with the
name Layer and the next number
in order.

To rename the layer, double-click
the layer name, enter or edit the
name (New!), and then press
Enter (Win) or Return (Mac).
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Create a New Top Level Layer or
Sublayer with Options

Select the Layers panel.

Click the top level layer that you
want the new layer to appear
above, or sublayer that you want
the new sublayer to appear within.

Alt+click (Win) or Option+click
(Mac) the New Layer or New
Sublayer button on the Layers
panel.

The Layer Options dialog box
appears.

Enter a name for the layer or
sublayer.

Click the Color list arrow, and then
select a color.

Select the check boxes that you
want to apply to the layer or
sublayer:

◆ Template. Select to make a
template layer uneditable.

◆ Show. Select to show the layer
in the Layers panel.

◆ Preview. Select to view the
layer in Preview view.

◆ Lock. Select to lock the layer.

◆ Print. Select to enable printing
for the layer. Nonprintable
layers appear in italics in the
Layers panel.

◆ Dim Images to 50%. Select to
gray out images by the
specified percentage.

Click OK.7
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Before you can create a new layer or work on an existing layer, you
need to select it first. Simply click the layer name in the Layers panel. A
single selected layer appears with the white triangle in the corner and
is called the current layer. In some cases, such as moving, deleting, or
restacking layers, you want to select multiple layers. You can select
multiple sublayers or objects at the same nesting level within the same
top-level layer. However, you can’t select multiple sublayers or objects
on different top-level layers. 

Selecting Layers 

Select Layers

Open a multi-layered document,
and then select the Layers panel.

To select a single layer, click the
name in the Layers panel.

To select multiple layers in the
Layers panel use the following
options:

◆ Contiguous Layers. Click on the
first layer, and then Shift+click
the last layer to select first, last,
and all layers in-between.

◆ Non-Contiguous Layers. Click on
a layer, hold down the Ctrl (Win)
or A (Mac) key, and then click
on another layer.

To deselect layers in the Layers
panel use the following options:

◆ Deselect Individual. Hold down
the Ctrl (Win) or A (Mac) key,
and then click on a layer for a
multiple selection.

◆ Deselect All. Click the Select
menu, and then click Deselect.
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While Illustrator lets you add a lot of layers to a document, it also lets
you delete layers. Remember that once you've deleted a layer and
saved the document, there is no way to recover the deleted layer.
However, while the document is open, you can use the Undo command
to recover a deleted layer.  

Deleting Layers

Delete Layers

Select the Layers panel.

Select the layers that you want to
delete. 

◆ Hold down the Ctrl (Win) or A
(Mac) key, and then click to
select multiple items.

Click the Delete Layer button.

If prompted, click Yes to delete
any objects on the layer or
sublayer. 

4

3

2

1

Did You Know?
You can delete layers without the
prompt.  Select the layers that you
want to delete, and then drag them
onto the Delete Layer button.

1

2

Layer deleted
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In an earlier chapter you learned how to select objects using selection
tools on the Tools panel and the Select menu. You can also select
objects using the Layers panel. When you click the Selection area to
the right of the target circle for a specific layer, all the paths, groups,
and objects on the layer become selected. A selection square appears
next to that target circle. In addition, the target circle for each path and
group becomes selected and ready for editing.

Selecting Objects with
Layers 

Select and Deselect Objects in a
Layer

Select the Layers panel.

To select objects in a layer use the
following options:

◆ Top-level. Click the Selection
area for the top-level layer.

A selection square appears for
each sublayer, group, and object
on all the layers within it.

◆ Individual Layers. Expand the
top-level layer, and then click
the Selection area for the layer
that you want to select.

To deselect objects in the Layers
panel use the following options:

◆ Top-level. Shift+click the
Selection square for the top-
level layer.

◆ Individual All. Expand the top-
level layer, and then Shift+click
the Selection square.
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Select Multiple Objects on
Different Layers 

Select the Layers panel.

Expand the layers with the objects
that you want to select in the
Layers panel.

Click the selection area or target
circle for the first object.

Shift+click the other individual
group or object layers that you
want to include in the selection. 

The layers don’t need to be
adjacent to each other. They can
be anywhere in the Layers panel.

To deselect a group or object
layer, Shift+click the Selection
square for the layer.
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The layers in the Layers panel appear from top to bottom as they
appear in the document window. The first layer (top-level layer) at the
top of the Layers panel is the topmost layer in the document window.
The last layer in the Layers panel is the bottommost layer in the docu-
ment window. You can change the stacking order of the layers in the
Layers panel. When you change the order in the Layers panel, the
objects in the document window change too.

Arranging Layers and
Objects 

Arrange Layers and Objects in
the Layers Panel

Select the Layers panel.

Select the layers that you want to
move.

Drag the selected layers up or
down the list in the Layers panel.

As you drag, the pointer changes to
a hand and a dark gray line
appears.

The dark gray line indicates the
new location of the layers when
you release the mouse.

Release the mouse at the location
where you want to move the layers.
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Did You Know?
You can reverse the order of layers.
Select the Layers panel, select the lay-
ers you want to reverse in order, click
the Options menu, and then click
Reverse Order. 
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Arrange Objects and Layers
Using an Arrange Command

Select the Layers panel.

Select the layers that you want to
move.

Click the Object menu, and then
point to Arrange.

Click one of the following
commands:

◆ Bring to Front. Moves the
selected layers up to the top
level.

◆ Bring Forward. Moves the
selected layers up a level.

◆ Send Backward. Moves the
selected layers down a level.

◆ Send to Back. Moves the
selected layers down to the last
level.

◆ Send to Current Layer. Moves
the selected layers to the
current layer.
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There are times when you will need a copy of a layer. Duplicating a
layer is a simple process that creates a pixel-to-pixel copy of the
selected layer. Once the copied layer is created, it becomes a separate
image within the document. You can then begin to make changes to the
new layer. Duplicating a layer gives you the ability to control each layer
separately and to apply nondestructive effects to your image by making
them on a copy of the image instead of the original. 

Duplicating Layers and
Objects

Duplicate Objects and Layers in
the Layers Panel

Select the Layers panel.

Select the layers that you want to
duplicate.

◆ Hold down the Ctrl (Win) or A
(Mac) key, and then click to
select multiple items.

Click the Options menu, and then
click Duplicate “Layer Name.”

3

2

1

Did You Know?
You can duplicate a layer with the
New Layer button. Drag the layer over
the New Layer button and Illustrator
creates an exact copy of the layer and
appends the word copy at the end of
the original layer name.

You can duplicate a layer by dragging
a Selection square. Drag+Alt (Win) or
Drag+Option (Mac) the Selection
square up or down in the Layers panel
to the location where you want to
place the duplicate layers.

Duplicated layer

1 3
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When you don’t want an object to be moved or modified, you can lock it
in the Layers panel. When you lock a layer, the objects remain visible in
the document window. When you click the edit (second) column in the
Layers panel, a padlock icon appears, indicating the layer is locked.
When you lock a layer, all the objects on the layer are locked, including
all groups and sublayers. To unlock a layer, you simply click the padlock
icon to remove it. You can lock/unlock individual layers, multiple layers,
and top-level layers.

Locking Layers and
Objects

Lock and Unlock Objects and
Layers in the Layers Panel

Select the Layers panel.

Use any of the following:

◆ Lock/Unlock Individual. Click
the edit (second) column for
each layer that you want to
lock or unlock. 

◆ Lock/Unlock Multiple. Click
and drag the edit (second)
column.

◆ Lock/Unlock Top-Level. Click
the edit (second) column for the
top-level layer.

All the layers in the top-level
are locked/unlocked.

◆ Lock/Unlock Except One.
Alt+click (Win) or Option+click
(Mac) the edit (second) column
for a top-level layer to
lock/unlock all the other top-
level layers except the one you
clicked.

2

1

1

2
Did You Know?

You can lock and unlock objects using
the Object menu. Click the Object
menu, point to Lock, and then click
Selection, All Artwork Above (objects
that overlap the area of the selected
object), or Other Layers (all layers
other than the layer that contains a
selected item or group). 
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When you have a lot of objects in the document window, it can be hard
to work with them. In the Layers panel, you hide layers and objects to
reduce the clutter and make it easier to work with the layers and
objects that you want. When you click the visibility (first) column in the
Layers, an eye icon appears indicating the layer is visible. To hide a
layer, you simply click the eye icon to remove it. When you hide a top-
level layer, all the objects within it are also hidden. The eye icons
appear dimmed. You need to make the top-level layer visible to show all
the objects within it. Hidden objects don’t print and don’t appear in the
document window in either Preview or Outline views. When you save,
close, and reopen your document, any hidden objects remain hidden
until you show them.

Showing and Hiding
Layers and Objects

Show and Hide Objects and
Layers in the Layers Panel

Select the Layers panel.

Use any of the following:

◆ Show/Hide Individual. Click the
visibility (first) column for each
layer that you want to show or
hide. 

◆ Show/Hide Multiple. Click and
drag the visibility (first) column.

◆ Show/Hide Top-Level. Click the
visibility (first) column for the
top-level layer.

All the layers in the top-level are
shown/hidden.

◆ Show/Hide Except One.
Alt+click (Win) or Option+click
(Mac) the visibility (first) column
for a top-level layer to
show/hide all the other top-level
layers except the one you
clicked.
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If you have objects on multiple layers and want to consolidate them
onto one layer, you can merge them together. You can merge two or
more groups, or a combination of groups and sublayers (if they are both
in the same top-level layer). However, you can’t merge an object with
another object. If a layer is locked or hidden, you can still use  them in
a merge. Before you use the Merge Selected command, it’s a good idea
to make a copy of your document as a backup to preserve a copy of the
separate layers. 

Merging Layers and
Groups

Merge Layers and Groups in the
Layers Panel

Select the Layers panel.

Select two or more layers,
sublayers, or groups that you want
to merge. 

◆ Hold down the Ctrl (Win) or A
(Mac) key, and then click to
select multiple items.

Click the last layer into which you
want to merge the selected layers. 

Click the Options menu, and then
click Merge Selected.
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Merged layer
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With the Collect in New Layer command, you can move all the selected
layers in the Layers  panel into a new layer. You can select top-level
layers, sublayers, groups, or objects. With the Release to Layers
(Sequence) command, you can move objects or groups that are nested
within a top-level layer into separate layers within the same layer. If
you want to build an animation, you can use the Release to Layers
(Build) command to create a sequence of objects that you can use to
create the animation in a program such as Adobe Flash.

Moving Objects to a
Layer

Move Objects to a New Layer

Select the Layers panel.

Select the layers that you want to
move. The layers must all have the
same indent level. 

◆ Hold down the Ctrl (Win) or A
(Mac) key, and then click to
select multiple items.

Click the Options menu, and then
click Collect in New Layer.

Sublayers, groups, or objects are
nested in a new sublayer within
the same top-level layer. 

To rename the layer, double-click
the layer name, enter or edit the
name (New!), and then press
Enter (Win) or Return (Mac).
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4 Moved to new layer

Did You Know?
You can paste objects between layers.
With the Paste Remembers Layers
option, artwork is pasted into the layer
from which it was copied, regardless
of which layer is active in the Layers
panel. This is useful when you want to
paste artwork between documents and
you want to automatically place it into
a layer of the same name. If the desti-
nation document doesn’t have a layer
of the same name, Illustrator creates a
new layer. In the Layers panel, click
the Options menu, and then select
Paste Remembers Layers.
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Release Objects to New Layers

Select the Layers panel.

Select the top-level layer, sublayer,
or group (not an object layer) that
you want to use. 

Click the Options menu, and then
click Release to Layers
(Sequence).

Sublayers, groups, or objects are
nested in a new sublayer within
the same top-level layer. 

To rename the layer, double-click
the layer name, enter or edit the
name (New!), and then press
Enter (Win) or Return (Mac).
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Did You Know?
You can create objects for animation.
Select the Layers panel, select the top-
level layer, sublayer, or group (not an
object layer) that you want to use, click
the Options menu, and then click
Release to Layers (Build).

After you separate your layers, you can
use the Export command on the File
menu to export your document layers
to a Flash SWF file. 

See Also
See “Exporting as a Flash Movie” on
page 410 for more information on
exporting an Illustrator document as a
Flash SWF file.

4 Released to new layer
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The Flatten Artwork command allows you to flatten an entire document
into one top-level layer with sublayers and groups nested within it.
After you use the Flatten Artwork command, all objects remain editable
and any appearances on layers are applied to all the objects in your
document.

Flattening Layers

Flatten Layers in the Layers
Panel

Select the Layers panel.

Select the top-level layer or a layer
within it that you want to use as a
new main layer for the document. 

Click the Options menu, and then
click Flatten Artwork.

If any of the layers are hidden, an
alert appears, asking if you want to
discard the hidden layers.

If prompted, click Yes to discard
the hidden layers, or click No to
preserve them.
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When the Layers panel contains a lot of layers, groups, and objects, it
can be hard to find the one you want to work on, especially if the object
is in a collapsed layer. All you need to do is select the object in the doc-
ument that you want to find and then click the Locate Object button
(New!) on the Layers panel or choose the Locate Object command on
the Options menu.

Locating Objects in the
Layers Panel

Locate an Object in the Layers
Panel

Select the object that you want to
find in the document window. 

Select the Layers panel.

Click the Locate Object button
(New!) on the Layers panel.

◆ You can also click the Options
menu, and then click Locate
Object.

This command changes to
Locate Layer if the Show Layers
Only panel option is selected.
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Located layer with object
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If you want to trace an image, the best way to do it is to create a tem-
plate layer, which dims the image and locks the layer. You can create a
template layer in the Layers panel for an existing image, or in the Place
dialog box. In the Place dialog box, you simply select the Template
check box. In the Layers panel, you choose the Template option on the
Options menu. After you create a template layer, you can change its
properties.

Creating a Template
Layer

Create a Template Layer

Select the Layers panel.

Select the layers that you want to
change into template layers. 

Click the Options menu, and then
click Template to select it.

The layer is locked and dimmed by
50%. A square with a border icon
appears in the Visibility column to
indicate a template layer.

You can use Illustrator tools to
trace the image.

To change options for the template
layer, double-click the layer (not on
the name), specify the options you
want, and then click OK.

◆ Template. Deselect to remove
the template from the layer. The
layer remains intact.

◆ Dim Images to. Specify the
transparency/opacity
percentage you want for the
image.

To remove the template from the
layer, click the Options menu, and
then click Template to deselect it.
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The Outline command on the View allows you to view your entire docu-
ment as an outline. If you only want to view the outline of a specific
layer, you can use a shortcut in the Visibility column in the Layers
panel. Viewing artwork in an outline displays only its paths without any
paint attributes. For complex artwork, this speeds up the time it takes to
redraw the screen when you make changes. When you finish viewing
layers as outlines, you can return to Preview view, where you can view
everything in color.

Viewing Layers as
Outlines

View a Layer as an Outline

Select the Layers panel.

Ctrl-click (Win) or A-click (Mac)
the eye icon for the layer in the
Layers panel to toggle the view of
the layer in Outline and Preview
view.

The eye icon in the Visibility column
in the Layers panel appears without
the center eye to indicate the layer
appears in Outline view.

◆ Unselected Layers as Outlines.
You can Alt+Ctrl-click (Win) or
Option+A-click (Mac) the eye
icon for the selected layer in the
Layers panel to toggle the view
of the layer in Outline and
Preview view for all unselected
layers. You can also click the
Options menu, and then click
Outline Others.

To show all layers in Preview view,
click the Options menu, and then
click Preview All Layers.
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Outline layer icon

Layers as an
Outline
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Working with Type

Introduction

Illustrator comes with 6 different type tools: Type, Area Type,
Type on a Path, Vertical Type, Vertical Area Type, and Vertical
Type on a Path. Three of the tools are used for horizontal type
and the other three are used for vertical type. The functional-
ity between the two types is the same; only the direction of
the type differs. 

Before you can work with type in Illustrator, you need to
select it. You can select the entire type object or the charac-
ters in the type object. The Selection tool allows you to select
both characters and their object, while the Direct Selection
tool allows you to select just the characters in the type object
or both characters and their object. You can also use the type
tools to select only the characters in the type object, not the
object itself. If you type, paste, or import more text than a
type object can hold, an overflow symbol (a tiny red plus
sign in a square) appears on the edge of the type object. You
can reshape the type object to display the text or create a
thread (link) to another type object. You can thread overflow
text from one type object to a new or existing type object. 

Illustrator provides two panels to modify characters and
paragraphs. With the Character panel, you can change the
font family (Arial or Times New Roman) and style (Italic, Bold,
or Condensed), as well as change other type attributes, such
as size, kerning, scale, tracking, leading, and language. With
the Paragraphs panel, you can change type alignment,
indenting, and before and after spacing. 

When integrating artwork and graphics with your type,
you can wrap the text in a type object around another object,
such as a graphic. Another type effect, Create Outlines,
allows you to convert characters in a type object into a sepa-
rate object with a path, which you can use as a mask object. 8

8
What You’ll Do

Use Type Tools

Create Type

Create Area and Path Type

Modify Type on a Path

Import Text

Select Type

Copy or Move Type

Work with Overflow Type

Change Fonts and Font Size

Lead, Kern, and Track Type

Scale and Rotate Type

Format Type

Anti-alias Type

Align Paragraphs

Indent and Space Paragraphs

Set Tabs

Work with Hyphenation

Work with Type Styles

Use Smart Punctuation

Work with Glyphs and OpenType Fonts

Work with Justification

Wrap Type Around an Object

Create Type Outlines
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Illustrator comes with 6 different type tools: Type, Area Type, Type on a
Path, Vertical Type, Vertical Area Type, and Vertical Type on a Path.
Three of the tools are used for horizontal type and the other three are
used for vertical type. The functionality between the two types is the
same; only the direction of the type differs.

Using Type Tools

Use Type Tools

Click the Type tool slot on the Tools
panel.

◆ Click the arrow on the right of
the Type tools menu to create a
detachable panel.

Click one of the following Type
tools:

◆ Type. Creates type that is not
associated with a path. You can
use it to enter type along the
edge of an open path or inside a
closed path. 

◆ Area Type. Creates type inside
an open or closed path.

◆ Type on a Path. Creates type
along the outer edge of an open
or closed path.

◆ Vertical Type. Creates vertical
text and works like the Type
tool.

◆ Vertical Area Type. Creates
vertical type inside an open or
closed path.

◆ Vertical Type on a Path. Creates
vertical type along the outer
edge of an open or closed path.

Click a blank area of the artboard,
and then type some text. 

◆ For some Type tools, you can
also draw a text box to create
the size you want. 
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Illustrator comes with 6 different type tools: Type, Area Type, Type on a
Path, Vertical Type, Vertical Area Type, and Vertical Type on a Path.
Three of the tools are used for horizontal type and the other three are
used for vertical type. The functionality between the two types is the
same; only the direction of the type differs. The Type and Type Vertical
tools create type known as point type, that is not associated with a
path. However, you can also use these tools to enter type along the
edge of an open path or inside a closed path. 

Creating Type

Create Type

Select the Type or Vertical Type
tool on the Tools panel.

◆ Click the arrow on the right of
the Type tools menu to create a
detachable panel.

Click a blank area of the artboard
to create a type object.

A flashing insertion point appears
in the type object.

Type some text. Press Enter (Win)
or Return (Mac) to start a new line.

◆ To keep the type tool selected
so you can create more type
objects, hold down Ctrl (Win) or
A (Mac), click outside the
current type object, release the
key, and then type more text.

Select a selection tool or select
the type tool again.
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Did You Know?
You can create vertical type with the
regular Type tool and horizontal type
with the Vertical Type tool. Select the
type tool you want, hold down the Shift
key, click or drag a rectangle, and then
type some text.
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Selected type object
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With the Type and Vertical Type tools, you can create a rectangle text
box any size that you want. When you type text in the type object, it
automatically wraps to the size of the box. If you type more text than the
box can hold, an overflow symbol (a tiny red plus sign in a square)
appears on the edge of the rectangle box. You can reshape the type
object to display the text or create a thread (link) to another type object.

Creating Type in a 
Text Box

Create Type in a Text Box

Select the Type or Vertical Type
tool on the Tools panels.

◆ Click the arrow on the right of
the Type tools menu to create a
detachable panel (optional).

Drag to create a rectangle text box
the size that you want.

A flashing insertion point appears
in the type object.

Type some text. The text
automatically wraps to the shape of
the type object. Press Enter (Win)
or Return (Mac) to start a new line.

◆ To keep the type tool selected
so you can create more type
objects, hold down Ctrl (Win) or
A (Mac), click outside the
current type object, release the
key, and then type more text.

◆ If the overflow symbol appears,
deselect the type object, select
the Direct Selection tool on the
Tools panel, and then drag a
corner to reshape the type
object.  

Select a selection tool or select the
type tool again.
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Selected type object
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With the Area Type and Vertical Area Type tools, you can add type
inside the path of any object or inside an open path. When you add
type with these type tools, the object is converted to a type object. So,
if you want to preserve the original object, you need to make a copy of
it before you add type. 

Creating Area Type

Create Area Type Inside an
Object

Select the Area Type or Vertical
Area Type tool on the Tools panels.

◆ Click the arrow on the right of
the Type tools menu to create a
detachable panel (optional).

◆ If you want to add type to a
closed path, you can also use
the Type or Vertical Type tools.

Click on the edge of the path
(closed or open) to which you want
to add type.

A flashing insertion point appears
in the type object. Any fill or stroke
on the object is removed.

Type some text. The text
automatically wraps to the shape of
the type object. Press Enter (Win)
or Return (Mac) to start a new line.

The type appears inside the object
and conforms to its shape. 

◆ To keep the type tool selected
so you can create more type
objects, hold down Ctrl (Win) or
A (Mac), click outside the
current type object, release the
key, and then type more text.

◆ If the overflow symbol appears,
deselect the type object, select
the Direct Selection tool on the
Tools panel, and then drag a
corner to reshape the type
object.  

Select a selection tool or select the
type tool again.

4
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1

Setting Area Type Options
The Area Type Options dialog box allows you to change the width
and height of the type object, add rows and columns, specify text
flow in the rows and columns, change the inset spacing between
area type and the edge of its type object, and adjust the first line of
the type object. Select an area type object, click the Type menu,
click Area Type Options, specify the options that you want, and then
click OK. 

For Your Information

Selected
type object

1 3

2
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With the Type on a Path and Vertical Type on a Path tools, you can add
type along the inner or outer edge of a path. You can place the text on
either side of the path, but not on both. If you initially place it on the
inner part of the path, you can always move it to the outer part of the
path later.

Creating Path Type

Create Type on a Path

Select the Type on a Path or
Vertical Type on a Path tool on the
Tools panel.

◆ Click the arrow on the right of
the Type tools menu to create a
detachable panel (optional).

◆ If you want to add type to a
open path, you can also use the
Type or Vertical Type tools.

Click on the edge of the path
(closed or open) to which you want
to add type.

A flashing insertion point appears
in the type object. Any fill or stroke
on the object is removed.

Type some text. The text
automatically wraps to the shape of
the type object. Don’t press Enter
(Win) or Return (Mac).

The type appears along the edge of
the object, conforms to its shape,
and removes the fill and stroke. 

◆ To keep the type tool selected
so you can create more type
objects, hold down Ctrl (Win) or
A (Mac), click outside the
current type object, release the
key, and then type more text.

◆ If the overflow symbol appears,
deselect the type object, select
the Direct Selection tool on the
Tools panel, and then drag a
corner to reshape the type
object.  

Select a selection tool or select the
type tool again.
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Selected type object
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Move Type on a Path

Select the Selection tool or Direct
Selection tool on the Tools panel.

Click on the type.

Center, left, and right brackets
appear around the type.

Drag the bracket (not the square)
to adjust the position of the type
on a path.

◆ Swap Sides. Drag the Center
bracket to the other side to
change the inner/outer position
of the type along the path.

◆ Left. Drag to position the left
side (or starting point) of the
type along the path.

◆ Center. Drag left or right to
position the type along the
path.

◆ Right. Drag to position the right
side (or ending point) of the
type along the path.

If the overflow symbol appears,
deselect the type object, select
the Direct Selection tool on the
Tools panel, and then drag a
corner to reshape the type
object. 

Select a selection tool or select
the type tool again.

4
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Did You Know?
You can change type case. To help you
format sentences correctly and
change capitalization, you can change
text case. Select the type that you
want to change, click the Type menu,
point to Change Case, and then click
UPPERCASE, lowercase, Title Case, or
Sentence case.

Selected type object

1
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After you create type on a path, you can change the alignment, shape,
and orientation of the type with the Type on a Path dialog box. You can
apply type effects, which include Rainbow, Skew, 3D Ribbon, Stair Step,
or Gravity, as well as change alignment and spacing. You can even flip
the type on the path. Experiment with the effects and alignment options
to create some unique type. 

Modifying Type on a
Path

Modify Type on a Path

Select the Selection tool or Direct
Selection tool on the Tools panel.

Click on the type along the path.

Center, left, and right brackets
appear around the type.

Click the Type menu, point to Type
on a Path, and then click Type on a
Path Options.

Select the Preview check box to
view your changes in the document
window. 

Click the Effect list arrow, and then
select an effect: Rainbow, Skew,
3D Ribbon, Stair Step, or Gravity.

◆ You can also select these effect
options from the Type on a Path
submenu on the Type menu.

Click the Align to Path list arrow,
and then select an alignment
option: Baseline, Ascender,
Descender, or Center. 

Specify a spacing value (-36 to 36).
The default is Auto.

Select or deselect the Flip check
box to position the type.

Click OK.9
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If you have text in a document that you want to use in your artwork, you
can use the Place command to import it into your document. You can
import text from the following text formats: plain text (TXT), Rich Text
Format (RTF), or Microsoft Word (DOC or DOCX). When you import text
using the Place command, Illustrator creates a new type object and
places the text in it.

Importing Text

Import Text

Click the File menu, and then click
Place.

Click the Files of Type (Win) or
Enable (Mac) list arrow, and then
click All Formats or select a text
format:

◆ Text (TXT). Plain text.

◆ Microsoft Word (DOC).
Microsoft Word 2003 or earlier.

◆ Microsoft Word (DOCX).
Microsoft Word 2007 or later.

◆ Microsoft RTF (RTF). Rich Text
Format.

Navigate to the drive or folder
location with the text file you want
to import.

Click the text file you want to place.

Click Place.

For some imported files, a dialog
box appears, asking for placement
options.

Select the options you want.

Click OK.7
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Before you can work with type in Illustrator, you need to select it. You
can select the entire type object or the characters in the type object.
The Selection tool allows you to select both characters and their
object, while the Direct Selection tool allows you to select just the
characters in the type object or both characters and their object. You
can also use the type tools to select only the characters in the type
object, not the object itself.

Selecting Type

Select Type and its Object

Select the Selection tool on the
Tools panel.

Use the appropriate selection
method:

◆ Point Type. Click on the type. 

◆ Path Type. Click on the path. 

◆ Area Type. Click on the type.
For a type object with a fill,
click the fill, a character, the
baseline, or outer path.

Select a Type Object and Not 
the Type

Select the Direct Selection tool on
the Tools panel.

Click the edge of a path or area
type object.

2

1

2

1

Did You Know?
You can show hidden characters. If it’s
hard to see spaces and paragraphs,
you can show hidden characters to
make them easier to see. Click the
Type menu, and then click Show
Hidden Characters.

1
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Selected type object

Selected type object
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Select and Deselect Type and
Not its Object

Select any of the Type tools on the
Tools panel.

Do any of the following to select:

◆ Text. Drag the I-beam cursor to
select and highlight a word or
line of type.

◆ Word. Double-click a word of
type. 

◆ Paragraph. Triple-click a
paragraph of type.

◆ All Text. Click to place the
insertion point, click the Select
menu, and then click All.

TIMESAVER Click in a type
object, press Ctrl+A (Win) or
A+A (Mac) to select all the text.

To deselect the type, Ctrl+click
(Win) or A+click (Mac) outside
the type object.

3

2

1

Did You Know?
You can use Smart Guides to help you
select text. Click the View menu, and
then click Smart Guides to turn the fea-
ture on. Click the Edit (Win) or
Illustrator (Mac), point to Preferences,
click Smart Guides, select the Object
Highlighting check box, and then click
OK.

1 Selected word

Selected paragraph

Selected
characters
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If you have text in a document that you want to use in your artwork, you
can copy and paste it into your Illustrator document. You can place the
text into an existing type object or have Illustrator create one for you. In
Illustrator, you can copy type in a type object or copy individual charac-
ters, and then paste them into another Illustrator artboard or document,
or into another program, such as Flash, Photoshop, or a word process-
ing program.

Copying or Moving 
Type

Copy or Move Text from Another
Program

Open the other program, such as
Microsoft Word.

Select the text that you want to
copy or move, and then use
commands to copy or cut (move)
the text.

Switch back to Illustrator.

To place the text into an existing
type object, click in a type object to
place the insertion point.

Click the Edit menu, and then click
Paste.

TIMESAVER Ctrl+V (Win) or
A+V (Mac).
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1 24

Pasted text

Did You Know?
You can delete empty type objects
from a document. Click the Object
menu, point to Path, click Clean Up,
select the Empty Text Paths check box,
and then click OK. 
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Copy Type and its Object

Select the Selection tool on the
Tools panel.

Select the type that you want to
copy.

Click the Edit menu, and then click
Copy.

TIMESAVER Ctrl+C (Win) or
A+C (Mac).

Click in another Illustrator artboard
or document.

◆ You can also switch to another
program and paste the text.

Click the Edit menu, and then click
Paste, Paste in Front, or Paste in
Back.

TIMESAVER Ctrl+V (Win) or
A+V (Mac).

Copy or Move Type from One
Object to Another

Select the Type or Vertical Type
tool on the Tools panel.

Select the type that you want to
copy or move.

Click the Edit menu, and then click
Copy or Cut (move).

TIMESAVER Ctrl+C (Win) or
A+C (Mac) to copy or Ctrl+X
(Win) or A+X (Mac) to cut.

To place the text into an existing
type object, click in a type object to
place the insertion point.

Click the Edit menu, and then click
Paste.

TIMESAVER Ctrl+V (Win) or
A+V (Mac).
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If you type, paste, or import more text than a type object can hold, an
overflow symbol (a tiny red plus sign in a square) appears on the edge
of the type object. You can reshape the type object to display the text
or create a thread (link) to another type object. You can thread overflow
text from one type object to a new or existing type object. After you
create a thread between two or more type objects, you can use the
Show Text Threads command on the View menu to display the thread
connection. If you no longer want to want to thread two or more type
objects, you can unthread or disconnect them. When you unthread type
objects, the text in the type object remains in the first type object (it
may still overflow). When you disconnect type objects, the text in the
type objects remains where it is. 

Working with Overflow
Type

Thread Overflow Type to Another
Object and Show Text Threads

Select the Selection tool on the
Tools panel.

Select the type object with the
overflow type.

Click the Out Port icon on the
selected object.

TIMESAVER Double-click an
Out Port icon with the Selection
tool to create a linked copy of the
type object.

The pointer changes to the Loaded
Text pointer.

To create a new type object for the
overflow text, click a blank area or
drag to create a type object.

To use an existing type object,
position the pointer over an existing
type object, and then click the
object’s path. A fill and stroke of
None is applied to the path.

Overflow text from the first type
object threads to the second type
object.

To display a text thread between
type objects, select a threaded type
object, click the View menu, and
then click Show Text Threads.
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Unthread Type Objects

Select the Selection tool on the
Tools panel.

Select a threaded type object.

Double-click the In Port or Out Port
icon on the selected object.

Unthread or Disconnect a Type
Object

Select the Selection tool on the
Tools panel.

Select a threaded type object that
you want to release or disconnect.

Do one of the following:

◆ Unthread. Click the Type menu,
point to Threaded Text, and then
click Remove Threading.

◆ Disconnect. Click the Type
menu, point to Threaded Text,
and then click Release
Selection.
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A font is a collection of alphanumeric characters that share the same
typeface, or design, and have similar characteristics. With the
Character panel, you can change the font family (Arial or Times New
Roman) and style (Italic, Bold, or Condensed), as well as change other
type attributes, such as size, kerning, scale, tracking, leading, and lan-
guage. You can also change these and other attributes by using the
Type menu and Control panel. You can access the Character panel from
the Window menu and the Control panel. As you can see, there are sev-
eral ways to change font attributes. You can use any one of them. We’ll
focus on the Character panel. If you want to know which fonts are cur-
rently being used in your document or find/change a font in your docu-
ment, the Find Font dialog box can help you do the job.

Changing Fonts

Change Font Family and Style

Select any type tool, and then
select the type that you want to
change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel. 

◆ Click the Window menu, point
to Type, and then click
Character. 

To change the type language, click
the Language list arrow, and then
select a language.

◆ To show all options, click the
Options menu, and then click
Show Options.

Click the Font Family list arrow,
and then select a font.

◆ To see the font family in the
style of the font, click the Type
menu, point to Font, and then
select a font. 

TIMESAVER To reuse a recent
font, click the Type menu, point to
Recent Font, and then select a
font.

Click the Font Style list arrow, and
then select a font style, such as
Italic, Bold, or Condensed.
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Find or Change a Font

Click the Type menu, and then
click Find Font.

The fonts in the top list are the
ones currently used in your
document. The list at the bottom
displays fonts in your document or
fonts on your computer, depending
on your setting.

To find a specific font in your
document, select it in the top list.

Select the check boxes at the
bottom to specify the font
attributes that you want to find.

To replace the font in the top list,
select a font in the bottom list.
Click the Replace With Font From
list arrow, and then click System to
show all the fonts on your
computer.

Click Find to display the first
instance of the font, and then click
Change to replace it, or click
Change All to replace all uses of
the font in your document.

When you’re done, click Done.6
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Did You Know?
You can change the type language.
Select the Character panel, click the
Language list arrow (available when
you Show Options on the Options
menu), and then select the language
that you want to use. You can also
select type using any type tool, and
then change the type language to
something else.
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After setting the font family and style, the next attribute to set is the
font size. The size of each font character is measured in points (a point
is approximately 1/72 of an inch). The font size can range from 6 points
to 72 points and beyond with the right type of font. Open or TrueType
fonts can be scaled to any size and still look and print well. Bitmap
(screen fonts), fonts, on the other hand, cannot be scaled and you need
to use the available sizes to print well. However, bitmap fonts are the
best choice for commercial print jobs. An “O” appears next to an
OpenType font, a “TT” appears next to a TrueType font, and an “a”
appears next to a bitmap font on the Font submenu.  

Changing Font Size

Change Font Size

Select any type tool, and then
select the type that you want to
change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel. 

◆ Click the Window menu, point
to Type, and then click
Character. 

Enter a font point size, or click the
Font Size list arrow, select a font
size, and then press Enter (Win) or
Return (Mac) to apply the value.

◆ You can also hold down
Ctrl+Shift (Win) or A+Shift
(Mac), and then press > to
increase the point size or press
< to decrease the point size.

The type increases or
decreases by the Size/Leading
value set in Type preferences.

Use Ctrl+Alt-Shift (Win) or
A+Option+Shift (Mac) to
change the point size 5 sizes 
at a time.
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Leading is the distance from the baseline of one line to the baseline of
the next line and is measured in points. Each line of type can have a
different leading. You can specify a specific setting or use Auto, which
is a percentage of the largest type size on each line. Leading is applied
to horizontal type. If you want to change vertical spacing in type, you
need to adjust horizontal tracking.

Leading Type

Change Type Leading

Select any horizontal type tool,
and then select the type that you
want to change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel. 

◆ Click the Window menu, point
to Type, and then click
Character. 

Enter a leading point size, or click
the Leading list arrow, and then
select a leading size. Press Enter
(Win) or Return (Mac) to apply the
value.

◆ You can also hold down Alt
(Win) or Option (Mac), and then
press the down arrow to
increase the point size or press
the up arrow to decrease the
point size.

The type increases or
decreases by the Size/Leading
value set in the Type
preferences.

To shift characters up or down
from the baseline, enter a baseline
value, or click the Baseline list
arrow, and then select a baseline
value. A positive size adds space
while a negative number removes
space. Press Enter (Win) or Return
(Mac) to apply the value.
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Kerning is the amount of space between each individual character that
you type. Sometimes the space between two characters is larger than
others, which makes the word look uneven. You can use the Character
panel to change the kerning setting for selected characters. You can
expand or condense character spacing to create a special effect for a
title, or realign the position of characters to the bottom edge of the
text—this is helpful for positioning copyright or trademark symbols.

Kerning Type

Change Type Kerning

Select any type tool, and then click
between the two characters of
type that you want to change the
distance between. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel. 

◆ Click the Window menu, point
to Type, and then click
Character. 

Enter a kerning size, or click the
Kerning list arrow, and then select
a kerning size. A positive size adds
space while a negative number
removes space. Press Enter (Win)
or Return (Mac) to apply the value.

◆ You can also hold down Alt
(Win) or Option (Mac), and then
press the right arrow to
increase the point size or press
the left arrow to decrease the
point size. 

The type increases or
decreases by the Tracking
value set in the Type
preferences.
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1

Did You Know?
You can fit headline type to its object.
Select any type tool, select or click in a
single-line paragraph of area type,
click the Type menu, and then click Fit
Headline. 
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Tracking is the adjustment of space between three or more characters.
Typically, you’ll track a line of type or a few words, depending on the
length and design application. This is useful for creating specialized
type for a caption or short heading. To adjust space between two char-
acters, kerning is the best choice. To adjust tracking between charac-
ters, you need to select them first and then set the Tracking option in the
Character panel.

Tracking Type

Change Type Tracking

Select any type tool, and then
select the type that you want to
change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel. 

◆ Click the Window menu, point
to Type, and then click
Character. 

Enter a tracking size, or click the
Tracking list arrow, and then
select a tracking size. A positive
size adds space while a negative
number removes space. Press
Enter (Win) or Return (Mac) to
apply the value.

◆ You can also hold down Alt
(Win) or Option (Mac), and then
press the right arrow to
increase the point size or press
the left arrow to decrease the
point size.

The type increases or
decreases by the Tracking
value set in the Type
preferences.
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Scaling allows you to make type wider or narrower for horizontal type
and taller or shorter for vertical type. You can use the Horizontal Scale
and Vertical Scale options in the Character panel to modify type. If the
scaling doesn’t look quite right, you can always use the Undo command
to reverse it.

Scaling Type

Change Type Scaling
Horizontally or Vertically

Select any type tool, and then
select the type that you want to
change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel. 

◆ Click the Window menu, point
to Type, and then click
Character. 

◆ To show all options, click the
Options menu, and then click
Show Options.

Enter a horizontal or vertical
percentage, or click the Horizontal
Scale or Vertical Scale list arrow,
and then select a percentage.
Press Enter (Win) or Return (Mac)
to apply the value. Other ways of
scaling text include:

◆ To scale a type object, select
the object, double-click the
Scale tool on the Tools panel,
select the Non-Uniform option,
specify a Horizontal and
Vertical percentage, and then
click OK.

◆ To scale a type object, select
the object, select the Free
Transform tool on the Tools
panel, and then drag a side
handle on the bounding box.
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After you create type, you can rotate text characters or the entire text
block to a custom angle. You change the custom angle in the Character
panel, which is available on the Type submenu on the Window menu.
For text blocks, you can also rotate them horizontally or vertically by
using the Horizontal or Vertical command on the Type Orientation sub-
menu on the Type menu.

Rotating Type

Rotate Type

Select any type tool, and then
select the type that you want to
change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel.

◆ Click the Window menu, point
to Type, and then click
Character. 

◆ To show all options, click the
Options menu, and then click
Show Options.

Enter a rotation value, or click the
Character Rotation list arrow, and
then select a rotation value. Press
Enter (Win) or Return (Mac) to
apply the value.

◆ Rotate Horizontal or Vertical.
Click the Type menu, point to
Type Orientation, and then click
Horizontal or Vertical.

Drag the bracket (not the square)
to adjust the position of the type
on the path.
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In addition to changing the font type and size, you can also apply for-
matting to type. The formatting options include: All Caps (New!), Small
Caps (New!), Superscript (New!), Subscript (New!), Underline, and
Strikethrough. You can access these formatting options on the
Character panel when you show all options. You can also access these
formatting options on the Options menu.

Formatting Type

Format Type

Select any type tool, and then
select the type that you want to
change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel.

◆ Click the Window menu, point
to Type, and then click
Character. 

◆ To show all options, click the
Options menu, and then click
Show Options.

Select any of the following
formatting options:

◆ All Caps. Click to format type
with all caps (New!).

◆ Small Caps. Click to format type
with small caps (New!).

◆ Superscript. Click to format
type that is raised above 
the  baseline (New!). For
example, 1st.

◆ Subscript. Click to format type
that is dropped below the
baseline (New!). For example,
H20.

◆ Underline. Click to format type
with an underline.

◆ Strikethrough. Click to format
type with a line through it.
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Anti-aliasing affects the pixels on the edge of text by allowing them to
blend in with the background. It is a crucial feature when working with
text as it makes it appear smoother and more integrated. The drawback
with anti-aliasing is that at smaller font sizes the text can appear blurry.
To avoid this problem, use sans serif text, such as Helvetica or Arial,
and don’t use bold and italic. You apply anti-aliasing to text boxes
instead of individual characters. The anti-aliasing settings are saved
along with the document and supported for PDF, AIT, and EPS formats.

Anti-aliasing Type

Set a Text Box to Anti-Alias Text

Select any type tool, and then
select the type that you want to
change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character panel. 

◆ Click the Window menu, point
to Type, and then click
Character. 

◆ To show all options, click the
Options menu, and then click
Show Options.

Click the Anti-Alias list arrow, and
then select one of the following:
None, Sharp, Crisp, or Strong. 

3

2

1
2

3

Anti-alias text
at small sizes

Alias text produces crisp
fonts at small sizes.

Alias text

Anti-aliasing blends the edge
pixels with the background.Did You Know?

You can set anti-aliasing options
when you export text to graphic for-
mats. When you export text to BMP,
PNG, Targa, JPEG, or TIFF formats, you
can set the following anti-aliasing
options: None, Art Optimized, or Type
Optimized. These options are also
available in the Save For Web 
dialog box. 
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When you press the Enter (Win) or Return (Mac) in a type object,
Illustrator creates a paragraph. You can use the Paragraph panel to
align and indent paragraphs in your document. At the top of the
Paragraph panel is a set of buttons that you can use to align text in one
or more paragraphs. The panel includes the typical options to align:
left, center, right and justify. However, it also includes options to justify
with only the last line aligned left, center, or right. 

Aligning Paragraphs

Align Paragraphs

Select any type tool, and then click
in a paragraph or select multiple
paragraphs that you want to align. 

◆ You can also select the
Selection tool, and then click
the paragraph.

Select the Paragraph panel. 

◆ Click the Window menu, point
to Type, and then click
Paragraph. 

Use any of the following alignment
buttons on the panel: 

◆ Align Left, Align Center, or
Align Right. Click these buttons
to align paragraph type left,
center, or right.

◆ Justify Left, Center, or Right.
Click these buttons to justify the
paragraph text with only the
last line aligned left, center, or
right.

◆ Justify. Click to justify all lines. 
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Quickly indent lines of text to precise locations from the left or right
margin with the horizontal ruler. Indent the first line of a paragraph
(called a first-line indent) as books do to distinguish paragraphs. Indent
the second and subsequent lines of a paragraph from the left margin
(called a hanging indent) to create a properly formatted bibliography.
Indent the entire paragraph any amount from the left and right margins
(called left indents and right indents) to separate quoted passages. In
addition to indenting paragraphs, you can also set the spacing you
want before or after a paragraph.

Indenting and Spacing
Paragraphs

Indent and Space Paragraphs

Select any type tool, and then click
in a paragraph or select multiple
paragraphs that you want to
change. 

◆ You can also select the
Selection tool, and then click
the paragraph.

Select the Paragraph panel. 

◆ Click the Window menu, point
to Type, and then click
Paragraph. 

Enter a Left Indent and/or Right
Indent value or use the up and
down arrows to specify one. Press
Enter (Win) or Return (Mac) to
apply the value.

To create a first-line indent, enter
a First-Line Indent value or use the
up and down arrows to specify
one. Press Enter (Win) or Return
(Mac) to apply the value.

◆ To create a hanging indent,
enter a negative value in the
First-line Left Indent box.

To add spacing between
paragraphs, enter a Space Before
Paragraph and/or Space After
Paragraph value or use the up and
down arrows to specify one. Press
Enter (Win) or Return (Mac) to
apply the value.
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In your document, tabs set how text or numerical data is aligned in
relation to the document margins. A tab stop is a predefined stopping
point along the document’s typing line. Default tab stops are set every
half-inch, but you can set multiple tabs per paragraph at any location.
Choose from four types of text tab stops: left, right, center, and decimal
(for numerical data). In the Tabs panel, you can view a ruler with the
current tab setting for the selected type and add, move, or delete tab
stops. When you press the Tab key with the insertion point, the text
shifts to the next tab stop.

248 Chapter 8

Setting Tabs

Set Tabs

Select any type tool, and then click
to place the insertion point in a
type object.

Select the Tabs panel.

◆ Click the Window menu, point
to Type, and then click Tabs. 

◆ To use the default tabs, press
the tab key to shift the text to
the next default tab stop.

To move the panel next to the text,
click the Position Panel Above
Text button on the panel.

Do any of the following:

◆ Insert. Click one of the tab stop
buttons, and then click in the
ruler where you want to place
it. You can also enter a number
in the X box to insert a tab at an
exact position.

◆ Move. Drag the tab stop left or
right or enter an exact position
in the X box.

◆ Delete. Drag a tab stop down
off the ruler.

◆ Leader. Enter a character that
repeats in the tabbed space,
such as a period.

◆ Align On. Enter a character that
is used with the Decimal tab,
such as a decimal point.
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When you select the Hyphenate check box in the Paragraph panel,
Illustrator automatically adds hyphenation as you need it in your docu-
ment based on the options set in the Hyphenation dialog box. If the
Hyphenate check box is not checked, you need to select any existing
type to apply hyphenation. The Hyphenation options allow you to spec-
ify how long a word needs to be before hyphenation takes place, the
maximum number of hyphens you can use, and what balance you want
between better spacing and fewer hyphens.

Working with
Hyphenation

Change Hyphenation Options

Select any type tool, and then
select the type that you want to
hyphenate. 

Select the Paragraph panel.

To enable hyphenation, select the
Hyphenate check box.

Click the Options menu, and then
click Hyphenation.

Specify the following options:

◆ Words Longer Than. Enter the
minimum number of characters
a word must have before
hyphens are added.

◆ After First. Enter the minimum
number of characters that can
be inserted before a hyphen.

◆ Before Last. Enter the minimum
number of characters that can
be inserted after a hyphen on
the next line.

◆ Hyphen Limit. Enter the
maximum number of hyphens in
a row (0-25).

◆ Hyphenation Zone. Drag the
slider to adjust the balance of
hyphenation between better
spacing and fewer hyphens.

◆ Hyphenate Capitalized Words.
Select to hyphenate capitalized
words.

Click OK.6
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A style is a group of format settings that you can create or modify to
get the exact look you want. When you create a new style, you can
specify if it applies to paragraphs or characters, and give the style a
short name that describes its purpose so you and others know when to
use that style. A paragraph style is a group of format settings that can
be applied only to all of the text within a paragraph (even if it is a one-
line paragraph), while a character style is a group of format settings
that is applied to any block of text at the user’s discretion. To modify a
style, adjust the formatting settings of an existing style. If you see a
style with a plus sign (+) after the name, it means that the type with the
applied style also contains other formatting, which you can remove, or
redefine the style.   

Working with Type
Styles

Create or Edit Styles

Select any type tool, and then
select the type that you want to
use as the style. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character Styles or
Paragraph Styles panel. 

◆ Click the Window menu, point
to Type, and then click
Character Styles or Paragraph
Styles. 

Use any of the following options: 

◆ Create. Alt+click (Win) or
Option+click (Mac) the Create
New Style button on the
Character Styles or Paragraph
Styles panel, and then enter a
name for the style.

◆ Edit. Deselect any styles, and
then double-click the style that
you want to edit.

Select a category, such as
General, Basic Character Formats,
Advanced Character Formats,
Character Color, or OpenType
Features.

View the current settings and
make any changes that you want.

Click OK.6
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Apply Styles

Select any type tool, and then
select the type that you want to
change. 

For paragraph styling, select a
type object or select paragraphs.
For character styling, select text,
not a type object.

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character Styles or
Paragraph Styles panel. 

Click a style name in one of the
panels.

Work with Styles

Select any type tool, and then
select the type with the style that
you want to change. 

◆ You can also select the
Selection tool, and then click
the type object.

Select the Character Styles or
Paragraph Styles panel. 

Do any of the following:

◆ Delete a Style. Select a style,
and then click the Delete
Selected Styles button.

◆ Clear Overrides. Alt+click 
(Win) or Option+click (Mac),
the style name to remove the
plus sign (+).

◆ Redefine a Style. Click the
appropriate Options menu, and
then click Redefine Character
Style or Redefine Paragraph
Style.
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Smart Punctuation turns your text into professional looking type.
Instead of using straight quotes, you can use smart quotes. Instead of
using hyphen as dashes, you can use En or Em dashes. You would not
want to make these changes manually, but you don’t have to. Illustrator
can do it for you with the Smart Punctuation command. You can change
the entire document all at one time or you can select the type that you
want to change.

Using Smart
Punctuation

Use Smart Punctuation

Select any type tool, and then
select the type that you want to
change, or deselect all to convert
the entire document. 

Click the Type menu, and then
click Smart Punctuation.

Select the check boxes with the
Smart Punctuation options that
you want to use.

Select the Selected Text Only or
Entire Document option.

Select the Report Results check
box to display a list of your
changes on the screen.

Click OK.6
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1

See Also
See “Setting Up a Document” on page
34 for information on specifying a quo-
tation marks style in the Document
Setup dialog box.

Did You Know?
You can force punctuation marks near
the edge to appear outside the type
object. Select the type that you want to
change, select the Paragraph panel,
click the Options menu, and then click
Roman Hanging Punctuation. 
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A glyph is a style variation—such as ligatures, ordinals, swashes, and
fractions—for a given character in an OpenType font. OpenType fonts
appear with an “O” next to the font name on the Font submenu.
OpenType fonts are designed to work well on both Windows and
Macintosh operating systems, which reduces font substitution prob-
lems when going back and forth between platforms. However, you can
always add more character styles to extend the font format. For exam-
ple, you can change fractions with numerals and slashes to properly
formatted fractions. You can automatically insert alternate glyphs with
the OpenType panel or insert them manually with the Glyphs panel to
extend the font format.

Working with Glyphs

Replace or Insert a Glyph

Select any type tool, and then
select a character (to replace a
glyph) or click in text (to insert a
glyph).

Select the Glyphs panel (from the
Type menu).

◆ Click the Window menu, point
to Type, and then click Glyphs.

Select a different font and font
style.

Click the Show list arrow, and then
select a glyphs category.

Alternative for Current Selection
or Entire Font are common
choices.

Double-click the glyph that you
want to replace or insert.
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Did You Know?
You can use the OpenType panel to
insert glyphs. Select the OpenType
panel, select the type that you want to
change or deselect all text for the
entire document, and then select the
buttons with the options for glyphs that
you want to apply, such as ligatures,
swashes, titling, ordinals, and 
fractions.
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When you use an OpenType font indicated by an O symbol in the font
list  (such as the ones with “Pro” at the end), you can apply additional
font attributes in the OpenType panel. These include standard and dis-
cretionary ligatures, contextual, tiling, or stylistic alternatives, swash,
ordinals, and fractions. A ligature is made by joining two or more char-
acters by merging their parts together, such as one above the other or
one inside the other. Some fonts have variations on different letter-
forms, known as alternatives. There are three types: contextual (better
joining behavior), stylistic, and titling (large text). You can view the
characters in a font using the Glyphs panel. Since OpenType fonts dif-
fer, not all options in the OpenType panel are available for every font. 

Working with
OpenType Fonts

Work with OpenType Fonts

Select any type tool, and then
select the type that you want to
change. 

Select the OpenType panel.

◆ Click the Window menu, point
to Type, and then click
OpenType.

Specify the following options:

◆ Figure. Select a figure style;
typically set to the default. 

◆ Position. Select a baseline
position; typically set to the
default. 

Click to enable/disable the
OpenType attributes you want:

◆ Standard Ligatures. These
include fi, fl, ff, ffi, and ffl.

◆ Contextual Alternates. Formats
script text, like handwriting.

◆ Discretionary Ligatures. These
include ct, st, and ft.

◆ Swash. An exaggerated part of
a serif character.

◆ Stylistic Alternates. Creates a
aesthetic effect.

◆ Tilting Alternates. Formats
large-sized text, like titles.

◆ Ordinals. Formatted numbers
with superscript characters.

◆ Fractions. Numbers separated
by a slash.
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If you need more control over word and letter spacing and character
scaling in justified text, you can use the Justification command in the
Paragraph panel. These advanced options allow you to enter minimum,
desired, and maximum values for Word Spacing, Letter Spacing, and
Glyph Scaling (glyph spacing). The minimum and maximum values
define the overall range for spacing, while the desired value defines
the spacing you want for both justified and unjustified paragraphs. The
best use of the Justification dialog box is to start with the initial values
and then adjust them with the Preview option set.

Working with
Justification

Change Justification Options

Select any type tool, and then
select the type that you want to
change. 

Select the Paragraph panel.

◆ Click the Window menu, point
to Type, and then click
Paragraph.

Click the Options menu, and then
click Justification.

Select the Preview check box to
view your changes in the
document window.

Specify the following options:

◆ Word Spacing. Enter a spacing
value (0% - 1000%; at 100%, no
additional space is added)
between words defined by
pressing the spacebar.

◆ Letter Spacing. Enter a spacing
value (-100% - 500%; at 0%, no
additional space is added)
between letters, including
kerning or tracking values. 

◆ Glyph Scaling. Enter a scaling
value (50% - 200%) for the
width of any font characters. 

◆ Auto Leading. Enter a
percentage value for leading.

◆ Single Word Justification.
Specify how to justify single-
word paragraphs.

Click OK.6
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When integrating artwork and graphics with your type, you can wrap
the text around objects to create the results that you want. You can
wrap area type around a path, a placed graphic, or another type object.
When wrapping type around an object, the important thing is to make
sure the wrapped object is in front of the area type object in the same
top-level, sublayer, or group. 

Wrapping Type Around
an Object

Wrap and Unwrap Type Around
an Object

Arrange the object to be wrapped
in front of the area type object in
the same top-level, sublayer, or
group. The objects should be
overlapping.

Select the object to be wrapped in
the Layers panel.

Click the Object menu, and then
point to Text Wrap Options.

◆ If prompted, click OK to create
the text wrap.

Click the Object menu, point to
Text Wrap, and then click Text
Wrap Options.

Select the Preview check box to
view your changes as you set
options.

Enter an Offset value to specify the
distance between the wrapped
object and the type object.

Click OK.

You can move the objects to
finalize the results. The type will
rewrap around the object.

To unwrap (release) a text wrap,
select the wrapped object (not the
type object), click the Object
menu, point to Text Wrap, and then
click Release.
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The Create Outlines command converts characters in a type object into
a separate object with a path. Some characters, such as “A” or “B,”
that contain an interior shape (known as a counter) are converted into
compound objects. After you create an outline, you can reshape the
path, use it as a mask object, fill it with a gradient or a mesh, or use it in
a compound object. When you create outlines, the fill and stroke attrib-
utes and any appearances of the type are applied to the outlines.
Before you use the Create Outlines command, it’s a good idea to make
a copy of the type object or your document as a backup to preserve a
copy of the type layers. 

Creating Type Outlines

Create Type Outlines

Select the Selection tool on the
Tools panel.

Select the type object or select
characters in the type.

Click the Type menu, and then click
Create Outlines.

To release a compound object into
separate objects, click the Object
menu, point to Compound Path, and
then click Release.
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Working with Graphics

Introduction

In addition to opening Illustrator documents, you can also
open graphic files created in different formats, such as TIFF,
JPEG, GIF, and PNG. You open a graphic file the same way
you open documents in Illustrator. You can also use
Illustrator's Place command to insert artwork. Illustrator lets
you place graphic files saved in Photoshop PSD, BMP, JPEG,
EPS, and PNG formats, to name a few. 

With Illustrator's Place command, you can link or embed
an image into your document. Embedding inserts a copy of
one document in another. When data is embedded, you can
edit it using the menus and toolbars of the program in which
it was created. Linking displays information stored in one
document in another. After you link or embed a graphic
image file into an Illustrator document, you can use the Links
panel in Illustrator to manage and work with the files. The
Links panel displays a list of all the linked or embedded files
in your document. 

If you have a raster graphic, such as a JPEG, TIFF, or PSD
file, in your document, you can use tracing options to convert
the graphic into editable vector artwork. You can set options
to create a close simulation of the graphic or a more artistic
rendering of it and then fine-tune your results. 

The Graphic Styles panel allows you to create, save, and
apply graphics styles. A graphic style is a collection of attrib-
utes that can be applied to a layer, sublayer, group, or object.
The Appearance panel allows you to apply and manage mul-
tiple attributes of an object. You can apply fills, strokes, opac-
ity, blending mode, effects, and other attributes to objects,
layers, groups, or graphic styles. The panel makes it easy to
apply, edit, duplicate, restack, or remove attributes. 9

9
What You’ll Do

Open Graphics

Place Graphics

Place Graphics from Adobe Bridge

Link Graphics

Manage Linked Graphics

Trace Raster Graphics

Adjust Tracing Options

Convert Tracing to Paths

Apply Graphic Styles

Create Graphic Styles

Edit Graphic Styles

Apply Appearance Attributes

Create a Mosaic Graphic
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In addition to opening Illustrator documents, you can also open graphic
files created in different formats, such as TIFF, JPEG, GIF, and PNG. You
open a graphic file the same way you open documents in Illustrator.
When you open a graphic file, a tab appears across the top of the
Document window, which you can click to display. If you need to man-
age, organize, or find graphic files, Adobe Bridge is the way to go. With
Adobe Bridge, you can search for the graphic files that you want to
edit, and then open them in Illustrator. 

Opening Graphics

Open a Graphic Image

Click the File menu, and then click
Open to display all file types in the
file list of the Open dialog box.

Click the Files of Type (Win) or
Enable (Mac) list arrow, and then
select a graphic format.

Navigate to the drive or folder
location with the image you want
to open.

Click the graphic file you want to
open. 

TIMESAVER Press and hold
the Shift key to select multiple
contiguous files to open in the
Open dialog box.

Click Open. 5
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See Also
See “Opening a Document with Adobe
Bridge” on pages 16-17 or “Placing
Graphics from Adobe Bridge” on pages
262-263 for more information on find-
ing, opening, or placing graphic files
from Bridge.
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You can use Illustrator's Place command to insert artwork into an open
document. To increase your control of the new image information,
Illustrator places the new image into a separate layer. Illustrator lets
you place graphic files saved in Photoshop PSD, BMP, JPEG, EPS, and
PNG formats, to name a few. When you first place a vector-based
image into Illustrator, you have the ability to modify the width, height,
and rotation while retaining the vector format of the file. 

Placing Graphics

Place a Graphic

Open an Illustrator document.

Click the File menu, and then click
Place.

Navigate to the drive or folder
location with the image you want
to open.

Select the graphic file that you
want to place into the active
document.

Select any of the following
options:

◆ Link. Places a screen version
of the graphic and links the
document to the graphic file.
Deselect to embed a copy of
the graphic file image in the
document.

◆ Template. Places a dimmed
version of the graphic on a
template layer for tracing.

◆ Replace. Replaces the
currently selected image.

Click Place.

Illustrator places the image in a
new layer, directly above the
active layer, and then encloses it
within a transformable bounding
box.

Control the shape by manipulating
the corner and side nodes of the
freeform bounding box.
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Adobe Bridge allows you to search, sort, filter, manage, and process
graphic files one at a time or in batches. You can open or place graph-
ics directly into Illustrator by using the Open With (Adobe Illustrator) or
Place (In Illustrator) commands in Bridge from the File menu. You can
also drag thumbnails from the Bridge into an open Illustrator document
window.

Placing Graphics from
Adobe Bridge

Browse and Open Graphics with
Adobe Bridge

Click the Go to Bridge button on
the Application bar or click the
File menu, and then click Browse
in Bridge.

Adobe Bridge opens, displaying
files and folders on your computer.

Navigate to the drive or folder
where the file is located.

Select the graphic thumbnail
representing the file that you want
to open in your Illustrator
document.

Click the File menu, point to Open
With, and then click Adobe
Illustrator CS6.
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Did You Know?
You can locate a linked graphic in
Bridge from Illustrator. In the Links
panel, select the graphic name, click
the Options menu, and then click
Reveal In Bridge.
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Place Graphics with Adobe
Bridge

Click the Go to Bridge button on
the Application bar or click the
File menu, and then click Browse
in Bridge.

Adobe Bridge opens, displaying
files and folders on your computer.

Navigate to the drive or folder
where the file is located.

Select the graphic thumbnail that
represents the file you want to
place in your Illustrator document.

Click the File menu, point to Place,
and then click In Illustrator.

◆ Drag to Illustrator. Drag the
graphic from Bridge to the
Illustrator icon on the taskbar
(Win) or Dock (Mac), hold for a
moment to display Illustrator,
release the mouse to place the
graphic image. 
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Did You Know?
You can drag-and-drop Photoshop ele-
ments into Illustrator. In Photoshop,
select all or part of an image or a layer,
select the Move tool, and then drag the
selection or layer into an Illustrator art-
board to place an embedded copy of it
in your document.

You can change XMP data for a
graphic. Click the Go to Bridge button
on the Application bar, locate and
select the image you want, select the
Metadata panel, click the Edit button
for a data item, enter data, and then
click the Apply button (check mark) at
the bottom of the panel. 

1

3

4



ptg8126863

264 Chapter 9

With Illustrator's Place command, you can link or embed an image into
your document. Embedding inserts a copy of one document into
another. When data is embedded, you can edit it using the menus and
toolbars of the program in which it was created (that is, the source pro-
gram). Linking displays information stored in one document (the source
file) in another (the destination file). You can edit the linked object from
either file, although changes are stored in the source file.  If you break
the link between a linked object and its source file, the object becomes
embedded. As you work with linked or embedded files in the Layers
panel, a linked image appears as <Linked File>, while an embedded
image appears as an image object.

Linking Graphics

Link to a Graphic

Open an Illustrator document.

Click the File menu, and then click
Place.

Select the graphic file that you
want to place into the active
document.

Select the Link check box.

◆ To embed a copy of the graphic
file image in the document,
deselect the Link check box.

Click Place.

Illustrator places the image in a
new layer, directly above the
active layer, and then encloses it
within a transformable bounding
box.
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See Also
See “Setting File Handling & Clipboard
Preferences” on pages 466-467 for
information on setting linking options.
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Edit a Linked Graphic in the
Source

Select the linked graphic.

Click Edit Original on the Control
panel.

◆ You can also click the Edit
Original button on the Links
panel.

Make the changes that you want
in the original program.

Return to Illustrator.

If prompted, click Yes to update
your document.

Select Placement Options for
Linked Graphics

Select the linked graphic.

Click image name on the Control
panel, and then click Placement
Options.

◆ You can also click the Options
menu in the Links panel, and
then click Placement Options.

Click the Preserve list arrow, and
then select an option: Transforms,
Proportions (Fit), Proportions
(Fill), File Dimensions, or Bounds.

If available, select an alignment
position, and select or deselect
the Clip To Bounding Box check
box.

Click OK.5
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After you link or embed a graphic image file into an Illustrator docu-
ment, you can use the Links panel in Illustrator to manage and work
with the files. The Links panel displays a list of all the linked or embed-
ded files in your document. You can use the Links panel to update,
replace, or relink a graphic image file. If a linked file is moved from its
original location, you need to repair the link the next time you open the
document. If a linked file needs to be updated, a warning icon appears
in the Links panel to let you know.

Managing Linked
Graphics

Replace a Linked or Embedded
Graphic

Select the Links panel.

Select the name of the graphic
that you want to replace.

Click the Relink button on the
panel.

◆ You can also select the image
in the document window, click
the image name or Embedded
on the Control panel, and then
click Relink.

Select the graphic file that you
want to use as the replacement in
the active document.

Click Place.

◆ You can also select the image
in the document window, click
the File menu, click Place,
select a replacement image,
select the Replace check box,
and then click Place.
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Did You Know?
You can locate a placed graphic in
your document. In the Links panel,
select the graphic that you want to
find, and then click the Go To Link 
button on the panel.
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Work with Linked or Embedded
Graphics

Select the Links panel.

Select the graphic name that you
want to change.

Do any of the following:

◆ Update a Link. Click the Update
Link button on the panel.

◆ Go to Link. Click the Go To
Link button on the panel.

◆ Edit Original. Click the Edit
Original button on the panel to
open the program that created
the file and edit it.

◆ View Information. Double-click
the graphic name, view the
information, and then click OK.

◆ Change from Linked to
Embedded. Click the Options
menu, and then click Embed
Image.
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1

See Also
See “Setting File Handling & Clipboard
Preferences” on pages 466-467 for
information on setting linking options.

Did You Know?
You can change the display of the
Links panel. In the Links panel, click
the Options menu, and then select a
display option, such as: Show All,
Show Missing, Show Modified, Show
Embedded, Sort By Name, Sort By
Kind, or Sort By Status.
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View link information
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If you have a raster graphic—such as a JPEG, TIFF, or PSD file—in
your document, you can use tracing options to convert the graphic into
editable vector artwork. You can set options to create a close simula-
tion of the graphic or a more artistic rendering of it and then fine-tune
your results. The Image Trace option (New!) on the Control or Image
Trace panel detects and traces the color and shading in a raster
graphic to create an editable vector object. You can use tracing presets
(recommended for first time users), such as Line Art, Technical
Drawing, or High Fidelity Photo, or set your own tracing options in the
Image Trace panel. You can also access options on the Image Trace
submenu on the Object menu. When applied, a traced object is known
as an image trace object.

Tracing Raster
Graphics

Trace a Raster Graphic

Select the graphic that you want
to trace.

◆ You can also select an image
trace object to change it.

Use one of the following:

◆ Preset. Click the Tracing
Presets list arrow on the
Control panel, and then select a
tracing preset.

◆ Last Used. Click the Image
Trace button on the Control
panel. If prompted, click OK.

The image trace preset is applied
to the graphic and Image Tracing
options appear on the Control
panel.

To change the view of the image
trace, click the View list arrow on
the Control panel, and then select
a view option:

◆ Tracing Result.

◆ Tracing Result with Outlines.

◆ Outlines.

◆ Outlines with Source Image.

◆ Source Image.

3

2

1
1 2

Tracing options available on the Control panel.

3Opens Image Trace panel
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Trace a Raster Graphic Using
the Image Trace Panel

Select the graphic that you want
to trace.

◆ You can also select an image
trace object to change it.

Click the Window menu, and then
click Image Trace.

Click a preset button or select a
preset from the Preset list arrow. 

The preset buttons include: 
Auto-Color, High Color, Low Color,
Grayscale, Black and White, and
Outline.

The Preview check box is selected
and the image trace preset is
applied to the graphic.

To change the view of the image
trace, click the View list arrow,
and then select a view option.

◆ Quick View of Source. Click
and hold the View Source
Image button (eye icon).
Release the mouse to return
back to tracing.

To not view your changes after
each individual option change,
deselect the Preview check box.

Change the image trace options
you want on the Image Trace
panel.

To apply setting changes to the
graphic, click Trace. 

7

6

5

4
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2

1

Did You Know?
You can restore a traced graphic back
to its original state. Select the traced
object, click the Object menu, point to
Image Trace, and then click Release.

2
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Results of conversion
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After you create an image trace, you can use the Image Trace panel to
make adjustments. The Image Trace panel (New!) provides a set of
simple standard options and a set of advanced options. With the
Preview option set, Image Tracing options are live, which means that
Illustrator applies an option change right after you make it, which can
sometimes slow down your work efficiently. When Illustrator applies a
change, a progress bar appears, which you can always stop if it takes
too long. If you don’t like an image tracing option that is applied to the
graphic, you can undo it.

Adjusting Tracing
Options

Change Image Tracing Options

Select the graphic that you want
to trace.

◆ You can also select an image
trace object to change it.

Click the Window menu, and then
click Image Trace.

To view your changes as you set
options, select the Preview check
box.

Specify the following options:

◆ Mode. Click the list arrow to
select a color mode.

◆ Palette. Click the list arrow to
select a color palette.

◆ Colors, Grays, or Threshold.
Drag the slider to adjust the
range or intensity of color.

To apply setting changes to the
graphic, click Trace. 

5

4
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2

1

Did You Know?
You can create, rename, or delete
tracing presets. Select the Image
Trace panel, and then click the
Manage Presets button. Click Save As
New Preset to create a new preset.
Select an existing custom preset, and
then click Rename or Delete.

2
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Change Advanced Image
Tracing Options

Select the graphic that you want
to trace.

◆ You can also select an image
trace object to change it.

Click the Window menu, and then
click Image Trace.

Click the Advanced arrow to
expand the Image Trace panel. 

To view your changes as you set
options, select the Preview check
box.

Specify any of the following
options:

◆ Paths. Drag the slider to adjust
path fitting; higher the value,
the tighter the fit.

◆ Corners. Drag the slider to
adjust the number of path
corners; higher the value, the
more corners.

◆ Noise. Drag the slider to adjust
the noise level, areas of
specific pixel size; higher the
value, less the noise.

◆ Method. Click the Abutting or
Overlapping button to connect
paths.

◆ Create Fills or Strokes. Select
to create filled regions or
stroked paths. For Strokes,
specify a width in pixels.

◆ Snap Curves To Lines. Drag the
slider to replace slightly curved
lines with straight lines.

◆ Ignore White. Drag the slider to
set white color fills to none.

To apply setting changes to the
graphic, click Trace. 

6
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After you finish creating an image trace object, you can convert
(expand) it to a path. When you expand an image trace object, it no
longer remains an image trace object. It becomes a standard path,
which you can reshape and recolor. The Expand button on the Control
panel converts an image trace object into paths, which you can view
and change on the Layers panel.

Converting Tracing to
Paths

Convert Image Tracing to Paths

Select the image trace object.

Click Expand on the Control panel.

◆ You can also click the Object
menu, point to Image Trace,
and then click Expand. 

◆ To make an image trace and
convert it to paths, click the
Object menu, point to Image
Trace, and then click Make 
and Expand. 

Illustrator creates a multitude of
paths, which you can view using
the Layers panel.

Select the Layers panel to view
the newly created paths.

3

2

1

Did You Know?
You can convert a traced object to a
live paint group. This is useful when
you want to paint a traced object.
Select the traced object, click the
Object menu, point to Live Paint, and
then click Make.

3

21

Results of conversion
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The Graphic Styles panel allows you to create, save, and apply graphic
styles. A graphic style is a collection of attributes that can be applied to
a layer, sublayer, group, or object. Graphic styles are similar in nature to
character or paragraph styles. From the Graphic Styles panel, you have
access to a host of graphic style libraries—including Vonster’s Pattern
Styles (New!), designed by Von Glitschka—from which to choose a
style. You can view styles for graphics and text. Not sure how a style
will look? Now you can preview a thumbnail before you apply it. If you
still don’t like it after you apply it, you can remove it without affecting
the underlying path. When you apply a graphic style to a layer or group,
the style is applied to all objects on it. 

Applying Graphic
Styles

Apply a Graphic Style

Select an object with the
Selection tool or click the target
circle for a layer, sublayer, group,
or object in the Layers panel.

Select the Graphic Styles panel.

Click the Graphic Styles Libraries
menu, and then select a library.

Click a graphic style thumbnail in
the graphic styles library.

The graphic style is added to the
Graphic Styles panel.

To preview and view styles, use
any of the following:

◆ Preview. Right-click (Win/Mac)
or Option-click (Mac) a graphic
style thumbnail to display a
preview of the style. 

◆ View. Click the Options menu,
and then click Use Square for
Preview or Use Text for
Preview. Select a view size:
Thumbnail View, Small List
View, or Large List View.

Click a graphic style thumbnail in
the Graphic Styles panel to apply it
to the selected object.

To remove all styles applied to a
graphic, click the Default Graphic
Style thumbnail in the upper left
corner of the Graphic Styles panel.

7
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Graphic styles result
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You can create a graphic style from an existing object or duplicate an
existing graphic style and then change it. I think the best way is to
apply the attributes you want to an object, and then use the object to
create a graphic style. Although, if you see a graphic style from one of
the libraries that is close to what you want, you can quickly duplicate
the graphic style, and then make changes to it. 

Creating Graphic
Styles

Create a Graphic Style from an
Object

Select an object with the
Selection tool or click the target
circle for a layer, sublayer, group,
or object in the Layers panel.

Select the Graphic Styles panel.

Alt+click (Win) or Option+click
(Mac) the New Graphic Style
button on the panel.

◆ You can also drag the selected
object directly to the Graphic
Styles panel or click the New
Graphic Style button to create a
graphic style. The graphic style
is given the name Graphic
Style, which you can double-
click to change.

Enter a name for the graphic style.

Click OK.5

4

3

2

1

1

2

3

New graphic style

4

5

Did You Know?
You can view graphic style attributes.
Select the Graphic Styles and
Appearance panels, click the graphic
style in the Graphic Styles panel, and
then view its attributes in the
Appearance panel.
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Duplicate a Graphic Style

Select the Graphic Styles panel.

Select the graphic style that you
want to duplicate.

Click the New Graphic Style
button on the panel.

The duplicate graphic style is
added to the Graphic Styles panel.

Double-click the duplicate graphic
style.

Rename the graphic style.

Click OK.6
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Did You Know?
You can save a graphic styles library.
Select the Graphic Styles panel, dis-
play only the styles that you want to
save in a library (delete the ones that
you don’t want), click the Options
menu, click Save Graphic Style Library,
enter a name, and then click Save.
When you save the library in the
default location, the new library
appears on the User Defined submenu
on the Graphic Styles Libraries menu
on the panel.
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After you create a graphic style, you can make changes to it. However,
when you make changes to the graphic, your changes are applied to
any object that uses the graphic style. If you want this to happen, then
you are good to go. If not, you can make a duplicate of the graphic style
and then make changes to it. If you no longer need or want a graphic
style, you can delete it. When you delete a graphic style, any attributes
that are linked to an object remain with the object, but any updates will
not be applied.

Editing Graphic Styles

Edit a Graphic Style 

Select an object with the
Selection tool or click the target
circle for a layer, sublayer, group,
or object in the Layers panel.

Select the Graphic Styles panel.

Apply the graphic style that you
want to edit to the selected object.

Select the Appearance panel.

Modify the appearance of the style
in the Appearance panel.

Click the Options menu, and then
click Redefine Graphic Style.

◆ You can also Alt-drag (Win) or
Option-drag (Mac) the edited
style from the Appearance
panel onto the original style in
the Graphic Styles panel.

6
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Did You Know?
You can merge graphic styles. Select
the Graphic Styles panel, Ctrl+click
(Win) or A+click (Mac) the graphics
styles you want to combine, click the
Options menu, click Merge Graphic
Styles, enter a name, and then click OK.

4
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Edited graphic style
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Delete a Graphic Style

Select the Graphic Styles panel.

Select the graphic style that you
want to delete.

Click the Delete Graphic Style
button on the panel.

Click Yes to confirm the deletion.

Break the Link to a Graphic
Style

Select an object with the
Selection tool or click the target
circle for a layer, sublayer, group,
or object in the Layers panel.

Select the Graphic Styles panel.

Click the Break Link to Graphic
Style button on the panel.
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Did You Know?
You can merge a style with an object’s
attributes. Alt+drag (Win) or
Option+drag (Mac) the style from the
Graphic Styles panel to the object. To
preserve the color of type when apply-
ing a graphic style, click the Options
menu, and then click Override
Character Color to deselect it.
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The Appearance panel allows you to apply and manage multiple attrib-
utes to an object. You can apply fills, strokes, opacity, blending mode,
effects, and other attributes to objects, layers, groups, or graphic
styles. The panel makes it easy to apply, edit, duplicate, restack, or
remove attributes. You can click links to open panels and option dialog
boxes for effects, strokes, and fills. When you have a lot of attributes
for an object, it can be hard to work with them. It’s easy to manage
multiple attributes in the Appearance panel; you can hide attributes to
reduce the clutter and make it easier to work with the attributes that
you want, much like working with the Layers panel.

Applying Appearance
Attributes

Apply and Change Appearance
Attributes

Select an object with the
Selection tool or click the target
circle for a layer, sublayer, group,
or object in the Layers panel.

Select the Appearance panel.

The currently targeted layer
appears in bold with a type name
at the top.

Click Fill, Stroke, Opacity, or other
available attributes to display a
panel with options.

Specify the options and values
that you want to set for the
attribute.

To apply multiple fill or stroke
attributes, click the Add New Fill
or Add New Stroke button on the
panel. 

To show or hide attributes, click
the Visibility column for each
attribute.

6
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Did You Know?
You can copy appearance attributes.
In the Layers panel, Alt+drag (Win) or
Option+drag (Mac) the target circle for
the item that you want to copy onto the
target circle for another layer, group,
or object.

6
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Remove Appearance Attributes

Select an object with the
Selection tool or click the target
circle for a layer, sublayer, group,
or object in the Layers panel.

Select the Appearance panel.

Select the attribute that you want
to delete.

Do one of the following:

◆ Delete. Removes an
appearance attribute, except
for stroke and fill. Click the
Delete Selected Item button 
on the panel.

◆ Clear Except Stroke and Fill.
Removes all the appearance
attributes, except the stroke
and fill. Click the Options menu,
and then click Reduce to Basic
Appearance.

◆ Clear. Removes all the
appearance attributes and
changes the stroke and fill to
None. Click the Clear
Appearance button on the
panel.

4
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2

1

Did You Know?
You can expand an object’s appear-
ance attributes. Select the object with
the appearance attributes that you
want to expand, click the Object menu,
and then click Expand Appearance.
The paths used to create the attributes
are changed to separate objects within
a group, which can then be edited.
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A mosaic is an art design made of small pieces of colored stone or
glass. In Illustrator, you can create a mosaic special effect. You can
apply this effect to a bitmap graphic or a rasterized vector object. The
graphic must be embedded in an Illustrator document (not linked) to
perform the Create Object Mosaic command. During the process, you
can change the dimensions of the mosaic, control the spacing between
tiles, and specify the total number of tiles.

Creating a Mosaic
Graphic

Create a Mosaic Graphic

Select a bitmap graphic or
rasterized vector object with the
Selection tool to use as the basis
for the mosaic.

Click the Object menu, and then
click Create Object Mosaic.

To change the dimensions of the
mosaic, specify the Width and
Height values in New Size.

Specify the Width and Height
values in Tile Spacing and Number
of Tiles.

Specify options in the following
areas:

◆ Constrain Ratio. Locks the
width or height to the
dimensions of the original
bitmap image.

◆ Result. Specifies whether the
mosaic tiles are color or gray.

◆ Resize Using Percentages.
Select to change the size of the
image by percentages of width
and height.

◆ Delete Raster. Select to delete
the original bitmap image.

◆ Use Ratio. Click to make the
tiles square; uses the number
of tiles to makes the tiles
square.

Click OK.6
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Mosaic
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Manipulating Artwork 
with Effects

Introduction

Adobe Illustrator effects are a designer's dream come true.
With effects you can turn an image into an oil painting or a
watercolor; you can even change night into day. Illustrator’s
Effect menu includes over 100 highly creative effects from
Illustrator and Photoshop, which can be applied once, reap-
plied, or combined with other filters to create any effect your
imagination can dream up. 

The potential combination of effects and images literally
runs into the millions. This means that effects are truly an
undiscovered territory. As a matter of fact, the Photoshop
Effect Gallery lets you view the effects of one or more filters
on the active document. This level of power gives you unbe-
lievable creative control over your images. 

Take a moment to view some of the various effects that
Illustrator offers. Because there are over 100 effects available,
we can't show you all of them, but we think you'll enjoy
viewing the selection at the end of the chapter. 10

10
What You’ll Do

Apply Illustrator Effects

Apply the Convert to Shape Effect

Apply the Scribble Effect

Apply the Inner or Outer Glow Effect

Apply the Drop Shadow Effect

Apply 3D Effects

Apply Warp Effects

Apply Distort & Transform Effects

Change Raster Effect Settings

Work with the Effect Gallery 

Apply Multiple Effects

Control Effects Using Selections

Use Blur Effects

View Various Effects

281
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Illustrator effects change the appearance of an object, not its underly-
ing path, and are fully editable. The effects can be edited or removed
without permanently affecting the object. So, you can experiment with
an effect and then undo it if you don’t like it. The Illustrator effects
appear at the top of the Effect menu. Most of the Illustrator effects are
vector-based for the display and upon output, so they can be modified
without affecting the object. However, some of the effects—Drop
Shadow, Inner Glow, Outer Glow, and Feather—are rasterized (con-
verted from vector to raster) upon output, which doesn’t allow for non-
destructive modification without affecting the object. After you apply an
effect, it appears on the Appearance panel, where you can make
changes. If you apply an effect to a targeted layer, sublayer, or group, it
automatically is applied to all current and future objects on the target.
If you use graphic styles, you can also apply effects to them.

Applying Illustrator
Effects

Apply an Illustrator Effect

Select the Layers panel, and then
select the target circle for a layer,
sublayer, group, or object.

◆ To apply an effect to a part of
an object, click the Stroke or
Fill on the Appearance panel. 

Click the Effect menu, point to a
submenu under Illustrator Effects
(if needed), and then select an
effect.

To preview an effect in your
document, select the Preview
check box.

Select the options you want for the
selected effect; options vary
depending on the effect.

Click OK.5

4

3

2

1

Did You Know?
You can edit an applied effect. Select
the layer, object or object’s stroke or
fill, open the Appearance panel, dou-
ble-click the effect, make changes, and
then click OK. 
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Apply an Illustrator Effect in
Graphic Styles

Select a style name or swatch on
the Graphic Styles panel or select
an object that uses a graphic style. 

The style name appears in the
Appearance panel.

Click the Effect menu, point to a
submenu under Illustrator Effects
(if needed), and then select an
effect.

To preview an effect in your
document, select the Preview
check box.

Select the options you want for the
selected effect; options vary
depending on the effect.

If you enter a value in a box, press
Tab to update the preview.

Click OK.

Click the Options button on the
Appearance panel, and then click
Redefine Graphic Style to update
the style.
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Did You Know?
You can remove an effect from a layer,
object, or graphic style. Select the
layer, object, or graphic style, open the
Appearance panel, select the effect
name, and then click the Delete
Selected Item button. If you’re remov-
ing an effect from a style, click the
Options button on the Appearance
panel, and then click Redefine Graphic
Style to update the style.

Working with Resolution Independent Effects
Raster effects are image effects that create pixels instead of vector
data. In Illustrator, you can create raster effects by using the Effects
menu. The raster effects include SVG Filters, Drop Shadow, Inner
Glow, Outer Glow, Feather, and all the Photoshop Effects. Illustrator
uses Resolution Independent Effects (RIE) to maintain a consistent
appearance across different types of output, such as print, Web, or
video. When you change the resolution setting in the Document
Raster Effects Settings dialog box, Illustrator interprets the raster
resolution effect on the image and modifies related parameter val-
ues (as minimally as possible) in the Effect Gallery dialog box to
maintain consistency. See “Changing Raster Effects Settings” on
page 292 for information on changing the resolution in the Document
Raster Effects Settings dialog box.

For Your Information

1
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With the Illustrator Convert to Shape effect, you can change an object’s
outline to a rectangle, rounded rectangle, or ellipse without changing
the actual underlying path. In the Shape Options dialog box, you can
specify the width and height of the converted shape. The size can 
be set to an absolute value or a relative one based on the original
object.

Applying the Convert
to Shape Effect

Apply the Convert to Shape
Effect

Select the Layers panel, and then
select the target circle for a layer,
sublayer, group, or object.

Click the Effect menu, point to
Convert to Shape, and then click
Rectangle, Rounded Rectangle, or
Ellipse.

To preview an effect in your
document, select the Preview
check box.

Click the Absolute or Relative
option, and then enter values for
width and height.

For the Relative option, if you want
the shape to be larger or smaller
than the actual path, enter a
positive or negative value.

For a Rounded Rectangle shape,
enter a Corner Radius value.

Click OK.6
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Did You Know?
You can round off sharp corners with-
out converting the shape. Select the
shape, click the Effect menu, point to
Stylize, and then click Round Corners. 

Selection

Convert results 
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If you want to make an object’s fill look as though it was drawn with a
pen or pencil, the Illustrator Scribble effect is the one for you. In the
Scribble Options dialog box, you can use one of the many presets to
create the look you want. It makes the job easy. The presets include
Childlike, Dense, Loose, Moire, Sharp, Sketch, Snarl, Swash, Tight, and
Zig-zag. After you select a preset (even if it’s just the Default), you can
adjust individual settings to customize the Scribble effect. As you make
changes, you can preview the results in your document. 

Applying the Scribble
Effect

Apply the Scribble Effect

Select the Layers panel, and then
select the target circle for a layer,
sublayer, group, or object.

Click the Effect menu, point to
Stylize, and then click Scribble.

To preview an effect in your
document, select the Preview
check box.

Select from the following options:

◆ Settings. Click the Settings list
arrow to select a preset for the
Scribble effect.

◆ Angle. Enter an Angle value or
rotate the dial to change the
angle of the sketch lines.

◆ Path Overlap. Drag the Path
Overlap slider toward Outside
to have the sketch lines extend
beyond the edge of the path, or
toward Inside to have the
sketch lines stay inside the
path along with the degree of
random variation.

◆ Line Options. Change the
Stroke Width for the lines, the
Curviness for the lines (angle
sharply or loosely) along with
the degree of random variation,
and the Spacing for the lines
(tight or loose) along with the
degree of random variation.

Click OK.5
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1

Scribble results
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With the Illustrator Inner Glow or Outer Glow effect, you can apply a
color special effect to an object. The inner glow effect spreads a color
from the edge of an object inward, while the outer glow effect spreads
a color from the edge of an object outward. You can also apply both
effects to the same object. As you make changes, you can preview the
results in your document. It’s important to remember that the Inner
Glow and Outer Glow effects are rasterized (converted from vector to
raster) upon output.

Applying the Inner or
Outer Glow Effect

Apply the Inner Glow or Outer
Glow Effect

Select the Layers panel, and then
select the target circle for a layer,
sublayer, group, or object.

Click the Effect menu, point to
Stylize, and then click Inner Glow
or Outer Glow.

To preview an effect in your
document, select the Preview
check box.

Select from the following options:

◆ Color. Click the Color box, and
then select a glow color.

◆ Blend Mode. Click the Mode
list arrow, and then select a
blending mode for the glow
color.

◆ Opacity. Click the arrow or
enter a value to adjust the
transparency of the glow.

◆ Blur. Click the arrow or enter a
value to adjust how far the
glow extends inward or
outward.

◆ Center or Edge. For the Inner
Glow effect, click Center to
have the glow spread outward
from the center of the object, or
click Edge to have the glow
spread inward from the edge of
the object toward the center.

Click OK.5
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Glow results
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The Illustrator Drop Shadow effect allows you to apply soft, natural
shadows to an object. With the Drop Shadow effect, you can specify a
color blend, opacity (degree of transparency), offset, blur, and shadow
color. As you make changes, you can preview the results in your docu-
ment. You can apply the Drop Shadow effect to images and editable
text. It’s important to remember that the Drop Shadow effect is raster-
ized (converted from vector to raster) upon output.

Applying the Drop
Shadow Effect

Apply the Drop Shadow Effect

Select the Layers panel, and then
select the target circle for a layer,
sublayer, group, or object.

Click the Effect menu, point to
Stylize, and then click Drop
Shadow.

To preview an effect in your
document, select the Preview
check box.

Select from the following options:

◆ Blend Mode. Click the Mode
list arrow, and then select a
blending mode for the shadow
color.

◆ Opacity. Click the arrow or
enter a value to adjust the
transparency of the shadow.

◆ X and Y Offset. Enter values for
the offset distance of the
shadow.

◆ Blur. Click the arrow or enter a
value to adjust how far the
shadow extends inward or
outward.

◆ Color. Click the Color option,
and then select a color or click
the Darkness option and
specify a percentage.

Click OK.5
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Shadow results
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With the Illustrator 3D Effects, you can create 3D objects from 2D
objects. The 3D Effects include Extrude & Bevel, Revolve, and Rotate.
You can specify multiple appearance options including: position, rota-
tion, surface, lighting, and shading. Every 3D object is composed of
multiple surfaces, such as a front, back, and sides. You can map 2D art-
work (as a symbol) from the Symbols panel to each surface on a 3D
object to create the look that you want.

Applying 3D Effects

Create a 3D Object

Select the object that you want to
change.

Click the Effect menu, point to 3D,
and then click Extrude & Bevel.

◆ Click More Options to display
all available options in the
dialog box.

To preview an effect in your
document, select the Preview
check box.

Select from the following options:

◆ Position. Specifies object
perspective and rotation angle.

◆ Extrude & Bevel. Specifies the
extent of object depth and
bevel. 

◆ Surface. Specifies the surface
of the 3D object.

◆ Lighting. Adds one or more
light sources, varies the light
intensity, changes shading
color, and changes the light
source direction.

◆ Map Art. Click to map 2D
artwork (as a symbol) onto the
surface of a 3D object.

Click OK.5
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3D results
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Create a 3D Revolving Object

Select the object that you want to
change.

Click the Effect menu, point to 3D,
and then click Revolve.

◆ Click More Options to display
all available options in the
dialog box.

To preview an effect in your
document, select the Preview
check box.

Select from the following options:

◆ Position. Specifies object
perspective and rotation angle.

◆ Revolve. Specifies how to
sweep the path around the
object to create a 3D object. 

◆ Surface. Specifies the surface
of the 3D object.

◆ Lighting. Adds one or more
light sources, varies the light
intensity, changes shading
color, and changes the light
source direction.

◆ Map Art. Click to map 2D
artwork (symbol) onto the
surface of a 3D object.

Click OK.5
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3D revolving results
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The Illustrator Warp effects allow you to apply different types of distor-
tion effects. You can specify how much bend and distortion, either hori-
zontal or vertical, takes place in the warp effect. You can apply a wide
variety of warp effects, including Arc, Arch, Bulge, Shell, Flag, Wave,
Fish, Rise, Fisheye, Inflate, Squeeze, or Twist. As you make changes,
you can preview the results in your document. You can apply the warp
effects to images and editable text.

Applying Warp 
Effects

Apply a Warp Effect

Select the Layers panel, and then
select the target circle for a layer,
sublayer, group, or object.

Click the Effect menu, point to
Warp, and then select a warp
command.

To preview an effect in your
document, select the Preview
check box.

Select from the following options:

◆ Style. Click the Style list arrow,
to change the warp effect.

◆ Direction. Click the Horizontal
or Vertical option to specify an
effect direction.

◆ Bend. Drag the Bend slider or
enter a value to adjust the
bending for the warp effect.

◆ Distortion. Drag the Horizontal
or Vertical slider or enter a
value to adjust the distortion
direction for the warp effect.

Click OK.5
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Selection

Twist warp results
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The Illustrator Distort & Transform effects allow you to apply different
types of distortion and transformation effects. You can apply a wide
variety of effects, including Free Distort, Pucker & bloat, roughen,
Transform, Tweak, Twist, and Zig Zag. Each effect provides different
options to create the results you want. As you make changes, you can
preview the results in your document (in most cases). You can apply
the warp effects to images and editable text.

Applying Distort &
Transform Effects

Apply a Distort & Transform
Effect

Select the Layers panel, and then
select the target circle for a layer,
sublayer, group, or object.

Click the Effect menu, point to
Distort & Transform, and then
select a command.

To preview an effect in your
document, select the Preview
check box (if available).

Select from the following options:

◆ Free Distort. Drag the resize
handles to distort the image. To
display the original, click Reset.

◆ Pucker & Bloat. Drag the slider
or enter a value to specify the
balance between pucker and
bloat. 

◆ Roughen. Drag sliders to adjust
the size and detail of the edges
and specify whether points are
smooth or corners.

◆ Transform. Drag sliders to
adjust scale, movement,
rotation, and other options.

◆ Tweak. Drag sliders to adjust
control and anchor points;
similar to Pucker & Bloat.

◆ Twist. Specify an angle to
adjust the twist from center. 

◆ Zig Zag. Drag sliders to create
a zig zag pattern; similar to
Roughen effect.

Click OK.5
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Selection

Roughen results
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Some of the Illustrator effects—Drop Shadow, Inner Glow, Outer Glow,
and Feather—and all of the Photoshop effects, are rasterized upon out-
put. You can control how a raster effect looks in your document and
how it will output from Illustrator by using the Document Raster Effects
Settings dialog box. The available options allow you to specify a color
model, resolution, background type (white or transparent), as well as
apply anti-alias, create a clipping mask, and preserve spot colors. These
options are globally applied to all raster effects. The raster settings con-
vert a vector object to a bitmap image. When you change the resolution
setting, Illustrator applies Resolution Independent Effects (RIE) and
modifies related raster parameter values in the Effect Gallery dialog
box to maintain consistency across different types of output. If you
want to apply raster settings to an individual object, you can specify
many of the same options in the Rasterize dialog box.

Changing Raster
Effects Settings

Change Raster Effects Settings

Click the Effect menu, and then
click Document Raster Effects
Settings.

Select from the following options:

◆ Color Model. Select a color
mode: CMYK or RGB,
Grayscale, or Bitmap.

◆ Resolution. Select a screen
size in points per inch (ppi). Use
Screen for web or video output,
Medium for desktop printers, or
High for commercial printing.

◆ Background. Use White to
make any transparent areas
white or Transparent to make
the background transparent by
creating an alpha channel. 

◆ Anti-alias. Select to soften the
edges of a rasterized object.

◆ Create Clipping Mask. Select
to create a clipping path
around the image and specify a
size to extend the effect. If you
selected the Transparent
option, you don’t need to 
select this option.

◆ Preserve Spot Colors. Select to
preserve spot colors.

Click OK.3
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Convert Vector Objects to
Bitmap Images

Select the Layers panel, and then
select the target circle for a layer,
sublayer, group, or object.

Click the Object menu, and then
click Rasterize.

◆ You can also click the Effects
menu, and then click Rasterize.

Select from the following options:

◆ Color Model. Select a color
mode: CMYK or RGB,
Grayscale, or Bitmap.

◆ Resolution. Select a screen
size in points per inch (ppi). Use
Screen for web or video output,
Medium for desktop printers,
High for commercial printing, or
Use Document Raster Effects
Resolution to apply the global
resolution.

◆ Background. Use White to
make any transparent areas
white or Transparent to make
the background transparent by
creating an alpha channel. 

◆ Anti-aliasing. Use Art
Optimized (Supersampling) to
soften shape edges. Use Type
Optimized (Hinted) to soften
type edges. Use None to keep
edges jagged.

◆ Create Clipping Mask. Select
to create a clipping path
around the image and specify a
size to extend the effect. If you
selected the Transparent
option, you don’t need to 
select this option.

◆ Preserve Spot Colors. Select to
preserve spot colors.

Click OK.4
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Convert to bitmap results
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The Effect Gallery enables you to maintain complete and total control
over Photoshop effects. In essence, the Effect Gallery gives you access
to all of Photoshop's effects and lets you apply the effects to any
image, while viewing a large preview of the results. The Effect Gallery
dialog box is composed of three sections—Image Preview, Effect
Selection, and Effect Controls. When you use the Effect Gallery to mod-
ify the image, you see exactly how the image will look; there is no
guesswork involved. When you apply an effect to an image, you are
physically remapping the pixel information within the image. Illustrator
provides almost 50 Photoshop effects and the combinations of those
effects are astronomical. That means there are a lot of different combi-
nations available for you to try…have fun.

Working with the 
Effect Gallery

Work with the Photoshop Effect
Gallery

Select the Layers panel, and then
select the layer you want to modify
with an effect.

Click the Effect menu, and then
click Effect Gallery.

Change the image preview by
clicking the plus or minus zoom
buttons, or by clicking the black
triangle and selecting from the
preset zoom sizes.

If necessary, drag the lower right
corner in or out to resize the Effect
Gallery dialog box.

Click the expand triangle, located
to the left of the individual
categories, to expand an effect
category. Effect categories
include:

◆ Artistic

◆ Brush Strokes

◆ Distort

◆ Sketch

◆ Stylize

◆ Texture
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Click an effect from the expanded
list to view its default effects on
the image.

Modify the results of the effect
using the effect controls.

To temporarily hide the Effect
Selections, click the Show/Hide
Effect Thumbnails button, located
to the left of the OK button. 

Click OK.

◆ Reset. Hold down Alt (Win) or
Option (Mac), and then click
Reset (the Cancel button
changes to Reset) to restore
the default settings for the
effect.

9

8

7

6 9

7

Did You Know?
You can reapply a specific effect using
a shortcut. Press Shift+Ctrl+E (Win) or
Shift+A+E (Mac) to reapply the last
effect to the image.

You can access the Photoshop effects
from the Effect menu. If you know the
Photoshop effect you want to use, you
can open the Effect Gallery directly to
the effect you want. Click the Effect
menu, point to an effect category, and
then click the effect you want. The
Photoshop Effect Gallery opens, dis-
play the effect you want.

You cannot access the Pixelate, Blur,
or Video effects from the Photoshop
Effect Gallery. The Pixelate, Blur, and
Video Photoshop are only available
from the Effects menu.

6 8
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With Photoshop's Effect Gallery you can preview, apply, show, or hide
only one individual effect at a time. If you want to apply multiple
Photoshop effects, you have to use the Effect Gallery multiple times.
After you apply multiple effect, you can use the Visibility icon in the
Appearance panel to show or hide any of the individual effects. The
order of the effects influences their impact on the image, so when you
use more than one effect, try dragging the effect up or down in the
stack to see the different possibilities. 

Applying Multiple
Effects

Apply Multiple Effects

Select the Layers panel, and then
select the layer you want to modify
with an effect.

Click the Effect menu, and then
click Effect Gallery.

Select the effect you want.

Adjust the effect as necessary.

Click OK.

To apply another effect to the
layer, repeat steps 2 thru 5.

Select the Appearance panel.

To change the effect’s influence on
the image, drag an effect to
another position in the stack.

To temporarily show or hide the
effect on the image, click the
Show/Hide button in the Visibility
column on the panel.

To delete a selected effect, select
it, and then click the Delete button
on the panel. 

To edit an effect, click the effect
name in the Appearance panel.

The Effect Gallery opens, where
you can make changes.
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When you apply an effect, Illustrator applies the effect equally to the
entire image. Unfortunately, that might not be what you had in mind. For
example, you might want to apply the Gaussian Blur effect to a portion
of the image. In that case, Illustrator's selection tools come to the res-
cue. The primary purpose of making a selection is to define a work
area, and when you select an area before applying an effect, the only
area impacted by the effect will be the selected area. 

Controlling Effects
Using Selections 

Control Effects Using Selections

Select the Layers panel, and then
select the layer to which you want
to apply an effect.

Select the Direct Selection tool on
the Tools panel, and then make a
selection in the document window.

Click the Effect menu, and then
click Effect Gallery.

Select any Photoshop effects.

Adjust the effect options until you
see the effect you want.

Click OK.

The effect is only applied to the
selected areas of the image.
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Using Blur Effects

Use the Smart Blur Effect

Select the Layers panel, and then
select the layer you want to modify
with an effect.

Click the Effect menu, point to
Blur, and then click Smart Blur.

Drag a slider or enter a pixel value
for the following:

◆ Radius. Specifies the area size
to apply the blur. 

◆ Threshold. Specifies how
dissimilar the pixels need to be
before they are changed. 

Click the Quality list arrow, and
then select a quality value: Low,
Medium, or High.

Click the Mode list arrow, and then
select a quality value:

◆ Normal. Applies the blur to the
entire selection. 

◆ Edge Only. Applies the blur to
the edge only for color
transitions. 

◆ Overlay Edge. Applies the blur
to edges with an overlay for
color transitions. 

Click OK.6

5
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You can apply the Photoshop blur effects—Gaussian, Radial, and
Smart—in Illustrator. The Gaussian Blur (New!) effect applies a typical
blur to an image or a selection by a controllable amount. The Gaussian
Blur effect can be used to add a sense of depth to the image. For exam-
ple, you could select and blur the background of an image while leaving
the foreground in focus. The outcome of the effect is to create a hazy,
out-of-focus effect on the image or selection. For the Gaussian Blur
effect, you can use the Preview option (New!) to see an enhanced live
preview in your document while you adjust the blur effect. If you want to
apply a blur with an additional effect, the Radial blur applies a soft blur
with a spin or zoom, and the Smart blur applies a precise blur with a
radius, threshold, quality level, and edge options.
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Use the Gaussian Blur Effect

Select the Layers panel, and then
select the layer you want to modify
with an effect.

Click the Effect menu, point to
Blur, and then click Gaussian Blur.

To preview an effect in your
document, select the Preview
check box.

Drag the Radius slider or enter a
pixel value to increase or
decrease the amount of Gaussian
blur applied to the image.

Click OK.5

4

3

2

1
1

Did You Know?
You can display or update the previous
version of Gaussian Blur filter. If you
open a document with a previous ver-
sion of Gaussian Blur filter applied it,
the effect is named Legacy Gaussian
Blur (New!) in the Appearance panel.
If you edit the effect, it’s converted to
the updated version. 

You can use the Radial Blur effect. In
the Layers panel, select the layer you
want to modify. Click the Effect menu,
point to Blur, and then click Radial Blur.
Select the Spin or Zoom option, select
an quality option, and then specify an
amount. To adjust the center position
of the blur, drag the pattern in the Blur
Center box. Click OK. 

4
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The Gaussian Blur filter
applied to the image
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Viewing Various Effects

Illustrator and Photoshop provide a bountiful
selection of over 100 effects.. Take a moment
to view some of the various effects you can
use. The original image is shown to the right,
and we've displayed some common effects on
the following pages. A good thing to think
about when using effects is your original
image. Look at the background colors, and
see if they will look good with some of the
effects. The best thing to do is open an image
that has a lot of varied details, and then apply
some effects to see what looks good to you.

Various Effects

Fresco

Cutout Dry Brush

Palette Knife
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Accented Edges Glass

Diffuse Glow Note Paper

Stamp Glowing Edges
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Plastic WrapGraphic Pen

Stained GlassMosaic Tiles

SpatterGrain
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Drawing and Painting

Introduction

After you create a path using the Pencil tool or other drawing
tool, you can use the Live Paint command or the Live Paint
Bucket tool to convert the paths into a Live Paint Group that
you can paint. Before you start using the Live Paint Bucket
tool, it’s important to select the painting options that you
want to use beforehand. 

With the Live Paint Bucket tool, you can recolor a Live
Paint Group. When you click an area formed by intersecting
lines in a Live Paint Group, the Live Paint Bucket tool applies
fill and stroke paint attributes. When you apply fill or stroke
attributes, you’re actually recoloring faces (fills) and edges
(strokes) and not the path itself. With the Live Paint Selection
tool, you can select faces (fills) and edges (strokes) in a Live
Paint Group. Before you start using the Live Paint Selection
tool, it’s important to choose the selection options that you
want to use beforehand. If you create a gap in a closed path
in a Live Paint Group, the face (fill) of the object disappears.
With the Gap Options dialog box, you can specify gap detec-
tion options to avoid this problem. 

The Brushes panel allows you to draw with different
brush tips, creating freestyle lines, shapes, patterns, and tex-
tures. There are five main categories of brushes: Scatter,
Calligraphic, Art, Pattern, and Bristle. You can use brushes
that come built-in with Illustrator in Brush libraries or you
can create your own. Illustrator's paintbrush tool was
designed to reproduce the visual effect of applying paint to
an artboard. When you use a stylus and a pressure-sensitive
drawing tablet, the Paintbrush tool is pressure-sensitive, too.
You select brushes from the Brushes panel or other Brush
libraries to use with the Paintbrush tool.

What You’ll Do

Use the Pencil Tool

Create Live Paint Groups

Set Live Paint Bucket Tool Options

Use the Live Paint Bucket Tool

Use the Live Paint Selection Tool

Modify Live Paint Groups

Set Gap Options

Use the Brushes Panel

Use the Paintbrush Tool

Create and Edit Scatter Brushes

Create and Edit Calligraphic Brushes

Create and Edit Art Brushes

Create and Edit Pattern Brushes

Create and Edit Bristle Brushes

Work with Brushes

Work with Liquify Tools
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The Pencil tool is exactly what its name implies…a pencil. If you like to
draw freehand or sketch objects, especially with a drawing tablet, the
Pencil tool is right for you. You can use the Pencil tool in several ways.
You can draw new line segments to create a path, reshape a path, or
add to a path. You can customize the way the Pencil tool works by set-
ting preferences in the Pencil Tool Preferences dialog box.

Using the Pencil Tool

Use the Pencil Tool

Select the Pencil tool on the Tools
panel.

Select a stroke color and weight
and a fill of None on the Tools and
Stroke panels.

Click the View menu, and then
click Pixel Preview to view the
drawing with attributes or click
Outline to view the drawing as
lines (wireframe).

Use any of the following methods:

◆ New Path. Drag in a blank area
to create an open or closed
path. To create a closed path,
hold down Alt (Win) or Option
(Mac) while you finish drawing. 

◆ Reshape Path. Drag along the
edge of a selected open or
closed path.

◆ Add to Path. Drag from an
endpoint of an open path.

4

3

2

1

Did You Know?
You can erase all or part of a path with
the Path Eraser tool. Select the Path
Eraser tool (same slot as the Pencil
tool), and then drag along the path that
you want to erase. 

1
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Set Pencil Tool Options

Double-click the Pencil tool on the
Tools panel.

Drag the slider or enter a Fidelity
value (.5-20). Fidelity determines
how far the mouse (or stylus) must
move before an anchor point is
added. A higher value creates
fewer anchor points and a
smoother path while a lower value
creates more anchor points and a
rougher path.

Drag the slider or enter a
Smoothness value (0-100). A high
value creates a smoother curve,
while a low value creates more
bends.

Select or deselect any of the
following check boxes:

◆ Fill New Pencil Strokes. Select
to fill new paths with the
current fill color.

◆ Keep Selected. Select to keep
pencil paths selected after you
draw them.

◆ Edit Selected Paths. Select to
enable Reshaping for the Pencil
tool within the specified pixel
range (2-20).

To revert settings back to the
defaults, click Reset.

Click OK.6
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Live Paint allows you to fill open or closed paths by creating Live Paint
Groups. After you create a path using the Pencil tool or other drawing
tool, you can use the Live Paint command or the Live Paint Bucket tool
to convert the paths into a Live Paint Group that you can paint. You can
also convert a traced object from a raster graphic into a Live Paint
Group, and then paint it. The Live Paint Bucket tool allows you to click
an area formed by intersecting lines to apply fill (known as face) and
stroke (known as edges) attributes. As you reshape the Live Paint
objects, the paint attributes also change.

Creating Live Paint
Groups

Create Live Paint Groups

Create a drawing using any of the
drawing tools or use the Live Trace
command to create a path from a
raster graphic.

For the best results, use a drawing
with multiple intersecting lines that
you can fill. 

◆ To create a Live Paint Group
from type, click the Type menu,
and then click Create Outlines
to create path outlines.

◆ To create a Live Paint Group
from a symbol or blend, click
the Object menu, and then click
Expand to create paths. 

Select all the paths using selection
tools on the Tools panel.

Click the Object menu, point to
Live Paint, and then click Make.

◆ You can also click the Live
Paint Bucket tool on the Tools
panel, and then click the
selected paths.

The paths are nested together into
a Live Paint Group, which appears
in the Layers panel.
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Live Paint Group
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Convert a Traced Object to a
Live Paint Group

Open or place a raster graphic in
an Illustrator document.

Select the graphic that you want
to trace.

◆ You can also select an Image
Trace object to change it.

Click the Image Trace button
(New!) on the Control panel. If
prompted, click OK.

Select all the paths using selection
tools on the Tools panel.

Click the Expand button on the
Control panel.

Click the Object menu, point to
Live Paint, and then click Make.

◆ You can also click the Live
Paint Bucket tool on the Tools
panel, and then click the
selected paths.

The paths are nested together into
a Live Paint Group, which appears
in the Layers panel.
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Live Paint Group
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With the Live Paint Bucket tool on the Tools panel, you can recolor fills
and strokes in a Live Paint Group. Before you start using the Live Paint
Bucket tool, it’s important to select the painting options that you want
to use beforehand. You can quickly set Live Paint Bucket tool options
by double-clicking the tool on the Tools panel. In the Live Paint Bucket
Options dialog box, you set options to paint fills and/or paint strokes in
a Live Paint Group. To make it easier to paint fills and strokes, you can
also select the Cursor Swatch Preview option to display a color strip
above the Live Paint Bucket pointer with the current or last color used
along with two adjacent colors. In addition, you can specify a highlight
color to make it easier to identify fill and stroke areas. 

Setting Live Paint
Bucket Tool Options

Select Options for Paint Fills or
Strokes with the Live Paint
Bucket Tool

Double-click the Live Paint Bucket
tool on the Tools panel.

Select the Paint Fills check box to
paint fills with the Live Paint
Bucket tool.

Select the Paint Strokes check
box to paint strokes with the Live
Paint Bucket tool.

Click OK.

◆ If only Paint Fills or Paint
Strokes is selected, you can
Shift-click with the Live Paint
Bucket tool to switch between
painting fills and applying
stroke colors and weight. 
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Set Live Paint Bucket Tool
Preferences

Double-click the Live Paint Bucket
tool on the Tools panel.

Select the Cursor Swatch Preview
check box to display a color strip
above the Live Paint Bucket
pointer with the current or last
color used, along with two
adjacent colors.

Select the Highlight check box to
change the highlight color, and
then select a color and specify a
width.

To get helpful tips and techniques
for using Live Paint, click Tips,
read the tip screen, click Next,
read the next tip screen, and then
click OK.

Click OK.5
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With the Live Paint Bucket tool on the Tools panel, you can recolor a
Live Paint Group. When you click an area formed by intersecting lines
in a Live Paint Group, the Live Paint Bucket tool applies fill and stroke
paint attributes. When you apply fill or stroke attributes, you’re actually
recoloring faces (fills) and edges (strokes) and not the path itself. Each
edge can have a different color (even None) and weight. You can cus-
tomize the way the Live Paint Bucket tool works by setting preferences
in the Live Paint Bucket Options dialog box.

Using the Live Paint
Bucket Tool

Fill Faces with the Live Paint
Bucket Tool

Select the Live Paint Bucket tool
on the Tools panel.

◆ Make sure the Paint Fills
option is set in the Live Paint
Bucket Options dialog box.
Double-click the Live Paint
Bucket tool.

◆ If only Paint Fills or Paint
Strokes is selected in Options,
you can Shift-click with the
Live Paint Bucket tool to switch
between painting fills and
applying stroke colors and
weight.

Display a Live Paint Group object.

Select a fill color on the Swatches,
Tools, or Control panels to use with
the Live Paint Bucket tool.

◆ If the Cursor Swatch Preview
appears above the pointer, you
can press the left or right arrow
keys to select or display the
next or previous color from the
Swatches panel.  

Point to the face that you want to
fill. The face becomes highlighted.

Click an individual face or drag
multiple faces.
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Change Stroke Edges with the
Live Paint Bucket Tool

Select the Live Paint Bucket tool
on the Tools panel.

◆ Make sure the Paint Strokes
option is set in the Live Paint
Bucket Options dialog box.
Double-click the Live Paint
Bucket tool.

◆ If only Paint Fills or Paint
Strokes is selected in Options,
you can Shift-click with the Live
Paint Bucket tool to switch
between painting fills and
applying stroke colors and
weight.

Display a Live Paint Group object.

Select a stroke color, weight, or
other attributes on the Strokes,
Tools, or Control panels to use with
the Live Paint Bucket tool.

◆ To remove colors from stroke
edges, select None.

Point to the edge that you want to
change. The edge becomes
highlighted.

Click an individual edge or drag
multiple edges.

◆ Double-click an edge to apply
the current stroke attributes to
all contiguous edges that have
the same color and weight. 

◆ Triple-click an edge to apply
the current stroke color and
attributes to all edges that have
the same attributes. 

5

4

3

2

1

1

3

2

4

5



ptg8126863

312 Chapter 11

With the Live Paint Selection tool on the Tools panel, you can select
faces (fills) and edges (strokes) in a Live Paint Group. Before you start
using the Live Paint Selection tool, it’s important to choose the selec-
tion options that you want to use beforehand. You can quickly set Live
Paint Selection tool options by double-clicking the tool on the Tools
panel. In the Live Paint Selection Options dialog box, you set options to
select fills and/or to select strokes in a Live Paint Group. In addition,
you can specify a highlight color for the selection. It’s a good idea to
select a different color than the Live Paint Bucket tool; they are initially
set to the same color.

Using the Live Paint
Selection Tool

Set Live Paint Selection Tool
Options

Double-click the Live Paint
Selection tool on the Tools panel.

Select the Select Fills check box
to paint fills with the Live Paint
Selection tool.

Select the Select Strokes check
box to paint strokes with the Live
Paint Selection tool.

Select the Highlight check box to
change the highlight color, and
then select a color and specify a
width.

Click OK.5
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Use the Live Paint Selection
Tool

Select the Live Paint Selection
tool on the Tools panel.

Display a Live Paint Group object.

Click a face or edge.

Shift-click to select or deselect
additional faces or edges.

Do any of the following:

◆ Fills. Select a fill color,
gradient, or pattern.

◆ Strokes. Select a stroke color,
weight, or other attributes.
Select None to hide stroke
edges.

◆ Delete. Press Backspace or
Delete to remove the selected
faces or strokes.
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After you create a Live Paint Group, you can use Isolation Mode to
reshape, move, and add to the group. To make your group easier to
select and modify, you can show a bounding box with star-filled selec-
tion handles around the path. If you no longer want a selected path,
you can remove it using the Delete key. When you modify a path in a
Live Paint Group, colors automatically refill and line segments reshape.

Modifying Live Paint
Groups

Reshape or Move Paths in a Live
Paint Group

Select the Selection tool on the
Tools panel.

Click the View menu, and then
click Show Bounding Box.

Select a path or area in a group.

Click the Isolate Selected Object
button on the Control panel.

TIMESAVER Double-click the
Live Paint Group to isolate it.

Do any of the following:

◆ Select the Selection tool, and
then drag a handle to modify it
or drag the path to move it.

◆ Select the Direct Selection
tool, click an anchor point, and
then drag to modify the
segment.

Click the gray bar above the
document to exit Isolation Mode.
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Add Paths to a Live Paint Group

Select the Selection tool on the
Tools panel.

Click the View menu, and then
click Show Bounding Box.

Select a path or area in a group.

Click the Isolate Selected Object
button on the Control panel.

TIMESAVER Double-click the
Live Paint Group to isolate it.

Draw the path that you want to
add to the group using drawing
tools on the Tools panel.

Click the gray bar above the
document to exit Isolation Mode.

◆ You can also draw a path on a
layer, select the new path and
the Live Paint Group, and then
click Merge Live Paint on the
Control panel.
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Did You Know?
You can expand a Live Paint Group.
Select the Live Paint Group, and then
click Expand on the Control panel.
Now, you can edit individual compo-
nents of the Live Paint Group path.

You can release a Live Paint Group.
Select the Live Paint Group, click the
Object menu, point to Live Paint, and
then click Release. Now, you can edit
individual components of the Live Paint
Group path.

1

5

4

6



ptg8126863

316 Chapter 11

If you create a gap in a closed path in a Live Paint Group, the face (fill)
of the object disappears. With the Gap Options dialog box, you can
specify gap detection options to avoid this problem. You can select a
predefined gap size or enter one of your own along with a gap preview
color.

Setting Gap Options

Set Gap Options

Select the Direct Selection tool on
the Tools panel.

Select a Live Paint Group.

Click the Gap Options button on
the Control panel.

Select the Preview check box to
view your changes as you set
options.

Select the Gap Detection check
box to enable the feature.

Click the Paint Stops At list arrow,
and then select a gap option.

◆ Select the Custom check box to
specify a custom size.

Click the Gap Preview Color list
arrow, and then select a color.

Click the Close gaps with paths
button to apply these settings to
the document.

Click OK.9
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The Brushes panel allows you to draw with different brush tips, to cre-
ate freestyle lines, shapes, patterns, and textures. There are five main
categories of brushes: Calligraphic, Scatter, Art, Bristle, and Pattern.
You can use built-in brushes that come with Illustrator (stored in Brush
libraries) or you can create your own. Sometimes it’s hard to find a
brush. To make it easier, you can use the Options menu to change the
panel views. Brushes are live, which means that any previous use of a
brush can be updated when you change the brush. 

Using the Brushes
Panel

Use and Apply Brushes to a Path
with the Brushes Panel

Select the Brushes panel.

Select a path with any of the
selection tools.

To change the Brushes panel view,
click the Options menu, and then
select any of the following
available view options:

◆ Show Calligraphic Brushes,
Show Scatter Brushes, Show
Art Brushes, Show Bristle
Brushes, or Show Pattern
Brushes

◆ Thumbnail View

◆ List View

Click the Brush Libraries Menu
button on the panel, point to a
brush category, and then select a
brush library.

Click a brush in the library panel to
add it to the Brushes panel.

◆ You can also drag a brush from
any brushes panel onto a path
to apply it.

Click a brush on the Brushes panel
to apply it to the selected path.
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Illustrator's paintbrush tool was designed to reproduce the visual effect
of applying paint to an artboard. When you use a stylus and a pressure-
sensitive drawing tablet, the Paintbrush tool is pressure-sensitive too.
You select brushes from the Brushes panel or other Brush libraries to
use with the Paintbrush tool. You can customize the way the Paintbrush
tool works by setting preferences in the Paintbrush Tool Preferences
dialog box.

Using the Paintbrush
Tool

Set Paintbrush Tool Options

Double-click the Paintbrush tool
on the Tools panel.

Drag the slider or enter a Fidelity
value (.5-20). Fidelity determines
how far the mouse (or stylus) must
move before an anchor point is
added. A higher value creates
fewer anchor points and a
smoother path while a lower value
creates more anchor points and a
rougher path.

Drag the slider or enter a
Smoothness value (0-100). A high
value creates a smoother curve,
while a low value creates more
bends.

Select or deselect any of the
following check boxes:

◆ Fill New Brush Strokes. Select
to fill new paths with the
current fill color.

◆ Keep Selected. Select to keep
brush paths selected after you
draw them.

◆ Edit Selected Paths. Select to
enable changing an existing
path with the Paintbrush tool
within the specified pixel range
(2-20).

To revert settings back to the
defaults, click Reset.

Click OK.6
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Use the Paintbrush Tool

Select the Paintbrush tool on the
Tools panel.

Select None for the fill color.

Select the Brushes panel.

Select a brush on the panel.

◆ You can also click the Brush list
arrow on the Control panel, and
then select a brush. 

Do any of the following:

◆ Open Path. Drag to draw a path
that doesn’t connect.

◆ Closed Path. Drag to draw a
path, and then Alt+drag (Win)
or Option+drag (Mac) to 
close it.
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Scatter brushes disperse copies of an object along a path. You create a
scatter brush from a path, compound path, type character, or type out-
line. When you use a scatter brush, the brush is applied using a fixed or
random method along a path. You use a similar method to create and
edit a Scatter brush. You use the Scatter Brush Options dialog box to
set the options that you want. 

Creating and Editing
Scatter Brushes

Create or Edit a Scatter Brush

Select the Brushes panel.

Do one of the following:

◆ Create. Select one or more
objects, click the New Brush
button on the panel, click the
Scatter Brush option, and then
click OK. Enter a name for the
brush.

◆ Edit. Deselect any brushes, and
then double-click a Scatter
brush.

Specify the following options:

◆ Size. Determines the size of the
scatter objects.

◆ Spacing. Determines the
spacing between the scatter
objects.

◆ Scatter. Determines the
distance between the path and
the objects.

◆ Rotation. Specifies the rotation
range relative to the page or
path.

For the Size, Spacing, Scatter, and
Rotation options, click the list
arrow, and then select one of the
following options: 

◆ Fixed. Enter a single fixed
value.

◆ Random. Drag sliders or enter a
range for variable value. 
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Selection for creating a brush
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◆ Pressure, Stylus Wheel, Tilt,
Bearing, or Rotation. Drag
sliders or enter values when
using a drawing tablet.

Click the Method list arrow, and
then select an option:

◆ None. Retains colors from the
Brushes panel.

◆ Tints. Changes black areas in
the brush stroke to the current
stroke color.

◆ Tints and Shades. Changes
colors in the brush stroke to
tints of the current stroke color.

◆ Hue Shift. Change the current
stroke color to the Key color
and change other colors to hue
colors. Select the Key color
that you want.

Click OK.

If the brush is being used, an alert
appears. 

Click Apply to Strokes to apply the
modified brush option to existing
strokes or Leave Strokes to apply
the modified brush only to new
strokes.
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Calligraphic brushes resemble strokes you create with a Calligraphy
pen. When you use a calligraphic brush, it applies the brush to the cen-
ter of the path. You use a similar method to create and edit a
Calligraphic brush. You use the Calligraphic Brush Options dialog box to
set the options that you want. The options include Angle, Roundness,
and Diameter. 

Creating and Editing
Calligraphic Brushes

Create or Edit a Calligraphic
Brush

Select the Brushes panel.

Do one of the following:

◆ Create. Select one or more
objects, click the New Brush
button on the panel, click the
Calligraphic Brush option, and
then click OK. Enter a name for
the brush.

◆ Edit. Deselect any brushes, and
then double-click a calligraphic
brush.

Specify the following options:

◆ Angle. Enter a value (-180 to
180) to specify the angle of
rotation for the brush. 

◆ Roundness. Enter a value (0-
100%) to specify the roundness
of the brush. Drag a black dot
in the preview away from or
toward the center. 

◆ Size. Drag a slider or enter a
value (0-1296 points) to specify
the diameter of the brush.
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For the Angle, Roundness, and
Size options, click the list arrow,
and then select one of the
following options: 

◆ Fixed. Enter a single fixed
value.

◆ Random. Drag sliders or enter a
range for a variable value. 

◆ Pressure, Stylus Wheel, Tilt,
Bearing, or Rotation. Drag
sliders or enter values if using
a drawing tablet.

Click OK.

If the brush is being used, an alert
appears. 

Click Apply to Strokes to apply the
modified brush option to existing
strokes or Leave Strokes to apply
the modified brush only to new
strokes.
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Art brushes create artistic strokes when painting. When you use an Art
brush, it stretches a brush shape or object shape evenly along the cen-
ter of a path. You use a similar method to create and edit an Art brush.
You can use the Art Brush Options dialog box to set the options that you
want. The options include: Width, Direction, Scale or Stretch, Flip Along
or Flip Across, Colorization, and Overlap (adjusts corner and folds).
When you use a writing tablet and 6D pen, such as a Wacom Art Pen,
with an art brush, you can set options for pressure, stylus wheel, bear-
ing, rotation, and tilt.

Creating and Editing
Art Brushes

Create or Edit an Art Brush

Select the Brushes panel.

Do one of the following:

◆ Create. Select one or more
objects, click the New Brush
button on the panel, click the
Art Brush option, and then click
OK. Enter a name for the brush.

◆ Edit. Deselect any brushes, and
then double-click an art brush.

Specify the following options: 

◆ Width. Specify a brush width
percentage. With a writing
tablet, select an art brush
width.

◆ Brush Scale Option. Specify
the scaling for art and pattern
brushes along a path. Click the
Scale Proportionately, Stretch
To Fit Stroke Length, or Stretch
Between Guides option.

◆ Direction. Select an icon to
specify the direction of the
artwork in relation to the line.
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Click the Method list arrow, and
then select an option:

◆ None. Retains colors from the
Brushes panel.

◆ Tints. Changes black areas in
the brush stroke to the current
stroke color.

◆ Tints and Shades. Changes
colors in the brush stroke to
tints of the current stroke color.

◆ Hue Shift. Changes the current
stroke color to the Key color
and changes other colors to
hue colors. Select the Key color
that you want.

Specify the following options: 

◆ Flip Along or Flip Across.
Select to change the
orientation of the artwork in
relation to the line.

◆ Do Not Adjust Corners And
Folds or Adjust Corners And
Folds To Prevent Overlap.
Select to set the brush corner
control.

Click OK.

If the brush is being used, an alert
appears. 

Click Apply to Strokes to apply the
modified brush option to existing
strokes or Leave Strokes to apply
the modified brush only to new
strokes.
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Pattern brushes paint with a pattern. Pattern brushes work the same
way as Scatter brushes; however, they follow the path exactly, while
Scatter brushes don’t. You use a similar method to create and edit a
Pattern brush. You use the Pattern Brush Options dialog box to set the
options that you want. The options include Scale, Spacing, Tile Buttons,
Flip Along or Flip Across, and Fit. When you use a writing tablet and 6D
pen, such as a Wacom Art Pen, with a pattern brush, you can set
options for pressure, stylus wheel, bearing, rotation, and tilt.

Creating and Editing
Pattern Brushes

Create or Edit a Pattern Brush

Select the Brushes panel.

Do one of the following:

◆ Create. Select one or more
objects, click the New Brush
button on the panel, click the
Pattern Brush option, and then
click OK. Enter a name for the
brush.

◆ Edit. Deselect any brushes, and
then double-click a pattern
brush.

Specify the following options: 

◆ Scale. Enter a value to adjust
the size of tiles relative to the
original size. With a writing
tablet, select a pattern brush
width.

◆ Spacing. Enter a value to adjust
the spacing between tiles.

◆ Tile Buttons. Select to apply
different patterns to different
parts of a path.

◆ Flip Along or Flip Across.
Select to change the
orientation of the artwork in
relation to the line.

◆ Fit. Select an option to adjust
the size of the tile.
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Click the Method list arrow, and
then select an option:

◆ None. Retains colors from the
Brushes panel.

◆ Tints. Changes black areas in
the brush stroke to the current
stroke color.

◆ Tints and Shades. Changes
colors in the brush stroke to
tints and shades of the current
stroke color.

◆ Hue Shift. Changes the current
stroke color to the Key color
and changes other colors to
hue colors. Select the Key color
that you want.

Click OK.

If the brush is being used, an alert
appears. 

Click Apply to Strokes to apply the
modified brush option to existing
strokes or Leave Strokes to apply
the modified brush only to new
strokes.
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Bristle brushes simulate the effects of painting with a natural brush,
such as watercolors and oils. When you use a bristle brush, it paints
with vectors to resemble a natural brush stroke. When you create a
bristle brush, you can set brush options, such as brush shape (either,
round, flat, or fan), brush size, length, density, thickness, paint opacity,
and stiffness. When you use a writing tablet and 6D pen, such as a
Wacom Art Pen, with a bristle brush, a cursor simulates the brush tip
and the pen automatically responds to pressure, bearing, rotation, and
tilt.

Creating and Editing
Bristle Brushes

Create or Edit a Bristle Brush

Select the Brushes panel.

Do one of the following:

◆ Create. Click the New Brush
button on the panel, click the
Bristle Brush option, and then
click OK. Enter a name for the
brush.

◆ Edit. Deselect any brushes, and
then double-click a bristle
brush.

Click the Shape list arrow, and
then select a brush shape, such as
Flat Point, Flat Angle, Round Blunt,
or Round Fan.  

Specify the following options: 

◆ Size. Specify the diameter of
the brush between 1mm and
10mm. The brush size is
measured at the point where
the bristles meet the handle.

◆ Bristle Length. Specify the
length of the bristle between
25% and 300%.

◆ Bristle Density. Specify the
density of the bristle between
1% and 100%. This option is
calculated based on the brush
size and bristle length. The
density is the number of bristles
in a specified area of the brush
neck.
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◆ Bristle Thickness. Specify the
thickness of the bristle from
fine to coarse between 1% and
100%.

◆ Paint Opacity. Specify the
opacity of the selected paint
between 1% (translucent) and
100% (opaque). This value is
the maximum opacity used in
the brush.

You can use the numeric keys
(0-9) as shortcuts to set bristle
brush opacity; 0=100%, 1=10%,
9=90%, etc.

◆ Stiffness. Specify the rigidness
of the bristle between 1% to
100%. A lower value creates
flexible bristles, while a higher
value creates stiffer bristles.

Click OK.

If the brush is being used, an alert
appears. 

Click Apply to Strokes to apply the
modified brush option to existing
strokes or Leave Strokes to apply
the modified brush only to new
strokes.
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As you create and edit brushes in the Brushes panel or add them into
the Brushes panel from other brush libraries, it’s important to save them
in a brush library if you want to use them again in the future. You can
create your own brush libraries by using the Save Brushes command
on the Options menu. The Save Brushes command saves all the
brushes currently in the Brushes panel, so you need to delete the ones
that you don’t want in the library. In addition to deleting brushes in the
Brushes panel, you can also remove brush strokes from objects.

Working with Brushes

Remove Brush Strokes and
Delete Brushes

Select the Brushes panel.

Do any of the following:

◆ Delete from Object. Select the
objects with brushes that you
want to remove, and then click
the Remove Brush Stroke
button on the panel.

◆ Delete from Brushes Panel.
Deselect all objects, select the
brush you want to delete, and
then click the Delete Brush
button on the panel. Click Yes
to confirm the deletion.

If the brush is currently being
used in objects, click Expand
Strokes to convert the brush to
paths or click Remove Strokes
to remove them from the
objects. 

2

1

Did You Know?
You can convert brush strokes into
outlined paths. Select the brushed
path, click the Object menu, and then
click Expand Appearance. Now, you
can edit individual components of the
brushed path.
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Save a Brush Library

Select the Brushes panel.

Display the brushes that you want
to save in the Brushes panel.
Remove the ones that you don’t
want.

Click the Brush Libraries Menu
button, and then click Save
Brushes.

Enter a name for the brushes
library.

Click Save.

To open the brush library, click the
Brush Libraries Menu button, point
to User Defined, and then select
the saved library.
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Illustrator provides Liquify tools on the Tools panel that allow you to dis-
tort a path quickly and easily with the click of a mouse. The Liquify
tools include Warp, Twirl, Pucker, Bloat, Scallop, Crystallize, and
Wrinkle. All the tools are grouped together in the same slot on the Tools
panel. The tools work the same way, they each apply a different distor-
tion effect. You can change the way each tool works by selecting
options in the tool’s Options dialog box, which you can open by double-
clicking the tool on the Tools panel. Some of the common options you
can change include brush dimensions.

Working with Liquify
Tools

Use a Liquify Tool

Select the liquify tool (Width,
Warp, Twirl, Pucker, Bloat,
Scallop, Crystallize, or Wrinkle)
that you want to use on the Tools
panel.

To change tool options, double-
click the tool on the Tools panel,
specify the options that you want,
and then click OK.

The options vary depending on the
liquify tool.

Position the cursor (which
changes to a circle with a
crosshair in the middle) over the
path that you want to change.

Click and/or drag to apply the
distortion to the path.
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Using Symbols

Introduction

If you use the same object in multiple places in a document,
you can use the Symbols panel to store and use it as an
instance. A symbol is stored once and used multiple times as
an instance, which speeds up printing and reduces the size of
your document. Each instance is linked to the original sym-
bol. When you break the link between a symbol and an
instance, the instance is converted back to a normal object. 

You can place instances one at a time or create a collec-
tion of instances with the Symbol Sprayer tool, known as a
symbol set. This allows you to quickly create artistic designs
without a lot of experience. 

With the Symbols panel, you can create, edit, rename,
duplicate, and delete symbols. You can create your own sym-
bol from a selected object or you can use the ones provided
by Illustrator. Illustrator gives you access to almost 30 differ-
ent symbol libraries, which include Arrows, Artistic Textures,
Flowers, Fashion, Maps, and Nature to name a few. 

The Symbol Sprayer allows you to create a symbol set.
After you create a symbol set, you can use one of 7 other
symbolism tools to modify it. The symbolism tools include:
Symbol Shifter (to shift direction and bring forward or send
backward), Symbol Scruncher (to move instances closer or
farther apart), Symbol Sizer (to increase or decrease size),
Symbol Spinner (to change the orientation), Symbol Stainer
(to increase or decrease the transparency), Symbol Screener
(to recolor with tints), and Symbol Styler (to apply a graphic
style). With the Expand command, you can break the link
between an instance and the original symbol or break apart a
symbol set. 12

12
What You’ll Do

Use the Symbols Panel

Use Symbol Libraries

Work with Symbols

Duplicate and Edit Symbols

Break Symbol Links

Use the Sprayer Tool

Set Symbolism Tools Options

Use the Symbol Shifter Tool

Use the Symbol Scruncher Tool

Use the Symbol Sizer Tool

Use the Symbol Spinner Tool

Use the Symbol Stainer Tool

Use the Symbol Screener Tool

Use the Symbol Styler Tool

Expand Symbol Instances

Use 9-Slice Scaling for Symbols

Align Symbols to the Pixel Grid

Set the Symbol Registration Point
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If you use the same object in multiple places in a document, you should
store it in the Symbols panel and use it as an instance. A symbol is
stored once in the Symbols panel and used multiple times as an
instance, which speeds up printing and reduces the size of your docu-
ment. Each instance is linked to the original symbol. When you select
an instance on the artboard, the symbol is selected in the Symbols
panel. You select a symbol instance by pointing to the symbol content
in normal mode (not just inside the bounding box). You can place
instances one at a time or create a collection of instances with the
Symbol Sprayer tool, known as a symbol set. This allows you to quickly
create artistic designs without a lot of experience. With the Symbols
panel you can create, edit, rename, duplicate, and delete symbols.  

Using the Symbols
Panel

Create Instances with the
Symbols Panel

Select the Symbols panel.

To change the Symbols panel view,
click the Options menu, and then
select any of the following view
available options:

◆ Thumbnail View

◆ Small List View

◆ Large List View

◆ Sort by Name

Select a symbol on the panel.

Click the Place Symbol Instance
button on the panel.

◆ You can also drag a symbol
from the Symbols panel onto an
artboard.
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Did You Know?
You can duplicate an instance on the
artboard. Alt+drag (Win) or Option+
drag (Mac) the instance on the art-
board. 
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Instead of creating your own symbols, you can use the ones provided
by Illustrator. Illustrator gives you access to almost 30 different symbol
libraries, which include Arrows, Artistic Textures, Flowers, Fashion,
Maps, and Nature, to name a few. When you open a symbol library
from the Symbols panel, a new panel appears, displaying the library
symbols. Instead of opening each library separately, you can use the
Load Previous Symbol Library or Load Next Symbol Library buttons on
the panel to quickly view libraries to find the symbols you want. When
you click a library symbol, it’s added to the Symbols panel.

Using Symbol 
Libraries

Use Symbol Libraries

Select the Symbols panel.

Select a path with any of the
selection tools.

Click the Symbol Libraries Menu
button on the panel, and then
select a symbol library.

Click the Load Previous Symbol
Library or Load Next Symbol
Library button to view other
libraries.

Click a symbol in the library panel
to add it to the Symbols panel.

Select a symbol on the Symbols
panel.

Click the Place Symbol Instance
button on the panel.

◆ You can also drag a symbol
from the Symbols panel or any
symbols library onto an
artboard.
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Did You Know?
You can arrange symbols on the
Symbols panel. In the Symbols panel,
you can drag a symbol to a new spot.
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With the Symbols panel you can create, edit, rename (New!), dupli-
cate, and delete symbols. You can use any object (path, type, and
graphics to name a few) in Illustrator to create a symbol. There are two
types of symbols: Graphic and Movie Clip (used for Flash, more later).
As you create symbols in the Symbols panel or add them into the
Symbols panel from other symbol libraries, it’s important to save them
in a symbol library if you want to use them again in the future. The Save
Symbols command saves all the symbols currently in the Symbols
panel, so you need to delete the ones that you don’t want in the library. 

Working with 
Symbols

Create a Symbol from an Object

Create the object that you want to
use, and then select it using the
Selection tool on the Tools panel.

Select the Symbols panel.

Click the New Symbol button on
the panel.

◆ You can also drag the object
directly to a blank area on the
Symbols panel.

Type a name for the symbol.

Click the Type list arrow, and then
click Graphic.

Click OK.

To rename a symbol in the
Symbols panel (New!), double-
click the name, edit it, and then
press Enter (Win) or Return (Mac).
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Did You Know?
You can create a symbol without the
dialog box. Select the object, and then
Alt+drag (Win) or Option+drag (Mac)
the object onto the New Symbol button
on the panel.  

You can change symbol options.
Select the symbol in the Symbols
panel, click the Symbol Options button
on the panel, change the options that
you want, and then click OK.

New symbol
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Delete Symbols

Select the Symbols panel.

Select the symbols that you want
to delete.

Click the Delete Symbol button on
the panel.

◆ You can also drag a symbol
over the Delete Symbol button
to delete it.

If there are no instances of the
deleted symbol, click Yes to
confirm the deletion. If there are
instances, click Expand Instances
to convert the instance to paths or
click Delete Instances to remove
them. 

Save and Create a Symbols
Library

Select the Symbols panel.

Display the symbols that you want
to save in the Symbols panel.
Remove the ones that you don’t
want.

Click the Symbol Libraries Menu
button, and then click Save
Symbols.

Enter a name for the symbols
library.

Click Save.

To open the symbol library, click
the Symbol Libraries Menu button,
point to User Defined, and then
select the saved library.
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Instead of creating your own symbols, you can duplicate an existing
symbol (from a symbol library) that is close to what you want and then
edit it. It’s faster than creating one from scratch. When you edit a sym-
bol, Illustrator creates a temporary instance in Isolation Mode, where
you can make your changes. When you exit Isolation Mode, your
changes are applied to all linked instances in your document.

Duplicating and
Editing Symbols

Duplicate a Symbol

Select the Symbols panel.

Select the symbol that you want to
duplicate.

Drag the symbol onto the New
Symbol button on the panel.

◆ You can also select an instance
on the artboard, and then click
Duplicate on the Control panel.

Click the Symbol Options button
on the panel.

Type a name for the symbol.

◆ You can also double-click the
name, edit it, and then press
Enter (Win) or Return (Mac) to
rename a symbol in the
Symbols panel (New!).

Click OK.

The two symbols are the same and
linked to the same instances on
the artboard. 

◆ To make them different, click
the Break Link to Symbol
button on the panel, and then
edit it.
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Did You Know?
You can assign names to instances for
export to Flash. Select the instance on
the artboard, enter a name in the
Instance Name field on the Control
panel. This is helpful when you export
the instances to Adobe Flash for use in
movies.
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Edit a Symbol

Select the Symbols panel.

Double-click the symbol (not the
name) that you want to edit.

◆ You can also select the symbol,
click the Options menu, and
then click Edit Symbol.

◆ If you’re working with an
instance, select it, and then
click Edit Symbol on the Control
panel. 

A temporary instance of the
symbol appears in isolation mode.
Make the changes that you want
to the symbol.

Click the gray bar above the
document to exit Isolation Mode.

The symbol updates in the
Symbols panel and all instances of
the symbol are updated as well.

4
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Did You Know?
You can replace the symbols in a sym-
bol set. Select a symbol set on an art-
board using the Selection tool, click a
replacement symbol on the Symbols
panel, click the Options menu, and then
click Replace Symbol.  

You can create sublayers. In symbol
editing mode, you can create sublayers
and use Paste Remembers Layers on
the Options menu on the Layers panel.  

1
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Edited symbol
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When you create an instance of a symbol, the instance is linked to the
symbol, which speeds up printing and reduces the size of your docu-
ment. When you break the link between a symbol and an instance, the
instance converts to a normal object. If you don’t want an instance to
be updated when you edit a symbol, you can break the link between the
symbol and the instance (which creates a normal object), and then cre-
ate a new symbol with the normal object.

Breaking Symbol 
Links

Break a Link Between a Symbol
and an Instance

Select the instance on the
artboard for which you want to
break the symbol link.

Select the Symbols panel.

Click the Break Link to Symbol
button on the panel.

◆ You can also click the Break
Link button on the Control
panel.

3

2

1

Did You Know?
You can replace one symbol with
another in an instance. Select the
instance on an artboard using the
Selection tool, click a replacement
symbol on the Symbols panel, click the
Options menu, and then click Replace
Symbol.  
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Break a Link and Create a New
Symbol

Select the instance on the
artboard for which you want to
break a symbol link.

Select the Symbols panel.

Click the Break Link to Symbol
button on the panel.

◆ You can also click the Break
Link button on the Control
panel.

Make the changes that you want
to the object (no longer an
instance) on the artboard.

Drag the object to a blank area on
the Symbols panel from an
artboard to create a new symbol.

Type a name for the symbol.

Click the Type list arrow, and then
click Graphic.

Click OK.8
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The Symbol Sprayer tool allows you to spray multiple instances of a
symbol to create a symbol set. The symbol set appears on the artboard
containing all the instances within a bounding box. After you create a
new symbol set, you can add or delete instances or quickly create
another set. You can customize the way the Symbol Sprayer tool works
by setting options in the Symbolism Tools Options dialog box.

Using the Symbol
Sprayer Tool

Use the Symbol Sprayer Tool

Select the Symbol Sprayer tool on
the Tools panel.

Select the Symbols panel.

Select the symbol that you want to
use.

Click once to create a single
instance or click and hold or drag
to create multiple instances.

The symbol set of instances
appears in a bounding box. 

Do any of the following:

◆ Create New Symbol Set.
Ctrl+click (Win) or
Command+click (Mac) in a
blank area outside the
bounding box, and then click
again, click and hold, or drag.

◆ Add Instances to Symbol Set.
Select the symbol set, click a
symbol on the Symbols panel,
and use the Symbol Sprayer
tool. 

◆ Delete Instances from a
Symbol Set. Select the symbol
set, select the Symbol Sprayer
tool, Alt+click (Win) or
Option+click the instances in
the symbol set that you want to
delete.
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Illustrator comes with 8 symbolism tools: Symbol Sprayer, Symbol
Shifter, Symbol Scruncher, Symbol Sizer, Symbol Spinner, Symbol
Stainer, Symbol Screener, and Symbol Styler. While each tool does a
different job, you can set common and specific options for any of them
in one place: the Symbolism Tools Options dialog box. The common
options are Diameter, Intensity, and Symbol Set Density.

Setting Symbolism
Tools Options

Set Symbolism Tools Options

Double-click any symbolism tool
on the Tools panel.

Enter a Diameter value (1-999
points) to specify a default size for
the symbols.

Enter an Intensity value (1-10) that
designates the rate at which the
tools create symbols or changes.
The lower the value, the slower
the action.

Enter a Symbol Set Density value
(1-10) to specify the distance
between instances. The higher the
value, the closer the instances.

Select the Show Brush Size and
Intensity check box to have the
current diameter setting display as
a ring around the tool pointer.

Click a symbolism button to specify
or display options for the tool.

◆ Symbol Sprayer. For the
available options, select
Average to add instances
based on an average sampling
of adjacent instances or User
Defined to set a value.

Click OK.7
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The Symbol Shifter tool allows you to modify the attributes of an exist-
ing symbol set. You can shift the direction of instances or change the
stacking order (bring forward or send backward) of instances. You can
set either of these with a click of the mouse. You can customize the
way the Symbol Shifter tool works by setting options in the Symbolism
Tools Options dialog box.

Using the Symbol
Shifter Tool

Use the Symbol Shifter Tool

Select the symbol set that you
want to use.

Select the Symbol Shifter tool on
the Tools panel.

Drag in the symbol set to shift the
instances in the direction you
want.

Do any of the following to shift the
position of an instance:

◆ Bring Forward. Shift+click an
instance.

◆ Send Backward. Alt+Shift+click
(Win) or Option+Shift+click
(Mac) an instance.
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Did You Know?
You can set Symbol Shifter options.
Double-click the Symbol Shifter tool on
the Tools panel, specify the options you
want (see page 343 for details), and
then click OK.  
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The Symbol Scruncher tool allows you to move instances in an existing
symbol set closer together (scrunched) or farther apart. It’s easy to do.
Simply click and hold or drag inside the symbol set to scrunch
instances. Press an additional key to move instances farther away. You
can customize the way the Symbol Scruncher tool works by setting
options in the Symbolism Tools Options dialog box.

Using the Symbol
Scruncher Tool

Use the Symbol Scruncher Tool

Select the symbol set that you
want to use.

Select the Symbol Scruncher tool
on the Tools panel.

Do any of the following to move
instances closer or farther apart: 

◆ Move Closer. Click and hold an
instance or drag across
instances inside the symbol set.

◆ Move Away. Alt+click (Win) or
Option+click (Mac) an instance
or drag across instances inside
the symbol set.

3
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1

Did You Know?
You can set Symbol Scruncher
options. Double-click the Symbol
Scruncher tool on the Tools panel,
specify the options you want (see page
343 for details), and then click OK.  

3

1

2



ptg8126863

346 Chapter 12

The Symbol Sizer tool allows you to resize individual instances in the
symbol set. It’s easy to do. Simply, click and hold or drag inside the
symbol set to enlarge instances. Press an additional key to reduce
instances. This way, you can get the visual look you want. You can cus-
tomize the way the Symbol Sizer tool works by setting options in the
Symbolism Tools Options dialog box.

Using the Symbol 
Sizer Tool

Use the Symbol Sizer Tool

Select the symbol set that you
want to use.

Select the Symbol Sizer tool on
the Tools panel.

Do any of the following to resize
instances: 

◆ Larger. Click and hold an
instance or drag across
instances inside the symbol set.

◆ Smaller. Alt+click (Win) or
Option+click (Mac) an instance
or drag across instances inside
the symbol set.
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Did You Know?
You can set Symbol Sizer options.
Double-click the Symbol Sizer tool on
the Tools panel, specify the options you
want (see page 343 for details), and
then click OK.  
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The Symbol Spinner allows you to change the orientation of individual
instances in the symbol set. Unlike other symbolism tools, click and
hold doesn’t do anything. With this tool, you drag inside the symbol set
in the direction you want to rotate the instance. A rotation icon appears
as you drag to specify the current direction. You can customize the way
the Symbol Spinner tool works by setting options in the Symbolism
Tools Options dialog box.

Using the Symbol 
Spinner Tool

Use the Symbol Spinner Tool

Select the symbol set that you
want to use.

Select the Symbol Spinner tool on
the Tools panel.

Drag an instance in the symbol set
in the direction you want it rotated.

A rotation icon appears as you
drag to indicate the current
direction. 
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1

Did You Know?
You can set Symbol Spinner options.
Double-click the Symbol Spinner tool
on the Tools panel, specify the options
you want (see page 343 for details),
and then click OK.  
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The Symbol Stainer allows you to recolor instances in an existing sym-
bol set. You can recolor solid fills, patterns, and gradients with different
tints (shades) of the current fill color for individual instances in the
symbol set. This is useful for adding variation to instances. You can
customize the way the Symbol Stainer tool works by setting options in
the Symbolism Tools Options dialog box.

Using the Symbol 
Stainer Tool

Use the Symbol Stainer Tool

Select the symbol set that you
want to use.

Select the Symbol Stainer tool on
the Tools panel.

Select the fill color that you want
to use.

Do any of the following to recolor
the tint of instances: 

◆ Increase Tint. Click and hold an
instance or drag across
instances inside the symbol set.

◆ Decrease Tint. Alt+click (Win)
or Option+click (Mac) an
instance or drag across
instances inside the symbol set.
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Did You Know?
You can set Symbol Stainer options.
Double-click the Symbol Stainer tool
on the Tools panel, specify the options
you want (see page 343 for details),
and then click OK.  
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The Symbol Screener tool allows you to make instances in an existing
symbol set more transparent. You can increase or decrease the opacity
for individual instances in the symbol set. This is useful for creating a
faded look to instances. You can customize the way the Symbol
Screener tool works by setting options in the Symbolism Tools Options
dialog box.

Using the Symbol 
Screener Tool

Use the Symbol Screener Tool

Select the symbol set that you
want to use.

Select the Symbol Screener tool
on the Tools panel.

Do any of the following to increase
or decrease instance opacity
(transparency): 

◆ Increase. Click and hold an
instance or drag across
instances inside the symbol set.

◆ Decrease. Alt+click (Win) or
Option+click (Mac) an instance
or drag across instances inside
the symbol set.
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Did You Know?
You can set Symbol Screener options.
Double-click the Symbol Screener tool
on the Tools panel, specify the options
you want (see 343 for details), and then
click OK.  
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The Symbol Styler tool allows you to apply the currently selected
graphic style on the Graphic Styles panel to instances in an existing
symbol set. It’s easy to do. Simply click and hold or drag instances
inside the symbol set to apply the graphic style. The longer you hold
down the mouse, the greater the intensity of the applied style. You can
customize the way the Symbol Styler tool works by setting options in
the Symbolism Tools Options dialog box.

Using the Symbol 
Styler Tool

Use the Symbol Styler Tool

Select the symbol set that you
want to use.

Select the Symbol Styler tool on
the Tools panel.

Select the Graphic Styles panel.

Select the graphic style that you
want to apply to instances in the
selected symbol set.

Do any of the following to apply or
remove a graphic style: 

◆ Apply Style. Click and hold an
instance or drag across
instances inside the symbol set.

The longer you hold down the
mouse, the greater the intensity
of the applied style.

◆ Decrease Style Intensity.
Alt+click (Win) or Option+click
(Mac) an instance or drag
across instances inside the
symbol set.
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Did You Know?
You can set Symbol Styler options.
Double-click the Symbol Styler tool on
the Tools panel, specify the options you
want (see page 343 for details), and
then click OK.  
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With the Expand command, you can break the link between an instance
and the original symbol or break apart a symbol set. When you break
the link between an instance and a symbol, the individual paths
become nested in a group. When you break apart a symbol set, the
individual instances are nested in a group, but the links to the original
symbol are maintained.

Expanding Symbol
Instances

Expand an Instance or a 
Symbol Set

Select the instances or symbol set
that you want to expand.

Click the Object menu, and then
click Expand or Expand
Appearance (if the instance
contains an effect). 

Select the Object and Fill check
boxes.

Click OK.4
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How do you scale objects without distorting them? In the past, you
would scale an object equally in height and width. For many objects,
this method of scaling doesn’t work very well. In Illustrator, a method
called 9-slice scaling is used. A symbol is visually divided into nine
areas, or slices, with a grid overlay (dotted lines called slide guides).
The 9-slice scaling grid is visible only in isolation mode. Each area of
the grid is scaled separately (except the corners), which provides more
accurate results. The slide guides are set at 25% of the symbol’s height
and width by default. Before you can scale a symbol, you need to
enable 9-slice scaling. You can use 9-slice scaling for symbols with
rotation, shear, and other complex transformations.

Using 9-Slice Scaling
for Symbols

9-Slice Scale a Symbol

Select the Symbols panel.

Select the symbol on the artboard
or in the Symbols panel using the
Selection tool on the Tools panel.

Click the New Symbol button on
the panel.

Type a name for the symbol.

Click the Type list arrow, and then
click Graphic or Movie Clip.

Select the Enable Guides for 9-
Slice Scaling check box.

Click OK.7
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Did You Know?
You can reset any transformation to
symbols. Select the symbol, and then
click the Reset button on the Control
panel or click the Options menu in the
Symbols panel, and then click Reset
Transformation. 
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Edit the 9-Slice Scaling Grid for
a Symbol

Select the Symbols panel.

Double-click the symbol in the
Symbols panel.

Position the pointer over any of the
four guides, and then drag the
guide to move it.

Click the Exit Isolated Group
button to exit isolation mode.
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When you create a symbol, you can enable the object to align to the
pixel grid. When you align a symbol to the pixel grid, it creates an
object that looks crisp and sharp for use on different outputs, such as
the Web and mobile devices. The Align to Pixel Grid option enables the
vertical and horizontal segments of the paths of the symbol to be
nudged and aligned to the pixel grid. The stroke width values become
full integer to create crisp paths. To view the pixel grid, zoom to 600%
or higher in Pixel Preview mode. The Align to Pixel Grid option remains
enabled with the object until it’s disabled, which you can deselect in
the Symbol Options dialog box or Transform panel.

Aligning Symbols to
the Pixel Grid

Create a Pixel Aligned Symbol

Select the Symbols panel.

Select the symbol on the artboard
or in the Symbols panel using the
Selection tool on the Tools panel.

Click the New Symbol button on
the panel.

Type a name for the symbol.

Click the Type list arrow, and then
click Graphic or Movie Clip.

Select the Align To Pixel Grid
check box.

Click OK.7
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3See Also
See “Creating Pixel Aligned Objects”
on page 67 for more information on
working with pixel aligned objects.
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A registration point is the origin of the symbol; the point on which all
transformations are based. For example, when you rotate a symbol, the
rotation takes place around the registration point. The symbol registra-
tion point in Illustrator is similar to Adobe Flash Professional. When you
create a symbol, you can select a registration point from any of the 8
points in the Symbol Options dialog box or change it in the Transform
panel. The center point is the default. The registration point is visible as
a crosshair in symbol edit/isolation mode and in normal mode when you
select the symbol instance.

Setting the Symbol
Registration Point

Set and Change the Symbol
Registration Point

Select the Symbols panel.

Select the symbol on the artboard
or in the Symbols panel using the
Selection tool on the Tools panel.

Click the New Symbol button on
the panel.

Type a name for the symbol.

Click the Type list arrow, and then
click Graphic or Movie Clip.

Click any of the 8 point squares to
set the registration point.

Click OK.

To view/change the registration
point coordinates, select the
Transform panel, select the symbol
in normal or isolation mode, and
then view or change the location.

To enable/disable the use of the
registration point, click the Options
menu on the Transform panel, and
then click Use Registration Point
for Symbol. 
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Registration coordinates
in normal mode

Registration point in
normal mode
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Automating the Way You
Work

Introduction

Actions are similar to recording information on a tape; they
record Illustrator commands and, like a tape recorder, can be
played back at any time. Actions can be applied to any num-
ber of images. You can modify existing actions, and save
them into a user-defined set. It's even possible to save them
and send them to another Illustrator user. This chapter is ded-
icated to all the Illustrator users who are tired of doing some-
thing over and over again. If you have ever considered using
actions as a part of your design workflow, then you're in for a
wonderful journey of discovery. 

A script is a series of commands that instructs Illustrator
to perform a set of specified actions. These actions can be
simple, affecting only a single object, or more complex,
affecting many objects. Scripts are useful for repetitive tasks
and can be used as a creative tool to streamline tasks that
are time consuming and boring. You can use one of
Illustrator’s built-in scripts, such as ExportDocsAsFlash or
ImageTracing, or create one of your own. 13

13
What You’ll Do

Examine the Actions Panel 

Build a New Action 

Record an Action 

Control the Playback of a Command 

Add a Stop to an Action 

Insert a Non-Recordable Command into
an Action

Add a Command to an Action 

Delete a Command from an Action 

Work with Batch File Processing

Open and Use Scripts

Create and Edit Data Variables

Create and Format a Data Graph

Add Graph Designs to Graphs

Clean Up Unneeded Elements
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The Actions panel is where you create, save, modify, and store all of
your actions. The analogy of a tape recorder is often used in describing
the Actions panel, and it's actually a good way to think of actions. The
action itself is a recording, and the Actions panel is the tape recorder.
When you begin an action, the panel records each step in the process,
saves them, and then lets you play them back on another image. In
order to record and play actions, you need to understand how to use
the Actions panel. 

Examining the 
Actions Panel

Examine the Actions Panel

Select the Actions panel.

Check the toggle box to toggle an
action on or off.

Click the dialog box to toggle the
dialog function on or off.

Click the expand triangle to
expand or contract an action or
set.

Click the Options menu to access
all of the Actions panel options.

5

4

3

2

1
2

3

1

Did You Know?
You can convert your Actions into 
single-click buttons. Click the Options
menu on the Actions panel, and then
click Button Mode. When the Actions
panel is in Button Mode, you cannot
access or edit the steps in the individ-
ual actions. To access the standard
Actions panel, click the Options menu
on the Actions panel, and then click
Button Mode to uncheck the option. 
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The following buttons are
accessible at the bottom of the
Actions panel, from left to right:

◆ Stop. Click to stop recording
and save an action.

◆ Record. Click to begin
recording an action.

◆ Play. Click to begin execution
of the selected action.

◆ Create New Set. Creates a new
action set. 

Sets are like file folders; they
store individual actions.

◆ Create New Action. Starts the
process of creating a new
action.

◆ Delete. Click to delete the
selected action or set.

6

6

Stop

Record

Play

Create New Set Delete

Create New Action

Did You Know?
You can save actions into sets. Action
sets are like file folders; they hold
groups of actions. Select the Actions
panel, click the Create New Set button,
enter a name for the set, and then click
OK.

You can save action sets as files.
Select the Actions panel, click the set
you want to save, click the Options
menu, click Save Actions, enter a
name for the file, specify a location,
and then click Save.

You can restore actions to the default
set. Select the Actions panel, click the
Options menu, click Reset Actions, and
then click OK to replace or Append to
combine with the current set.
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Building a New 
Action

Build a New Action

Open a document, and then select
the Actions panel.

Click the Create New Action
button.

Enter a name for the action in the
Name box.

Click the Set list arrow, and then
select in which set to save the
action.

Click the Function Key list arrow,
and then click F1 - F12 to assign
your new action to a function key.

Select the Shift or Control (Win) or
Command (Mac) check boxes to
require the pressing of the Shift
key, or the Ctrl (Win) or A (Mac)
key in conjunction with the
function key. 

For example, F1, or Shift+F1, or
Ctrl+F1, or Shift+Ctrl+F1.

Click the Color list arrow, and then
select from the available colors.

IMPORTANT If you choose a
color for the action, it will only be
visible if the actions are viewed in
Button Mode.

Click Record to begin creating the
action.

Click the Stop button on the
Actions panel.
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Building an action is almost as simple as clicking the record button on
a tape recorder. Actions are simply a series of program instructions.
When you build an action, you're instructing Illustrator what to name
the action, where to store it, and what shortcut keys, if any, will be
used to activate the action. Since an action is simply a record of the
work performed on an image, it's a good idea to plan out what you
intend to do, and then build the action. Remember, actions are designed
for tasks you plan to do repeatedly. It wouldn't make sense to create an
action for a one-time use. 

1

2

5

3

6

4

8

7



ptg8126863

Chapter 13 Automating the Way You Work 361

Not all actions are created perfectly. Sooner or later, you'll work
through the process of action building only to find out (after the action
is saved), that you forgot a step, or you need to remove or modify an
existing step. Fortunately, Illustrator doesn't make you recreate the
action; all you have to do is modify it. When you create an action, all of
the commands execute in the order they appear in the list of action
steps. However, it's possible you might occasionally want to skip one of
the steps in the list, without permanently deleting it. To play an action,
simply select it and then click the Play button.

Controlling the
Playback of a
Command

Control the Playback of 
a Command

Open a document, and then select
the Actions panel.

Click the expand triangle of the
action you want to modify.

Select the action that you want to
play.

To remove commands from
playback, uncheck the command
or commands you do not want to
execute.

Make a selection if necessary for
use with the action.

Click the Play button on the
Actions panel to run the action
without executing the unchecked
command(s).

Recheck the command(s) to return
them to executable status.
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Did You Know?

You can specify the playback speed.
Select the Actions panel, click the
Options menu, click Playback Options,
specify a speed (Accelerated, Step By
Step or Pause For), and then click OK.

You can copy an action. Select the
Actions panel, drag the action over the
Create New Action button on the panel
or select the action, click the Options
menu, and then click Duplicate.
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There are times when you want to make changes to individual files dur-
ing the playback of an action. For example, you want to create an
action to transform artwork using the Rotate, Scale, and Shear com-
mands, yet the rotation, scale, and shear settings are not always the
same. If the settings you want to use for the action are not the same
every time or there is a potential problem, you can insert a stop that
allows you to specify the settings you want, and then have the action
continue on its way to complete the rest of the steps or stop it all
together. This provides you with the automation you want with the flexi-
bility to specify the settings you want.

Adding a Stop to 
an Action

Add a Stop to an Action

Open a document, and then select
the Actions panel.

Click the expand triangle of the
action you want to modify.

Click the command directly above
where you want to place the
action.

Click the Options menu, and then
click Insert Stop.

Enter a message associated with
the purpose of the stop action.

Select the Allow Continue check
box to add a Continue button to the
stop alert box.

Click OK.

Click the Play button on the
Actions panel to run the action.
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Did You Know?
You can run an action inside an
action. Select the Actions panel, click
the command directly above where
you want to insert the run step for
another action, click the Record but-
ton, click the action to be added, click
the Play button to record the second
action into the first action, and then
click Stop.

1 4

7

5



ptg8126863

Chapter 13 Automating the Way You Work 363

When you create an action, not all commands and tools can be
recorded, such as Selection, Pen, Paintbrush, Pencil, Pencil, Gradient,
Mesh, Eyedropper, Live Paint Bucket, and Scissors tools or Effects and
View menu commands. However, you can insert many non-recordable
commands into an action by using an Insert Menu Item command. The
Insert Menu Item command can be used when recording an action or
after it has been recorded. Inserted commands do not execute until the
action is played, so the file remains unchanged when the command is
inserted. This gives you the ability to experiment with different non-
recordable commands without the risk of damaging a valuable image. 

Inserting a Non-
Recordable Command
into an Action

Insert a Non-Recordable
Command into an Action

Open a document, and then select
the Actions panel.

Click an action, and then click the
expand triangle.

Click the name of the action to
insert the item at the end of the
action, or click a specific action
step to insert the item after the
selected step.

Click the Options menu, and then
click Insert Menu Item. 

Select a command from the
available options (the command is
selected by clicking and selecting
an item from Illustrator's drop-
down menu system).

Click OK.

The non-recordable command is
added to the action steps.

IMPORTANT When you use
the Insert Menu Item command for
a command that opens a dialog
box, you cannot disable the modal
control in the Actions panel. 
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Actions are very versatile; in fact, almost anything that can be done to
an image can be placed into an action. You might find that as you per-
form an action, you need to add an additional command. You can do
this with ease; that's why actions are so great to work with. For exam-
ple, you might create an action to convert an image from the RGB to
the CMYK mode, and after you save the action, you decide it would be
great to include an effect. You don't have to throw away the previous
action and start all over; all you have to do is select where the com-
mand will be inserted, restart the action, and perform the new step. The
Actions panel is a powerful time-saving tool, and if you forget a step,
it's also a breeze to modify. 

Adding a Command to
an Action

Add a Command to an Action

Open a document, and then select
the Actions panel.

Click the expand triangle of the
action to which you want to add
the command.

Click the command directly above
where you want to insert the new
command.

Click the Options menu, and then
click Start Recording.

Add the additional command by
selecting an Illustrator option.

When you're finished adding
commands, click the Stop button
on the Actions panel.

The next time the action is run, the
additional command will be
performed.
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Did You Know?
You can change the order of com-
mands in an action. Select the Actions
panel, drag the command you want to
change up or down in the actions
stack. Release the mouse when you
see a dark line underneath the com-
mand where you want the action.

Using Modal Controls with an Action
Modal controls are pauses in an action that allow you to modify a
command before proceeding. Modal controls are available for every
command that utilizes a dialog box, or any command that requires
the pressing of the Enter/Return key to process the effect. Select the
Actions panel, click the second column to activate or deactivate the
Modal Control button.

For Your Information
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Occasionally, you may want to permanently delete a command from an
existing action. If that's the case, Illustrator makes the process quick
and easy. An action consists of a group of steps. As the action exe-
cutes, each step is completed in the order in which it appears within
the action list. No one step is dependent upon another, so if you want
to remove a step, it's a simple process of deletion. Once the command
is removed, the action will perform as if the deleted command never
existed. 

Deleting a Command
from an Action

Delete a Command from 
an Action

Open a document, and then select
the Actions panel.

Click the expand triangle of the
action from which you want to
delete the command.

IMPORTANT You cannot
delete a command from a running
action.

Click the command you want to
delete.

Select from three deletion
methods:

◆ Drag the command over the
Delete button.

◆ Click the command, click the
Delete button, and then click
Yes in the Delete the Selection
alert box.

◆ Click the command, and then
hold down the Alt (Win) or
Option (Mac) key, and then
click the Delete button to
delete the command without
the alert box message.
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The selected action
is removed.
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There is nothing more exciting than working on a new creative project,
and watching your designs come to life. Conversely, there is nothing
more tiresome than having to apply a new creative concept or correc-
tion individually to many additional images. For example, you just spent
three hours coming up with a procedure to apply color and blending
modifications to one of the company's logos. The photo logo looks
great; however, you now have to apply color and blending modifica-
tions to all of the company's logos. You could create an action, but you
would still have to open each image and apply the action individually.
The solution is to batch process the images after you have created the
action. Batch file processing lets you apply an action to an entire folder
of files, and all you have to do is click a button. Now, what could be
simpler than that? 

Working with Batch
File Processing  

Work with Batch File
Processing

Create a new folder, and then
move all the images into the folder.

IMPORTANT These files must
be Illustrator files. There should
not be any other files, such as text
files, inside this folder.

Create a second folder to hold the
modified images (optional).

Select the Actions panel.

Click the Options menu, and then
click Batch. 

Select from the following Play
options:

◆ Click the Set list arrow, and
then select the Set containing
the Action you want to apply to
the images.

◆ Click the Action list arrow, and
then select the correct Action.

Click the Source list arrow, and
then select an image source from
the following: Folder or Data Sets.
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Click Choose (available if Folder is
selected as the source), and then
select the location of the image
folder.

Select the check boxes for any
options you want:

◆ Override Action “Open”
Commands. Select to use an
open command embedded into
the Action.

◆ Include All Subdirectories.
Select to batch process any
images located in folders
embedded in the main image
folder.

Click the Destination list arrow,
and then click None, Save and
Close, or Folder.

Specify options for the Save or
Export commands:

◆ Click Choose (available if Folder
is selected as the source), and
then select the destination of
the modified images.

◆ Select the Override Action
“Save” Commands or Override
Action “Export” Commands
check box to use a save or
export command embedded
into the Action.

◆ Select File Name options to
create sequential files name in
a batch sequence.

Click the Errors list arrow, select
an errors option, and then click
Save As to save your error
information, if necessary.

Click OK.12
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Things to Remember About Batch File Processing
There are many settings and requirements in order to make your
batch file processing a success. Remember that before you begin,
you need to have a created action. After your action is created, and
all the kinks are worked out, you can then set up your batch file pro-
cessing. Knowing ahead of time where the source images are,
where you'll be storing them (destination), having a naming conven-
tion, and other similar details will help reduce your setup of the
batch file processing to a few easy steps.

For Your Information
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A script is a series of commands that instructs Illustrator to perform a
set of specified actions. These actions can be simple, affecting only a
single object, or more complex, affecting many objects. The actions
can call not only Illustrator, but also invoke other applications. Scripts
are useful for repetitive tasks and can be used as a creative tool to
streamline tasks that are time consuming and boring. A scripting lan-
guage lets you ask a question (an event), and use the answer to that
question to perform any commands (an action) that are available in
Illustrator. You can use one of Illustrator’s built-in scripts, such as
ExportDocsAsFlash, ImageTracing (New!), or SaveDocsAs PDF, or cre-
ate one of your own. To create your own scripts you need a working
knowledge of a scripting language like JavaScript, and either a script-
editing application or a simple text editor, such as Notepad (Win),
TextEdit (Mac) BBEdit or even Microsoft Word. The languages you can
use to perform scripting are varied and include Visual Basic,
AppleScript, and JavaScript, to name a few. As a matter of fact, the
Scripts Events Manager lets you set JavaScript and Illustrator Actions
to run automatically when a specified Illustrator event occurs.

Opening and Using
Scripts

Use Built-in Scripts

Click the File menu, and then point
to Scripts.

Select one of the following built-in
scripts:

◆ ExportDocsAsFlash.

◆ Flex Skins. Then select Create
Flex 3 Skin or Export Flex 3
Skin.

◆ ImageTracing. (New!) 

◆ SaveDocsAsPDF.

◆ SaveDocsAsSVG.
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Open and Use Enhanced
Scripting

Open a text editor, and then create
a script using any approved
scripting language.

Save the document with the
correct extension, for example,
ActiveLayer.js for JavaScript.

To access the script in Illustrator,
click the File menu, point to
Scripts, and then click Other
Script.

TIMESAVER Press Ctrl+F12
(Win) or A+F12 (Mac).

Navigate to the folder or drive
where your script file is located.

Click the script that you want to
run.

Click Open to run the script.

Your script appears in a browser
window.
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Sample script
folders
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When you work with objects in Illustrator, you can define variables to
drive them in a template document. Data-driven objects make it possi-
ble to create multiple versions of an object quickly and precisely. For
example, you need to produce several web banners using the same
template. Instead of creating each banner, one at a time, you can use
data-driven graphics to generate web banners using variables and data
sets. Any artwork can be converted into a template for data-driven
graphics by defining variables for objects in the image. A data set is a
collection of variables and associated data. You can switch between
data sets to upload different data into your template. You can work with
variables and data sets in the Variables panel. The left column displays
the variable name and the right column displays the bound object name
as shown in the Layers panel. There are four types of variables: Graph
Data, Linked File, Text String, and Visibility.

Defining and Editing
Data Variables      

Create Data Variables

Select the Variables panel. 

Select from the available options: 

◆ Variable. Click the New
Variable button. To bind it to an
object, select the object and
variable, and then click the
Make Object Dynamic or Make
Visibility Dynamic button.

◆ Graph Data. Select the graph
object, and then click the Make
Object Dynamic button.

◆ Linked File. Select the linked
file, and then click the Make
Object Dynamic button.

◆ Text String. Select the text
object, and then click the Make
Object Dynamic button.  

◆ Visibility. Select the object that
you want to show or hide, and
then click the Make Visibility
Dynamic button. 

To delete a variable, select it, click
the Delete Variable button, and
then click Yes or No for all
occurrences.
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Create a Data Set

Select the Variables panel. 

Display the variables that you want
in the data set.

Click the Capture Data Set button
on the panel to create a data set.

Edit the objects associated with
the variables on the artboard.

Image visibility, the text in a type
layer, or exchanging one image for
another, can now be controlled
through changing variables.

Click the Capture Data Set button
on the panel to create another
data set.

Repeat Steps 4 and 5 for each
variable in the template. 

To switch between data sets, click
the Data Set list arrow, and then
select a data set.

To apply the data on the artboard
to the current data set, click the
Options menu, and then click
Update Data Set.

8

7

6

5

4

3

2

1

Did You Know?
You can delete a data set. Select the
Variables panel, click the Data Set list
arrow, select the data set that you
want to delete, click the Options menu,
and then click Delete Data Set.

You can rename a data set. Select the
Variables panel, click the Data Set list
arrow, select the data set that you
want to rename, select the name in the
Data Set box, type a name, and then
press Enter (Win) or Return (Mac).
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Text variable changes
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A graph allows you to display data in a visual way. With Illustrator, you
can create nine different graphs: Column, Stacked Column, Bar,
Stacked Bar, Line, Area, Scatter, Pie, and Radar. After you select the
type of graph you want to create, you draw the size of the graph you
want, and then enter data in the Graph Data window. To edit and modify
a graph, select the graph object, and use commands on the Graph sub-
menu on the Object menu. After you create a graph, you can format it.
You can change the appearance and position of the graph’s axes, add
drop shadows, move the legend, and combine different types. For a
more customized look, you can change colors, shading, typeface, and
apply transparency, gradient, blends, brush strokes, and graphic styles.

Creating and Formatting
a Data Graph

Create a Data Graph

Select a graph tool on the Tools
panel.

Drag to create a data graphic the
size that you want. Alt+drag (Win) or
Option+drag (Mac) to draw from the
center.

Enter data labels in the first row and
column for the graph in the Graph
Data window. Press Enter (Win) or
Return (Mac) to add the text.

Enter data for the graph in the
Graph Data window. Press Enter
(Win) or Return (Mac) to add the
data.

Click the Apply button to display
your data changes in the graph on
the artboard.

When you’re done, click the Close
button in the Graph Data window.

To edit and modify graphs, select
the graph object, click the Object
menu, point to Graph, and then
select a graph command: Type,
Data, Design, Column, or Marker.
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Format a Data Graph

Select the Selection tool on the
Tools panel.

Select the graph.

Click the Object menu, point to
Graph, and then click Type. 

TIMESAVER Double-click the
Graph tool on the Tools panel.

Do any of the following to format
the data graph: 

◆ Type. Click a type button.

◆ Value Axis. Places axis values
on the left, right, or both sides. 

◆ Add Drop Shadow. Applies a
drop arrow behind items.

◆ Add Legend Across Top.
Displays the legend
horizontally. 

◆ First Row In Front. Controls the
overlap of graph data.

◆ First Column In Front. Places
the column of data on top.

Select the graph specific options
you want; the options vary
depending on the graph type. For
line graphs, select check boxes to
Mark Data Points, Connect Data
Points, and Draw Filled Lines.

Click OK.

To select parts of a graph, click
the Group Selection tool on the
Tools panel, and then click the
graph part. To select a group of
parts, click the graph part again.

To change the color, stroke, style,
or opacity, select the graph part,
and then use the options on the
Control panel.

◆ To combine graph types, select
the graph data part, double-
click the Graph tool, select a
type, and then click OK.
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You can use graph designs to add graphics or symbols to columns or
markers in a graph. You can create your own graph designs using a
graphic or symbol, or use one of the sample swatch libraries provided
by Illustrator (in the Adobe/Adobe Illustrator CS6/Cool Extras/Sample
Files/Graphics Designs). After you create a graph and select a column
or marker (line or scatter type), you can add a graph design to it. 

Adding Graph Designs
to a Graph

Add a Graph Design to a Graph

Select the Group Selection tool on
the Tools panel.

Select the column or marker in the
graph you want to replace.

Click the Object menu, point to
Graph, and then click Column or
Marker.

Select the design you want to use.

For a column design, select any of
the following:

◆ Column Type. Select a column
type: Vertically Scaled,
Uniformly Scaled, Repeating, or
Sliding (scale bottom, not top).

◆ Rotate Legend Design. Rotate
the design in the legend. 

◆ Each Design Represents. The
number of units per design
(Repeating type).

◆ For Fractions. Chop or scale a
partial design (Repeating type). 

Click OK.6
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Did You Know?
You can create a column or marker
design. Create the design using any of
the drawing tools. Select the design
with the Selection tool. Click the Object
menu, point to Graph, click Design,
click New Design, click Rename, type a
name, click OK, and then click OK.
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While you work on revision after revision of a document, it may contain
stray anchor points, empty text objects or unpainted objects that may
cause problems later. Stray anchor points can sometimes cause files to
export with unexpected size boundaries. A stray point is a single
anchor point with no path. Empty text objects may contain references
to fonts that may not be available when you send source files to pre-
press. Unpainted objects, those without a fill nor a stroke, may cause
overlapping objects to display or print incorrectly. With the Clean Up
command, you can have Illustrator automatically remove unneeded ele-
ments from your document. 

Cleaning Up Unneeded
Elements

Clean Up Unneeded Elements

Click th Object menu, point to
Path, and then click Clean Up.

Select any of the following:

◆ Stray Points. Select to remove
stray points, those with a single
anchor point with no path.

◆ Unpainted Objects. Select to
remove unpainted objects,
those without a fill nor stroke. 

◆ Empty Text Paths. Select to
remove empty text objects. 

Click OK.3
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Proofing and Printing
Documents

Introduction

The Print command is probably the most used of all
Illustrator's print options. The Print command is a portal to
other menus that let you control specific printing functions,
such as crop marks and bleeds, output ink, graphics, and
color management. Color separations divide artwork into
four plates by color, known as process colors. Each plate rep-
resents a CMYK (Cyan, Magenta, Yellow, and Black) color. The
Separations Preview panel allows you to preview color sepa-
rations on your screen. You can preview spot color objects
and check for rich black areas and overprinting. If you fre-
quently use custom settings to send an Illustrator document
to a local printer or commercial printer for printing, you can
save time by creating a preset. Before you print your docu-
ment, it’s important to check the Summary category in the
Print dialog box. The summary information is good to have if
you’re having problems printing your job at a commercial
printer. 

When you save a document, you have the ability to save
more than just Illustrator information. You can save copy-
right, camera, and even image category information. This
data is saved with the file as metadata in the XMP format
(Extensible Metadata Platform) in Illustrator files, and can be
recognized and accessed by any application, such as Adobe
Bridge, that reads XMP metadata. The Document Info panel
allows you to view information about a selected object or the
entire document. You can display information about graphic
styles, brushes, spot colors, patterns, gradients, fonts, linked
images, and embedded images by using the Options menu. 14

14
What You’ll Do

Use Spell Check

Use the Custom Dictionary

Find and Replace Text and Elements

Find and Change Fonts

Print a Document

Print with Presets

Set General Print Options

Set Marks and Bleed Options

Set Graphics Options

Preview Color Separations

Set Output Options

Set Advanced Options

Set Color Management Options

Check for Print Problems

Insert File Information

Use the Document Info Panel
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There's nothing more embarrassing than creating a document that con-
tains misspelled words. Although you wouldn't use Illustrator if all you
needed to do was create a text document, Illustrator includes a fully
functional spell checking system, which at least lets you make sure all
of your words are spelled correctly. 

Using Spell Check 

Use Spell Check

Open a document that contains
one or more Type objects. 

Click the Edit menu, and then click
Check Spelling.

Click Start.

When Illustrator encounters a
word not in its dictionary, it
displays that word in the Word Not
Found box, and allows you to
choose one of the following
options:

◆ Ignore. Ignore this word one
time.

◆ Ignore All. Ignore all instances
of this word.

◆ Change. Change the word,
based on the selected
suggestion.

◆ Change All. Change all
occurrences of the word,
based on the selected
suggestion.

◆ Add. Add the word to
Illustrator's dictionary.

Illustrator continues to highlight
misspelled words until the
document is completely scanned.

To specify additional find and
ignore options, click the Options
arrow.

When you’re finished, click Done.6
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Highlighted word identified by spell checker.
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Illustrator comes with a custom dictionary for the spell checker. If you
need to manage dictionary content, you can use the Edit Custom
Dictionary dialog box to add, delete, or edit words. The ability to edit
the dictionary becomes useful when you accidentally enter a word that
you don’t want in the dictionary, or you have some specialty words that
you want to enter in all at once.

Using Custom
Dictionaries

Use a Custom Dictionary

Click the Edit menu, and then click
Edit Custom Dictionary.

Do any of the following:

◆ Add an Entry. Enter an entry,
and then click Add.

◆ Delete an Entry. Select an
entry, and then click Delete.

◆ Change an Entry. Select an
entry, edit it, and then click
Change.

When you’re finished, click Done.3
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Finding and Replacing
Text and Elements

Use Find and Replace 

Click the Edit menu, and then click
Find and Replace.

Enter the text to locate in the Find
box.

Select from the following Find and
Replace options:

◆ Match Case. Select to search
for the word in the same case
as typed in the Find box.

◆ Find Whole Word. Select to
search for whole words as
typed in the Find box.

◆ Check Hidden Layers. Select to
search hidden layers.

◆ Check Locked Layers. Select to
search locked layers.

◆ Search Backwards. Select to
search in the reverse direction.

Enter the replacement text in the
Replace With box.

Click Find Next to locate the next
occurrence of the word:

◆ Click Replace to change the
word.

◆ Click Replace & Find to auto-
matically change the word and
locate the next occurrence.

◆ Click Replace All to change all
occurrences of the word.

When you’re finished, click Done.6
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In the editing process, it is sometimes helpful to find and replace a par-
ticular word or phrase because the text needs to be changed, either in
one spot or globally throughout the document. The Find and Replace
command makes it easy to locate and replace specific text in a docu-
ment. In addition to text, you can also find and replace other elements,
such as a bullet character, tab character, Em Space, and quotation
marks.

Replaced word
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Use Find and Replace Elements

Click the Edit menu, and then click
Find and Replace.

Click the Arrow button next to the
Find box, and then select the
element type that you want to find.

The special characters are added
to the Find box. You can also add
text.

Select from the following Find and
Replace options:

◆ Match Case. Select to search
for the word in the same case
as typed in the Find box.

◆ Find Whole Word. Select to
search for whole words as
typed in the Find box.

◆ Check Hidden Layers. Select to
search hidden layers.

◆ Check Locked Layers. Select to
search locked layers.

◆ Search Backwards. Select to
search in the reverse direction.

Click the Arrow button next to the
Replace With box, and then select
the element type that you want to
use for replacement.

The special characters are added
to the Replace With box. You can
also add text.

Click Find Next to locate the next
occurrence of the element:

◆ Click Replace to change the
element.

◆ Click Replace & Find to auto-
matically change the element
and locate the next
occurrence.

◆ Click Replace All to change all
occurrences of the element.

When you’re finished, click Done.6
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Find and replace elements
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Finding and Changing
Fonts

Find or Change a Font

Click the Type menu, and then
click Find Font.

The fonts in the top list are the
ones currently used in your
document. The list at the bottom
displays fonts in your document or
on your computer, depending on
your setting.

To find a specific font, select it in
the top list.

Select the check boxes at the
bottom to specify the font
attributes that you want to find.

To replace the font in the top list,
select a font in the bottom list.
Click the Replace With Font From
list arrow, and then click System to
show all the fonts on your
computer.

Click Find to display the first
instance of the font, and then click
Change to replace it, or click
Change All to replace all uses of
the font in your document.

When you’re done, click Done.6
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Say you create some artwork using a certain font. After the customer
or client reviews, they ask you to change it. Instead of manually chang-
ing each use of the font, you can use the Find Font command to quickly
find and change every instance of the font in your document. If you’re
not sure what fonts are used in your document, the Find Font dialog box
gives you a list. If there are paragraphs with inconsistent use of capi-
talization in your document, you can also use change case options to
fix them.
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Change Case

Select the type for which you want
to change case.

Click the Type menu, and then
point to Change Case.

Select one of the following:

◆ UPPERCASE.

◆ lowercase.

◆ Title Case.

◆ Sentence case.

3
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Printing a Document

Print a Document

Click the File menu, point to
Document Color Mode, and then
click CMYK Color or RGB Color. 

◆ Check your printer for the best
color mode setting.

Click the File menu, and then click
Print.

Click the Print Preset list arrow,
and then select a preset.

Click the Printer list arrow, and
then select an available printer.

Click the PPD list arrow, and then
select a PPD (if available).

◆ A PPD (PostScript Printer
Description) is a printer driver,
a specific file used by
commercial and specialty
printers to define an output
device.

Select a print category (General,
Marks and Bleed, Output,
Graphics, Color Management,
Advanced) with your desired
settings.

Select the options that you want;
see other pages in this chapter for
option specifics.

Use the navigation buttons to view
preview pages. Drag artwork in
the preview to move it around.

When you’re finished, click Print.9
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The Print command is probably the most used of all Illustrator's print
options. The Print command is a portal to other menus that let you con-
trol specific printing functions, such as crop marks and bleeds, output
ink, graphics, and color management. Understand that the options
available for the Print command will be partially determined by your
default printer. For example, if your default printer uses more than one
paper tray, you will see options for selecting a specific tray for the cur-
rent print job. In spite of the differences, there are some universal
options for all print jobs, and these are covered here. 
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Printing with Presets

Create a Preset for Printing

Click the Edit menu, and then click
Print Presets.

Perform any of the following:

◆ New. Click the New button,
specify the options that you
want, and then click OK.

◆ Edit. Select a custom preset
(not a predefined one), click the
Edit button, change the options,
and then click OK.

◆ Delete. Select a custom preset
(not a predefined one), and
then click the Delete button.

◆ Import. Click Import, navigate to
the preset file, select it, and
then click Open.

◆ Export. Select a preset, click
Export, specify a location and
name, and then click Save.

Click OK.3

2

1

If you frequently use custom settings to send an Illustrator document to
a local printer or commercial printer for printing, you can save time by
creating a preset. Adobe Creative Suite programs, including Illustrator,
InDesign, Photoshop, and Acrobat, provides built-in presets that you
can use in any of the programs. When you create your own preset, you
can also use it in other CS programs. 

2
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Setting General Print
Options

Set General Print Options

Click the File menu, and then click
Print.

Click the General category.

Select from the various General
and Media options:

◆ Copies. Enter the number of
copies you want to print.

◆ Collate. Select to print artboard
pages in collated order.

◆ All or Range. Select an option
to print all or a range of
artboard pages.

◆ Reverse Order. Select to print
artboard pages in reverse
order.

◆ Ignore Artboards. Select to
print artwork from all artboards
on a single page.

◆ Skip Blank Artboards. Select to
not print blank artboard pages.

◆ Size. Select a page size.

◆ Transverse. Select to rotate the
printed artwork 90 degrees.

This option is only available
when your PPD supports it.

◆ Width and Height. For a custom
page size, specify a width and
height.

◆ Auto-Rotate. Select to auto-
matically rotate artboards to
print to the media size.
(Selected by default)

3

2

1

The General category in the Print dialog box allows you to set the page
size and orientation (Portrait Up, Portrait Down, Landscape Left,
Landscape Right), number of artboards to print, and artboard scale and
tiling options. You can also ignore and skip blank artboards for printing.
In addition, you can specify which layers you want to print: Visible &
Printable Layers, Visible Layers, or All Layers.  

3
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◆ Orientation. Click an icon to
select a page orientation.

Select from the various options:

◆ Print Layers. Select an option
to print layers: Visible &
Printable Layers, Visible Layers,
or All Layers.

◆ Placement. Click a square on
the Placement icon to select an
origin for aligning artwork to
the page.

◆ Scaling. Click the list arrow,
and then select an option:

◆ Do Not Scale. Select to not
scale artboards during
printing.

◆ Custom. Select to specify a
custom width and height for
artboards during printing.

◆ Fit to Page. Select to scale
artboards to the page during
printing.

◆ Tile Full Pages or Tile
Imageable Areas. Select to
tile artwork on multiple
pages. 

When you’re finished, click Done.5

4

Did You Know?
You can show and hide print tiling in
the document window to preview
pages. Click the View menu, and then
click Show Print Tiling or Hide Print
Tiling. 

4
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Setting Marks and
Bleed Options

Set Marks and Bleed Print
Options

Click the File menu, and then click
Print.

Click the Marks and Bleed
category.

Select from the various Marks
options:

◆ All Printer's Marks. Select to
enable the following check
boxes: Trim Marks, Registration
Marks, Color Bars, and Page
Information.

◆ Trim Marks. Select to add trim
lines for cutting the page. 

◆ Registration Marks. Select to
add small targets for aligning
color separations.

◆ Color Bars. Select to add small
color squares with color
information for the printer.

◆ Page Information. Select to add
labels with document
information: name, artboard
number, time and date, plate
color, and screen angle.

◆ Printer Mark Type. Select a
type: Roman or Japanese.

◆ Trim Mark Weight. Specify a
thickness for the trim marks.

3

2

1

The Marks and Bleed category in the Print dialog box allows you to
select printer’s marks and create a bleed. Printer marks appear at the
edge of the printable page. Commercial printers use printer marks to
trim the paper, registration marks to align printing plates, and color bars
to print colors properly. Bleed is the amount of artwork that appears
outside of the printing area, which includes the bounding box and trim
marks. Bleed is useful as a margin of error. It makes sure that ink is
printed to the edge of the page so that there are no gaps between the
artwork and the edge of the trimmed document page. Your commercial
printer can advise you on bleed settings based on your print job.  

2
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◆ Offset. Specify an offset value
(0-72 points) for the distance
between trim marks and the
bounding box.

Enter an offset value to make
sure that any printer’s marks
will not be overlapped by the
bleed.

Select from the various Bleeds
options:

◆ Use Document Bleed Settings.
Select to use bleed settings
defined in the New Document
dialog box.

◆ Top, Left, Bottom, and Right.
Enter values to define the bleed
area.

Your commercial printer can
advise you on bleed settings
based on your print job.  

When you’re finished, click Done.5

4
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Setting Graphics 
Options

Set Graphics Print Options

Click the File menu, and then click
Print.

Click the Graphics category.

Select from the various Graphics
options:

◆ Flatness (Paths). Select the
Automatic check box to use a
setting supplied by Illustrator.

If you have problems printing a
document, adjust the Flatness
level, and then reprint it.

◆ Download (Fonts). Select a
download option: None, Subset
(only characters, or glyphs,
used), or Complete (all fonts
used).

◆ PostScript (Options). Choose
from Language Level 2 or
Language Level 3. Level 3
delivers the best speed and
quality if you are printing to a
PostScript 3 device.

◆ Data Format (Options). Choose
ASCII or Binary to determine
how the data is sent to the
printer.

◆ Compatible Gradient and
Gradient Mesh Printing. Select
only if you're having problems
printing gradients or gradient
meshes.

When you’re finished, click Done.4

3

2

1

The Graphics category in the Print dialog box allows you to set printing
options for paths, fonts, PostScript files, gradients, meshes, and blends.
The Flatness option (under Paths) controls how well objects in your
document print on a PostScript printer. The Automatic setting is recom-
mended. If a document has problems printing, adjust the Flatness level.
When you include type in your document, the fonts that you use in your
document need to be downloaded to your printer. 
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Previewing Color
Separations

Preview Color Separations with
the Separations Preview Panel

Open a document that contains
the artwork that you want to
preview.

Select the Separations Preview
panel.

Select the Overprint Preview
check box.

Do any of the following:

◆ Hide Separation Ink. Click the
eye icon for each ink you want
to hide. Click the eye icon again
to make the effects of the ink
visible.

◆ Hide All Separation Inks
Except One. Alt+click (Win) or
Option+click (Mac) the eye icon
to show just one ink color. Click
the eye icon again to make all
the inks visible.

◆ View All Inks. Click the CMYK
eye icon.

Deselect the Overprint Preview
check box to return to normal
view.

5

4

3

2

1

Color separations divide artwork into four plates by color, known as
process colors. Each plate represents a CMYK (Cyan, Magenta, Yellow,
and Black) color. The Separations Preview panel allows you to preview
color separations on your screen. You can preview spot color objects
and check for rich black areas and overprinting. Rich black is process
black ink mixed with color inks for increased opacity and richer color
instead of a normal black, while overprinting prevents the knockout of
overlapping areas and makes those areas transparent. This is used to
avoid the need for trapping and to avoid gaps between touching colors.
Use it when your artwork doesn’t share common ink color. In the
Separations Preview panel, you can use the Visibility column to show
and hide different separation color inks to preview your artwork on the
artboard.

23
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Setting Output 
Options

Set Output Print Options

Click the File menu, and then click
Print.

Click the Output category.

Check with your commercial
printer for help with specific
values for your print job.

Select from the various Output
options:

◆ Mode. Select an output mode:
Composite, Separations (Host-
Based), or In-RIP Separations.

Use Composite to print a
general print job (not
separations); use Separations
(Host-Based) to have Illustrator
create the separations; or use
In-RIP Separations to have
Illustrator create a PostScript
file that creates the
separations.

◆ Emulsion. Select an option: Up
(Right Reading) or Down (Right
Reading).

◆ Image. Select an option:
Positive or Negative.

◆ Resolution. Select a printer
resolution. The first number
represents the halftone screen
ruling (LPI) and the second
number represents the device
resolution (DPI).

Check with your commercial
printer for these settings.

3

2

1

The Output category in the Print dialog box allows you to create and
print color separations. When you choose to create color separations,
you also have the option of selecting which color plates that you want
to print. Since options vary from job to job, check with your commercial
printer for help with specific values for your print job. Some of the
options include Mode (composite or separation), Emulsion, Image, and
Resolution.
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If you selected a Separation option
from the Mode menu, select from
the various Document Ink options:

◆ Document Inks. For each
process or spot color that you
don’t want to print, click the
printer icon.

◆ Convert All Spot Colors to
Process. Select to convert all
spot colors in the artwork to
process colors.

◆ Overprint Black. Select to
allow black fills and strokes to
overprint color underneath.

When you’re finished, click Done.5

4
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Setting Advanced
Options

Set Advanced Print Options

Click the File menu, and then click
Print.

Click the Advanced category.

Select from the various Advanced
options:

◆ Print as Bitmap. Select if you
have problems printing vector
objects to a non-PostScript
printer.

◆ Overprints. Select an overprint
option: 

Preserve. Use to keep the file’s
overprint settings.

Discard. Use to discard the
file’s overprint settings.

Simulate. Use to simulate
overprinting for proofing
purposes.

◆ Preset. Select a resolution
option:

High Resolution. Use for high-
quality color separations.

Medium Resolution. Use for
desktop PostScript printing. 

Low Resolution. Use for black
and white printing.

For Complex Art. Use for
printing art with a lot of shape
and line paths (New!).

Custom. Click to select custom
settings.

When you’re finished, click Done.4

3

2

1

The Advanced category in the Print dialog box allows you to set options
or use presets (New!) for the overprinting and transparency flattening
of vector artwork when you print. You can set overprint options for fills
and strokes for color composite or separations printing. You can use
the Flattener Preview panel to highlight the areas affected by flattening
artwork. If you have problems printing vector objects to a non-
PostScript printer, select the Print as Bitmap option to convert vector
objects to bitmap raster images for print purposes.
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Preview Flattened Artwork

Click the Window menu, and then
click Flattener Preview.

Click the Highlight list arrow, and
then select a highlight option.

Options vary depending on the
content of the artwork.

To display a fresh preview based
on your current settings, click
Refresh.

Create a Preset for Transparency
Flattener

Click the Edit menu, and then click
Transparency Flattener Presets.

Perform any of the following:

◆ New. Click the New button,
specify the options that you
want, and then click OK.

◆ Edit. Select a custom preset
(not a predefined one), click the
Edit button, change the options,
and then click OK.

◆ Delete. Select a custom preset
(not a predefined one), and
then click the Delete button.

◆ Import. Click Import, navigate to
the preset file, select it, and
then click Open.

◆ Export. Select a preset, click
Export, specify a location and
name, and then click Save.

Click OK.3

2

1

3

2

1

2
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Setting Color
Management Options

Set Color Management Print
Options

Click the File menu, and then click
Print.

Click the Color Management
category.

Select from the various Color
Management options:

◆ Color Handling. Select a color
option: Let Illustrator determine
colors or Let PostScript printer
determine colors.

◆ Printer Profile. Select the
profile for your output device.

◆ Rendering Intent. Select an
option to specify how the
program converts colors to the
destination color space.

◆ Preserve CMYK Numbers.
Select to preserve the CMYK
color mode when a color profile
is not available. Deselect to
have Illustrator convert colors
for use on the output device.

When you’re finished, click Done.4

3

2

1

The Color Management category in the Print dialog box allows you to
select a printer profile and rendering intent for printing. Rendering
intent specifies how the program converts colors to the destination
color space. In most cases, it’s best to use the default options for Color
Management unless you’ve been given specific instructions from a
commercial printer to change them. 
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Checking for Print
Problems

View Summary Print Options

Click the File menu, and then click
Print.

Click the Summary category.

Scroll through the print summary
to review your print settings.

Check the Warnings box for
problems or warning that you
should fix before you print.

To print the summary information
to a file, click Save Summary,
enter a name, specify a location,
and then click Save.

When you’re finished, click Done.6

5

4
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2

1

Before you print your document, it’s important to check the Summary
category in the Print dialog box. The summary information is good to
have if you’re having problems printing your job at a commercial
printer. You can save the information and send it to the printer to help
diagnose the problem. The important area is the Warnings box, which
displays warnings about printing problems with your document. Check
to make sure your print job is clear of all warnings before you send it to
a printer. 
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When you save a document, you have the ability to save more than just
Illustrator information. You can save copyright, camera, and even image
category information. This data is saved with the file as metadata in the
XMP format (Extensible Metadata Platform) in Illustrator files, and can
be recognized and accessed by any application, such as Adobe Bridge,
that reads XMP metadata. In addition, if an image is a photograph, you
can save data specifying the type of image, where it was shot, or the
camera used. You can even get information on shutter speed and f-stop.
You can do the same with video and audio data, too. That information
will not only protect your intellectual property, but will supply you with
vital statistics on exactly how you created that one-of-a-kind artwork. 

Inserting File
Information 

Insert File Information into 
a Document

Open a document.

Click the File menu, and then click
File Info.

Click the Description tab, and then
enter information concerning the
document title, description of file,
author, and copyright information.

Click the IPTC and IPTC Extension
tabs to enter information
concerning the image's creator,
description and keywords, location
where photograph was taken, date
created, copyright, and usage
terms. 

Click the Camera Data tab, which
reveals information about the
camera that took the image. 

Click the GPS Data tab, which
reveals Exif information about the
camera and subject location. 

Click the Video Data tab or Audio
Data tab to reveal information
about video and audio data, and
then enter your video and audio
data.

7

6

5
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Click the Mobile SWF tab, and
then enter the file information for
a mobile SWF document.

Click the Categories tab, and then
enter category keywords for
search purposes.

Click the Origin tab, and then
enter data pertaining to the origin
of the image. 

Click the DICOM tab, and then
enter data pertaining to the Digital
Imaging and Communications in
Medicine options (patient name,
ID, etc.).

Click the History tab to view
historical information about the
active document, such as dates
last opened and saved, and a list
of image adjustments.

Click the Advanced tab to view 
additional information on the 
active document, such as EXIF,
and PDF document properties. 

Click OK.14

13

12

11

10

9

8

Did You Know?
You can add metadata to files saved in
the PSD, PDF, EPS, PNG, GIF, JPEG,
and TIFF formats. The information is
embedded in the file using XMP
(Extensible Metadata Platform). This
allows metadata to be exchanged
between Adobe applications and
across operating systems. 

You can use the XMP Software
Development Kit to customize the 
creation, processing, and interchange
of metadata. You can also use the XMP
kit to add fields to the File Info dialog
box. For information on XMP and the
XMP SDK, check the Adobe Solutions
Network.
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The Document Info panel allows you to view information about a
selected object or the entire document. You can display information
about graphic styles, brushes, spot colors, patterns, gradients, fonts,
linked images, and embedded images by using the Options menu. If you
want to use the provided information in another document, you can
also save the data as a text file.

Using the Document
Info Panel

Use the Document Info Panel

Select the object that you want to
review information about.

Select the Document Info panel.

Click the Options menu, and then
select any of the following:

◆ Selection Only. Select for info
on the current selection.
Deselect for all objects.

◆ Document.

◆ Objects.

◆ Graphic Styles.

◆ Brushes.

◆ Spot Color Objects.

◆ Pattern Objects.

◆ Gradient Objects.

◆ Fonts.

◆ Linked Images.

◆ Embedded Images.

◆ Font Details.

To save the information to a text
file, click the Options menu, click
Save, enter a name for the file,
specify a location, and then click
Save. 
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Exporting a Document

Introduction

After you finish creating your document in Illustrator, you can
save or export your artwork in another file format for use in
other programs. There are five file formats to which you can
save your artwork, which include AI (Adobe Illustrator),
Adobe PDF (Portable Document Format), EPS (Encapsulated
PostScript), FXG (Adobe Flex/Flash Builder), and SVG
(Scalable Vector Graphics). These file formats are native to
Illustrator, which means they preserve Illustrator content,
including multiple artboards, when you re-open them. 

If you want to save your artwork in another file format,
you need to export it. Illustrator allows you to export your
artwork in 13 different file formats, including Flash,
Photoshop, Bitmap, JPEG, and PNG. When you export from
Illustrator, your content is altered using the Options dialog
box for the specific file format. If you want to use an
Illustrator document in a Microsoft Office program, you need
to save the document as a PNG (Portable Network Graphics)
image with the Save for Microsoft Office command. 

If you frequently create the same kind of document, then
you should create a template. A template is a special docu-
ment that makes it easier to reuse frequently used material in
order to create a new document. An Illustrator Template file
uses the (AIT) file format instead of the normal (AI) document
file format. 15

15
What You’ll Do

Export a Document

Understand Export File Formats

Export as a Bitmap

Export as a TIFF

Export as a PNG or JPEG

Export to Photoshop

Export with Presets

Export as a Flash Movie

Save as Adobe PDF

Save as an EPS

Save as SVG

Save for HTML5 and CSS

Save as Adobe FXG

Save for Microsoft Office

Save as a Template
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Exporting a Document

Export a Document

Click the File menu, and then click
Export.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then select a file format.

See the list on the next page for
more information about all the file
formats.

Navigate to the location where
you want to save the document. 

To preserve artboards, select the
Use Artboards check box (if
available), and then select the All
or Range option. If you selected
the Range option, enter a range.

Click Save.

For some formats, an Options
dialog box appears, prompting you
for additional settings.

If prompted, specify the options
that you want, and then click OK.

◆ For help, point to an option to
display a description at the
bottom of the Options dialog
box. 

7
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5

4

3

2

1

After you finish creating your document in Illustrator, you can export it
for use in other programs. If you have a document with text, you can
export it to a text document, which you can open in a word processing
program. If you have a document with artwork, you can export it as a
PSD file (for use in Photoshop) or a JPEG file (for use on the web). See
the list on the next page for more information about all the file formats.
If you have multiple artboards in a document, many file formats pre-
serve them or create multiple page documents during export.

2
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5

6

Export file formats
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Understanding Export File Formats

Format Usage

BMP Uses the BMP (Bitmap) format. This is the standard image format on the Windows 
platform.

Targa Uses the Targa format for high-end image editing on the Windows platform.

PNG Uses the PNG (Portable Network Graphics) format. This format is used for saving images 
to the Web; it supports up to 16 million colors and 256 levels of transparency. 

AutoCAD Drawing Uses the DWG format. This format creates a file used for 2- and 3-dimensional design 
data.

AutoCAD Interchange Uses the DXF (Drawing Interchange Format, or Drawing Exchange Format) format. This 
File format creates a CAD (Computer Aided-Design) data file.

Enhanced Metafile Uses the EMF format. This drawing format (32-bit) uses metafile commands to create 
simple artwork.

Flash Uses the SWF movie format. This format creates a movie for use on the Web using 
the Flash player. 

JPEG Uses the JPG or JPEG (Joint Photographic Experts Group) format. This format uses a
compression method to reduce the size of image files primarily for the Web.

Macintosh PICT Uses the PICT or PICT Resource format. This is the standard image format on the 
Macintosh platform.

Photoshop Uses the PSD  (Photoshop) format, which saves layers, channels, notes, and color 
profiles.

TIFF Uses the TIFF (Tagged-Image File Format) format. These files can be opened by almost 
any image-editing or layout program. TIFF is a common format for printing and saving 
flattened images without losing quality.

Text Format Uses the TXT format. This format creates a plain text document.

Windows Metafile Uses the WMF format. This drawing format (16-bit) uses metafile commands to create 
simple artwork.

Export File Formats
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Exporting as a Bitmap

Export a Document as a Bitmap

Click the File menu, and then click
Export.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click BMP (*.BMP).

Navigate to the location where
you want to save the document. 

Click Save.

Specify the following options:

◆ Color Model. Select a color
mode: RGB, Grayscale, or
Bitmap.

◆ Resolution. Select a resolution
option in ppi (pixels per inch).

◆ Anti-aliasing. Select to smooth
out the edges of text or
artwork.

Click OK.7
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A bitmap document (BMP) is a raster image, which means it’s made up
of individual pixels. Since an Illustrator document is made up of vector
data, the artwork in the document is converted from mathematical cal-
culations to individual pixels. During the export process, you can spec-
ify a color mode for the pixels, resolution size (the number of pixels per
inch), and whether you want to smooth out the edges with anti-aliasing
for either text or artwork.

4
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5

See Also
See “Anti-aliasing Type” on page 245
for more information on setting a text
box to anti-alias text.
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Exporting as a TIFF

Export a Document as a TIFF

Click the File menu, and then click
Export.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click TIFF (*.TIF).

Navigate to the location where
you want to save the document. 

To preserve artboards, select the
Use Artboards check box (if
available), and then select the All
or Range option. If you selected
the Range option, enter a range.

Click Save.

Specify the following options:

◆ Color Model. Select a color
mode: RGB, CMYK, or
Grayscale.

◆ Resolution. Select a resolution
option in ppi (pixels per inch).

◆ Anti-aliasing. Select to smooth
out the edges of text or
artwork.

◆ LZW Compression. Select to
compress the image.

◆ Embed ICC Profile. Select to
attach the color profile of the
document to the image.

Click OK.8
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TIFF (Tagged-Image File Format) files can be opened by almost any
image-editing or layout program. TIFF is a common format for printing
and saving flattened images without losing quality. During the export,
you can specify a color mode for the pixels, resolution size (the number
of pixels per inch), and whether you want to smooth out the edges with
the Anti-alias option for text or artwork, compress the image with the
LZW compression method, and embed the color profile in the image. If
you have multiple artboards in a document, they are preserved.
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Exporting as a PNG 
or JPEG

Export a Document as a PNG

Click the File menu, and then click
Export.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click PNG (*.PNG).

Navigate to the location where
you want to save the document. 

To preserve artboards, select the
Use Artboards check box (if
available), and then select the All
or Range option. If you selected
the Range option, enter a range.

Click Save.

Specify the following options:

◆ Resolution. Select a resolution
option in ppi (pixels per inch).

◆ Anti-aliasing. Select to smooth
out the edges of text or
artwork.

◆ Interlaced. Select to load/
display the image from top to
bottom.

Click the Background Color list
arrow, and then specify an option:
Transparent, Black, White, or a
custom color.

Click OK.9
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If you have an image that you want to post on the web, you can export
it as a PNG (Portable Network Graphic) or JPEG (Joint Photographic
Experts Group) file. PNG and JPEG are a compressed format with rela-
tively high quality, so it’s a common file format for the web. The Export
command for PNG and JPEG give you options to specify image resolu-
tion and use anti-alias to smooth jagged edges for text and images. For
PNG, you can also set options to use a transparent background. For
JPEG, you can also set options to specify the color model, quality, and
compression as well as embed an ICC color profile.
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Export a Document as a JPEG

Click the File menu, and then click
Export.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click PNG (*.PNG).

Navigate to the location where
you want to save the document. 

To preserve artboards, select the
Use Artboards check box (if
available), and then select the All
or Range option. If you selected
the Range option, enter a range.

Click Save.

Specify the following options:

◆ Color Model. Select a color
mode: RGB, CMYK, or
Grayscale.

◆ Quality. Select a balance
between file size and quality.

Specify the following options:

◆ Compression Method. Select a
method: Standard (used by
most browsers), Optimized for
color and size, and Progressive
display for a series of scans.

◆ Resolution. Select a resolution
option in ppi (pixels per inch).

◆ Anti-aliasing. Select to smooth
out the edges of text or
artwork.

◆ Imagemap. Select to generate
code for image maps.

Select the Embed ICC Profile
check box to attach the color
profile of the document to the
image.

Click OK.10
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Exporting to
Photoshop

Export a Document as a
Photoshop File

Click the File menu, and then click
Export.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click Photoshop (*.PSD).

Navigate to the location where
you want to save the document. 

Click Save.

Click the Color Model list arrow,
and then select a color mode:
RGB, CMYK or Grayscale.

Click the Resolution list arrow, and
then select a resolution option.

Specify the following options:

◆ Flat Image. Select to flatten
image to one layer.

◆ Write Layers. Select to
preserve layers and maximum
editability for objects and text.

◆ Anti-aliasing. Select to smooth
out the edges of the image.

◆ Embed ICC Profile. Select to
attach the color profile of the
document to the image.

Click OK.9
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Adobe Photoshop is a graphics and image editing program. When you
export artwork to Photoshop, Illustrator converts objects into pixels and
preserves layers and transparency. Other conversions include remov-
ing strokes and effects from text and changing opacity masks to layer
masks. During the export process, you can specify a color mode for the
pixels, resolution size (the number of pixels per inch), and whether you
want to flatten or preserve layers, smooth out the edges with the Anti-
aliasing option, and embed the color profile in the image. In addition to
exporting, you can also copy and paste objects into Photoshop, which
automatically creates Smart Objects that you can re-edit in Illustrator.
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Exporting with Presets

Create a Preset for Adobe PDF
or Flash SWF

Click the Edit menu, and then click
Adobe PDF Presets or SWF
Presets.

Perform any of the following:

◆ New. Click the New button,
specify the options that you
want, and then click OK.

◆ Edit. Select a custom preset
(not a predefined one), click the
Edit button, change the options,
and then click OK.

◆ Delete. Select a custom preset
(not a predefined one), and
then click the Delete button.

◆ Import. Click Import, navigate to
the preset file, select it, and
then click Open.

◆ Export. Select a preset, click
Export, specify a location and
name, and then click Save.

For PDF files, the preset is
saved with the .joboptions
extension.

Click OK.3

2

1

If you frequently use custom settings to export an Illustrator document
to an Adobe PDF or Flash SWF file, you can save time by creating a
preset. Adobe Creative Suite programs, including Illustrator, InDesign,
Photoshop, and Acrobat, provide built-in presets that you can use in
any of the programs. When you create your own preset, you can also
use it in other CS programs. The process for creating a preset for an
Adobe PDF or Flash SWF is similar; just the settings are different.

PDF2

SWF2

3
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Exporting as a Flash
Movie

Export a Document as a Flash
Movie

Click the File menu, and then click
Export.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click Flash (*.SWF).

Navigate to the location where
you want to save the document. 

To preserve artboards, select the
Use Artboards check box, and
then select the All or Range
option. If you selected the Range
option, enter a range.

Click Save.

Click the Preset list arrow, and
then select a preset option, or
specify your own options to create
a custom preset.

◆ To create a preset that you can
use later, set your options, click
the Save Preset button, enter a
name, and then click OK.

Click the Export As list arrow, and
then select an export method.

Click the Version list arrow, and
then select a target Flash Player
version.
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Adobe Flash is a vector-based animation and interactivity program. If
you want to use individual Illustrator objects in Flash, you can simply
copy and paste them directly into a Flash movie document (FLA).
However, if you want to create a Flash movie (SWF) that you can use
on a web page and display using Flash Player, you should use the
Export command. The Export command gives you options to specify
how you want to create a SWF movie. If you have multiple artboards in
a document, these are preserved in the SWF file format.
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Tagging Text for Export to Flash

You can export text from Illustrator to text in Flash as a static, dynamic,
or input text. Before you export the text, you need to tag the text first.
By default, text is set to static, which is converted to regular text in
Flash. Dynamic and input text have similar properties in Flash and
Illustrator, which you can update and edit. To tag text in Illustrator,
select a text object, click Flash Text on the Control panel, click the
Type list arrow, and then click Static Text, Dynamic Text, or Input Text.
Enter an optional instance name, specify a Rendering Type, and then
select text options: Selectable, Show Border Around Text, and Edit
Character Options. For dynamic text, you can specify a URL and target.
For input text, you can specify a maximum number of characters.

For Your Information
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Specify the following options:

◆ Clip to Artboard Size. Select to
export only objects within an
artboard.

◆ Preserve Appearance. Select to
flatten artwork to a single layer.

◆ Compress File. Select to
compress the SWF file.

◆ Include Unused Symbols.
Select to export all unused
symbols.

◆ Export Text as Outlines. Select
to convert type to vector paths.

◆ Ignore Kerning Information for
Text. Select to export text
without kerning.

◆ Include Metadata. Select to
export metadata with the file.

◆ Protect from Import. Select to
prevent changes to the SWF.

◆ Password. Select to protect the
file with a password.

◆ Curve Quality. Select a number
for Bezier curve accuracy. The
higher the number, the more
accurate.

◆ Background Color. Specify a
background color for the file.

◆ Local Playback Security.
Specify whether you want to
access only local file or
network files.

To set image compression and
quality or animation frame rates
and layer order options, click
Advanced.

Click OK.12

11

10

11

12

7

10

9

8



ptg8126863

412 Chapter 15

Saving as Adobe PDF

Save a Document as an Adobe
PDF

Click the File menu, and then click
Save As.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click Adobe PDF (*.PDF).

Navigate to the location where
you want to save the document. 

Select the All or Range option to
create individual pages for each
artboard. If you selected the
Range option, enter a range.

Click Save.

Click the Adobe PDF Preset list
arrow, and then select a preset
option, or specify your own options
to create a custom preset.

◆ To create a preset that you can
use later, set your options, click
the Save Preset button, enter a
name, and then click OK.

Select a category (General,
Compression, etc.) from the list to
display options. 

Specify the options for the
category that you want.

◆ To reset options to defaults,
hold down Alt (Win) or Option
(Mac), and then click Reset.

Click Save PDF.10
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If a co-worker or client doesn’t have Illustrator, you can create an
Adobe PDF of a document for them to review your work. Adobe PDF
(Portable Document Format) is a useful file format for document shar-
ing, viewing, and proofing with Adobe Acrobat Reader, which is free for
download on the web at www.adobe.com. If recipients of the file have
Adobe Acrobat, they can add comments to an Adobe PDF. If you have
multiple artboards in a document, these are preserved in the Adobe
PDF file format.
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Use Adobe PDF Preset Options

Follow steps 1 through 6 on the
previous page.

Click the Adobe PDF Preset list
arrow, and then select one of the
following presets:

◆ Illustrator Default. Creates
PDFs that preserve all
Illustrator content, which can
be reopened in Illustrator,
InDesign, or QuarkXPress.

◆ High Quality Print. Creates
PDFs for quality printing on
desktop printers and proofing
devices.

◆ PDF/X-1a: 2001/2003. Creates
PDFs that meet printing
standards for Acrobat Reader
4.0 or later. Useful for a CMYK
workflow.

◆ PDF/X-3: 2002/2003. Creates
PDFs that meet printing
standards for Acrobat Reader
7.0 or later. Useful for a color-
managed workflow.

◆ PDF/X-4:2008. Creates PDFs
that meet printing standards for
Acrobat Reader 7.0 or later.
Useful for a color-managed
workflow with added support
for preserving transparency.

◆ Press Quality. Creates PDFs for
high quality print production
(digital printing or separations).

◆ Smallest File Size. Creates
compressed PDFs for use on
the Web or e-mail distribution.

Click Save PDF.3
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Adobe PDF
Presets
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Saving as an EPS

Save a Document as an EPS File

Click the File menu, and then click
Save As.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click Illustrator EPS (*.EPS).

Navigate to the location where
you want to save the document. 

To preserve artboards, select the
Use Artboards check box, and
then select the All or Range
option. If you selected the Range
option, enter a range.

Click Save.

Click the Version list arrow, and
then select an Illustrator EPS
version.

To create an image preview for
Open dialog boxes, click the
Format list arrow, select a format,
and then select the Transparent or
Opaque option.

If the artwork contains transparent
objects and overprints, specify the
options you want.

Select the Embed Fonts (for other
applications) check box to attach
fonts used in the document to the
image file, so they will be available
in other programs.
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EPS (Encapsulated PostScript) is a commonly used file format that you
can import into graphics, word processing, and page layout programs.
An EPS file can contain vector and bitmap graphics, so it makes the
format more versatile for use in other programs. EPS does a good job 
of preserving graphic objects in an Illustrator document. If you have
multiple artboards in a document, these are preserved in the EPS file
format.
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Specify the following options:

◆ Include Linked Files. Select to
embed linked files in artwork.

◆ Include Document Thumbnails.
Select to create a thumbnail
image of the artwork.

◆ Include CMYK PostScript in
RGB Files. Select to allow the
use of RGB output when it’s not
supported in a program.

◆ Compatible Gradient and
Gradient Mesh Printing. Select
to allow older printers and
PostScript devices to print
gradients and gradient meshes
by converting them to JPEG.

◆ Use Printer’s Default Screen.
Select to use a printer’s default
settings.

◆ Adobe PostScript. Select a
PostScript level to save with
the image. PostScript Language
Level 2 is widely used. If you
want to work with mesh
objects, use Level 3.

Click OK.12
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Saving as a SVG

Save a Document as a SVG File

Click the File menu, and then click
Save As.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click SVG (*.SVG) or SVG
Compressed (*.SVGZ).

Navigate to the location where
you want to save the document. 

To preserve artboards (New!),
select the Use Artboards check
box, and then select the All or
Range option. If you selected the
Range option, enter a range.

Click Save.

Click the SVG Profiles list arrow,
and then select a SVG
specification by version number.

Specify the following font options:

◆ Type. Select a font display
option: Adobe CEF has the best
display, yet not as widely
supported; SVG is the most
supported; and Convert to
Outline provides the smallest
size, yet lowest quality. 

◆ Subsetting. Select the set of
font characters you want to
include in the file. 
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SVG (Scalable Vector Graphics) is a vector based format, like the
Illustrator AI format, that describes images as shapes, paths, text and
filter effects. Vector images can be resized without sacrificing sharp-
ness and clarity. The SVG format is XML-based, which allows you to
add code (XML and JavaScript) so that the web graphic can respond to
user actions. Things to remember when you save a document to SVG,
each layer is converted to a group (<g>) element, objects appear trans-
parent based on opacity, use slices, image maps, and scripts to add
web links, and symbols and paths improve performance.
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Click the Embed or Link option to
specify where you want the image
location (embedded in or external),
and then select the check box if
you want to preserve Illustrator
editing capabilities for future
revisions.

To specify additional options, click
More Options. 

The button changes to Less
Options.

Specify the following Advanced
options:

◆ CSS Properties. Select an
option to create a CSS
properties.

◆ Optimize for Adobe SVG
Viewer. Select to optimize for
the best performance with the
Adobe SVG Viewer.

◆ Include Slicing Data. Select to
include slicing locations and
settings.

◆ Include XMP. Select to include
XMP metadata information.

◆ Output fewer <tspan>
elements. Select to reduce the
file size by ignoring kerning
position.

◆ Use <textPath> element for
Text on Path. Select to use
<textPath> tag for path text,
which creates more compact
XML; deselect to use <text>
tag.

If you want to view the SVG code
in a web browser, click SVG Code.

Click OK.13
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Saving for HTML5 and
CSS

Create a Canvas and Save as
SVG for Use in HTML

Select the object you want to
create into a canvas.

Click the Object menu, point to
HTML5 Canvas, and then click
Make.

◆ If the menu is not available,
please check your installation.

After you create a canvas, you can
save it as a SVG file for use in an
HTML editing program, such as
Adobe Dreamweaver, where you
can add scripting and other
functionality.

To return a canvas object back to
a normal Illustrator object, click
the Object menu, point to HTML5
Canvas, and then click Release.
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With the HTML5 Pack installed on your computer with Adobe Illustrator
CS5.1 or later, you can get support for HTML5 and CSS3, and extend
SVG capability. You can download the HTML5 Pack from Adobe Labs
for free at labs.adobe.com/downloads/ illustrator_html5.html. Be sure
to download or print out the installation instructions and then follow
them carefully. On the Object menu, the HTML5 Canvas submenu
appears, where you can make and release canvas (bitmap-based) art-
work on output. This allows you to use scripting, such as JavaScript, to
manipulate the canvas content in a HTML program, such as Adobe
Dreamweaver. You can export artboards for unique screen sizes using
SVG and CSS3 media queries, create web widgets, and export the
Appearance panel to CSS3.

See Also
See “Saving as a SVG” on pages 
416-417 for more information on saving
a document as a SVG file for use in
other programs.
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Save as a CSS File

Select the object with the
appearance you want to save as a
CSS file.

Select the Appearance panel.

To set CSS preferences for the
exported CSS file, click the
Options menu, click CSS Export
Preferences, specify the options
you want, and then click OK.

◆ CSS Units. Select the Pixels or
Points option.

◆ Object Appearance. Select
check boxes for Include Fill,
Include Stroke, or Include
Opacity.

◆ Position and Size. Select check
boxes for Include Absolute
Position or Include
Dimensions.

Click the Options menu, and then
click Export Selected as CSS.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

The format is set to CSS (*.css).

Navigate to the location where
you want to save the document. 

Click Save.7

6

5

4

3

2

1

6

7

5

4

3

2



ptg8126863

420 Chapter 15

Saving as Adobe FXG

Save a Document as an Adobe 
FXG File

Click the File menu, and then click
Save As.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click Adobe FXG (*.FXG).

Navigate to the location where
you want to save the document. 

To preserve artboards, select the
Use Artboards check box, and
then select the All or Range
option. If you selected the Range
option, enter a range.

Click Save.

Specify the following options:

◆ FXG Version. FXG 2.0 is only
supported for export and
import.

◆ Save Illustrator Private Data.
Select to preserve Illustrator-
specific data in the export to
FXG so you can import it back
to Illustrator.

◆ Include Unused Symbols.
Select to include unused
symbols in the export.
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Adobe FXG (Flash XML Graphics) is a file format based on a subset of
MXML, the XML-based programming language used by the Flex frame-
work, which you can use to build rich Internet applications. The FXG file
format allows designers to exchange graphic content between pro-
grams with high fidelity. Illustrator allows you to save your artwork in
the Adobe FXG file format (version 2.0), which you can use in Adobe
Flash Catalyst, Adobe Flash Builder, and Adobe Flash Professional to
build applications. When you save a document in Adobe FXG, the FXG
Options dialog box appears, where you can specify the FXG specific
save options you want. FXG always uses the RGB color mode. If you
have multiple artboards in a document, these are preserved in the FXG
file format.

4

35

6

2



ptg8126863

Chapter 15 Exporting a Document 421

◆ Downsample Linked Images
(72 ppi). Select to resample
linked images to 72 points per
inch resolution.

◆ Filters. Drop Shadow, Inner
Glow, Outer Glow and Gaussian
Blur are the only supported
filters in FXG. Select an option
to preserve appearance
(Expand or Rasterize) or
maintain editability  (Convert 
to FXG).

◆ Text. Select an option to
preserve appearance (Create
Outline or Rasterize) or
maintain editability (Convert to
FXG), or choose Automatic.

◆ Gradients. Select an option to
have Illustrator automatically
convert the gradient or
maintain editability (Convert to
FXG).

◆ Blend. Select an option to have
Illustrator automatically convert
the blend or preserve
appearance (Rasterize).

Click Show Code to see the
resulting FXG code for your
artwork in your browser.

Click OK.9
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Saving a Document for
Microsoft Office

Save a Document for Microsoft
Office

Click the File menu, and then click
Save for Microsoft Office.

The Save for Microsoft Office
dialog box appears with the PNG
file format.

Enter a name for the file in the File
Name (Win) or Save As (Mac) box.

Navigate to the location where
you want to save the document. 

Click Save.4
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The Illustrator format (AI) is not compatible with Microsoft Office pro-
grams. If you want to use an Illustrator document in a Microsoft Office
program, you need to save the document as a PNG (Portable Network
Graphics) image. This format makes transparent areas opaque. In a
Microsoft Office program, you can insert the PNG image file by using
the Insert Picture command. To save a document as a PNG image, you
use the Save for Microsoft Office command on the File menu. 
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Saving as a Template

Save a Document as a Template

Open a new or existing document.

Create a custom document.

Click the File menu, and then click
Save As Template.

The Templates folder appears,
displaying different types of
templates available for Illustrator.

Type a name for the new template.

Click the Save as Type list arrow
(Win) or Format popup (Mac), and
then click Illustrator Template
(*.AIT), if necessary.

Navigate to a different location if
you want to save your custom
templates in a folder other than
the Illustrator Templates folder.

Click Save. 7
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If you find yourself frequently creating the same kind of document, then
you should create a template. A template is a special document that
makes it easier to reuse frequently used material. An Illustrator
Template file uses the (AIT) file format instead of the normal (AI) docu-
ment file format. When you create a new document from a template, a
new document appears with the filename "Untitled," so you don’t mis-
takenly make and save changes over the template file.
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Designing for the Web 

Introduction

If you need to manipulate a photographic image to place it
on the web, there's not a better program on the market than
Adobe Illustrator that will do the job for you. Illustrator uses
various document formats, such as JPEG, GIF, PNG, SWF
(Flash movie), and SVG, to save images for the web. For
example, the JPEG format is used primarily for compressing
photographic images, while the GIF format is used for com-
pressing clip art and text. Each format is designed to serve a
purpose, and knowing when to use a specific format will help
you design fast-loading, dynamic web documents. 

However, saving files in a specific file format is not the
only way Illustrator helps you create web-friendly images;
you can also slice images. When you slice an image, you're
cutting the image into several pieces. Since the Internet han-
dles smaller packets of information more efficiently than one
large piece, slicing an image makes the whole graphic load
faster, and Illustrator helps you slice images with ease. 

16

16
What You’ll Do

Save for the Web

Work with Save for Web Options

Work with Web File Formats

Optimize a JPEG Document

Optimize a GIF Document

Optimize a PNG-8 Document

Optimize a PNG-24 Document

Optimize an Image to File Size

Slice Images the Easy Way

Work with Slices

Add HTML Text or an URL to a Slice

Arrange Slices

Combine or Divide Slices

Save Slices for the Web

Save Selected Slices

Preview in a Browser

425
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Illustrator's Save for Web command is a dream come true for preparing
images for the Internet, or even for saving images in a quick-loading
format for Microsoft PowerPoint slide presentations, and you don't
even have to leave Illustrator. The Save for Web command lets you
open any Illustrator document, and convert it into a web-friendly format
using the GIF, JPEG, or PNG formats. You can even try different opti-
mization settings or compare different optimizations using the 2-Up
pane. In addition, the dialog area below each image provides optimiza-
tion information on the size and download time of the file. 

Saving for the Web    

Save for the Web

Open a document.

Click the File menu, and then click
Save for Web.

Click the Original, Optimized, or  
2-Up tabs to view the document
using different layouts.

Click one of the sample images to
change its default format.

IMPORTANT If you're viewing
the document using 2-Up, the first
image is the original. You can't
change the original; you can only
edit one of the sample images.

Click the Preset list arrow, and
then select a new format from the
available options.

Click the Optimized File Format list
arrow, and then select from the
following options:

◆ GIF. The Graphics Interchange
Format is useful for clip art,
text, or images that contain a
large amount of solid color. GIF
uses lossless compression.

◆ JPEG. The Joint Photographic
Experts Group format is useful
for images that contain a lot of
continuous tones, like photo-
graphs. JPEG uses lossy
compression.
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◆ PNG-8. The Portable Network
Graphics 8-bit format functions
like the GIF format. PNG uses
lossless compression.

◆ PNG-24. The Portable Network
Graphics 24-bit format
functions like the JPEG format.
PNG-24 uses lossless
compression.

Select from the various options
that change based on your File
Format selection.

Use the Image Size section to
change the selected image’s width
and height, and make other image
related adjustments.

Use the Color Table section
(available for the GIF and PNG-8
formats), to add, subtract, or edit
colors in the selected document.

Click Save.

Enter a name, and then select a
location in which to save the
image file.

Click OK.

Illustrator saves the modified file
and returns you to the original
image.
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Working with Matte and Transparency

The Matte option, when available, specifies the background color
used to fill anti-aliased edges that lie adjacent to transparent areas of
the image. When the Transparency option is selected, the matte is
applied to edge areas to help blend the edges with a web back-
ground of the same color. When the Transparency option is not
selected, the matte is applied to transparent areas. Choosing the
None option for the matte creates hard edges if Transparency is
selected; otherwise, all transparent areas are filled with 100% white.
The image must have transparency for the Matte options to be 
available.

For Your Information
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When you choose Save for Web, you are able to save your image in
one of three web formats: GIF, JPEG, or PNG. The Save for Web dialog
box comes with options that will help you through the process. For
example, if you choose the JPEG format, you can select the amount of
compression applied to the image or, if you select the GIF format, you
can choose how many colors are preserved with the image. The PNG
format lets you save images in an 8-bit (256 colors) or a 24-bit (millions
of colors) format. The options available with Save for Web give you the
control you need to produce small image files with high quality. 

Working with Save 
for Web Options    

Work with Save for Web Options

Open a document.

Click the File menu, and then click
Save for Web.

Select from the various tools:

◆ Hand Tool. Drag inside the
image to change the view.  

◆ Slice Select Tool. Select a
predefined image slice. 

◆ Zoom Tool. Click on the image
to expand the view size. 

◆ Eyedropper Tool. Drag within
the image to perform a live
sampling of the colors. 

Click the Zoom list arrow, and then
select a view size for the images.

Click the Toggle Slice Visibility
button to show or hide the slices.
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See Also
See “Optimizing an Image to File 
Size,” on page 439 for information 
on reducing file sizes for the web.

Did You Know?
You can view image details in the Save
for Web dialog box. Below the selected
sample, you can view file format, size,
and color palette information. 

Image details for the selected sample

2-Up viewing pane
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Select from the various options
that change based on your File
Format selection.

Use the Image Size section to
change the selected image’s width
and height, and make other image
related adjustments.

◆ Width and Height. Specify a
new image width and height;
click the Lock icon to retain
original proportions.

◆ Percent. Specify a resize
percentage.

◆ Anti-aliasing. Select to smooth
out the edges of text or
artwork.

◆ Clip to Artboard. Select to set
the clipping boundary to the
artboard rather than the
smallest enclosed box or
clipping box.

Use the Color Table section
(available for the GIF and PNG-8
formats) to add, subtract, or edit
colors in the selected document.

◆ Color Palette Menu. Click the
menu to add or remove colors,
select colors, sort colors, load
or save a color table. 

Click the Preview in Default
Browser button to preview the
image in your default web
browser. 

◆ Click the Select Browser Menu
button to choose a browser or
edit the browser list.

Click Save.10
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If you design web documents, you know that the size of your images is
very important. Illustrator gives you the option of compressing images
in one of three formats appropriate for use on the web:  GIF, JPEG, or
PNG. The GIF format compresses images that contain solid colors with
sharp, definable edges, such as clip art and text. The JPEG format
reduces the size of image files that contain a lot of soft transitional col-
ors, such as photographs. The PNG format is a hybrid format designed
to take the place of the GIF and JPEG format. Illustrator will help you
transform your images into whatever format you need in order to cre-
ate stunning web images.  

Working with Web 
File Formats     

Work with Web File Formats

Open a document.

Click the File menu, and then click
Save for Web.

Click the Original, Optimized, or 
2-Up tabs to view the document
using different layouts.

Select one of the samples.

Click the Optimized File Format list
arrow, and then select a format
from the available options.

Select the options you want to use
to change image compression, and
then specify your desired color
options.

Click Save.

The Save Optimized As dialog box
appears.
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Enter a name in the File Name box.

The Save as Type (Win) or Format
(Mac) list arrow is set to Images
Only.

Click the Save In (Win) or Where
(Mac) list arrow, and then select
the location in which to save the
file. 

Click Save. 10
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Illustrator comes complete with everything you will need to properly
compress any JPEG Document. The Internet can sometimes be slow to
navigate, and your visitors typically do not have much patience. When
you compress a JPEG image, you're essentially removing information
from the image to reduce its file size and speed up the loading time.
The unfortunate result of that reduction is loss of image quality. Internet
graphics are not always the best quality; however, reducing file size is
a necessary evil to keep visitors from clicking off your site and moving
to another. To keep visitors happy, your JPEG images must load fast,
and Illustrator is just the application to help you accomplish that goal. 

Optimizing a JPEG
Document

Optimize a JPEG Document

Open a document.

Click the File menu, and then click
Save for Web.

Click the Original, Optimized, or 
2-Up tabs to view the document
using different layouts.

Click one of the sample images to
change its default format.

Click the Optimized File Format list
arrow, and then click JPEG.

Select from the following Quality
options:

◆ Compression Quality. Click the
list arrow, and then select a
preset JPEG quality from Low
(poor quality) to Maximum (best
quality).

◆ Quality Amount. Enter a JPEG
quality compression value (0%
to 100%). The lower the value,
the more information (color) is
sacrificed for image size.

◆ Blur. JPEG images compress
better when the image has soft
edges. Apply the Blur option to
increase the softness of the
image (at a sacrifice of image
quality).
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Click the Matte list arrow, and then
select from the available options.

JPEG images do not support
transparency. If your image
contains transparent areas, use
the Matte option to fill them in
using a specific color.

Select the Optimized check box to
further compress the image. This
is not supported by all browsers.

Select from the following options:

◆ Progressive. Select the check
box to load a JPEG in three
progressive scans. Not
supported by all browsers.

◆ ICC Profile. Select the check
box to embed an ICC color
profile into the JPEG image.
This increases file size but
helps maintain color
consistency between monitors
and operating systems.

Click Save to save the current
image, and then save it using the
Save Optimized As dialog box.
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The GIF file format is used primarily for images that contain solid colors
with sharp edges, such as clip art, text, line art, and logos. Since the
Internet can generally be slow to navigate, using the GIF format for
images significantly reduces their file size, and will create fast-loading
graphics. The GIF format supports 8-bit color, and creates a document
with a maximum of 256 colors (the fewer colors, the smaller the file
size). The GIF format has been around long enough for it to be consid-
ered a "native" Internet format. A native format is one that does not
require a specific plug-in for the browser to display the file. 

Optimizing a GIF
Document     

Optimize a GIF Document

Open a document.

Click the File menu, and then click
Save for Web.

Click the Original, Optimized, or 
2-Up tabs to view the document
using different layouts.

Click one of the sample images to
change its default format.

Click the Optimized File Format list
arrow, and then click GIF.

Select from the following options:

Color Options:

◆ Reduction. Click to select a
visual reduction method for the
image’s colors.

◆ Colors. Enter or select a value
from 2 to 256 maximum colors.

◆ Web Snap. Enter or select a
value from 0% to 100% to
instruct the GIF compression
utility how many of the image
colors should be web-safe.
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Dither Options:

◆ Method. Click the list arrow, and
then select from the available
dithering schemes. Dithering
refers to how the GIF format
mixes the available colors in the
image.

◆ Amount. Enter or select a value
from 0% to 100% to instruct the
GIF compression utility how
many of the image’s colors
should be dithered.

Transparency Options:

◆ Transparency. Check to keep the
transparent areas of a GIF
image transparent.

◆ Matte. Click to fill the trans-
parent areas of a GIF image.

◆ Dither. Click to select a dithering
scheme and enter an amount for
the mixing of the matte color.

Other Options:

◆ Interlaced. Check to have the
GIF image load in three scans.

◆ Lossy. Enter or select a value
from 0 to 100 to instruct the GIF
compression utility how much
image loss is allowed.

Click Save to save the current
image, and then save it using the
Save Optimized As dialog box.
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The PNG-8 file format is used primarily for images that contain solid
colors with sharp edges—clip art, text, line art, and logos—and was
designed as an alternative to the GIF file format. Since the PNG-8 for-
mat generates an image with a maximum of 256 colors, it significantly
reduces an image's file size. While similar to the GIF file format, the
PNG-8 format is not completely supported by older browsers. However,
it is considered a native format for the creation of Flash animation
movies. 

Optimizing a PNG-8
Document     

Optimize a PNG-8 Document

Open a document.

Click the File menu, and then click
Save for Web.

Click the Original, Optimized, or 
2-Up tabs to view the document
using different layouts.

Click one of the sample images to
change its default format.

Click the Optimized File Format list
arrow, and then click PNG-8.

Select from the following options:

Color Options:

◆ Reduction. Click to select a
visual reduction method for the
colors in the image.

◆ Colors. Enter or select a value
from 2 to 256 maximum colors.

◆ Web Snap. Enter or select a
value from 0% to 100% to
instruct the PNG-8 compression
utility how many of the image’s
colors should be web-safe.
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Dither Options:

◆ Method. Click the list arrow,
and then select from the
available dithering schemes.
Dithering is how the PNG-8
format mixes the available
image’s colors.

◆ Amount. Enter or select a value
from 0% to 100% to instruct the
PNG-8 compression utility how
many of the image’s colors
should be dithered.

Transparency Options:

◆ Transparency. Check to keep
the transparent areas of a
PNG-8 image transparent.

◆ Matte. Click to fill the trans-
parent areas of a PNG-8 image.

◆ Dither. Click to select a
dithering scheme and enter an
amount for the mixing of the
matte color.

Other Options:

◆ Interlaced. Check to have the
PNG image load in three scans.

Click Save to save the current
image, and then save it using the
Save Optimized As dialog box.
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The PNG-24 file format is used primarily for images that contain lots of
colors with soft transitional edges, such as photographs, and was
designed as an alternative to the JPEG file format. The PNG-24 format
generates an image with millions of colors, and still manages to reduce
the size of a file. While similar to the JPEG file format, the PNG-24 uses
lossless compression, and does not compress files as small as the
JPEG format. So for the time being, most designers are still using the
JPEG format for creating faster-loading web graphics. 

Optimizing a PNG-24
Document     

Optimize a PNG-24 Document

Open a document.

Click the File menu, and then click
Save for Web.

Click the Original, Optimized, or 
2-Up tabs to view the document
using different layouts.

Click one of the sample images to
change its default format.

Click the Optimized File Format list
arrow, and then click PNG-24.

Select from the following options:

Transparency Options:

◆ Transparency. Check to keep
the transparent areas of a
PNG-24 image transparent.

◆ Matte. Click to fill the trans-
parent areas of a PNG-24
image.

Other Options:

◆ Interlaced. Check to have the
PNG-24 image load in three
scans.

Click Save to save the current
image, and then save it using the
Save Optimized As dialog box.
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The Save for Web dialog box has many options to help you create the
exact image you need—including helping you compress an image
down to a specific file size. For example, you've just created an image
you want to display on the web, but the maximum file size you can use
is 35 KB. You could experiment with compression options in the Save
for Web settings, or you could use the Optimize to File Size option.

Optimizing an Image 
to File Size    

Optimize an Image to File Size

Open a document.

Click the File menu, and then click
Save for Web.

Click the 2-Up tab, and then select
the sample image to the right.

Click the Optimize Menu button,
and then click Optimize To File
Size.

Enter a file size in the Desired File
Size data box.

Click the Current Settings option
or the Auto Select GIF/JPEG
option to let Illustrator choose
between the GIF or JPEG format.

Click the following Use options:

◆ Current Slice

◆ Each Slice

◆ Total of All Slices

Click OK.

Illustrator compresses the
selected sample.

Click Save to save the compressed
image. 
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Illustrator allows you to slice a document into smaller pieces. You might
want to slice an image to create interactive links; however, the best
reason is speed. You gain speed by compressing individual slices to
reduce the image size. You can draw directly on an image to create a
user-defined slice using the Slice tool. When you create a slice,
Illustrator also creates auto slices, which fill the space in the image
that is not defined by user defined slices. There are two types of auto-
matic slices: auto slices and subslices. Subslices show overlapping
user-defined slices. User-defined slices are identified by a solid blue
line, while auto slices are identified by dotted red lines. The slices also
are numbered from left to right and top to bottom. If you want to make
changes to the slice, you need to select it first. When you edit or move
the layer contents, the slice automatically changes. 

Slicing Images the
Easy Way      

Create a User Slice with the
Slice Tool

Open a document.

Select the Slice tool on the Tools
panel.

IMPORTANT To make slicing a
little easier, drag a few guides
from the Ruler bar to help guide
your slicing tool.

Drag and release the slice tool in
the document to create a
rectangular or square slice.

◆ To constrain the slice to a
square, hold down Shift as you
drag. 

Continue to drag and release until
you have the image correctly
sliced.
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Create a User Slice from a
Selected Object

Open a document.

Select the object that you want to
use to create a slice.

Click the Object menu, point to
Slice, and then click Make or
Create from Selection.

3

2
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Did You Know?
You can create slices from guides.
Add guides to the image, select the
Slice tool on the tools panel, click the
Object menu, point to Slice, and then
click Create From Guides.

You can lock guides. To keep a guide
from being moved, click the View
menu, point to Guides, and then click
Lock Guides.

You can remove guides. To remove
guides, click the View menu, point to
Guides, and then click Clear Guides.

You can show and hide guides. Click
the View menu, point to Guides, and
then click Show Guides or Hide Guides.

What’s a Subslice?

The subslice is a type of auto slice that is automatically created when
you create overlapping slices. They are created as a stack, one on top
of the other, which you can rearrange. The subslice shows you how
the image is divided when you save the optimized file. Subslices
appear with a number and a slice symbol. When you make changes 
to a slice related to a subslice, the subslice automatically gets 
recreated.

For Your Information

2

3



ptg8126863

442 Chapter 16

After you create slices within an image, you can use the Options bar or
the Save for Web dialog box to work with slices. You can select options
to show or hide slices, select one or more slices, delete or duplicate
slices, and view or change slice settings. If you have an image with
more than one slice, you need to optimize the slices in the Save for
Web dialog box. You can use the Optimize menu to link multiple slices
together. For linked slices in the GIF and PNG-8 format, Illustrator uses
the same color palette and a dithering pattern to hide the seams
between slices. 

Working with Slices  

Work with Slices in the
Illustrator Window

Open a document with slices.

Use any of the following:

◆ Show or Hide Slices. Click the
View menu, and then click
Show Slices or Hide Slices. 

◆ Select Slices. Click the Slice
Selection tool, and then click
the slice you want. Use
Shift+click or drag to select
multiple slices.

◆ Delete Slices. Select the slices,
and then press Delete.

◆ Duplicate Slices. Select the
slices, and then Alt (Win) or
Option (Mac) and drag the
selection.

◆ View Slice Options. Click the
Slice Selection tool, select the
slice you want, click the Object
menu, point to Slice, and then
click Slice Options.
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Slice tools

Auto slice

User slice

Slice Options
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Work with Slices in the Save for
Web Dialog Box

Open a document with slices.

Click the File menu, and then click
Save for Web.

Select the file type you want,
select any options, and then make
any adjustments you want.

◆ Show or Hide Slices. Click the
Toggle Slices Visibility button. 

◆ Select Slices. Click the Slice
Select tool, and then click the
slice you want. Use Shift+click
or drag to select multiple slices.

◆ View Slice Options. Click the
Slice Select tool, and then
double-click the slice you want.

◆ Link Slices. Select the slices
you want to link, click the
Optimize Menu button, and
then click Link Slices. 

A link icon appears on the
slices.

◆ Unlink Slices. Select the slice,
click the Optimize Menu button
button, and then click Unlink
Slice or Unlink All Slices.

◆ Export Slices. Click the Export
list arrow, and then select a
slices export option (New!).

When you’re done, click Save to
save the image or click Done to
save your settings.

TIMESAVER Hold down Ctrl
(Win) or Command (Mac) to switch
between the Slice tool and the
Slice Select tool.
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If you want to include text within a slice for use on the web, you can
enter plain or formatted text with standard HTML tags directly on a
slice with the type No Image. The text doesn't show up in Illustrator;
you need to use a web browser to see it. Don't enter too much text as it
might affect the exported layout. You can add text using the Slice
Select tool on the Tools panel, or in the Save for Web dialog box. If you
want to create a hyperlink out of a slice for use on the web, you can
add an URL to a slice with the type Image.

Adding HTML Text or
an URL Link to a Slice     

Add HTML Text to a Slice

Open a document with the slice.

Open the Slice dialog box to add
text using one of the following: 

◆ Tools Panel. Select the Slice
Selection tool on the Tools
panel, select the slice you want
to add HTML text, click the
Object menu, point to Slice,
and then click Slice Options.

◆ Save for Web dialog box. Click
the File menu, click Save for
Web, and then double-click the
slice to which you want to add
HTML text.

Click the Slice Type list arrow, and
then click No Image.

Enter the text you want.

Click the Background list arrow,
and then select a background:
None, Matte, Eyedropper Color,
White, Black, or Other.

Select the Text is HTML check box
to include HTML formatted tags.

Select the horizontal and vertical
cell alignment options you want.

◆ To line up text in cells in the
same row, set a common
baseline for all cells in the row.

Click OK.8
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Add an URL Link to a Slice

Open a document.

Select the Slice Selection tool on
the Tools panel.

Double-click the slice to which you
want to add an URL link. 

◆ You can also click the Object
menu, point to Slice, and then
click Slice Options.

Click the Slice Type list arrow, and
then click Image.

Enter an URL address or select a
previously created one from the
list. Be sure to use the complete
URL address, such as
http://www.perspection.com.

If you want to enter a target frame: 

◆ _blank. Displays the linked file
in a new window.

◆ _self. Displays the linked file in
the same frame as the original
file.

◆ _parent. Displays the linked file
in its own original parent
frameset. 

◆ _top. Replaces the entire
browser window with the
linked file, removing all current
frames.

Click OK.7
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Selecting a Slice Content Type

The slice type determines how the slice appears in a web browser
after you save it for the web from Illustrator. There are three content
types:  Image, No Image, and HTML Text. Image contains image data,
while No Image creates empty table cells where you can put text or a
solid color. HTML Text specifics the text is formatted with HTML tags;
available when you select the Text is HTML check box. To change the
slice content type, click the Object menu, point to Slice, and then
click Slice Options. Click the Type list arrow, and then select the type
you want.

For Your Information
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Moving and resizing objects in Illustrator is a common task. You can
move or resize slices in the same basic way you do other objects. In
addition to moving slices, you can also align them along an edge or to
the middle, and evenly distribute them horizontally or vertically. When
you align and distribute slices, you can reduce the amount of unneces-
sary auto slices, thereby creating smaller files and faster load times.
When you have slices overlapping each other, you can change the
stacking order to move them up or down in the order. For example, if
you have one slice behind another, you can bring the slice forward one
level at a time or to the top (front).

Arranging Slices  

Move or Resize Slices

Open a document with slices.

Select the slices you want to move
or resize.

To move a slice selection, drag the
slice to a new location. You can
press Shift to constrain movement
up, down, or diagonally.

To resize a slice, drag the side or
corner handle of the slice. When
you select adjacent slices with
common edges, the slices resize
together.

◆ You can also set exact slice
position or size on the Control
panel.
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Did You Know?
You can copy and paste a slice. You
can copy and paste a slice like any
other object using the Copy and Paste
commands. If you copy a slice to
Dreamweaver, it retains information
from the original file in Illustrator. 
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Align, Distribute, or Stack Slices

Open a document with slices.

Select the slices you want to
arrange.

To align slices, select the
alignment button on the Align
panel you want: Horizontal Align
Left, Center, or Right, and Vertical
Align Top, Center, or Bottom.

To evenly distribute slices, select
the distribute button on the Align
panel you want: Vertical Distribute
Top, Center, or Bottom, and
Horizontal Distribute Left, Center,
or Right.  

To change the slice stacking order,
click the Object menu, point to
Arrange, and then select the
command you want: Bring To
Front, Bring Forward, Send
Backward, or Send To Back.
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Did You Know?
You can snap slices to a guide, user
slice, or other object. Click the View
menu, and then click Snap To Grid or
Snap To Point. When you move a slice
toward an element, the slice snaps to
the elements within 4 pixels.
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In addition to moving and resizing slices, you can also combine or
divide slices. If you want to combine slices, you simply select the slices
you want to combine and then choose the Combine Slices command.
When you divide slices, you select options to divide the slice horizon-
tally or vertically, down or across in equal parts, or enter an exact size
in pixels. As you specify divide values, you can select the Preview
option to see how it effects the slice in the document window. 

Combining or Dividing
Slices  

Combine or Divide Slices

Open a document with slices.

Select the slices you want to
combine or the slice you want to
divide.

To combine the slice selection,
click the Object menu, point to
Slice, and then click Combine
Slices.

To divide the slice selection, click
the Object menu, point to Slice,
and then click Divide Slices.

◆ To preview slice divide, select
the Preview check box.

◆ Specify options to divide the
slice horizontally or vertically,
and then click OK.
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Did You Know?
You can duplicate user and auto
slices. Select the slice, click the Object
menu, point to Slice, and then click
Duplicate Slice. 
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After you create slices within an image, you can export and optimize
each slice using the Save for Web command, which saves each slice
as a separate file.  In the Save for Web dialog box, you can specify the
slices you want to save (New!), either All Slices, All User Slices, or
Selected Slices. After you click Save in the Save for Web dialog box,
the Save Optimized As dialog box appears, where you can specify file
names for the image slices.

Saving Slices 
for the Web  

Save a Slice for the Web

Open a document with the slice
you want to save.

Click the File menu, and then click
Save for Web.

Select the file type you want,
select any options, and then make
any adjustments you want.

Click the Slices list arrow (New!),
and then click All Slices, All User
Slices, or Selected Slices.

Click Save.

Enter a name in the File Name box.

The Save as Type (Win) or Format
(Mac) list arrow is automatically
set to Images Only.

Click the Save In (Win) or Where
(Mac) list arrow, and then select
the location in which to save the
files. 

Click Save.8
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Instead of using the Save for Web dialog box to select and save slices,
you can select and slices directly from the document window. In the
document window, select the slices you want to save, and then use the
Save Selected Slices command on the File menu. In the Save Selected
Slices dialog box, you can enter a name for the image slice files and
specify where you want to save the individual files. Each selected slice
is saved as a separate file with consecutive numbers at the end to dis-
tinguish them apart. 

Saving Selected 
Slices

Save a Selected Slice

Open a document with slices.

Select the slices you want to save.

Click the File menu, and then click
Save Selected Slices.

Enter a name in the File Name box.

The Save as Type (Win) or Format
(Mac) list arrow is automatically
set to Images Only.

Click the Save In (Win) or Where
(Mac) list arrow, and then select
the location in which to save the
files. 

Click Save.6
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While you’re working with images in the Save for Web dialog box, you
can preview them in your web browser to see how they will look on the
web. If you want to use your default browser, you can click the Preview
button to quickly see your results. If you want to preview it in other
browsers, you can add them to your browser list. Illustrator makes it
easy to find all the browsers installed on your computer. In the
Browsers dialog box, simply click Find All and Illustrator does the rest.
If you want to see see how a browser dithers your image, you can
select the Browser Dither option (New!).  

Previewing in a
Browser

Preview in a Browser

Open a document.

Click the File menu, and then click
Save for Web.

Specify the settings you want for
the image that you want to
preview.

To view how a browser dithers the
image, click the Browser Dither
check box (New!).

To add a browser to the list of
available ones or set a new
default, click the Select Browser
Menu button, and then select from
the following options:

◆ Other. Click to select the
browser you want to use.

◆ Edit List. Click to find, add,
remove, or set as default.

◆ Add. Add a browser.

◆ Remove. Removes the
selected browser.

◆ Set As Default. Set the
selected browser as the
default.

◆ Find All. Finds all browsers
on your computer.

Click Preview to open the image in
your default browser.

◆ When you’re done, close your
browser.

Click Done.7
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Customizing the Way 
You Work

Introduction

No description of Adobe Illustrator would be complete with-
out that well-known, but little utilized area called Preferences.
Illustrator preferences serve several purposes. They help cus-
tomize the program to your particular designing style, and
they help you utilize available computer resources to
increase the overall performance of the program. 

As you use Illustrator, you'll come to realize the impor-
tance of working with units and rulers. Precision is the name
of the game when you are working with images. What about
the color of your guides, grids, and slices? No big deal, you
say. Well, if you've ever tried viewing a blue guide against
predominantly blue artwork, you know exactly why guide
color is important. By working through preferences, such as
Display Performance and Scratch Disks, speed increases of
up to 20% can be achieved. 

In addition, customizing the program helps make you
more comfortable, and studies show that the more comfort-
able you are as a designer, the better your designs. Plus,
being comfortable allows you to work faster, and that means
you'll accomplish more in the same amount of time. What
does setting up preferences do for you? They make Illustrator
run faster, you work more efficiently, and your designs are
better. That's a pretty good combination. Illustrator doesn't
give you Preferences to confuse you, but to give you choices,
and those choices give you control. 17

17
What You’ll Do

Set General Preferences

Change Selection & Anchor Display
Preferences

Set Type Preferences

Change Units & Display Performance
Preferences

Set Slices and Hyphenation Preferences

Select Plug-Ins

Select Scratch Disks

Set User Interface Preferences

Set File Handling & Clipboard
Preferences

Work with Appearance of Black
Preferences

Define Shortcut Keys

Use Drawing Tablets
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Illustrator's General preferences help you configure some of the more
common features of the program. Some of the options include keyboard
increment choices to move selected objects with arrow keys, anti-
aliased artwork to smooth out edges, showing tooltips to display
onscreen help tags, and scaling stroke & effects to scale an object’s
stroke weight and appearance. You can also click the Reset All
Warning Dialogs to allow warnings for which you previously selected
the Don’t Show Again check box.

Setting General
Preferences

Set General Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click General. 

Select the various options you
want to use:

◆ Keyboard Increment. Enter a
distance value (0-1296 points)
that a selected object moves
when an arrow key is pressed.

◆ Constrain Angle. Enter the
angle (-360 to 360) for the x and
y axes. Many tool operations
and other measurements are
calculated relative to this
angle.

◆ Corner Radius. Enter a value 
(0-1296 points) to specify the
curvature in the corners of
objects drawn with the
Rounded Rectangle tool.

◆ Disable Auto Add/Delete.
Select to disable the behavior
of the Pen tool to change to the
Add Anchor Point or Delete
Anchor Point tool when you
point to an anchor.

◆ Use Precise Cursors. Select to
use crosshairs instead of the
tool icon for drawing and
editing tools. 

◆ Anti-aliased Artwork. Select to
display smoother edges of
vector objects.

3
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◆ Show Tool Tips. Select to display
a popup tag with a name or short
description when you point to a
program item, such as a button
or tool.

◆ Select Same Tint %. Select to
select only objects with the same
spot color and tint percentage as
the currently selected object
when you use the Fill Color and
Stroke Color commands.

◆ Append [Converted] Upon
Opening Legacy Files. Select to
append “[Converted]” to
Illustrator 11 or earlier files when
you open them.

◆ Double Click To Isolate. Select
to place a double-clicked group
in Isolation Mode.

◆ Use Japanese Crop Marks.
Select to use Japanese-style
crop marks when you print
separations.

◆ Transform Pattern Tiles. Select to
transform a pattern when you
use a transformation tool on an
object that contains a pattern.

◆ Scale Strokes & Effects. Select
to scale an object’s stroke
weight and appearance when
you scale an object by using its
bounding box, the Scale tool or
the Free Transform tool.

◆ Use Preview Bounds. Select to
include an object’s stroke weight
and any effects when calculating
its dimensions.

◆ Reset All Warning Dialogs. Click
to allow warnings for which you
previously selected the Don’t
Show Again check box.

Click OK. 4

3

4
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Illustrator's Selection & Anchor Display preferences allow you to set
selection and anchor-related options. The Selection options include
Tolerance, which specifies a value within which an anchor point
becomes selected when you click near it; Object Selection by Path
Only, which selects an object when you click a path segment or anchor
point; and Snap to Point, which snaps objects to an anchor point or
guide within the specified value. If an object is behind another object,
you can set an option to use the keyboard shortcut Ctrl+click (Win) or
A+click (Mac) to select it. The Anchor Display main options include
Anchors and Handles, which allow you to select the display of anchor
points and handle end points. 

Changing Selection &
Anchor Display
Preferences

Change Selection & Anchor
Display Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Selection & Anchor Display. 

Select the Selection options you
want to use:

◆ Tolerance. Enter a value (in
pixels) within which an anchor
point becomes selected when
you click near it with the Direct
Selection tool.

◆ Object Selection by Path Only.
Choose to select an object with
the Selection or Direct
Selection tool when you click a
path segment or anchor point. 

Deselect to select a filled
object in Preview view with a
selection tool when you click
the filled area.

◆ Snap to Point. Select to snap
objects to an anchor point or
guide within the specified value
(in pixels).

◆ Control or Command Click to
Select Objects Behind. Select
to use the keyboard shortcut
Ctrl+click (Win) or A+click
(Mac) to select an object
behind another object.

3
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Select the Anchor Point and
Handle Display options you want
to use:

◆ Anchors. Specify the display of
anchor points. 

◆ Handles. Specify the display of
handle end points (direction
points).

◆ Highlight anchors on mouse
over. Select to highlight the
anchor point located directly
below the mouse pointer.

◆ Show handles when multiple
anchors are selected. Select to
display direction lines on all
selected anchor points when
you use the Direct Selection or
Group Selection tool to select
an object.

Deselect to display direction
lines for an anchor point when
it is the only anchor point on
the path or when the Bezier
segment for the direction line is
selected and the anchor point
is not selected.

Click OK.5

4

4
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Although Illustrator is not by definition a typesetting application, such
as Adobe InDesign, it does have some very powerful type features. For
example, Adobe Illustrator allows you to set options to customize the
way you select text. In addition, Illustrator's type menu lets you see
fonts exactly as they will print or display. For designers who use a lot of
fonts, this WYSIWYG (What You See Is What You Get) font menu is a
timesaver. You can use Type preferences to help you select the type
and font options you want to use. 

Setting Type
Preferences

Set Type Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Type. 

Specify values for Size/Leading,
Tracking, and Baseline Shift to
increment selected text each time
you press a keyboard shortcut for
the command.

Select from the following Type
options you want to use:

◆ Type Object Selection by Path
Only. Choose to select text
when you click on a type path.

Deselect to select text when
you click with a selection tool
on or near the type.

◆ Show Asian Options. Select to
display Japanese, Chinese, and
Korean type options in the
Character and Paragraph
panels.

◆ Show Font Names In English.
Select to display non-Roman
fonts using their Roman names.

4
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◆ Font Preview Size. Select to
display fonts on the menu in
small, medium, or large size.

◆ Enable Missing Glyph
Protection. Select to
automatically select incorrect,
unreadable characters
between roman and non-
Roman (Japanese or Cyrillic)
fonts.

◆ Use Inline Input for Non-Latin
Text. Select to type non-Roman
characters directly into
Illustrator instead of using a
separate dialog box.

Click OK.5

4
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Changing Units
Preferences

Change Units Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Units. 

Select from the following Units
options you want to use:

◆ General. Select a unit of
measure for rulers, dialog
boxes, and Transform, Control,
and Info panels.

◆ Stroke. Select a unit of
measure for the Strokes panel
and Stroke Weight field on the
Control panel.

◆ Type. Select a unit of measure
for the Character and
Paragraph panels.

◆ Asian Type. Select a unit of
measure for Asian type.

◆ Numbers Without Units Are
Points. Select to not convert
points to picas when Picas is
set as the General unit.

◆ Identify Objects By. For
dynamic objects, select an
option to assign variables to the
Object Name or an XML ID.

Click OK.4

3

2

1

While changing the measurable units and rulers do not affect output
quality, they do help to measure information in a document consistent
with the specific output device. In Units preferences, you can set units
of measure for general, stroke, and type-related features. The General
option (Units) sets a unit of measure for rulers, dialog boxes, and
Transform, Control, and Info panels.
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Setting Slices 
Preferences

Set Slices Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Slices. 

Select from the following Slices
options you want to use:

◆ Show Slice Numbers. Select to
show slice numbers.

◆ Line Color. Click the list arrow,
and then select a line color for
slices. 

◆ To select a custom color
(New!), click the color box,
select a color, and then 
click OK.

Click OK.4

3

2

1

Illustrator allows you to slice a document into smaller pieces. You might
want to slice an image to create interactive links; however, the best
reason is speed. You gain speed by compressing individual slices to
reduce the image size. In Slices preferences, you can set options to
show a slice number on the screen for easier management and select
a line color for slices. You can select a predefined color or a custom
one that you can select or specify in the Color dialog box.
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Setting Dictionary 
& Hyphenation
Preferences

Set Dictionary & Hyphenation
Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Dictionary & Hyphenation. 

Select the Update legacy
documents to new dictionary
check box to use the new
dictionary with older illustrator
documents (.AI) (New!).

Select from the following
Hyphenation options you want to
use:

◆ Default Language. Select a
default language for use with
Hyphenation.

◆ Exceptions. Enter words in the
New Entry box that you want
hyphenated a certain way
(include the hyphen), and then
click Add. To delete an entry,
select it from the list, and then
click Delete.

Click OK.5

4

3

2

1

The Dictionary & Hyphenation Preferences give you the ability to spec-
ify whether to use the new dictionary with legacy Illustrator documents
(New!) and set the default language for hyphenation and any excep-
tions. When you select a default language for hyphenation, it includes
language specific rules for hyphenating the language. If you want to
add your own rules for hyphenation, you can add exceptions. You can
enter words in the New Entry box that you want hyphenated a certain
way. If you no longer want an exception, you can delete it at any time.
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The Plug-ins preferences give you the ability to organize your plug-ins
by saving them in one or more folders. These additional folders are typ-
ically used to hold third-party plug-ins. When selected, plug-ins con-
tained within the folder will be available in Illustrator. Organizing your
plug-ins into folders helps keep your projects focused and reduces the
clutter of plug-ins when you want to select them. If you’re not sure
what plug-ins are installed you can view a list using System Info.

Selecting Plug-Ins

Select Plug-Ins Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Plug-ins & Scratch Disks. 

Select the Additional Plug-ins
Folder check box if you have
additional plug-ins stored outside
the default Illustrator plug-ins
folder.

If you change the location of your
additional plug-ins folder, you can
always click Choose and navigate
to it.

Click OK.

Display Plug-Ins

Click the Help menu, and then
click System Info.

Scroll down the list until you can
see the plug-ins. 

Click OK.3
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Selecting Scratch
Disks

Select Scratch Disks Options

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Plug-ins & Scratch Disks. 

Click the Primary list arrow, and
then select a location for use as a
virtual memory location for
processing.

Click the Secondary list arrow, and
then select a location for use as a
secondary virtual memory location
for processing when needed.

IMPORTANT Illustrator holds
scratch disk space as long as the
application is open. To delete
scratch disk space you must close
Illustrator.

Click OK.5

4

3

2

1

The Scratch Disk preferences are available to help you get the best
performance out of your computer by letting you choose one or more
hard drives for scratch operations. When your computer doesn't have
enough RAM to perform an operation, Illustrator uses free space on
any available drive, known as a Scratch Disk. Illustrator runs faster
when you divide the Scratch Disk workload. Scratch operations are
performed on your hard drive and take place when Illustrator is using
one of its many filters and adjustments. Illustrator detects and displays
all available disks in Plug-ins & Scratch Disks preferences, where you
can select the disks you want to use. By assigning additional hard
drives to the task, you speed up Illustrator's overall performance.
Scratch Disk changes take effect the next time you start Illustrator.
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User Interface preferences give you control over some user interface
features. If you prefer to use individual windows for your documents,
you can turn off the Open Documents As Tabs option; otherwise, it’s on
by default. You can use the Brightness control to specify different
shades of gray for the program user interface. You can also set the
canvas area to the Brightness control setting or white (New!). In addi-
tion, you can also set options to automatically collapse icon panels
when you click away from them. You can also adjust the location of
scroll arrows in the scroll bar to your personal preference, either
together or at two ends (New!).  

Setting User Interface
Preferences

Set User Interface Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click User Interface. 

Select from the following
Interface options:

◆  Brightness. Drag the slider to
specify a gray value from Dark
to Light for the background of
all panels.

◆  Canvas Color. Select an option
to match the color with the
user interface brightness or
use white (New!).

◆ Auto-Collapse Iconic Panels.
Automatically collapses icon
panels when you click away.

◆ Open Documents As Tabs.
Select to open documents as
tabs instead of individual
document windows.

◆ Scroll Buttons. Select an option
to place scroll arrows at two
ends or use them together on
one side (New!).

Click OK.

Some options don’t take effect
until you restart Illustrator.
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In File Handling & Clipboard preferences, you can set file linking and
copying to the Clipboard options. You can set file linking options to dis-
play linked images as low-resolution to increase performance, set dis-
play options to view bitmaps as anti-aliased images in Pixel Preview
(New!), and specify how to update the links. In addition, you can set
options to specify what format you want to use to copy content to the
Clipboard. The available options include PDF and AICB (a PostScript
format). For the AICB option, you can also select an option to copy the
selection as a set of detailed paths or to preserve the selection’s
appearance and any overprinting.

Setting File Handling
& Clipboard
Preferences

Work with File Handling &
Clipboard Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click File Handling & Clipboard. 

Select from the following Files
options:

◆  Use Low Resolution Proxy for
Linked EPS. Select to display
linked images as low-resolution
to increase performance.

◆  Display Bitmaps as Anti-
Aliased Images in Pixel
Preview. Select to display
bitmaps as anti-aliased images
in Pixel Preview mode (New!).

With Pixel Preview, you can
preview how objects appear
when rasterized. Click the View
menu, and then click Pixel
Preview. Anti-aliasing provides
a sharper edge.

◆ Update Links. Specify how to
update linked images:
Automatically (no dialog box),
Manually (update in the Links
panel), or Ask When Modified
(use dialog box). 
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Select from the following
Clipboard on Quit options:

◆ Copy As PDF. Select to copy a
selection to the Clipboard in the
PDF file format, which
preserves transparency.

◆ Copy As AICB (no transparency
support). Select to copy a
selection to the Clipboard in the
AICB file format (a PostScript
format). Select an option to
copy the selection as a set of
detailed paths or to preserve
the selection’s appearance and
any overprinting.

Click OK.5
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If a printer uses a combination of CMYK inks instead of the actual 100K
black tone to create a rich black look, you can set options in the
Appearance of Black preferences to specify how you want to create
the appearance of black in your documents. There are two available
options to determine the appearance of black in your document: one
for On Screen and another one for Printing/Exporting. Each of the
options allows you to specify how you want to work with the appear-
ance of black (true black or rich black) in your documents.

Working with
Appearance of Black
Preferences

Work with Appearance of Black
Preferences

Click the Edit (Win) or Illustrator
(Mac) menu, and then point to
Preferences.

Click Appearance of Black. 

Select from the following
Appearance of Black options:

◆  On Screen. Select Display All
Blacks Accurately to display
blacks based on actual CMYK
color values or select Display
All Blacks as Rich Black to
display all blacks as rich blacks
(a mix of CMYK values).

◆ Printing / Exporting. Select
Output All Blacks Accurately
to print blacks using actual
CMYK color values on RGB and
grayscale devices, or select
Output All Blacks as Rich
Black to print blacks as rich
blacks (a mix of CMYK values)
on RGB devices.

Click OK.4
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A wise man once wrote "time is money," and Illustrator is a program that
can consume a lot of time. That's why the Illustrator application uses
keyboard shortcuts. Keyboard Shortcuts, as their name implies, let you
perform tasks in a shorter period of time. For example, if you want to
open a new document in Illustrator, you can click the File menu, and
then click New, or you can abandon the mouse and press Ctrl+N (Win)
or A+N (Mac) to use shortcut keys. Using shortcut keys reduces the
use of the mouse and speeds up operations. In fact, studies have
shown, it can save 1 hour out of every 8 in a work day. Illustrator raises
the bar by not only giving you hundreds of possible shortcut keys, which
you can search for (New!), but also allowing you to define your own.

Defining Shortcut 
Keys 

Create a Keyboard Shortcut

Click the Edit menu, and then click
Keyboard Shortcuts.

Click the list arrow, and then click
Menu Commands or Tools.

To search for a command or
shortcut, enter a phrase in the
Search box (New!). The results
appear as you type.

◆  Match Case. Select to view
exact results (New!).

Select an item from the list.

Use the keyboard to create the
new shortcut. For example, press
Ctrl+N (Win) or A+N (Mac).

To work with the shortcut, do any
of the following:

◆  Undo. Click to undo shortcut.

◆  Clear. Click to clear the
selected shortcut.

◆  Go To Conflict. Click to display
the shortcut conflict.

To work with a keyset file, do any
of the following:

◆  Save. Click to save the custom
keyset file.

◆  Delete. Click to delete the
selected custom keyset.

Click OK

Specify a keyset file name, and
then click OK.
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Using Drawing Tablets

When you design on a computer, you're leav-
ing the natural world of oil, watercolor, and
canvas, for the electronic world of computer
monitors and pixels (don't worry, it's a rela-
tively painless transition). Without a doubt,
there are many differences between tradi-
tional and digital design; however, it's not
necessary to abandon all aspects of the natu-
ral media world. For example, the computer
mouse has always been a problem with
designers who miss the feel and control of a
brush in their hands. Fortunately, technology
came to the rescue years ago, with the inven-
tion of the drawing tablet. Drawing tablets
combine a drawing surface and a brush-like
drawing tool in the form of a pen. A designer
picks up the pen and moves it across the
drawing tablet surface. In turn, the drawing
tablet interprets those movements as brush
strokes. Not only does Illustrator fully support

drawing tablet technology, it also interprets
the particular drawing style of the designer.
For example, pushing harder with the brush
against the drawing tablet instructs Illustrator
to create a wider stroke, or to apply more
color. Drawing tablets have helped to trans-
late the control of working with real art
brushes on canvas, into the world of the digi-
tal designer. Of all the manufacturers, Wacom
stands out as the leader in drawing tablet
technology. Wacom returns the feel of design-
ing with a brush to the digital designer's
world, and the software required to power the
tablet works seamlessly with Illustrator and
the Windows or Macintosh operating sys-
tems. To check out which tablet might be right
for your needs, point your browser to
www.wacom.com and check out the available
options.

Drawing pen

Wacom tablet

www.wacom.com
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Working Together with
Adobe Programs

Introduction

Adobe programs are designed to work together so you can
focus on what you need to do, rather than on how to do it. In
fact, the Adobe programs share tools and features for your
most common tasks so you can work uninterrupted and
move seamlessly from one program to another. Adobe
Creative Suite is an integrated collection of programs that
work together to help you create designs in print, on the
web, or on mobile devices. When you install Adobe Creative
Suite or a stand-alone Adobe program, you also get addi-
tional Adobe programs and services—Bridge, Camera Raw
plug-in, Media Encoder, Extension Manager, and ExtendScript
Toolkit—to help you perform specific jobs, such as locating,
downloading, and modifying images for projects, managing
files and program extensions, testing files for different
mobile devices, and creating scripts.

Adobe Bridge is a program that lets you view, open, mod-
ify, and manage images located on your computer from any
Adobe Creative Suite program. Adobe Bridge is literally the
glue that binds Adobe Creative Suite programs together into
one cohesive unit with shared tools. Bridge allows you to
search, sort, filter, manage, and process image files one at a
time or in batches. You can also use Bridge to do the follow-
ing: create new folders; rename, move, delete and group
files; edit metadata; rotate images; create web galleries and
contact sheets; and run batch commands. You can also
import files from your digital camera and view file informa-
tion and metadata. 18

18
What You’ll Do

Explore Adobe Programs

Explore Adobe Bridge

Get Started with Adobe Bridge

Get Photos from a Digital Camera

Work with Raw Images from a 
Digital Camera

Modify Images in Camera Raw

Work with Images Using Adobe Bridge

Set Preferences in Adobe Bridge

Apply Image Adjustments

Create a Web Photo Gallery

Automate Tasks in Adobe Bridge

Use Mini Bridge

Work with Adobe Media Encoder

Work with Adobe Extension Manager

Script with Adobe ExtendScript Toolkit
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Adobe Creative Suite
Adobe Creative Suite is an integrated collec-
tion of programs that work together to help
you create designs in print, on the web, or on
mobile devices. Adobe's Creative Suite comes
in different editions with different combina-
tions of Adobe programs. The main programs
for print design include InDesign and Acrobat
Professional; for graphic design the programs
include Photoshop, Illustrator, and Fireworks;
for video and sound design the programs
include Premiere Professional, After Effects
Professional, Encore, and Soundbooth; and
for web design the programs include Flash
Professional, Dreamweaver, Fireworks, and
Contribute.

Working Together with Adobe
Programs
When you install Adobe Creative Suite or a
stand-alone Adobe program, you also get
additional Adobe programs—Bridge, Camera
Raw plug-in, Media Encoder, Extension
Manager, and ExtendScript Toolkit—to help
you perform specific jobs such as managing
files and program extensions and testing files
for mobile devices.

Adobe Bridge
Adobe Bridge is a file management/batching
program that manages and processes images
while you work. To use Bridge, click Browse in
Bridge on the File menu or the Go to Bridge
button on the Applications bar within an
Adobe CS product or from the desktop use
the Start menu (Win) or the App folder (Mac).

Camera Raw Plug-In
The Camera Raw plug-in—available in Adobe
Bridge, Adobe Photoshop, and other Adobe

programs—allows you to open and process
with fine control RAW image formats (not
processed, also known as digital negatives)
produced by digital cameras. Raw image for-
mats are intended to capture as closely as
possible the characteristics of the picture.
DNG (Digital NeGative) is a raw format
developed by Adobe.

Adobe Media Encoder
Adobe Media Encoder allows you to encode
and compress video and audio files and con-
vert them to distribution formats: F4V, FLV,
H.264, and MP3. You can select a format and
preset for systems—such as high-definition
(HD), desktops, and the web (Flash, Vimeo,
and YouTube)—and devices—such as Apple
TV, iPad, iPhone, and Android. The presets
include: size, bitrate (data rate), and frames
per second (fps) rate. 

Adobe Extension Manager
Adobe Extension Manager allows you to
install and delete added program functional-
ity, known as extensions, to many Adobe
programs. The Extension Manager is auto-
matically installed when you install InDesign,
Flash Professional, Dreamweaver, or
Fireworks. You can use the Extension
Manager to access the Adobe Exchange site,
where you can locate, research, and down-
load many different types of extensions for
use in Adobe programs.

Adobe ExtendScript Toolkit
Adobe ExtendScript Toolkit allows you to cre-
ate, edit, and debug an extended version of
JavaScript, called ExtendScript, to be used
for scripting Adobe programs. If you perform
the same set of tasks on a regular basis, you
can use scripting as a powerful tool to make
a lengthy set of tasks simple.

Exploring Adobe Programs
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Exploring Adobe Bridge

Folders panel
Displays the folders
on your computer in
a tree structure.

Keywords panel
Allows you to assign

and remove keywords
associated with

images.

Filter panel
Displays files

based on filter
criteria.

Favorites panel
Displays links to

common features
and favorite places.

Metadata panel
Provides metadata

information about the
selected image.

Preview panel
Displays a preview of
the selected image.

Content panel
Displays the current content.

Workspaces  
Choose from common
workspaces.

Quick Search 
Search for file names,
keywords, folder names.

File path 
To trace file

back to its
folder.
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Adobe Bridge CS6 (New!) is a stand-alone program that lets you view,
open, and manage images located on your computer from any Adobe
Creative Suite program. Adobe Bridge is literally the glue that binds
Adobe Creative Suite programs and shared tools together into one cohe-
sive unit. The Bridge program provides a set of panels that make it easy
to find, view, and manage the files on your computer or network. As you
work with Bridge, you'll open, close, and move (dock and undock) the
panels to meet your individual needs. After you customize the work-
space, you can save the location of the panels as a custom workspace,
which you can display using the Workspace command on the Window
menu. Bridge also provides some predefined workspaces.

Getting Started with
Adobe Bridge

Get Started with Adobe Bridge

Launch your Adobe product, click
the File menu, and then click
Browse in Bridge.

◆ You can also click the Go to
Bridge button on the Application
bar (if available). Ctrl (Win) or
A (Mac)+ click for a
maximized view, Alt (Win) or
Option (Mac)+click to open a
new Bridge window, or
Shift+click to open Mini Bridge.

◆ You can also start Adobe Bridge
from the Start menu (Win) or the
Applications folder (Mac).

To open and close a panel, click the
Window menu, and then click the
panel name you want. 

To move a panel, drag the panel tab
you want to another location in the
Bridge window.

To save a workspace, click the
Window menu, point to
Workspace, click New Workspace,
type a name, and then click OK.

To display a workspace, click the
Window menu, point to
Workspace, and then click the
workspace you want.

When you’re done, click the Close
button in the Bridge window.

6

5

4

3

2

1
1 The Go to Bridge button on the Application bar in InDesign
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Getting Photos from 
a Digital Camera

Import Raw and Other Files from
a Camera

In Adobe Bridge, click the File
menu, and then click Get Photos
from Camera or click the camera
icon on the Application bar.

Click the Get Photos From list
arrow, and then select the source
camera or memory card. 

Click the Browse button to select
a folder location, and then create
a new subfolder to store the
images (optional).

To rename the files, select a
method, and then enter file name
text.

Select the options you want:

◆ Preserve Current Filename in
XMP. Select to save the current
filename as image metadata.

◆ Open Adobe Bridge. Select to
open and display the files in
Adobe Bridge.

◆ Convert To DNG. Select to
convert Camera Raw files to
DNG. Click Settings to set DNG
conversion options.

◆ Delete Original Files. Select to
delete original files from
camera or memory card.

◆ Save Copies To. Select to save
copies to another folder for
backup. 

To apply metadata to the files,
click Advanced Dialog.

Click Get Photos.7
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If you have raw or other images from your digital camera, you can use
the Get Photos from Camera command in Adobe Bridge to retrieve and
copy them to your computer. This allows you to specify where you want
to store the files, rename them if you want, preserve metadata, or con-
vert them to the DNG format. When you convert raw files to the DNG
format, you specify preview size, compression, and whether to pre-
serve the raw image data or embed the original raw file.

6

2

3

7

4

5



ptg8126863

476 Chapter 18

Working with Raw
Images from a Digital
Camera

Set Camera Raw Preferences

In Adobe Bridge, click the Edit
(Win) or Adobe Bridge (Mac) menu,
and then click Camera Raw
Preferences.

◆ In the Camera Raw dialog box,
you can also click the Open
Preferences Dialog button on
the toolbar to access camera
raw preferences.

Select the preferences you want:

◆ General. Specify where Camera
Raw file settings are stored. Use
Sidecar XMP files to store
settings separately, or Camera
Raw Database to store settings
in a searchable database.

◆ Default Image Settings. Select
options to automatically apply
settings or set defaults.

◆ Camera Raw Cache. Set a
cache size to shorten loading
time for thumbnails and
previews. 

◆ DNG File Handling. Select
options to ignore XMP files or
update embedded content.

◆ JPEG and TIFF Handling.
Automatically open JPEGs
and/or TIFFs in Camera Raw.

Click OK.3

2

1
3

2

Raw image file formats are created by most mid- to high-end digital
cameras and contain information about how the image was taken. The
raw format turns off all camera adjustments, and simply saves the image
information. Using the raw format is as close to using traditional film as
a digital camera can get. Raw images are larger; however, the increase
in file size gives you more information that can be used by Camera Raw
to adjust the image. Camera Raw version 7 (New!) is installed along
with an Adobe CS program as a plug-in. It supports more than 400 cam-
eras. Before you get started with Camera Raw, you can set preferences
to apply default image options and specify how you want to open and
work with work with DNG (Digital Negative), JPEG, and TIFF images.
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Save
Options

Work with Images in Camera
Raw

In Adobe Bridge, select the images
(camera raw, TIFF or JPEG), right-
click the selection, and then click
Open in Camera Raw.

◆ In Photoshop, you can use the
Open dialog box to open a file in
Camera Raw.

The Camera Raw dialog box opens.

Click any of the tools to modify or
enhance the image, and select the
Preview check box to  see all
changes that have been made.

Click any of the tabs to modify or
enhance the image.

The Basics tab is easier to use
with all sliders having a starting
point in the middle (New!).

Click the Camera Raw Menu
button to Load, Save, or Apply a
specific set of Raw settings.

◆ You can use the Presets tab to
apply, create, or delete presets.

Click Save Image(s) to specify a
folder destination, file name, and
format for the processed images.

When you’re done, click Done to
process the file, but not open 
it, or click Open Image(s) to
process and open it in Photoshop.
Hold Alt (Win) or Option (Mac) to
use Open Copy or Reset.
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Modifying Images in
Camera Raw

Modify Images in Camera Raw

In Adobe Bridge, select the images,
right-click the selection, and then
click Open in Camera Raw.

◆ In Photoshop, you can use the
Open dialog box to open a file in
Camera Raw.

The Camera Raw dialog box opens.

Click any of the tabs—Basic, Tone
Curve, Detail (Sharpen & Noise
Reduction), HSL / Grayscale, Split
Toning, Lens Corrections, Effects,
Camera Calibration, Presets, or
Snapshots—to change the options
you want.

To automatically make tonal
adjustments, click Auto on the
Basic tab.

Use sliders or enter values to make
any other manual adjustments.

◆ Basic. Use sliders for
Temperature, Tint, Exposure,
Contrast, Highlights (New!),
Shadows (New!), Whites
(New!), Blacks (New!), Clarity,
Vibrance, and Saturation.

4

3

2
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From Adobe Bridge, you can use Camera Raw version 7 (New!) to open
raw files (extensions differ based on the digital camera), JPEG, and TIFF
files to make image touch-ups and enhancements. For example, you can
have a poorly take image, and then use the Basic settings to automati-
cally or manually enhance image exposure, contrast, highlights, shad-
ows, clarity, and vibrance. If you're not sure what to do, you can click
Auto to have Camera Raw do it or drag sliders to adjust options manu-
ally. You can adjust color tones (Hue, Saturation, and Luminance or
grayscale), reduce luminance and color noise, add grain, add sharpen-
ing, correct for lens defects, add post-crop vignetting and effects, and
retouch images with the Heal, Clone and Red Eye tools. In addition, raw
images can be converted into 16-bit mode, which provides more control
over adjustments such as tonal and color correction. Once processed,
raw images can be saved in the DNG (Digital Negative), TIFF, PSD, or
JPEG formats. After you make Camera Raw adjustments, you can save
the settings so you can use them later. All changes made to raw images
are non-destructive, meaning only the metadata is changed to make dif-
ferent versions, leaving the original data unchanged.

2
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Use tools to modify the image:

◆ Use the Zoom, Hand, Rotate,
Crop, and Straighten tools to
change the size, orientation,
and position of the image.

◆ Use the White Balance tool to
set the image white balance or
the Color Sampler tool to
sample a color from the image.

◆ Use the Spot Removal or Red
Eye Removal tool to fix the
image.

◆ Use the Adjustment Brush,
Gradient Filter (New!), or
Targeted Adjustment tool to
make adjustments to exposure,
brightness, contrast, saturation,
clarity, sharpness, and color.

Use options to view the image:

◆ Preview. Select to display the
image with all changes that
have been made.

◆ Zoom Level. Changes to the
level of image magnification
can be made here.

Click the file name to change the
(color) Space, (bit) Depth, Size,
and Resolution of the image.

Click Save Image(s) to specify a
folder destination, file name, and
format for the processed images.

Select the images you want to
synchronize (apply settings) in the
Filmstrip (if desired, click Select
All), and then click Synchronize.

Click the Camera Raw Menu
button to Load, Save, or Apply a
specific set of Raw settings.

◆ You can use the Presets tab to
apply, create, or delete presets.

When you’re done, click Done to
process the file, but not open 
it, or click Open Image(s) to
process and open it in Photoshop.
Hold Alt (Win) or Option (Mac) to
use Open Copy or Reset.
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What is the DNG File Format?
The DNG, or Digital Negative, format is an openly published raw file
format from Adobe that stores "raw" pixel data captured by digital
cameras before it has been converted to another format, such as
TIFF or JPEG. In addition, it captures standard ‘EXIF’ metadata, such
as date, time, camera used, and camera settings. Saving raw files in
the DNG format provides several advantages. DNG files are smaller
than uncompressed TIFFs, and they do not have the artifacts of com-
pressed JPEGs. Many key camera parameters, such as white bal-
ance, can be modified even after the image is captured. You have
access to 16-bit data for greater detail and fidelity, and the added
flexibility of converting a single file using multiple conversion set-
tings. When you convert raw images into the DNG format, you are
using a format that is openly published by Adobe and usable by other
software and hardware vendors, which makes it a safe format for
the long-term storage and archiving of digital images. The raw for-
mat used by digital cameras is proprietary to the specific camera
(e.g., NEF for Nikon, CR2 for Canon, RAF for Fuji), so the format might
not be supported once that camera and its proprietary software is
obsolete, which means at some point in the future, you might not be
able to open any of your archived raw images. The DNG format
solves that problem. To get a free copy of the DNG converter, go to
www.adobe.com and then search for DNG converter.

For Your Information

www.adobe.com
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With Adobe Bridge, you can drag assets into your layouts as needed,
preview them, and add metadata to them. Bridge allows you to search,
sort, filter, manage, and process image files one at a time or in batches.
You can also use Bridge to create new folders; rename, move, delete
and group files (known as stacking); edit metadata; rotate images; and
run batch commands. You can also view information about files and
data imported from your digital camera.

234

7

Working with Images
Using Adobe Bridge

Work with Images Using Bridge

Launch your Adobe product, click
the File menu, and then click
Browse in Bridge, or click the
Launch Bridge button (if available).

Click the Folder path, and then
select a folder.

Click the Folders tab and choose a
folder from the scrolling list.

Click the Favorites tab to choose
from a listing of user-defined items,
such as Pictures.

Click an image within the preview
window to select it.

Click the Metadata tab to view
image information, including date
and time the image was shot, and
aperture, shutter speed, and f-stop. 

Click the IPTC Core or IPTC
Extension arrow to add user-
defined metadata, such as creator
and copyright information, or
captions.

Click the Preview tab to view a
larger thumbnail of the selected
image. Multiple images appear
when you select them.

◆ Click the image in the Preview
tab to display a Loupe tool for
zooming. Drag magnified box to
change positions. Click it to
deactivate the tool. 

Drag the Zoom slider to increase or
decrease the thumbnail views.
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Click the preview buttons to select
a different view of the workspace
you have chosen. If you want to
view your images in filmstrip or
metadata focus mode, choose that
workspace from the Window
menu.

◆ View Content as Thumbnails.
Default view. Displays the
images as thumbnails with the
file name underneath.

◆ View Content as Details.
Displays a thumbnail of each
image with selected details
about the image such as date
created, document type,
resolution.

◆ View Content as List. Displays
a small thumbnail of each
image with metadata
information details, such as
date created and file size.

Use the file management buttons
to sort, open or delete images, or
create a new folder.

To narrow down the list of images
using a filter, click the criteria you
want to use in the Filter panel.

To add a label or rating to images,
select the ones you want, click the
Label menu, and then select the
label or rating you want.

To group related images as a
stacked group, select the images,
click the Stacks menu, and then
click Group as Stack.

◆ Use the Stacks menu to
ungroup, open, expand, or
collapse stacks.

Double-click on a thumbnail to
open it in the default program, or
drag the thumbnail from Bridge
into an open Adobe application.

15
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What is Metadata?
Metadata is information about an image file, such as its author,
copyright, creation date, size, version, color space, resolution, and
searchable keywords. This data is stored in the file or in a separate
file known as a sidecar file, using a standard format called
Extensible Metadata Platform (XMP). Bridge uses XMP files to help
you organize and search for files on your computer. Metadata is also
stored in other formats, such as EXIF (digital camera data), IPTC
(photographer and image data), GPS (global positioning system
data), and TIFF, which are all synchronized with XMP.

For Your Information

14

13 Rotate buttons
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Setting Preferences 
in Adobe Bridge

Set Bridge Preferences

In Adobe Bridge, click the Edit
(Win) or Bridge (Mac) menu, and
then click Preferences.

Click the General category.

Select the appearance, behavior,
and Favorite Items you want.

◆ Appearance. Select options for
color theme (New!), user
interface brightness, image
backdrop, and accent color.

◆ Favorite Items. Select the items
you want to access and use.

Click the Thumbnails category.

Specify the performance and
details options you want:

◆ Performance and File Handling.
Choose the maximum size of
file to be processed (default:
1000 MB).

◆ Details. Select the metadata
details you want to show with
the thumbnail.

Click the Metadata category.

Select the check boxes with the
metadata you want and clear the
ones you don’t want.

Click the Labels category.

Enter names for labels you want to
be associated with a specific
color.
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Adobe Bridge allows you to set preferences to customize the way you
work. The Preferences dialog box is organized into categories—includ-
ing General, Thumbnails, Playback, Metadata, Keywords, Labels, File
Type Associations, Cache, Startup Scripts, Advanced, and Output. You
can set specific options within these categories to suit your particular
needs. For example, you can choose to display more metadata informa-
tion with thumbnails, such as dimensions, size, keywords, color mode,
label, etc. In addition, you can change the user interface with a color
theme (New!), brightness, backdrop, and accent color.
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10

11

14
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Click the File Type Associations
category.

The left column displays the file
type and the right column displays
the current program that will open
the file by default.

To change the default program,
click the list arrow next to the file
type, and then select a program or
choose Browse to locate another
application you would like to use.

Click the Cache category.

Choose where to store the cache,
choose a cache size, and optimize
or purge the cache from here.

Click the Startup Scripts category.

Select the check boxes with the
programs you want to enable and
clear the ones you want to disable.

Click the Advanced category, and
specify whether to use software
rendering and monitor-size
previews, and then choose the
language and keyboard options
you want. You can also choose to
have Bridge start automatically at
login.

Click OK.17
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Adobe Bridge makes it easy to make adjustments to one image in
Camera Raw and then apply those adjustments to other images directly
from Bridge without going back into Camera Raw. For instance, you
may be correcting the white balance for an image and have many other
images that were shot at the same time, under the same lighting condi-
tions. You can use the initial settings to correct the rest of your images
right from Bridge. You can also make a preset from your favorite adjust-
ments, which will then be available as a develop setting within Bridge.

Applying Image
Adjustments 

Modify Images in Adobe Bridge

In Adobe Bridge, display and
select the images that you want to
adjust. 

Use any of the following methods
to modify an image:

◆ Apply a Preset Adjustment.
Click the Edit menu, point to
Develop Settings, and then
select a preset adjustment.

◆ Copy and Paste Settings. Click
the Edit menu, point to Develop
Settings, and then click Copy
Settings. Select the image(s) to
which you want to apply the
settings. Click the Edit menu,
point to Develop Settings, and
then click Paste Settings.
Select the options to apply, and
then click OK.

◆ Apply the Most Recent
Adjustment. Click the Edit
menu, point to Develop
Settings, and then click
Previous Conversion. 

2

1

Did You Know?
You can use Photoshop automation
commands in Adobe Bridge. You can
use the Batch or Image Processor
commands on the Tools menu under
Photoshop in Bridge to automate the
processing of your camera's raw files.

1

Paste Settings

2
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Adobe Bridge takes the drudgery out of creating a Web Photo Gallery
(thumbnail images on web pages). The pages generated with this com-
mand display small thumbnails of a group of images—when you click
on an image, a larger version is displayed within another window or
section of the page. If your goal is to show the world your photographs,
but you don't want to write all the HTML code involved in making that
happen, then the Web Photo Gallery is just what you need. 

Creating a Web Photo
Gallery 

Create a Web Photo Gallery in
Adobe Bridge

In Adobe Bridge, select the
images that you want to use for
the photo gallery. 

Click the Workspace menu, and
then click Output.

Click the Web Gallery button.

Click the Template list arrow, and
then select a template. 

◆ Click the Refresh Preview
button to view your template
choices or click the Preview in
Browser button to see how it
would look on the web.

Use the following panels to
customize the Web gallery:

◆ Site Info. Provide descriptive
information about the Web
Photo gallery.

◆ Color Palette. Select custom
colors for screen elements.

◆ Appearance. Specify options to
show file names, a preview and
thumbnail size, slide duration,
and a transition effect. 

In the Create Gallery panel, enter a
gallery name, and then select  a
creation option:

◆ Save to Disk. Click Browse to
specify a location, and then
click Save.

◆ Upload. Specify the FTP server
location, user name, password,
a folder, and then click Upload.
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The Tools menu provides commands you can use to automate tasks in
Bridge. For example, you can automate the process of renaming a
group of files using the Batch Rename command. If you use Photoshop,
or InDesign, you can use commands on submenus to run automated
tasks, such as processing raw images with Photoshop, or you can cre-
ate a contact sheet of images in InDesign. You can also use the Tools
menu to start other Adobe programs as well as create and edit
Metadata templates, which you can use to append or replace metadata
in InDesign or other XMP-enabled programs. 

Automating Tasks in
Adobe Bridge

Rename Files Automatically in
Adobe Bridge

In Adobe Bridge, select the files or
folders you want to use.

Click the Tools menu, and then
click Batch Rename.

Select the Destination Folder
option you want: Rename in same
folder, Move to other folder, or
Copy to other folder, and then
click Browse to specify a new
folder location.

Click the Element drop-down, and
then select options to specify how
you want to name the files:

◆ Text, New Extension, Current
Filename, Preserved Filename,
Sequence Number, Sequence
Letter, Date/Time, Metadata, or
Folder Name.

Enter the text you want to use in
conjunction with the Element
selection to name the files.

Select the Preserve Current File
Name In XMP Metadata check
box to retain the original filename
in the metadata.

Select the check boxes for the
operating systems with which you
want the renamed files to be
compatible.

Click Rename.8
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Adobe Mini Bridge is a condensed version of Adobe Bridge available in
a panel within an Adobe CS program (Photoshop, InDesign, and
InCopy). Mini Bridge allows you to directly access graphics within a CS
program, where you can drag and drop them in a document. Within
Mini Bridge, you can navigate to different locations on your computer,
search, sort, filter, and preview content as well as  access Adobe
Bridge. In Photoshop, the Mini Bridge panel appears in film strip mode
(New!), like in Lightroom.

Using Mini Bridge 

Use Mini Bridge

Launch your Adobe product, and
then start Mini Bridge: 

◆ Photoshop. Click the File menu,
and then click Browse in Mini
Bridge or click the Window
menu, point to Extensions, and
then click Mini Bridge.

◆ InDesign/InCopy. Shift+click the
Go to Bridge button on the
Application bar.

If prompted, click Launch Bridge. 

Mini Bridge opens in the panel. 

Use the Path or Path button and the
Navigation pod to locate the
graphics you want to view.

Use the buttons (View, Sort, and
Filter) on the Tool bar to show,
select, sort, and filter files.

To preview files, click the View
button, and then click an option:

◆ Slideshow. Displays a slide
show of the viewed files.

◆ Review Mode. Displays a full
screen preview of the viewed
files.

◆ Full Screen Preview. Displays a
full screen preview. You can also
press the Spacebar.
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1 The Go to Bridge button on the Application bar
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Adobe Media Encoder CS6 (New!) is a program you can use to encode
and compress video and audio files and convert them to a variety of dis-
tribution formats: F4V, FLV, H.264, and MP3. With the Preset Browser
(New!), you can select a format and preset for systems—such as high-
definition (HD), desktops and the web (Flash, Vimeo, and YouTube)—and
devices—such as Apple TV, iPad, iPhone, and Android. The presets
include: size, bitrate (data rate), and frames per second (fps) rate. When
you export a movie for playback on a specific type of device at a certain
bandwidth, you select an encoder (codec). Each encoder has a corre-
sponding decoder that decompresses and interprets the data for play-
back. You can batch process multiple media files to expedite the
workflow process. For example, you can add, reorder, and change the
encoding settings of files in the batch processing queue while Media
Encoder encodes other files. You can also use the Watch folder to help
you automate the process. It’s a folder you add to the Watch folder list
that automatically encodes any files you place in it. 

Working with Adobe
Media Encoder

Convert Media Files Using
Presets

Start Adobe Media Encoder from
the All Programs menu (Win) or the
Applications folder (Mac).

Click the Add Source button (+),
select the media files you want to
convert, and then click Open.

Select each media file, click the
Format list arrow, and then select a
conversion file format. Click the
Preset list arrow, and then select a
predefined setting.

To use the Preset Browser, select
the media file, select a preset, and
then click Apply Preset (New!).

This adds a copy of the selected
file with the preset applied.

◆ Presets. Use toolbar buttons to
create, delete, group, view
settings, import, and export
presets (New!). 

Click the Start Queue button.

The media files are converted to
the new media format and placed
in the same folder as the original. 

When you’re done, click the Close
button to exit the program.
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Multiple conversion formats 4
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Convert Media Files Using
Custom Settings

Start Adobe Media Encoder from
the All Programs menu (Win) or the
Applications folder (Mac).

Click the Add Source button (+),
select the media files you want to
convert, and then click Open.

TIMESAVER You can drag one
or more files from the desktop or
file window directly into the queue.

To create a duplicate copy of a
media file to set different settings,
select the media file, and then click
the Duplicate button.

To apply custom export settings,
select the media file, click the Edit
menu, click Export Settings,
specify the settings you want, and
then click OK.

To use a watch folder, click the Add
Folder button (+), select the folder
you want to use, and then click OK.

◆ Select each folder, click the
Format list arrow, and then
select a conversion file format.
Click the Preset list arrow, and
then select a predefined setting. 

TIMESAVER You can drag one
or more folders from the desktop or
file window directly into the queue.

Click the Start Queue button.

The media files are converted to
the new media format and placed
in the same folder as the original. 

When you’re done, click the Close
button to exit the program.
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Adobe Extension Manager CS6 (New!) is a program you can use to
install and delete added program functionality, known as extensions, to
many Adobe programs. The Extension Manager is automatically
installed when you install Flash, Dreamweaver, InDesign, or Fireworks.
You can use the Extension Manager to access the Adobe Exchange site,
where you can locate, research, and download many different types of
extensions with the ZXP or MXP (for compatibility) file format. ZXP is an
Adobe Zip Format Extension Package file. Some are free and some are
not. After you download an extension, you can use Extension Manager
to install it for all users or only the current user. In Extension Manager,
you can search and filter (New!), enable, disable, and remove exten-
sions. You can also create, edit, activate, import, and export extension
sets for better management (New!). 

Working with Adobe 
Extension Manager

Install and Use an Extension

Start Adobe Extension Manager
from the Start menu (Win) or the
Applications folder (Mac).

TIMESAVER In Flash,
Dreamweaver, InDesign, or
Fireworks, click the Help menu, and
then click Manage Extensions.

To locate an extension, click
Exchange to access the Exchange
web site, download an extension,
and then save it.

To install an extension, click Install,
locate and select the extension
(.zxp or .mxp), and then click Open.

To create, edit, activate, import, and
export extension sets, click
Manage Sets (New!). 

Perform any of the following:

◆ Search. Select a filter from the
down arrow, and then enter
search name (New!).

◆ Extension Set. Click the down
arrow to select a set (New!).

◆ Sort. Click a column heading.
◆ Enable or Disable. Select or

deselect the Enabled check box.
◆ Remove. Select the extension,

and then click Remove.

When you’re done, click the Close
button.
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Adobe ExtendScript Toolkit CS6 (New!) is a program you can use to
create and test scripts to control and automate features in many Adobe
Create Suite programs. If you perform the same set of tasks on a regu-
lar basis, you can use scripting as a powerful tool to make a lengthy set
of tasks simple. A script is a series of statements in a language—an
extended version of JavaScript, called ExtendScript—that tells a pro-
gram what to do. For example, you can write a script to open an image
in Photoshop, make some enhancements, and then insert the image
into an InDesign document. If you’re new to scripting, take a look at the
Adobe Intro To Scripting document, which you can open from the Help
menu. You can also use the Scripts panel to access favorite and sam-
ple scripts by target program. You can open the script, modify it, save it,
and run it within the target program. Another option is the search the
web for ExtendScript sample scripts. ExtendScript programs and
scripts end with the extension JSX. A normal JavaScript file ends with
the extension JS.

Scripting with Adobe
ExtendScript Toolkit

Use ExtendScript Toolkit to Work
with Scripts

Start Adobe ExtendScript Toolkit
from the All Programs menu (Win)
or the Applications folder (Mac).

To use a built-in script, select the
Scripts panel, select a target
program, and then navigate to a
script, and then double-click it to
open it.

To start a new script, click the File
menu, and then click New
JavaScript.

Enter or edit the script in the
Document window.

To start, stop, pause, or step
through the script, click the buttons
on the Document window toolbar.

◆ You can also use commands on
the Debug menu. 

Click the File menu, and then click
Save. If a new script, enter a name,
specify a location, and then click
Save.

When you’re done, click the Close
button to exit the program.

7
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New! Features

n

n
Adobe Illustrator CS6
Adobe Illustrator CS6 means superior results faster, with new features and enhance-
ments that help you create and manage your images more easily and efficiently. The
indispensable new and improved features help graphic web designers, photogra-
phers, and video professionals create the highest quality images, with the control,
flexibility, and capabilities that you expect from the professional standard in desktop
digital imaging.

Each new release of Illustrator brings with it new features, improvements, and
added sophistication. This edition is aimed at the web designer, interactive media
professional, or subject matter expert developing multimedia content, and the appli-
cation developer.

Only New Features
If you’re already familiar with Illustrator CS5, you can access and download all the
tasks in this book with Adobe Illustrator CS6 New Features to help make your transi-
tion to the new version simple and smooth. The Illustrator CS6 New Features as well
as other Illustrator CS5 to Illustrator CS6 transition helpers are available on the web
at www.perspection.com.

What’s New
If you’re searching for what’s new in Illustrator CS6, just look for the icon: New!. The
new icon appears in the table of contents and throughout this book, so you can
quickly and easily identify a new or improved feature in Illustrator CS6. The follow-
ing is a brief description of each new feature and its location in this book.

Illustrator CS6
◆ 64-bit now available (p. 2-3, 5)   All features have been enabled to work in 64-bit

to provide faster processing, quicker application of effects, and a smoother
workflow. 32-bit plug-ins don’t work in the 64-bit version of Illustrator. Windows
users can choose between the 32-bit and 64-bit versions, while Mac users use
the 64-bit version exclusively.

www.perspection.com
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◆ User Interface redesigned (p. 6-7, 465-466)   The user interface has been
redesigned with the ability to choose a different interface color by selecting
from a range of tonal values between light and dark themes. Four presets are
available with custom values as an option. You can also choose to use white for
a canvas color or to match the canvas color to the interface brightness, and
adjust the location of scroll arrows.

◆ Dialog Box redesign (p. 6-7)   Dialog boxes use the interface color. Commit
buttons, such as OK, Cancel, etc., are at the bottom-right corner in all modal
dialog boxes. In addition, you have full keyboard access in all dialog boxes.

◆ Panels redesign (p. 8-11)   There are new icon designs for all panels, giving the
program a completely new look. There is a Resize bar at the bottom of some
panels to make it easier to resize them.

◆ Control panel redesign (p. 13)   The Control Panel icons have been reorganized
and de-cluttered. For consistency, most controls now appear in the same place
on the panel as you change from one object type to another.

◆ Open Adobe Idea File (p. 14-15)   Adobe Illustrator CS6 comes with the Adobe
Creative Cloud desktop plug-in, which you can open and edit files (.IDEA)
created in your Adobe Touch Apps.

◆ Saving legacy documents (p. 26-27)   When you save a document created in an
earlier version of Illustrator, known as a legacy format, you get a dialog box,
asking if you want to continue.

◆ Document Profile changes (p. 31)   The Basic CMYK profile has been removed.
The Web profile has new sizes: 960 x 560 pixels and 1280 x 800 pixels. The
Mobile and Devices profile has been replaced with the Devices profile, which
provides templates for the iPad, iPhone, Xoom, Fire/Nook tablets, and Galaxy S
phones. The Flash Catalyst profile has been changed to use Flash Builder.

◆ New Document Setup Preset (p. 34-35)   For Complex Art is a new Document
Setup preset available with the High, Medium, Low, and Custom options.

◆ Artboard display buttons (p. 38-39)   You can access artboard buttons on the
Control panel, instead of using list arrows.

◆ Workspaces (p. 60-61)   The Workspaces menu adds built-in workspaces for
Layout and Tracing, which goes along with the Image Trace feature.

◆ Maximum size for Rounded Rectangle (p. 68)   The maximum value for the
Rounded Rectangle shape is 16,383 points.

◆ Scale Strokes & Effects option (p. 98-99, 102-103)   The check box option has
been added to the Transform panel and the Transform and Transform Each
dialog box. The option is still available on the Options menu.

◆ Transform options (p. 102-103)   Check box options for Transform Objects and
Transform Patterns have been added to the  Transform and Transform Each
dialog boxes. Select options to transform only objects or the object’s pattern.

◆ Fill and Stroke Color options (p. 113)   The Default Fill and Stroke and Swap Fill
and Stroke icons are available on the Color panel.

◆ Inline name editing (p. 116-117, 202, 214-215, 336, 338)   You can edit the names
of layers, swatches, symbols and other content directly in panels. Double-click
the item name in a list view to select and edit the name in the panel.
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◆ Color groups (p. 118-119)   You can use colors in selected artwork to create a
color group.

◆ Vonster patterns and styles (p. 120, 273)   Swatch Libraries and Graphic Styles
Libraries include Vonster patterns and styles designed by artist Von Glitschka. 

◆ Pattern creation (p. 146--148)   With the Pattern Options panel, you create, edit,
and save pattern designs. In Pattern Editing mode (within the Pattern Options
panel), you can create and edit patterns interactively and view your changes on
the artboard as you design.

◆ Anti-alias rasters (p. 158)   The anti-alias option has been added to the Flatten
Transparency dialog box. 

◆ Gradient on stroke (p. 160-161)   You can apply a gradient directly to a stroke
without needing to expand the stroke and then fill it with a gradient. You have
three types of gradient strokes: Within Stroke (gradient fills the stroke), Along
(gradient follows path), and Across (gradient crosses path).

◆ Locate Object (p. 200, 217)   The Layers panel button allows you to jump to the
layer on which your selected object is located. The option is still available on the
Options menu.

◆ Formatting type (p. 244)   The Character panel includes formatting options: All
Caps, Small Caps, Superscript, and Subscript. The formatting options are still
available on the Options menu.

◆ Image Trace (p. 268-271, 307, 368)   Live Trace has been replaced with Image
Trace. This upgraded tracing tool produces tracings with less paths and anchor
points, as well as better color recognition than Live Trace. Use the Image Trace
panel options to choose from new presets and make modifications. You can
also use the ImageTracing script to perform batch processing.

◆ Gaussian Blur (p. 298-299)   The Gaussian Blur filter has been upgraded with a
live preview and better performance. Older versions of the blur filter effect are
titled “Legacy Gaussian Blur” in the Appearance panel. If you edit the effect, it’s
converted to the new filter version.

◆ For Complex Art print option (p. 394)   The print option is available as a preset
for printing artwork with complex shapes and lines.

◆ Preserve artboards with SVG (p. 416-417)   When you save a document as a
SVG, you can preserve artboards within the file.

◆ Save Slices (p. 443, 449)   In the Save for Web dialog box, you can specify the
slices you want to save.

◆ Browser Dither (p. 451)   In the Save for Web dialog box, you can select the
Browser Dither option to view how a browser dithers your image. 

◆ Slices preferences (p. 461)   In the Slices Preferences dialog box, you can select
a custom color from a Color box.

◆ Dictionary preferences (p. 462)   In the Dictionary & Hyphenation Preferences
dialog box, you can select an option to update legacy documents to the new
dictionary.

◆ File preferences (p. 466)   In the File Handling & Clipboard Preferences dialog
box, you can select an option to display bitmaps as anti-aliased images in pixel
preview.

n
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◆ Keyboard shortcuts (p. 469)   In the Keyboard Shortcuts dialog box, you can
search for a command or shortcut.

◆ Adobe Bridge (p. 474, 482-483)   Adobe Bridge CS6 allows you to manage
images and work with metadata. You can change the user interface with a color
theme, brightness, backdrop, and accent color.

◆ Camera Raw 7.0 (p. 476-479)   You can recover more highlights than ever before
and have access to a wider dynamic range. The Basics tab is easier to use with
all sliders having a starting point in the middle. The plug-in supports more than
400 camera models.

◆ Mini Bridge (p. 478)   The Mini Bridge panel appears in film strip mode, like in
Lightroom.

◆ Adobe Media Encoder (p. 488-489)   Adobe Media Encoder CS6 allows you to
render and export video files.

◆ Adobe Extension Manager (p. 490)   Adobe Extension Manager CS6 allows you
to create, edit, activate, import, and export extension sets.

◆ Adobe ExtendScript Toolkit (p. 491)   Adobe ExtendScript Toolkit CS6 allows you
to create and test scripts to control and automate features in many Adobe
Create Suite programs.

What Happen To ...
◆ CS Live   The CS Live menu command has been removed. This also includes the

Share My Screen commands on the File menu. 

◆ Device Central command   The Device Central command on the File menu has
been removed. The Save for Web & Devices commands has been changed to
Save for Web. The Devices portion of the feature has been removed.

◆ Scripts   The FreehandToAI script on the Scripts submenu on the File menu has
removed. The LiveTrace script has been replaced by the ImageTrace command.

◆ Workspaces   The Like Freehand, Live InDesign, and Like Photoshop
workspaces have been removed from the Workspaces menu.

◆ Unsharp Mask   The Unsharp Mask Photoshop Effect on the Effect menu has
been removed.

◆ Flash Text   The Flash Text has been removed. This includes the Flash Text panel
and the Flash Dynamic Text and Flash Input Text commands on the Object
submenu on the Select menu.

◆ Tracing Presets command   The Tracing Presets command on the Edit menu has
been removed. The functionality has been incorporated into the Image Trace
feature.

◆ WBMP File Format   The WBMP file format has been removed from the Save for
Web dialog box.

◆ SWF and SVG File Format   The SWF and SVG file formats have been removed
from the Save for Web dialog box; however, they are still available in the Save
As dialog box.n
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Adobe Certification
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c
About the Adobe Certified Expert (ACE) Program
The Adobe Certified Expert (ACE) program is for graphic designers, web designers,
systems integrators, value-added resellers, developers, and business professionals
seeking official recognition of their expertise on Adobe products.

What Is an ACE?
An Adobe Certified Expert is an individual who has passed an Adobe Product Profi-
ciency Exam for a specific Adobe software product. Adobe Certified Experts are eli-
gible to promote themselves to clients or employers as highly skilled, expert-level
users of Adobe software. ACE certification is a recognized worldwide standard for
excellence in Adobe software knowledge. There are three levels of ACE certification:
Single product certification, Specialist certification, and Master certification. To
become an ACE, you must pass one or more product-specific proficiency exams and
sign the ACE program agreement. When you become an ACE, you enjoy these spe-
cial benefits:

◆ Professional recognition

◆ An ACE program certificate 

◆ Use of the Adobe Certified Expert program logo

What Does This Logo Mean?
It means this book will prepare you fully for the Adobe Certified Expert exam for
Adobe Illustrator CS6. The certification exam has a set of objectives, which are
organized into broader skill sets. The Adobe Certified Expert objectives and the spe-
cific pages throughout this book that cover the objectives are available on the web
at www.perspection.com.

IL 3.1

www.perspection.com
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Choosing a Certification Level
There are three levels of certification to become an Adobe Certified Expert. 

◆ Single product certification. Recognizes your proficiency in a single Adobe
product. To qualify as an ACE, you must pass one product-specific exam. 

◆ Specialist certification. Recognizes your proficiency in multiple Adobe products
with a specific medium: print, web, or video. To become certified as a Specialist,
you must pass the exams on the required products. To review the requirements,
go online to http://www.adobe.com/support/certification/ace_certify.html.

◆ Master certification. Recognizes your skills in terms of how they align with the
Adobe product suites. To become certified as a Master, you must pass the exam
for each of the products in the suite. 

Preparing for an Adobe Certified Expert Exam
Every Adobe Certified Expert Exam is developed from a list of objectives, which are
based on studies of how an Adobe program is actually used in the workplace. The
list of objectives determine the scope of each exam, so they provide you with the
information you need to prepare for ACE certification. Follow these steps to com-
plete the ACE Exam requirement: 

Review and perform each task identified with a Adobe Certified Expert objective
to confirm that you can meet the requirements for the exam. 

Identify the topic areas and objectives you need to study, and then prepare for
the exam. 

2

1

http://www.adobe.com/support/certification/ace_certify.html
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Review the Adobe Certified Expert Program Agreement. To review it, go online
to http://www.adobe.com/support/certification/ace_certify.html.

You will be required to accept the ACE agreement when you take the Adobe
Certified Exam at an authorized testing center.  

Register for the Adobe Certified Expert Exam. 

ACE testing is offered at more than a thousand authorized Pearson VUE and
Thomson Prometric testing centers in many countries. To find the testing center
nearest you, go online to www.pearsonvue.com/adobe (for Pearson VUE) or
www.2test.com (for Prometric). The ACE exam fee is US$150 worldwide. When
contacting an authorized training center, provide them with the Adobe Product
Proficiency exam name and number you want to take, which is available online
in the Exam Bulletin at http://www.adobe.com/support/certification/ 
ace_certify.html. 

Take the ACE exam.

Getting Recertified
For those with an ACE certification for a specific Adobe product, recertification is
required of each ACE within 90 days of a designated ACE Exam release date. There
are no restrictions on the number of times you may take the exam within a given
period. 

To get recertified, call Pearson VUE or  Thomson Prometric. You will need to verify
your previous certification for that product. If you are getting recertified, check with
the authorized testing center for discounts.

5

4

3

http://www.adobe.com/support/certification/ace_certify.html
www.pearsonvue.com/adobe
http://www.adobe.com/support/certification/ace_certify.html
http://www.adobe.com/support/certification/ace_certify.html
www.2test.com


ptg8126863

500

c

Taking an Adobe Certified Expert Exam
The Adobe Certified Expert exams are computer-delivered, closed-book tests con-
sisting of 60 to 90 multiple-choice questions. Each exam is approximately one to
two hours long. A 15-minute tutorial will precede the test to familiarize you with the
function of the Windows-based driver. The exams are currently available worldwide
in English only. They are administered by Pearson VUE and Thomson Prometric,
independent third-party testing companies. 

Exam Results
At the end of the exam, a score report appears indicating whether you passed or failed
the exam. Diagnostic information is included in your exam report. When you pass
the exam, your score is electronically reported to Adobe. You will then be sent an
ACE Welcome Kit and access to the ACE program logo in four to six weeks. You are
also placed on the Adobe certification mailing list to receive special Adobe
announcements and information about promotions and events that take place
throughout the year.

When you pass the exam, you can get program information, check and update your
profile, or download ACE program logos for your promotional materials online at:

http://www.adobe.com/support/certification/community.html

Getting More Information
To learn more about the Adobe Certified Expert program, read a list of 
frequently asked questions, and locate the nearest testing center, go online to:

http://www.adobe.com/support/certification/ace.html

http://www.adobe.com/support/certification/community.html
http://www.adobe.com/support/certification/ace.html
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To learn more about other Adobe certification programs, go online to:

http://www.adobe.com/support/certification

http://www.adobe.com/support/certification
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Index

A
accented edges effects, 301
actions

Actions panel, 358–359
adding commands to, 364
adding stops to, 362
batch file processing, 366–367
building new, 360
built-in scripts, 368
controlling playback of, 361
deleting commands from, 365
inserting a non-recordable command in

an Action, 363
order of commands in, changing, 364
recording, 360
running actions within actions, 360
saving

as files, 359
into sets, 359

scripts, 368–369
activation, 2
active documents, 21
active windows, 20
Adobe.com, 450
Adobe Bridge

automating tasks in, 486
browsing documents with, 16
Camera Raw feature, 476–479
color settings, 109
components of, 473
description of, 472
editing images in, 484
Get Photos from Camera command, 475
opening documents with, 16–17, 474
placing graphics from, 262–263
preferences, setting, 482–483
revealing documents in, 16

Web Photo Gallery creation, 485
working with images using, 17, 480–481

Adobe Creative Cloud, 15
Adobe Dreamweaver, 418
Adobe ExtendScript Toolkit, 472, 491
Adobe Extension Manager, 472, 490
Adobe Flash Builder, 31
Adobe Flex File, saving documents as, 

420-421
Adobe Idea File (IDEA), 14-15
Adobe Media Encoder, 488-489
Adobe Mini Bridge, 487
Adobe PDF Presets command (Edit menu),

409
Adobe Product Improvement Program, 25
Adobe Studio Exchange, 2
Adobe SVG Viewer, 418-419
Adobe Updater, 23
Adobe Web site

Adobe Studio Exchange, 2
Community Help, 24

advanced print options, 394–395
Advanced tab (File Info dialog box), 399
alignment

anchor points, 178–179
objects, 96
paragraphs, 246
pixel grid, 67
slices, 447
stroke, 138

All Objects command (Select menu), 90
All Objects in Active Artboard command

(Select menu), 90
anchor points

adding new, 176–177
alignment, 178–179
average, 173
Convert Anchor Point tool, 175
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anchor points (continued)
converting, 174–175
deleting, 177
direction lines, 172
endpoints, 179
highlighting, 172
moving, 172–173
paths and, 65
preferences, 172
selecting with Direct Selection tool, 84
showing and hiding, 65
smooth points, converting to corner

points, 174
anchors, 457
Android (Media Encoder), 488-489
anti-aliasing, 245, 454
Appearance of Black preferences, 468
Appearance panel, 278–279

exporting as CSS3 file, 418-419
Apple devices (Media Encoder), 488-489
Arc tool, 72
arcs, drawing, 72
area graphs, 372-373
Area Type tool, 222, 225
arranging

documents, 20
layers, 208–209
slices, 446–447

arrowheads, stroke, 140-141
art brushes, 324–325
Artboard tool

artboard creation, 36
Artboard Options button, 37
multiple artboards, 38

artboards
within artboards, 36
aspect ratio, 37
centerpoints, 37
deleting, 38
display options, 39
duplicating, 36
exiting editing mode, 36
landscape/portrait orientation, 37
moving, 38
multiple, working with, 38
navigating within, 36
presets, 36
previewing, 38

resizing, 38
rotating, 38
size, 37
switching between, 19, 39
video safe areas, 37
X and Y positioning, 37

artwork, inserting in documents, 18
Assign Profile command (Edit menu), 110
attributes

appearance, 278–279
stroke, 138–141

Audio Data tab (File Info dialog box), 398
auto slices, 440
AutoCAD File format, 403

B
bar graphs, 372-373
batch file processing, 366–367
Batch Rename command, 486
bend styles, 95
bevel bend style, 95
bevel joins, 139
bitmap, exporting documents as, 404
black appearance options, 468
bleed

bleed print option, 389
document creation, 34

Blend command (Objects menu), 151–152
Blend tool, 153
blends

blending fill colors, 150
changing and applying blend options,

152
creating automatically, 151
creating with Blend tool, 153
making and releasing blend objects, 151
objects, modifying, 154
opacity, 155
transformation, 154
transparency settings, 156

Bloat tool, 332
Blob Brush tool

brush options, setting, 189
merging paths with, 188

blur effects, 298-299
BMP format, 403
bold font, 236
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Bounding Box command (View menu),
314–315

Bridge (Adobe)
automating tasks in, 486
browsing documents with, 16
Camera Raw feature, 476–479
color settings, 109
components of, 473
description of, 472
editing images in, 484
Get Photos from Camera command, 475
Mini Bridge, 487
opening documents with, 16–17, 474
placing graphics from, 262–263
preferences, setting, 482–483
revealing documents in, 16
Web Photo Gallery creation, 485
working with images using, 17, 480–481

Bristle brushes, 328-329
creating and editing, 328-329

Browse in Bridge command (File menu),
16–17, 262–263

browser
preview in (Save for Web), 451

brushes
art, 324–325
Blob Brush tool, 189
Bristle, 328-329
Brushes panel, 317
calligraphic, 322–323
deleting, 330
library, saving, 331
Paintbrush tool, 318–319
pattern, 326–327
scatter, 320–321
strokes, removing, 330

Brushes panel, 317
built-in scripts, actions, 368

C
calligraphic brushes, 322–323
Camera Data tab (File Info dialog box), 398
Camera Raw feature, 472, 476–479
canvas (user interface), 465
canvas (Object menu)

HTML5 Canvas (HTML5 Pack), 418

caps, 139
case, text, 383
Categories tab (File Info dialog box), 398
center mark, 39
centerpoints, 37
Character panel, 238-245

formatting type, 244
Character Styles panel, 250-251
Check Spelling command (Edit menu), 378
circles, drawing, 68
clean up unneeded elements, 375
clearing

guides, 51
objects, 93

clipping masks
creating, 194
creating for groups or layers, 195
editing, 196
masked object, editing in Isolation

Mode, 197
release objects from, 195

clipping sets, 197
Close button, 28
Close command (File menu), 28
closed paths, 65
closing

documents, 28
Illustrator, 28
panels, 8-9

CMYK (Cyan, Magenta, Yellow and Black)
color mode, 30, 111, 115

collapsing panels, 8-9
Color Guide panel

applying color with, 128–129
color groups, 129
harmony rules, variations based on, 129
variation options, selecting, 127
variation types, displaying, 127

color management print options, 396
color modes. See also colors

changing, 112
CMYK, 30, 111, 115
document creation, 30
Grayscale, 30, 114
RGB, 30, 111, 114
switching between, 111
working with, 111
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Color panel
Color sliders, 114
working with, 114–115

colored paper simulation, 35
colors. See also Color Guide panel; color

modes; Swatches panel
applying to objects, fills, or stroke, 113,

136-137
applying with Eyedropper tool, 144–145
Color Guide Panel, 127–129
Color panel, 114–115
color profiles, changing or removing, 109
color settings, changing, 108–109
converting to grayscale, 125
crop mark registration color, 56-57
gamut warning icon, 115
global, 124–126
grayscale images, 125
grid colors transparency settings, 35
grids, 54
group, creating, 118-119
guides, 50, 53
hue, 115
inverting, 126
Kuler panel, 122–123
Live Color feature, 130–131
luminosity, 115
nonglobal, 124–126
proofing, 132-133
replacing, 124–125
saturation, 115
selecting, 115
soft proof, 132-133
Swatches panel, 116–121
themes, 122–123
ungroup, 119
view box color, 44
Web-safe, 115

column graphs, 372-373
combining

slices, 448
commands

adding to actions, 364
basic description of, 6-7
deleting from actions, 365
Panel Options menu, 11

Community Help site, 24
compound paths

creating, 192
releasing, 193
reversing object's fill in, 193

condensed font, 236
Constrain Angle general preference, 454
Control panel

anchor points, converting, 175
basic description of, 13
splitting paths using, 186-187
tools in, 6-7

Convert Anchor Point tool, 175
Convert to Shape command (Effect menu),

284
convert to shape effects, 284
converting anchor points, 174–175
Copy command (Edit menu), 233
copying text, 232–233
corner points, 174
Corner Radius general preference, 454
Create New Action button (Actions panel),

359
Create New Set button (Actions panel), 359
crop marks

creating, 56-57
deleting, 56
general preferences, 455
registration color, 56
trim marks, editable, 57

cross hairs, 39
Crystallize tool, 332
CSS (Cascading Style Sheets)

exporting as CSS3 file, 418-419
setting properties, for SVG, 417

cursor preferences, 454
curved segments, 173
curves, drawing, 171
custom dictionaries, spell checking, 379
Cut command (Edit menu), 233
cutout effects, 300

D
dashed stroke, 140
data graphs, 372-373
data sets

creating, 370–371
deleting, 370–371
renaming, 371
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data variables, 370–371
deactivate Illustrator, 22
Delete button (Actions panel), 359
deleting

anchor points, 177
artboards, 38
brushes, 330
commands from actions, 365
crop marks, 56-57
data sets, 370–371
files, 14
graphic styles, 277
layers, 205
objects, 93
selections, 92
slices, 442
symbols, 337
workspaces, 61

Description tab (File Info dialog box), 398
Deselect command (Select menu), 90
dialogs

Reset All Warning Dialogs, 455
DICOM tab (File Info dialog box), 399
dictionary preferences, 462
dictionaries, spell checking, 379
diffuse glow effects, 301
Direct Selection tool

anchor points, adding new, 176
anchor points or segments, moving, 173
deleting anchor points using, 177
end points, connecting, 179
selecting anchor points and segments

with, 84
showing/hiding direction lines, 65
understanding selections, 82

direction lines
anchor points, 172
showing and hiding, 65

Distort & Transform command (Effect
menu), 102, 291

distributing
objects, 96
slices, 447

dithering, 435
dividing 

paths, 185
slices, 448

drawing mode, 66

behind, 66
normal, 66
inside, 66

DOC format, 229
docking

documents, 21
panels, 10

Document Color Mode command (File
menu), 112, 384

Document Info panel, 400
Document Setup command (File menu), 34,

159
Document window, 6-7
documents

active, 21
arranging, 20
bleed and view options settings, 34
browsing with Adobe Bridge, 16
closing, 28
color modes, 30
creating

from scratch, 30
from templates, 32–33
using presets, 31

docking/undocking, 21
exporting

as bitmap, 404
Export command, 402
export file formats, 403
as Flash Movie, 410–411
to Photoshop, 408
with presets, 409
as TIFF format, 405

file information, inserting, 398–399
finding and replacing text and elements

in, 380–381
grid pattern, 21
inserting images in, 18
language settings, 35
linking, 18
measurement units, 34
opening

with Adobe Bridge, 16–17
existing documents, 14
recently opened, 15

printing, 384
revealing in Adobe Bridge, 16
rulers, 48–49
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documents (continued)
saving, 26–27

as Adobe Flex File, 420-421
as EPS format, 414–415
as FXG format, 420-421
as Microsoft Office, 422
as PDF format, 412–413
as SVG format, 416-418
as template, 423
for the Web, 426–427

setting up, 34–35
spell checking, 378–379
switching between, 20
tabbed, 20
templates, 18
transparency settings, 34–35
type options settings, 35
view size, 19
viewing information in, 19
views, 40–43
windows, 20–21
working with multiple, 20–21

DOCX format, 229
double quotes, 35
drawing

arcs, 72
circles, 68
curves, 171
ellipses, 68
line segments, 71
with Pencil tool, 304–305
polygons, 70, 170
rectangle grids, 74
rectangles, 69
spirals, 72–73
stars, 70

drawing tablets, 470
drop shadow effects, 287
duplicating

artboards, 36
color in Swatches panel, 117
graphic styles, 275
layers, 210
objects, 94–95
slices, 442, 448
symbols, 338

E
Edit Colors command (Edit menu), 126, 150
Edit Custom Dictionary command (Edit

menu), 379
Edit menu commands

Adobe PDF Presets, 409
Assign Profile, 110
Check Spelling, 378
Color Settings, 108
Copy, 233
Cut, 233
Edit Colors, 126, 150
Edit Custom Dictionary, 379
Find and Replace, 380–381
Paste, 232–233
Paste in Back, 233
Paste in Front, 233
Print Presets, 385
Redo, 59
Transparency Flattener Presets, 395
Undo, 59

Edit Selection command (Select menu), 92
Edit View command (View menu), 40
editing

blend objects, 154
clipping masks, 196
color in Swatches panel, 117
colors with Live Color, 130–131
gradients, 164
graphic styles, 276
images in Adobe Bridge, 484
paths within clipping sets, 197
patterns, 148
selections, 92
symbols, 339

Effect menu commands
Convert to Shape, 284
Crop Marks, 56
Distort & Transform, 102
Effect Gallery, 294–297
Stylize, 285

effects
accented edges, 301
applying multiple, 296
blur, 298-299
controlling with selections, 297
convert to shape, 284
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cutout, 300
diffuse glow, 301
distort, 291
drop shadow, 287
dry brush, 300
Fresco, 300
gaussian blur, 298-299
glass, 301
glowing edges, 301
grain, 302
graphic pen, 302
Illustrator, 282–283
inner glow, 286–287
mosaic tiles, 302
note paper, 301
outer glow, 286–287
panel knife, 300
Photoshop Effect Gallery, 294–295
plastic wrap, 302
previewing, 282
raster graphics, 292
scribble, 285
spatter, 302
stained glass, 302
stamp, 301
text, 228
transform, 291
3D, 288–289
vector objects, 293
warp, 290

Ellipse tool, 68
ellipses, drawing, 68
embedded graphics, 266–267
endpoints, 179
Enhanced Metafile format, 403
Envelopes, reshaping with, 104-105
EPS format, 27, 399, 414–415
Eraser tool, 182
erasing path parts, 182
exiting Illustrator, 28
Expand button (Pathfinder panel), 190
Expand command (Objects menu), 160-161
expanding

gradients, 160-161
panels, 8-9
patterns, 149

ExportDocsAsFlash, script, 368–369

exporting
documents

as bitmap, 404
as CSS3, 418-419
Export command, 402
as Flash Movie, 410–411
as JPEG, 406-407
to Photoshop, 408
as PNG, 406-407
with presets, 409
as TIFF format, 405

export file formats, 403
ExtendScript Toolkit, 472, 491
Extension Manager (Adobe), 472, 490
Extensions command (Window menu),

122–123
Eyedropper tool

applying colors and attributes with,
144–145

color attributes, changing, 145
Save for Web tool, 428-429

F
families, font, 236
File Handling & Clipboard preferences, 

466-467
File Info command (File menu), 398
file information, inserting into documents,

398–399
File menu commands

Browse in Bridge, 16–17, 262–263
Close command, 28
Device Center, 41
Document Color Mode, 112, 384
Document Setup, 34, 159
File Info, 398
New, 30–31
New From Template, 32
Open, 14, 260
Open Recent, 15
Open With, 262
Place, 18, 261, 264, 266
Print, 384, 386
Return to Adobe Illustrator, 16
Revert, 26
Save, 26
Save a Copy, 27
Save As, 27, 33
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File menu commands (continued)
Save for Web, 426–429, 430-431
Scripts, 368–369

files
deleting, 14
formats (Save for Web), 426-431
images, optimizing to file size (Save for

Web), 439
saving actions as, 359

fills
applying color to, 113, 128, 136-137
blending fill colors, 150
patterns as, 146–149

Find and Replace command (Edit menu),
380–381

Find Font command, 382
Fire/Nook device, 31
Fit All In Window command (View menu),

46
Fit Artboard In Window command (View

menu), 46
Flare tool, 69
Flash Builder, 31
Flash format, SWF, 403, 410-411
Flash Movie, exporting documents as,

410–411
Flash (Media Encoder), 488-489
Flattener Preview command (Window

menu), 41, 395
flattening layers, 216
flattening object transparency, 158
fonts

bold, 236
condensed, 236
families and styles, 236
Find Font command, 382
finding, 237
italic, 236
OpenType fonts, 254
replacing, 237
reusing recent, 236
size, 238

formatting type, 244
Freehand format, 14
Free Transform tool, 98–99
Fresco effects, 300
full screen mode, 45
FXG format, 27, 420-421

G
gamut warning icon, 115
Galaxy S device, 31
Gap options, 316
gaussian blur effects, 298-299
General preferences, 454
Get Photos from Camera command

(Adobe), 475
GIF documents, optimizing, 434–435
GIF format, 399
glass effects, 301
global colors, 124–126
glowing edges effects, 301
glyphs, 253
Go to Bridge button, 16–17
GPS Data tab (File Info dialog box), 398
Gradient tool, 165
gradients

applying to objects, 160-161
creating, 163
editing, 164
expanding, 160-161
fill, 160
Gradient Annotator, 165
Gradient tool, 165
libraries, using, 162
linear type, 163
mesh, 104-105, 166-167
radial type, 163
stroke, 161

grain effects, 302
graphic pen effects, 302
graphics

embedded, 266–267
linked, 266–267
linking, 264–265
mosaic, 280
opening graphic images, 260
placing, 261–263
print options, 390
raster

interpolation and, 64
tracing, 268–272
understanding raster graphics, 64

styles
applying, 273
breaking links to, 277
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creating, 274
deleting, 277
duplicating, 275
editing, 276

graphs, 372-373
add designs, 374
create and format, 372-373

Grayscale color mode, 30, 114
grayscale images, 125
grid colors transparency settings, 35
grid patterns, 21
Grid, Perspective

adjusting, 79
copying, 80
customizing, 81
drawing, 78
moving, 80
objects, adding, 80
resizing, 80
text, adding, 80

grid, pixel aligned, 67
grid size transparency setting, 34
grids. See also guides

color, 54
displaying in back of artwork, 54
Polar Grid tool, 75
preferences, 54
Rectangle Grid tool, 74
showing and hiding, 54
Snap to Grid command, 54
styles, 54
subdivisions, 54
Transparency, 159

Group command (Objects menu), 88
Group Selection tool, 82
grouping objects, 88–89
groups

creating clipping masks for, 195
colors, creating in the Swatches panel,

118-119
guides. See also grids

clearing, 51
color, 50
converting vector objects to, 51
creating, 51
locking, 50
preferences, 50
ruler, 49

showing and hiding, 50
smart guides

object transformation, 99
preferences, 53
turning on/off, 52
working with, 52–53

snap to point, 50
style, 50
switching, 51

H
Hand tool

moving elements around with, 55
quick access to, 55
Save for Web tool, 428-429

handles, 457
hanging indents, 247
hardware, Illustrator system 

requirements, 3
Help menu commands

Adobe Product Improvement Program,
25

Illustrator Help, 24–25
Updates, 23

help options
Community Help site, 24
searching topics, 25

Hide Edges command (View menu), 65
Hide Panels command (Window menu), 20
hiding

anchor points, 65
direction lines, 65
grids, 54
guides, 50
layers, 212
panels, 10, 45
rulers, 49
slices, 442–443
Transparency grid, 159

highlighting anchor points, 172
histograms, 479
History tab (File Info dialog box), 399
HSB color slider (Color panel), 114
HTML text, adding to slices, 444
HTML5 Pack, 418-419

exporting as CSS3, 419
saving as SVG, 418
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hue, 115
hyphenation, 249, 462
hyphenation preferences, 462

I
icons, collapsing and expanding panel sets

between icons and panels, 11
Illustrator Help command (Help menu),

24–25
Illustrator tab (File Info dialog box), 399
images

inserting in documents, 18
replacing, 18
working with images using Bridge, 17

ImageTracing, script, 368–369
image tracing options, 268-271
Image Trace panel, 268-271
importing text, 229
indentation

hanging indents, 247
paragraphs, 247

Info panel
color fill and stroke information, 58
uses for, 58

inner glow effects, 286–287
iPad device, 31

Media Encoder, 488-489
IPTC tab (File Info dialog box), 398
IPTC Extension tab (File Info dialog box),

398
iPhone device, 31

Media Encoder, 488-489
installing Illustrator

in Macintosh, 3
in Windows, 2

Internet, checking for updates from, 22
interpolation, 64
Inverse command (Select menu), 90
inverting colors, 126
IPTC tab (File Info dialog box), 398
Isolation Mode, 197
italic font, 236

J
JavaScript, 416-418
joining anchor endpoints, 179
joins, 139

JPEG documents, optimizing, 432–433
JPEG format, 399, 403

exporting as, 406-407
justification options, 255

K
kerning type, 240
Keyboard Increment general preference,

454
keyboard shortcuts, 469
Knife tool, 185
Knockout Group option, 156
Kuler panel, 122–123

L
landscape/portrait orientation, 37
language settings, document creation, 35
Lasso tool

selecting objects with, 85
understanding selections, 82

layers. See also Layers panel
arranging, 208–209
creating clipping masks for, 195
creating top level layers, 202–203
deleting, 205
deselecting, 204
duplicating, 210
flattening, 216
hiding, 212
locking, 211
merging, 213
moving, 208–209
moving objects to, 214–215
naming, 203
outlines, viewing, 219
Paste Remembers Layers, 214
releasing objects to, 215
reverse order, 208
selecting, 204
selecting objects with, 206–207
showing and hiding, 212
sublayers, 202–203
template, creating, 218

Layers panel. See also layers
accessing, 200
components of, 200
locating objects in, 217
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options, setting, 201
layouts, workspace, 60
leading text, 239
libraries

brushes, saving, 331
gradients, 162

ligature, 255
line graphs, 372-373
Line Segment tool, 71
line segments, drawing, 71
linear gradient type, 163
linked graphics, 266–267
linking

documents, 18
graphics, 264–265
slices, 443

Liquify tools, 335
Live Color feature

applying color groups to objects with,
130–131

editing colors with, 130–131
Live Paint Bucket tool

paint fills, 310
preferences, setting, 309
selecting options to paint fills or strokes

with, 308
stroke edges, changing, 311

Live Paint Groups
adding paths to, 315
converting traced objects to, 307
creating, 306–307
Gap options, 316
reshaping or moving paths in, 314–315

Live Paint Selection tool, 312–313
locking, 211
guides, 50
layers, 213

lossy compression, 435
lowercase text, 383
luminosity, 115

M
Macintosh

Illustrator system requirements, 3
installing Illustrator in, 3
starting Illustrator in, 5

Macintosh PICT format, 403

Magic Wand tool
selecting objects with, 86–87
understanding selections, 82

marks print options, 388–389
Measure tool, 58
measurement

distance between objects, measuring, 58
measurement units, document creation,

34
Media Encoder, 488-489
menus, 6-7
merging

layers, 213
paths, 188–189

mesh, 104-105, 166-167 
metadata, 398-399
Microsoft Office, saving documents as, 422
Mini Bridge, 487
miter bend style, 95
miter joins, 139
Mobile SWF tab (File Info dialog box), 398
mode, drawing, 66
mosaic tiles effects, 280, 302
Move tool, 52
moving

anchor points, 172–173
artboards, 38
document elements with Hand tool, 55
layers, 208–209
objects, 93
objects to layers, 214–215
segments, 172–173
slices, 446
text, 227, 232–233
between tools, 55

N
naming

layers, 203
selections, 92
workspaces, 60

navigation
artboards, 39
within artboards, 36

Navigator panel
customizing, 44
view area, 43
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Navigator panel (continued)
view box color, 44
view size, 42

New command (File menu), 30–31
New From Template command (File menu),

32
New View command (View menu), 40
Next Object Above command (Select

menu), 90
Next Object Below command (Select

menu), 90
9-slice scaling, 352-353
nonglobal colors, 124–126
non-recordable command in an Action, 363
normal screen mode, 45
note paper effects, 301

O
objects

alignment, 96
applying color to, 113, 128, 136-137
clearing, 93
deleting, 93
distributing, 96
duplicating, 94–95
grouping, 88–89
measuring distance between, 58
moving, 93
moving to layers, 214–215
Perspective Grid

adjusting, 79
copying, 80
customizing, 81
drawing, 78
moving, 80
objects, adding, 80
resizing, 80
text, adding, 80

pixel grid, aligned, 67
reflecting, 97, 101
rotating, 97–98, 100
scaling, 97, 100
selecting

with Lasso tool, 85
with Magic Wand tool, 86–87
similar objects, 90–91
using Direction Selection tool, 84

using Select menu, 90–91
using Selection tool, 83

Shape Builder tool, 76-77
transforming, 97–99

Objects menu commands
Blend, 151–152
Clipping Mask, 194
Compound Path, 192
Expand, 160-161
Group, 88
Text Wrap, 256
Transform, 102
Ungroup, 88

offsetting paths, 95, 187
opacity, blends, 155
opacity mask, transparency, 157
Open command (File menu), 14, 260
open paths, 65, 177
Open Recent command (File menu), 15
OpenType fonts, 254
Open With command (File menu), 262
opening

documents
with Adobe Bridge, 16–17
existing documents, 14
recently opened, 15

graphic images, 260
panels, 8-9

optimizing
images to file size (Save for Web), 439

Origin tab (File Info dialog box), 399
outer flow effects, 286–287
Outline view, 40–41
outlines, 257
outlines, viewing layers as, 219
output print options, 392–393
overflow, text, 234–235
Overprint Preview command (View menu),

41, 391

P
Paintbrush tool, 181
painting

art brushes, 324–325
Brushes panel, 317
calligraphic brushes, 322–323
Live Paint Bucket tool, 308–311
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Live Paint Groups
adding paths to, 315
converting traced objects to, 307
creating, 306–307
Gap options, 316
reshaping or moving paths in,

314–315
Live Paint Selection tool, 312–313

Paintbrush tool, 318–319
pattern brushes, 326–327
scatter brushes, 320–321

panel knife effects, 300
Panel Options menu, 8-11
panels

adding, 10
closing, 8-9
collapsing, 8-9, 11
displaying hidden, 45
docking/undocking, 10
expanding, 8-9, 11
hiding, 10, 45
opening, 8-9
Panel Options menu, 11
resizing, 8-9
sets, collapsing and expanding between

icons and panels, 11
subtracting, 10

paragraphs
alignment, 246
indentation, 247
spacing, 247

Paragraph panel, 246-247, 249
Paragraph Styles panel, 250-251
Paste command (Edit menu), 232–233
Paste in Back command (Edit menu), 233
Paste in Front command (Edit menu), 233
Pathfinder commands, 191
Pathfinder panel, 190-191
paths

anchor points and, 65
clean up unneeded elements, 375
clipping mask, 194–197
closed, 65
compound, 192–193
convert mesh object to, 174
convert strokes to compound, 192
dividing, 185
erasing parts of, 182, 304

join, 179
merging, 188–189
offsetting, 95, 187
open, 65, 177
outline stroke, 181
reshaping, 180–181
segments and, 65
Shape Mode command, 190
shape of, changing, 65
simplify, 184
smoothing, 183
splitting, 186–187
splitting into grid, 187

pattern brushes, 326–327
patterns

applying to objects, 149
creating, 146-147
editing, 148
expanding, 149
as fills, 149
as strokes, 149

PDF format, 27 
saving as, 399, 412–413
SaveDocsAsPDF, script, 368–369

Pen tool
anchor points, adding, 177
drawing curves with, 171
drawing polygons with, 170

Pencil tool
preferences, 305
reshaping paths with, 181
working with, 304–305

Perspective Grid
adjusting, 79
copying, 80
customizing, 81
drawing, 78
moving, 80
objects, adding, 80
resizing, 80
text, adding, 80

Photoshop Effect Gallery, 294–295
Photoshop, exporting to, 408
Photoshop format, 403
pie graphs, 372-373
pixel grid, align, 30, 67, 354
Pixel Preview command (View menu), 41
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pixels, 37
Place command (File menu), 18, 261, 264,

266
placing graphics, 261–263
plastic wrap effects, 302
Play button (Actions panel), 359
playback, action, 361
plug-in preferences, 463
PNG format, 399, 403

exporting as, 406-407
PNG-8 document, 436–437
PNG-24 document, 438
point type, 223
point/pica size, 48
points, anchor

adding new, 176–177
alignment, 178–179
average, 173
Convert Anchor Point tool, 175
converting, 174–175
deleting, 177
direction lines, 172
endpoints, 179
highlighting, 172
moving, 172–173
paths and, 65
preferences, 172
selecting with Direct Selection tool, 84
showing and hiding, 65
smooth points, converting to corner

points, 174
Polar Grid tool, 75
Polygon tool, 70
polygons, drawing, 70, 170
portrait/landscape orientation, 37
preferences

Adobe Bridge, 482–483
anchor points, 172
Appearance of Black, 468
cursor, 454
dictionary, 462
File Handling & Clipboard, 466-467
General, 454
grids, 54
guide, 50
hyphenation, 462
keyboard shortcut, 469
Live Paint Bucket tool, 309

Pencil tool, 305
plug-in, 463
ruler, 48
Scratch Disk, 464
Selection & Anchor Display, 456–457
slices, 461
smart guides, 53
text, 458–459
Transparency grid, 159
type, 458–459
Units Performance, 460
updates, 22
user interface, 465

presets
artboard, 36
creating new documents using, 31
exporting with, 409
list of, 31
printing with, 385, 394

Preview in browser (Save for Web), 451
Preview view, 40–41
Preview View command (View menu), 304
previewing

artboards, 38
color separations, 391
effects, 282
Save for Web, 451

Print command (File menu), 384, 386
Print Presets command (Edit menu), 385
printing

advanced print options, 394–395
bleed options, 389
color management settings, 396
color separations, previewing, 391
documents, 384
general print options, 386–387
graphics print options, 390
marks options, 388–389
number of copies, specifying, 387
output options, setting, 392–393
Overprint preview, 391
overprints, 394
presets, 394
with presets, 385
Print command, 384
print problems, checking for, 397
print tiling, 387
reverse order, 386
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Separations preview, 391
summary print options, 397

Product Improvement Program (Adobe), 25
Proof Colors command (View menu), 

132-133
Proof Setup command (View menu), 41
proofing colors, 132-133
PSD format, 399
Pucker tool, 332
punctuation, 252

Q
Quit Illustrator command (Illustrator menu),

28
quotes, 35

R
radar graphs, 372-373
Radial Blur, 298-299
radial gradient type, 163
raster graphics

effects, 283, 292
interpolation and, 64
Resolution Independent Effects (RIE), 283
tracing, 268–272
understanding raster graphics, 64

Record button (Actions panel), 359
recording actions, 360
Rectangle Grid tool, 74
Rectangle tool, 69
Redo command (Edit menu), 59
Reflect tool, 101
reflecting objects, 97, 101
registration, 4–5
registration point, 355
releasing

compound paths, 193
objects from clipping masks, 195
objects to layers, 215

renaming
data sets, 371
selections, 92
workspaces, 61

rendering intent color management print
option, 396

replacing
colors, 124–125

fonts, 237
images, 18

Reselect command (Select menu), 90
Reset All Warning Dialogs, 455
Reshape tool, 180
reshaping objects, with Envelopes, 104-105
reshaping paths, 180–181
resizing

artboards, 38
slices, 446

Resolution Independent Effects (RIE), 283
resolution preset transparency setting, 35
Return to Adobe Illustrator command (File

menu), 16
reverse order printing, 386
Revert command (File menu), 26
revolving 3D effects, 289
RGB (Red, Green, Blue) color mode, 30, 111,

114
Rotate tool, 100
rotating

artboards, 38
objects, 97–98, 100
text, 243

round bend style, 95
round joins, 139
Rounded Rectangle tool, 69
RTF format, 229
rulers

artboard display options, 39, 49
displaying, 48–49
document, 48–49
guides

alignment, 53
changing, 49
clearing, 51
color, 50
converting vector objects to, 51
creating, 51
locking, 50
preferences, 50
ruler, 49
showing and hiding, 50
smart guides, 52–53
snap to point, 50
style, 50
switching, 51

hiding, 49
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rulers (continued)
origin, changing, 49
preferences, 48

S
safe area, artboard display options, 39
Same command (Select menu), 91
saturation, color, 115
Save a Copy command (File menu), 27
Save As command (File menu), 27, 33
Save command (File menu), 26
SaveDocsAsPDF, script, 368–369
SaveDocsAsSVG, script, 368–369
Save for Web command (File menu),

426–429
as GIF format, 426-427, 434-435
as JPEG format, 426-427, 432-433
as PNG-8 format, 426-427, 436-437
as PNG-24 format, 426-427, 438

Save Selection command (Select menu), 82
Save Workspace command (Workspace

menu), 60
saving

actions
as files, 359
into sets, 359

brush library, 331
documents, 26–27

as Adobe Flex File, 420-421
as EPS format, 414–415
as FXG format, 420-421
as Microsoft Office, 422
as PDF format, 412–413
as SVG format, 416-418
as template, 423
for the Web, 426–427

selections, 82
slices for Web, 449
slices (from selection) for Web, 450
symbols, 337

Scale Strokes & Effects option, 455
Scale tool, 100
scaling

9-slice scaling, 352-353
objects, 97, 100
type, 242

Scallop tool, 332

scatter brushes, 320–321
scatter graphs, 372-373
Scissor tool, 186
Scratch Disk preferences, 464
screen modes, 45
scribble effects, 285
scripts, actions, 368–369
searching

fonts, 237
for help information, 25

segments
curve, 173
moving, 172–173
paths and, 65
selecting with Direct Selection tool, 84

Select menu commands, 90–91
Edit Selection, 82
Same command, 91
Save Selection, 82

Selection & Anchor Display preferences,
456–457

Selection tool. See also selections
aligning and distributing objects using,

96
duplicating objects with, 94–95
moving objects with, 93
reflecting or shearing objects, 101
rotating and scale objects with, 100
selecting objects with, 83
transforming objects with, 97
understanding selections, 82

selections. See also Selection tool
anchor points, 84
controlling effects using, 297
deleting, 82
editing, 82
examples of, 82
inverting color of, 90
layers, 204
naming, 82
renaming, 82
reselecting, 90
saving, 82
selecting next object above/below 

current, 90
slices, 442–443
type, 230–231
understanding selections, 82
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sentence case, 383
Separations Preview command (Window

menu), 41
Shape Mode command (Pathfinder panel),

190
Shape Builder tool, 76-77
Shear tool, 101
shortcuts

starting Illustrator, 4–5
tool, 13

Show Bounding Box command (View
menu), 97

Show Edges command (View menu), 65
Show Panels command (Window menu), 20
Show Print Tiling command (View menu),

40
Show Text Threads command (View menu),

234
Show Transparency Grid command (View

menu), 159
simplify paths, 184
single quotes, 35
size

artboard, 37
font, 238
views, 42

Slice tool, 440
Slice Selection tool, 442
Slice Select tool (Save for Web), 428-429,

443
slices

alignment, 447
arranging, 446–447
auto, 440
combining, 448
deleting, 442
distributing, 447
dividing, 448
duplicating, 442, 448
hiding, 442–443
HTML text, adding, 444
images, optimizing to file size, 439
linking, 443
moving, 446
preferences, 461
resizing, 446
saving for Web, 449, 450
selecting, 442–443
showing, 442–443

stacking, 447
subslices, 441
unlinking, 443
URL links, adding, 445
user, 440
viewing slice options, 442–443
working with, 443

Smart Blur, 298-299
smart guides

object transformation, 99
preferences, 53
turning on/off, 52
working with, 52–53

Smart Punctuation, 252
smooth paths, 183
smooth points, converting to corner points,

174
Snap to Grid command, 54
Snap to Point command, 50, 456
soft proof colors, 132-133
software, Illustrator system requirements, 3
spacing paragraphs, 247
spatter effects, 302
spell checking, 378–379
Spiral tool, 72–73
spirals, drawing, 72–73
splitting paths, 186–187
stacked bar graphs, 372-373
stacked column graphs, 372-373
stacking slices, 447
stained glass effects, 302
stamp effects, 301
Star tool, 70
stars, drawing, 70
Start menu, opening documents using, 15
starting Illustrator

in Macintosh, 5
shortcuts, 4–5
in Windows, 4

status bar, 19
Stop button (Actions panel), 359
stops, adding to actions, 362
stroke

alignment, 138
applying color to, 113, 128, 136-137
arrowheads, 140-141
attributes, changing, 138–141
caps or joins, changing, 139
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stroke (continued)
dashed, 140
patterns as, 146–149
weight of, changing, 138
widths, variable, 142-143

styles
font, 236
graphic

applying, 273
breaking links to, 277
creating, 274
deleting, 277
duplicating, 275
editing, 276

grids, 54
guides, 50
type, 250–251

Stylize command (Effect menu), 285
sublayers, 202–203
subscript text, 35
subslices, 441
subtracting panels, 10
summary print options, 397
superscript text, 35
SVG format, 27

HTML5 Pack, 418
saving as, 416-417
SaveDocsAsSVG, script, 368–369

Swatches Library
copying swatches between libraries, 120
customized swatch panels, saving, 121
displaying, 120
gradient library, 160, 162

Swatches panel
creating color groups in, 117
deleting colors from, 116
display of, changing, 116
editing or duplicating color in, 117
groups, creating, 118-119
sorting colors in, 116
swatches, displaying by type, 116
Swatches Library, 120–121

SWF format, Flash, 403, 410-411
symbols

9-slice scaling, 352-353
creating, 336
deleting, 337

duplicating, 338
editing, 339
links, breaking, 340–341
pixel grid, align, 354
registration point, 355
saving, 337
sets, expanding instances of, 351
Symbol Libraries, 335
Symbol Screener tool, 349
Symbol Scruncher tool, 345
Symbol Shifter tool, 344
Symbol Sizer tool, 346
Symbol Spinner tool, 347
Symbol Sprayer tool, 342
Symbol Strainer tool, 348
Symbol Styler tool, 350
symbolism tool options, setting, 343
Symbols panel, 334

Symbol Libraries, 335
Symbol Screener tool, 349
Symbol Scruncher tool, 345
Symbol Shifter tool, 344
Symbol Sizer tool, 346
Symbol Spinner tool, 347
Symbol Sprayer tool, 342
Symbol Strainer tool, 348
Symbol Styler tool, 350
system requirements, 3

T
tab stops, 248
tabbed documents, 20
tabs, 248
Tabs panel, 248
Targa format, 403
templates

creating documents from, 32–33
document, 18, 32–33
saving documents as, 423

template layer, creating, 218
text

anti-aliasing, 236, 245
case, 383
clean up unneeded elements, 375
copying, 232–233
effects, 228
fonts, 236–238
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glyphs, 253
hyphenation, 249
importing, 229
justification, 255
kerning, 240
leading, 239
moving, 227, 232–233
outlines, 257
overflow, 234–235
paragraphs, 246–247
preferences, 458–459
rotating, 243
scaling, 242
selecting, 230–231
spacing, 255
styles, 250–251
subscript, 35
superscript, 35
tabs, 248
threads, 234–235
tracking, 241
typing new, 223–224
wrapping, 256

Text Format, 403
Text Wrap command (Objects menu), 256
themes, color, 122–123
threads, text, 234–235
3D effects, 288–289
thumbnail views, 43
TIFF format, 399, 403, 405
Tolerance selection option, 456
tool tips, 455
tools

accessing in Tools panel, 12
accessing multiple, 12
Control panel, 6-7
moving between, 55
shortcuts to, 13

Tools panel
accessing tools in, 12
contents of, 6-7

tracing raster graphics, 268–270
tracking type, 241
transformations

applying multiple, 102–103
blends, 154
Distort & Transform command, 102

repeating, 102
Transform Each command, 102

transforming objects, 97–99
Transparency Flattener Presets command

(Edit menu), 395
Transparency grid, 159
transparency settings

blends, 156
colored paper simulation, 35
controlling transparency effects, 156
document creation, 34–35
flattening object transparency, 158
grid colors, 35
grid size, 34
opacity mask, 157
resolution preset, 35

trim marks, editable, 57
turning on/off smart guides, 52
TXT format, 229
type

anti-aliasing, 236, 245
Area Type tool, 225
copying, 232–233
deleting empty text paths, 232
fonts, 236–238
justification, 255
kerning, 240
leading, 239
moving, 232–233
OpenType fonts, 254
outlines, 257
overflow, 234–235
paragraphs, 246–247
preferences, 458–459
rotating, 243
scaling, 242
selecting, 230–231
spacing, 255
styles, 250–251
threads, 234–235
tracking value, 241
Type on a Path tool, 226
Vertical Area Type tool, 225
Vertical Type on a Path tool, 226
Vertical Type tool, 223
wrapping, 256

Type on a Path tool, 222, 226
Type tool, 222-223
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typographer's quotes, 35
Twirl tool, 332

U
Undo command (Edit menu), 59
undocking

documents, 21
panels, 10

Ungroup command (Objects menu), 88
ungroup, color group, 119
Units Performance preferences, 460
Updater (Adobe), 23
updates

checking for, 22–23
preferences, 22

Updates command (Help menu), 23
updating, from previous versions, 2
uppercase text, 383
URL links, adding to slices, 445
user interface 

changing, 6-7
preferences, 6-7, 465

user slices, 440

V
variables, data

creating, 370–371
deleting, 370–371
renaming, 371

variable stroke widths, 142-143
vector objects

converting to guide, 51
effects, 293
understanding vector graphics, 64

Vertical Area Type tool, 222, 225
Vertical Type on a Path tool, 222, 226
Vertical Type tool, 222, 223
Video Data tab (File Info dialog box), 398
video safe areas, artboards, 37
View menu commands

Bounding Box, 314–315
Edit View, 40
Fit All In Window, 46
Fit Artboard In Window, 46
Hide Edges, 65
New View, 40
Overprint Preview, 41

Pixel Preview, 41
Preview View, 304
Proof Colors, 132-133
Proof Setup, 41
Rulers, 48
Show Bounding Box, 97
Show Edges, 65
Show Print Tiling, 40
Show Text Threads, 234
Show Transparency Grid, 159
Smart Guides, 52
Soft Proof, 132-133

view size, documents, 19
views

box color, 44
changing, with Zoom tool, 46–47
display view, changing, 40–41
document, 40–43
fit in window, 46
Outline, 40–41
Preview, 40–41
ruler options, 48
size, 42
thumbnail, 43

Vimeo (Media Encoder), 488-489

W
Warp effect, 290
Warp tool, 332
Web

browser preview in (Save for Web), 451
file formats, 430–431
GIF files, optimizing, 426-427, 434–435
images, optimizing to file size, 439
JPEG files, optimizing, 426-427, 432–433
PNG-8 files, optimizing, 426-427, 436–437
PNG-24 files, optimizing, 426-427, 438
saving documents for, 426–427
saving slices for, 449

Web-safe color, 115
Window menu

Extensions, 122–123
Flattener Preview, 41
panel display, 8–10

Window menu commands
Flattener Preview, 395
Hide Panels, 20
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Separations preview, 41
Show Panels, 20

Windows
Illustrator system requirements, 3
installing Illustrator in, 2
starting Illustrator in, 4

windows
active, 20
document, 20–21

Windows Metafile format, 403
Workspace menu commands, 60
workspaces

creating, 60
deleting, 61
displaying, 60
layouts, 60
naming, 60
renaming, 61

wrapping text, 256
Wrinkle tool, 332

X
X and Y positioning, 37
XMP metadata, 398-399
XMP Software Development Kit, 399
Xoom device, 31

Y
YouTube (Media Encoder), 488-489

Z
zoom

in/out, 47
using Navigator thumbnail, 43
view size, 42

Zoom tool
changing view with, 46–47
Save For Web tool, 394
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Ready to start using the skills you just learned? The Online 
Workshop is a great place to get started. The Workshop is filled 
with projects that will help you use Adobe Illustrator CS6 
in the real world.

Each project in the Workshop takes you step-by-step from 
beginning to end to make sure you get just the result you’re 
looking for. Not only will you put individual step-by-step tasks 

into projects, but you’ll also reinforce the skills you learned so you’ll know how and when to incorporate the  
tasks into your work.

Bonus Online Content
To access the Online Workshop and bonus content, follow these simple steps:

1. Go to queondemand.com/register and sign in or create an account. 

2. To register this product to your account, enter 9780789749352 into the box, and click Submit. 

3. Answer challenge question to show proof of purchase.

4. On the Registered Products area of your account page, you will now see an “Access Bonus Content”  
link—click that link to be taken to the page with the bonus material for this title.

5. You may return to the bonus material at any time by clicking on this link, which appears in your account. 
(Must be logged in to view.) 

Also available at www.perspection.com

HERE ARE SOME OF THE WORKSHOPS YOU’LL FIND:

Illustrator CS6 Projects
Illustrator allows you to use professional tools and your own creativity to create artwork that 
you can use on the web, in on-screen presentations and in commercial printing. The projects in 
Illustrator CS6 focus on learning techniques that you can use in everyday life.

The projects include

•	 Creating	and	using	multiple	artboards

•	 Tracing	and	recoloring	artwork

•	 Creating	stylized	3D	type

•	 Creating	and	using	bristle	brushes

•	 Exporting	to	other	formats

•	 Preparing	for	a	printer

Online Workshop
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