Bienvenido

Con L&H Dictionary Utilities puede realizar tareas globales de uso de diccionarios en los programas de traducción de L&H. Puede importar y exportar diccionarios de productos L&H actuales y anteriores, compartir los diccionarios con otros equipos y apilar los diccionarios especializados según las preferencias de traducción para las utilidades.

Esperamos que disfrute al máximo de este producto y que le saque el mayor partido posible para las tareas globales de uso de diccionarios.


Ficha Exportar

Con la ficha Exportar puede crear un formato de archivo denominado Lexicon Interchange Format (formato de intercambio de léxico, *.LIF). Los archivos *.LIF son archivos con formato de texto.

Si trabaja con L&H Power Translator Pro, o con una de las versiones anteriores del producto, y ha agregado o modificado palabras de los diccionarios generales, puede convertir los diccionarios auxiliares resultantes para utilizarlos con otras aplicaciones como, por ejemplo, Microsoft Excel, Bloc de notas de Windows o L&H Power Translator Pro.

Los diccionarios de usuario anteriores pueden utilizarse con la última versión de L&H Power Translator Pro. Los diccionarios de Power Translator 5.X (con extensión *.DIC) pueden exportarse a formato *.LIF e importarse después al formato *.CDS actual para utilizarlos con esta versión de L&H Power Translator Pro. Lo único que hay que hacer con los diccionarios de Language Assistant 2.0 y Power Translator 6.X es copiarlos al diccionario de esta última versión de L&H Power Translator Pro. El directorio de instalación predeterminado es C:\Archivos de programa\LHSP\Power Translator Pro.

Para utilizar los diccionarios con otras aplicaciones, debe hacer uso de la ficha Exportar de L&H Dictionary Utilities.

Exportar diccionarios de Power Translator 5.X

Utilización de diccionarios anteriores con esta versión de L&H Power Translator Pro


Exportar diccionarios de Power Translator

Para utilizar los diccionarios de L&H Power Translator Pro con otras aplicaciones, debe exportarlos a un formato de archivo intermedio denominado Lexicon Interchange Format (LIF) con L&H Dictionary Export. Los archivos *.LIF son archivos con formato de texto.

Para utilizar los diccionarios exportados con Microsoft Excel o el Bloc de notas de Windows, abra los archivos *.LIF resultantes en las aplicaciones. Si desea utilizar el diccionario de Power Translator 5.X con esta versión de L&H Power Translator Pro, tendrá que importarlo a un formato *.CDS para que el programa pueda abrirlo.

Notas sobre los diccionarios de Power Translator 5.X

Para exportar un diccionario a un archivo *.LIF, siga estos pasos:

  1. Seleccione L&H Dictionary Utilities en el menú Inicio: Programas\L&H Power Translator Pro\L&H Dictionary Utilities.

  2. Haga clic en la ficha Exportar.

  3. Escriba el nombre del diccionario auxiliar que desee exportar en el campo Archivo de diccionario o utilice el botón Examinar para localizarlo.

Los diccionarios de Power Translator 5.X que puedan convertirse tendrán cualquiera de los siguientes nombres:

Los diccionarios de L&H Power Translator Pro 7.X que puedan convertirse tendrán cualquiera de los siguientes nombres:

ESMICUSR.DIC (inglés a español)
SEMICUSR.DIC (español a inglés)
EFMICUSR.DIC (inglés a francés)
FEMICUSR.DIC (francés a inglés)
EGMICUSR.DIC (inglés a alemán)
GEMICUSR.DIC (alemán a inglés)
EIMICUSR.DIC (inglés a italiano)
IEMICUSR.DIC (italiano a inglés)

ESUSER.CDS (inglés a español)
SEUSER.CDS (español a inglés)
EFUSER.CDS (inglés a francés)
FEUSER.CDS (francés a inglés)
EGUSER.CDS (inglés a alemán)
GEUSER.CDS (alemán a inglés)
EIUSER.CDS (inglés a italiano)
IEUSER.CDS (italiano a inglés)
EPUSER.CDS (inglés a portugués)
PEUSER.CDS (portugués a inglés)

Aviso: el campo de texto Lexicon Interchange File (*.LIF) asigna automáticamente un nombre de archivo predeterminado que incluye la ruta de acceso del archivo que se está exportando. Puede utilizar este nombre o escribir uno nuevo.

Nota: anote este nombre de archivo ya que se utilizará posteriormente en el proceso.

Tiene la opción de generar un informe de todos los registros que no se hayan exportado correctamente. Para obtener instrucciones sobre la forma de hacerlo, consulte el tema Generación de informes.

  4. Inicie el proceso de exportación haciendo clic en el botón Aplicar.

Aviso: aparecerá un cuadro de mensaje de estado de la conversión.

  5. Haga clic en Aceptar.

  6. Salga de L&H Dictionary Utilities haciendo clic en el botón Cerrar.

En este punto, el proceso de exportación ha creado un archivo LIF que ya puede importarse en L&H Power Translator Pro.

Nota: el proceso de conversión de diccionarios debe completarse para todos los diccionarios (en ambas direcciones) que desee convertir.


Utilización de diccionarios anteriores con esta versión de L&H Power Translator Pro

Si está actualizando a partir de Assistant 2.0 o Power Translator Pro 6.X, y previamente ha agregado o modificado términos de los diccionarios generales, puede utilizar los diccionarios auxiliares anteriores con la nueva versión de L&H Power Translator Pro.

La actualización de los diccionarios es un proceso de dos fases:

  1. Localización de los diccionarios de usuario anteriores.

  2. Copia de los diccionarios al directorio actual de L&H Power Translator Pro.

Fase 1 - Localización de los diccionarios de usuario anteriores.

Puede encontrar los diccionarios de usuario en el directorio en el que instaló Language Assistant 2.0 o Power Translator Pro 6.X. Por ejemplo, el directorio predeterminado para Language Assistant 2.0 es C:\LA20.

Nota: si instaló L&H Power Translator Pro en el mismo directorio que el producto L&H anterior, los diccionarios de usuario se copiaron en un subdirectorio denominado LexData. Por ejemplo, C:\LA20\LexData.

Los diccionarios de Language Assistant 2.0 y Power Translator Pro 6.X tendrán cualquiera de los siguientes nombres:

ESUSER.CDS (inglés a español)
SEUSER.CDS (español a inglés)
EFUSER.CDS (inglés a francés)
FEUSER.CDS (francés a inglés)
EGUSER.CDS (inglés a alemán)
GEUSER.CDS (alemán a inglés)
EIUSER.CDS (inglés a italiano)
IEUSER.CDS (italiano a inglés)
EPUSER.CDS (inglés a portugués)
PEUSER.CDS (portugués a inglés)

Fase 2 - Copia de los diccionarios de usuario anteriores al directorio actual de L&H Power Translator Pro.

Una vez localizados los diccionarios anteriores, puede copiarlos en el directorio actual de L&H Power Translator Pro. Si instaló L&H Power Translator Pro en el directorio de instalación predeterminado, copie los archivos de diccionario antiguos en C:\Archivos de programa\LHSP\Power Translator Pro.

La próxima vez que inicie L&H Power Translator Pro, traducirá con las entradas que agregó a los diccionarios de usuario antiguos.

Nota: para obtener información sobre cómo buscar o copiar archivos, consulte la guía del usuario o la ayuda del sistema operativo.


Ficha Importar

L&H Dictionary Utilities le ofrece la posibilidad de convertir archivos *.LIF en archivos *.CDS para su utilización con L&H Power Translator Pro.

Si ha agregado o modificado términos en los diccionarios generales de Power Translator 5.X, puede importar los diccionarios auxiliares resultantes para utilizarlos con esta versión de L&H Power Translator Pro.

Nota: es aconsejable que consulte los nuevos diccionarios predeterminados de L&H Power Translator Pro antes de transferir los diccionarios de usuario anteriores al directorio actual. Los diccionarios de L&H Power Translator Pro son más recientes que los que se incluyen en los productos anteriores y pueden ofrecer mejores traducciones.

Para utilizar los diccionarios de usuario anteriores con Power Translator Pro 7.X, tendrá que exportar los archivos al formato *.LIF e importar después este formato a formato *.CDS.

Si tiene previsto importar los diccionarios de usuario de Power Translator 5.X, hágalo antes de empezar a utilizar esta versión de L&H Power Translator Pro, ya que de lo contrario sobrescribirá las nuevas entradas que haya agregado.

Para importar los archivos *.LIF en archivos *.CDS para utilizarlos en L&H Power Translator Pro, siga estos pasos:

  1. Seleccione L&H Dictionary Utilities en el menú Inicio: Programas\L&H Power Translator Pro\Utilidades\L&H Dictionary Utilities.

  2. Haga clic en la ficha Importar.

  3. Escriba el nombre del diccionario auxiliar que desee importar en el campo Archivo LIF o utilice el botón Examinar para localizarlo.

Aviso: el campo de texto Archivo de diccionario asigna automáticamente un nombre de archivo predeterminado que incluye la ruta de acceso del archivo que se está importando. Puede utilizar este nombre o escribir uno nuevo. De cualquier forma, debe comprobar que la ruta de acceso del nuevo diccionario sea la misma que el directorio de L&H Power Translator Pro. L&H Power Translator Pro utilizará el nombre del diccionario como referencia durante el proceso de mantenimiento de diccionarios.

  4. Escriba una descripción del diccionario en el campo de texto Descripción del diccionario.

Tiene la opción de generar un informe de todos los registros que no se han importado correctamente. Para obtener instrucciones sobre la forma de hacerlo, consulte el tema Generación de informes.

  5. Inicie el proceso de importación haciendo clic en el botón Aplicar.

Aviso: aparecerá un cuadro de mensaje de estado de conversión.

  6. Haga clic en Aceptar.

  7. Salga de L&H Dictionary Utilities haciendo clic en el botón Cerrar.

En este punto, el proceso de importación ha creado un archivo *.CDS que ya puede utilizarse con L&H Power Translator Pro.

Nota: el proceso de conversión de diccionarios debe completarse para todos los diccionarios (en ambas direcciones) que desee importar.

Exportar diccionarios de Power Translator 5.X


Ficha Apilar diccionarios

Si el texto que traduce contiene terminología sobre un tema concreto y ha creado o adquirido un diccionario especializado en dicho tema, la mejor opción es asignarle prioridad sobre los demás diccionarios colocándolo en el primer lugar de la lista o "pila" de diccionarios.

Al apilar los diccionarios se establece el orden en que L&H Power Translator Pro los consulta. Si la palabra matriz que se busca aparece en varios diccionarios, L&H Power Translator Pro seleccionará la traducción del diccionario con mayor prioridad, siempre y cuando se trate de la parte correcta de la oración.

Nota: cuando se cambia el orden de los diccionarios con esta utilidad, se modifica el orden para todas las utilidades de traducción de L&H, a excepción de la aplicación principal L&H Power Translator Pro.

Para modificar la prioridad de un diccionario especializado, siga estos pasos:

  1. Seleccione el icono L&H Dictionary Utilities en el menú Inicio: Programas\L&H Power Translator Pro\Utilidades\L&H Dictionary Utilities.

  2. Haga clic en la ficha Apilar.

  3. Seleccione la pareja de idiomas para la que desee cambiar la prioridad de los diccionarios.

  4. En el grupo Orden de búsqueda de los diccionarios, haga clic en el diccionario cuya prioridad desee modificar.

  5. Haga clic en flecha arriba o flecha abajo.

Aviso: el diccionario seleccionado se desplazará hacia arriba o hacia abajo en la lista.

  6. Haga clic en Aplicar para guardar la configuración.


Ficha Compartir diccionarios

Si desea mover los diccionarios a una nueva localización y que los equipos de los usuarios apunten a ella, tendrá que ejecutar L&H Dictionary Utilities desde los equipos locales para que L&H Power Translator Pro sepa dónde tiene que buscar los diccionarios.

Para mover los diccionarios a una nueva localización, siga estos pasos:

  1. Seleccione el icono L&H Dictionary Utilities en el menú Inicio: Programas\L&H Power Translator Pro\Utilidades\L&H Dictionary Utilities.

  2. Haga clic en la ficha Compartir.

  3. En el cuadro Localización de diccionarios compartidos, haga clic en el botón Examinar para buscar los archivos *.LEX o *.CDS de la instalación en red.

Nota: el directorio de instalación predeterminado es: C:\Archivos de programa\LHSP\Power Translator Pro.

Aviso: la localización del archivo aparecerá en el cuadro de texto situado a la izquierda del botón Examinar.

  4. Haga clic en la caja de selección No utilice diccionarios compartidos si Ud. quiere utilizar los diccionarios que se encuentran en el directorio local donde el L&H Power Translator Pro está instalado.

Nota: Se necesita instalar los diccionarios en su directorio local para que sus aplicaciones L&H Power Translator Pro puedan hacer traducciones.

  5. Haga clic en Aplicar para finalizar el uso compartido de diccionarios.


Generación de informes

Durante el proceso de exportación de diccionarios auxiliares a formato *.LIF o de importación de diccionarios con formato *.LIF en L&H Power Translator Pro, dispone de la opción de generar simultáneamente un informe con todas las entradas que no se hayan incluido correctamente en la conversión.

Entre las entradas que generalmente se convertirán se incluyen:

  • Sustantivos

  • Verbos
  • Adjetivos
  • Adverbios
  • Oraciones sustantivas
  • Oraciones adjetivas
  • Oraciones adverbiales

Los elementos restantes no se convertirán.

Para generar un informe de todas las entradas que no se han convertido, siga estos pasos:

  1. Antes de importar o exportar los diccionarios, seleccione el botón de opción Generar informe de la ficha Exportar o Importar.

    Aviso: el cuadro de texto Archivo de informe de excepción asigna automáticamente un nombre de archivo predeterminado que incluye la ruta de acceso del archivo que se está convirtiendo. Puede utilizar este nombre o escribir uno nuevo.

  2. Haga clic en Mostrar informe en Notepad si desea ver el informe inmediatamente después de su generación.

  3. Una vez haya importado o exportado los diccionarios, podrá disponer del informe. Puede guardar el archivo y, si lo desea, cerrar el Bloc de notas.

Nota: si no se producen errores durante el proceso de conversión, no se generará archivo alguno aunque se haya seleccionado la opción Generar informe.


Notas sobre los diccionarios de Power Translator 5.X

Si va a actualizar a una versión más reciente a partir de Power Translator 5.X y ha agregado o modificado términos de los diccionarios generales, puede exportar los diccionarios auxiliares resultantes para utilizarlos con la nueva versión de L&H Power Translator Pro.

Nota: para utilizar los diccionarios de usuario de Power Translator 5.X con Power Translator Pro 7.X, también tendrá que exportar los archivos a formato *.LIF y convertir después este formato en formato *.CDS.

Si tiene previsto importar versiones anteriores de diccionarios de usuario de Power Translator, hágalo antes de empezar a utilizar esta versión de L&H Power Translator Pro, en caso contrario perderá las entradas nuevas.