El Editor de reglas

El Editor de reglas proporciona a L&H Power Translator Pro más flexibilidad y un mayor control para agregar frases y sus traducciones que el simple hecho de agregarlas a los diccionarios. Las reglas que L&H Power Translator Pro usa durante el proceso de traducción determinan cómo se analizan las oraciones origen (original), cuáles traducciones se usan para palabras individuales y frases en la oración origen y cómo se construyen las oraciones traducidas.

El ejemplo siguiente ilustra las ventajas de ingresar una "frase verbal" en un conjunto de reglas para mejorar la traducción. Suponga que se está traduciendo la oración La pareja contrajo matrimonio, y que usted quiera que el verbo contraer se tradujera de una manera específica. Ciertamente usted no desearía que contraer sea traducido como adquirir sin como asumir compromiso.

Si agrega 'contraer matrimonio' como una regla, asegurará que L&H Power Translator Pro utiliza la traducción de la frase verbal específicada y no traducirá la frase incorrectamente.

Se pueden consultar los siguientes temas relativos:

Cómo agregar un conjunto de reglas nuevo

Cómo editar un conjunto de reglas

Cómo borrar un conjunto de reglas


Cómo agregar un conjunto de reglas nuevo

L&H Power Translator Pro le ofrece plantillas para agregar frases al Editor de reglas. Estas plantillas le permiten agregar las frases verbales sin necesidad de aprenderse todo el idioma de reglas.

Regla para español/inglés

Regla para español/italiano


Cómo editar un conjunto de reglas

Siga estos pasos para cambiar una regla que ya se ha ingresado:

  1. Abra el Editor de reglas.

    • Elija Reglas del menú Herramientas.

    • Elija la pareja de idiomas Origen/Destino apropiada.

    • Haga clic en Aceptar.

  2. Haga clic en el icono Editar conjunto de reglas.

  3. Elija el conjunto de reglas que desea editar del cuadro de lista Conjunto de reglas a editar.

  4. Haga clic en Aceptar.

  5. Efectúe los cambios deseados.

  6. Guarde el conjunto de reglas.

  7. Haga clic en el botón Compilar todo para recompilar las reglas que cambió.

  8. Elija Cerrar del menú Archivo para salir del Editor de reglas.

Nota: Recuerde que tal vez haya creado dos o más conjuntos de reglas para cada una de las reglas que ingresó y que pueda ser necesario editar todos aquellos conjuntos de reglas relativos a esa regla.


Cómo borrar un conjunto de reglas

Siga estos pasos para borrar una regla que ya se ha ingresado:

  1. Abra el Editor de reglas.

    • Elija Reglas del menú Herramientas.

    • Elija la pareja de idiomas Origen/Destino apropiada.

    • Haga clic en Aceptar.

  2. Haga clic en el icono Editar conjunto de reglas. Aparecerá el cuadro de diálogo Abrir conjunto de reglas.

  3. Haga clic en la frase User Keyed Rules (reglas clave del usuario) bajo del botón Grupo. Todos los conjuntos de reglas que usted agregó para el idioma de esa dirección aparecerán en el cuadro Conjunto de reglas a editar.

  4. Haga clic en el nombre del conjunto de reglas que desea borrar.

  5. Haga clic en Aceptar. El conjunto de reglas aparece en el Editor de reglas.

  6. Haga clic en el botón Borrar conjunto de reglas.

  7. Haga clic en Aceptar en el cuadro de diálogo Borrar conjunto de reglas para confirmar que desea que se borre ese conjunto de reglas.

  8. Elija Cerrar del menú Archivo para salir del Editor de reglas.

Nota: Si usted creó dos o más conjuntos de reglas para una regla que ingresó, quizá deseará borrar todos los conjuntos de reglas asociados con esa regla.


Regla para español/inglés

A continuación, se describe el procedimiento para el uso de una plantilla para agregar una regla de traducción.

  1. Abra el Editor de Reglas.

    • Elija Reglas del menú Herramientas.

    • Elija una pareja de idiomas Origen/Destino en el cuadro de diálogo Seleccione traductor.

    • Haga clic en Aceptar.

Nota: Es muy importante observar la diferencia entre una regla y un conjunto de reglas. La regla es el procedimiento que el programa sigue para obtener una traducción mejor. El conjunto de reglas es una colección de una o más reglas que constituyen el proceso.

  2. Agregar y nombrar a su conjunto de reglas nuevo.

    • Haga clic en el botón Agregar conjunto de reglas.

    • Teclee un nombre para su conjunto de reglas.

    • Tome nota de ese nombre. Es posible que lo necesite para editar el conjunto de reglas más adelante.

    • Haga clic en Aceptar.

  3. Abra uno de los archivos de plantillas (enumerados a continuación) en el directorio de plantillas de C:\Archivos de Programa\Lernout & Hauspie\Power Translator Pro\Tmplates utilizando un editor de textos como serían WordPad, Notepad o Write.

Nota:

NO SALGA de L&H Power Translator Pro. L&H Power Translator Pro y el editor de textos tendrán que estar abiertos al mismo tiempo.

Archivos de plantillas*

* Los archivos disponibles dependerán de los módulos de idiomas instalados.

ESTMPLT.TXT Archivos de plantillas inglés-español

SETMPLT.TXT Archivos de plantillas español- inglés

Por ejemplo: Para abrir un archivo de plantillas del español al inglés:

  • Abra Notepad.

  • Vaya a Abrir en el menú Archivo principal.

  • Teclee o explore hacia: C:\Archivos de Programa\Lernout & Hauspie\Power Translator Pro\TMPLATES\SETMPLT.TXT.

Nota: Después de abrir un archivo de plantillas, usted observará todas las plantillas de reglas que están disponibles para los idiomas en esa dirección.

  4. Desplácese hasta la plantilla que desea usar.

Por ejemplo: Vamos a agregar la frase 'hacer daño' como una regla desde el español hacia el inglés, para que sea traducida como harm. Utilizaremos la plantilla español- inglés VERBO + OBJETO DIRECTO ==>VERBO, como se muestra a continuación.

O modelo VERBO + OBJETO DIRECTO ==> VERBO español-inglés

// VERBO + OBJETO DIRECTO ==> VERBO

// Ejemplo: hacer daño ==> harm

// SOURCE.1 = hacer; SOURCE.2 = daño; TARGET.1 = harm

"hacer" Obj(SX_Direct, Primary.IsAttr Noun:"daño")

==> "harm" Make(SX_Direct,SX_Direct,Primary.Target.Hidden=True);

// Conjunto de Reglas1

// Procedimiento = Verb Frame; Fase = Frame; Palabra clave = SOURCE.1

"SOURCE.1" Obj(SX_Direct,Primary.HasAttr Noun:"SOURCE.2")

==> "TARGET.1" Make (SX_Direct,SX_Direct,Primary.Target.Hidden=True);

Nota: El conjunto de barras hacia adelante (//) se utiliza para indicar un comentario al conjunto de reglas y no constituye parte de la regla actual. En consecuencia, no importa si usted copia o no los comentarios al Editor de reglas. Como una referencia, tal vez desee copiar el renglón que contiene Procedimiento, Fase y Clave.

  5. Copiar y pegar Conjunto de Reglas1.

    • En la regla que desea introducir, solamente resalte la primera sección del conjunto de reglas (es decir, únicamente la sección que viene después de //Conjunto de Reglas1).

    • Cópiela al Portapapeles de Windows (Ctrl-C).

    • Cambie a L&H Power Translator Pro.

    • Pegue el texto (Ctrl-V) en el conjunto de reglas en blanco que usted abrió.

  6. Elija el Procedimiento y la Fase apropiados, como se indica en el renglón debajo de //Conjunto de Reglas1.

Por ejemplo: Procedimiento = Verb Frame

Fase = Frame

  7. Teclee la Clave (substituyendo la(s) palabra(s) correcta(s) en la frase que usted está ingresando) según lo que se indica en el renglón debajo de //Conjunto de Reglas1.

Por ejemplo: Clave = contraer

  8. Reemplace cualquier aparición de SOURCE.1, SOURCE.2, TARGET.1, etc. con las palabras origen y destino de la frase que usted desea ingresar (excepto cuando ocurren en los renglones de comentarios, los cuales aparecen marcados con //)

  9. Guarde la regla seleccionando Guardar del menú Archivo.

Nota: Si hay un solo conjunto de reglas para la plantilla que usted seleccionó, salte al paso 17.

Si la plantilla de reglas tiene más de una sección de CONJUNTO DE REGLAS (por ejemplo, si usted vea //Conjunto de Reglas2, //Conjunto de Reglas3), será necesario configurar conjuntos de reglas adicionales para estas secciones. Continúe con el paso 10.

  10. Creando conjuntos de reglas adicionales.

    • Haga clic en el botón Agregar conjunto de reglas para abrir un conjunto de reglas nuevo.

    • Teclee un nombre diferente para su conjunto de reglas nuevo.

    • Haga clic en Aceptar.

Una vez más aparecerá una ventana de conjuntos de reglas en blanco.

  11. Vuelva al archivo de plantillas que usted abrió.

  12. Copie y pegue el conjunto de reglas Conjunto de Reglas2.

    • Seleccione la segunda sección (es decir, únicamente la sección que siguen a //Conjunto de Reglas2) en la regla que usted desea ingresar.

    • Cópiela al Portapapeles de Windows (Ctrl-C).

    • Vuelva a L&H Power Translator Pro.

    • Pegue el texto (Ctrl-V) en el conjunto de reglas en blanco que usted abrió.

  13. Elija el Procedimiento, la Fase y la Clave apropiados.

Por ejemplo: Procedimiento = Verb Frame

Fase = Frame

Clave = contraer

  14. Reemplace cualquier aparición de SOURCE.1, SOURCE.2, TARGET.1, etc. con las palabras origen y destino de la frase que usted desea ingresar (excepto cuando ocurren en los renglones de comentarios, los cuales aparecen marcados con //)

  15. Guarde la regla en curso seleccionando Guardar del menú Archivo.

  16. Repita los pasos 10 al 15 para para cada uno de los conjuntos de reglas (es decir, las secciones que siguen a //Conjunto de Reglas2, //Conjunto de Reglas3). Asegúrese de guardar cada conjunto de reglas con un nombre diferente.

Después de ingresar toda la información relativa a los conjuntos de reglas, está listo para compilar las reglas y salir del Editor de reglas.

  17. Haga clic en el botón Compilar todo para compilar sus nuevas reglas.

  18. Seleccione Cerrar del menú Archivo para salir del Editor de reglas.

Sus reglas ahora están incluidas dentro del proceso de traducción para el par de idiomas que usted seleccionó.

Nota: Todas las palabras origen que se ingresan a una regla deben ser agregadas en el diccionario con la misma parte de la oración que se les asignó en la regla. Si tanto las palabras como las partes de la oración ya existen para cada una, no es necesario agregarlas de nuevo.

Para más información acerca de cómo agregar palabras a los diccionarios, vea la sección Cómo editar el diccionario.


Regla para español/italiano

A continuación, se describe el procedimiento para el uso de una plantilla para agregar una regla de traducción.

  1. Abra el Editor de Reglas.

    • Elija Reglas del menú Herramientas.

    • Elija una pareja de idiomas Origen/Destino en el cuadro de diálogo Seleccione traductor.

    • Haga clic en Aceptar.

Nota: Es muy importante observar la diferencia entre una regla y un conjunto de reglas. La regla es el procedimiento que el programa sigue para obtener una traducción mejor. El conjunto de reglas es una colección de una o más reglas que constituyen el proceso.

  2. Agregar y nombrar a su conjunto de reglas nuevo.

    • Haga clic en el botón Agregar conjunto de reglas.

    • Teclee un nombre para su conjunto de reglas.

    • Tome nota de ese nombre. Es posible que lo necesite para editar el conjunto de reglas más adelante.

    • Haga clic en Aceptar.

  3. Abra uno de los archivos de plantillas (enumerados a continuación) en el directorio de plantillas de C:\Archivos de Programa\Lernout & Hauspie\Power Translator Pro\Tmplates utilizando un editor de textos como serían WordPad, Notepad o Write.

Nota: NO SALGA de L&H Power Translator Pro. L&H Power Translator Pro y el editor de textos tendrán que estar abiertos al mismo tiempo.

Archivos de plantillas*

* Los archivos disponibles dependerán de los módulos de idiomas instalados.

SITMPLT.TXT Archivos de plantillas italiano-español

ISTMPLT.TXT Archivos de plantillas español- italiano

Por ejemplo: Para abrir un archivo de plantillas del español al italiano:

  • Abra Notepad.

  • Vaya a Abrir en el menú Archivo principal.

  • Teclee o explore hacia: C:\Archivos de Programa\Lernout & Hauspie\Power Translator Pro\TMPLATES\SITMPLT.TXT.

Nota: Después de abrir un archivo de plantillas, usted observará todas las plantillas de reglas que están disponibles para los idiomas en esa dirección.

  4. Desplácese hasta la plantilla que desea usar.

Por ejemplo: Vamos a agregar la frase 'contraer matrimonio' como una regla desde el español hacia el italiano, para que sea traducida como sposarsi.. Utilizaremos la plantilla español- italiano VERBO + OBJETO DIRECTO ==>VERBO, como se muestra a continuación.

O modelo VERBO + OBJETO DIRECTO ==> VERBO español-italiano

// VERBO + OBJETO DIRECTO ==> VERBO

// Ejemplo: contraer matrimonio ==> sposarsi

// SOURCE.1 = contraer; SOURCE.2 = matrimonio; TARGET.1 = sposarsi

"contraer" Obj (SX_Direct, Primary.HasAttr Noun:"matrimonio")

==> "sposarsi" Make (SX_Direct,SX_Direct,Primary.Target.Hidden=True);

// Conjunto de Reglas1

// Procedimiento = Verb Frame; Fase = Frame; Palabra clave = SOURCE.1

"SOURCE.1" Obj(SX_Direct,Primary.HasAttr Noun:"SOURCE.2")

==> "TARGET.1" Make (SX_Direct,SX_Direct,Primary.Target.Hidden=True);

Nota: El conjunto de barras hacia adelante (//) se utiliza para indicar un comentario al conjunto de reglas y no constituye parte de la regla actual. En consecuencia, no importa si usted copia o no los comentarios al Editor de reglas. Como una referencia, tal vez desee copiar el renglón que contiene Procedimiento, Fase y Clave.

  5. Copiar y pegar Conjunto de Reglas1.

    • En la regla que desea introducir, solamente resalte la primera sección del conjunto de reglas (es decir, únicamente la sección que viene después de //Conjunto de Reglas1).

    • Cópiela al Portapapeles de Windows (Ctrl-C).

    • Cambie a L&H Power Translator Pro.

    • Pegue el texto (Ctrl-V) en el conjunto de reglas en blanco que usted abrió.

  6. Elija el Procedimiento y la Fase apropiados, como se indica en el renglón debajo de //Conjunto de Reglas1.

Por ejemplo: Procedimiento = Verb Frame

Fase = Frame

  7. Teclee la Clave (substituyendo la(s) palabra(s) correcta(s) en la frase que usted está ingresando) según lo que se indica en el renglón debajo de //Conjunto de Reglas1.

Por ejemplo: Clave = contraer

  8. Reemplace cualquier aparición de SOURCE.1, SOURCE.2, TARGET.1, etc. con las palabras origen y destino de la frase que usted desea ingresar (excepto cuando ocurren en los renglones de comentarios, los cuales aparecen marcados con //)

  9. Guarde la regla seleccionando Guardar del menú Archivo.

Nota: Si hay un solo conjunto de reglas para la plantilla que usted seleccionó, salte al paso 17.

Si la plantilla de reglas tiene más de una sección de CONJUNTO DE REGLAS (por ejemplo, si usted vea //Conjunto de Reglas2, //Conjunto de Reglas3), será necesario configurar conjuntos de reglas adicionales para estas secciones. Continúe con el paso 10.

  10. Creando conjuntos de reglas adicionales.

    • Haga clic en el botón Agregar conjunto de reglas para abrir un conjunto de reglas nuevo.

    • Teclee un nombre diferente para su conjunto de reglas nuevo.

    • Haga clic en Aceptar.

Una vez más aparecerá una ventana de conjuntos de reglas en blanco.

  11. Vuelva al archivo de plantillas que usted abrió.

  12. Copie y pegue el conjunto de reglas Conjunto de Reglas2.

    • Seleccione la segunda sección (es decir, únicamente la sección que siguen a //Conjunto de Reglas2) en la regla que usted desea ingresar.

    • Cópiela al Portapapeles de Windows (Ctrl-C).

    • Vuelva a L&H Power Translator Pro.

    • Pegue el texto (Ctrl-V) en el conjunto de reglas en blanco que usted abrió.

  13. Elija el Procedimiento, la Fase y la Clave apropiados.

Por ejemplo: Procedimiento = Verb Frame

Fase = Frame

Clave = contraer

  14. Reemplace cualquier aparición de SOURCE.1, SOURCE.2, TARGET.1, etc. con las palabras origen y destino de la frase que usted desea ingresar (excepto cuando ocurren en los renglones de comentarios, los cuales aparecen marcados con //)

  15. Guarde la regla en curso seleccionando Guardar del menú Archivo.

  16. Repita los pasos 10 al 15 para para cada uno de los conjuntos de reglas (es decir, las secciones que siguen a //Conjunto de Reglas2, //Conjunto de Reglas3). Asegúrese de guardar cada conjunto de reglas con un nombre diferente.

Después de ingresar toda la información relativa a los conjuntos de reglas, está listo para compilar las reglas y salir del Editor de reglas.

  17. Haga clic en el botón Compilar todo para compilar sus nuevas reglas.

  18. Seleccione Cerrar del menú Archivo para salir del Editor de reglas.

Sus reglas ahora están incluidas dentro del proceso de traducción para el par de idiomas que usted seleccionó.

Nota: Todas las palabras origen que se ingresan a una regla deben ser agregadas en el diccionario con la misma parte de la oración que se les asignó en la regla. Si tanto las palabras como las partes de la oración ya existen para cada una, no es necesario agregarlas de nuevo.

Para más información acerca de cómo agregar palabras a los diccionarios, vea la sección Cómo editar el diccionario.